[ KERNEL ] [ NetHunter ] CYPHER v3.0

Search This thread

delafonze19

New member
Jun 6, 2017
4
0
42
Yeah, there seems to be some mess with the bbc code.

Here you go

->

https://github.com/kimocoder/android_static_tools/blob/master/nethunter_angler.zip

The rest of the apps and some pics from kimocoder can be found here

->

https://github.com/kimocoder/android_static_tools
So I was running the los build. I wanted full functionality so decided to fall back to 7.1.2. I used my fbe TWRP to erase all partitions. Then used the Nexus root toolkit to flash 7.1.2, it was the only method that didn't hang on boot can't parse 0x. That went well, only issue 2 vendor partitions stock and squashfs. In any event I used the link from post 15 as it's the only one that works for 8 core. The issue is both sideboard and TWRP install ends with can't patch boot IMG. Anyone one else experiencing this, more important anyone got a fix. EDIT
Durring write up.i decided to use the Nexus root toolkit to flash zips and got success. I'm not sure what the magic element is but it worked.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    nethunter_logo.png


    Supports Android 7.0 to 8.1
    Recommended for all WiFi tools to work is Android v7.1.2. Installation steps is described further below.



    FEATURES:
    Features from @flar2 kernel which this is built on.
    All credits to him for hosting awesome kernel sources.

    * Easy installation and setup with Aroma installer
    * Wake Gestures (sweep2wake and doubletap2wake)
    * Sweep2sleep
    * Overclock or underclock CPU
    * Advanced color control (RGB, Saturation, Value, Contrast, Hue)
    * Sound control (headphones, speaker and mic)
    * Backlight dimmer option
    * High Brightness Mode option
    * Option to disable touchboost
    * NTFS r/w and exFAT support
    * Option to disable fsync
    * Adjustable vibration
    * MultiROM support
    * WireGuard support
    * Does not force encryption
    * Does not modify system partition
    * Compatible with systemless root and Android Pay


    Added by me on top:
    * Big collection of wireless drivers & firmware
    * Big collection of ethernet USB, USB hubs and general USB adapters of various kinds.
    * rtl8812au drivers from https://github.com/aircrack-ng/rtl8812au
    * rtl8188eus drivers from https://github.com/aircrack-ng/rtl8188eus (added but not working yet)
    * "linux-firmware" built in
    * CD-ROM patch
    * USB HID support
    * WIFI injection patches for several adapters
    * Nexmon support with both monitor mode & frame injection via internal adapter
    * SELINUX patched
    * USB OTG (w/ACA) is supported
    * linux-stable patches merged inside
    * wireless-tools (iw, iwconfig, ifconfig etc) is bulilt into Android /system (packing them in a new release in a few days)


    [ TODO / W.I.P ]
    * Add a bunch of compiled binaries
    * Change to anykernel3 installer
    * Merge more from linux-stable
    * See if we may fix the Android 8.1 issue


    [ Images / Media ]

    Running wifite2 through SSH with JuiceSSH
    wifite_new.jpg
    adapter_airodump_new.jpg


    Running airodump-ng using the external AWUS036ACH. - Hijacker packs aircrack-ng suite, reaver wps and mdk3 but also has a cracking & scripting option.
    adapter_alfa_new.jpg
    hijacker_new.jpg


    A few of my tools, for me WiFi and MITM is important.
    desktop_new.png
    hijacker_reaver_new.png
    hijacker_mdk3_new.png
    hijacker_crack_new.png


    [ Installation ]
    We recommend you start from scratch and setup the device, full restore to fresh v7.1.2 is recommended,
    even though this kernel supports Android 8.1 too, some of the tools can't right now unfortunately.


    1. Find the original, stock firmware over here and choose the latest 7.1.2 (N2G48C, Aug 2017)
    2. Press & hold VOLUME DOWN [ - ] and POWER to reboot to bootloader
    3. Flash the stock firmware with "flash-all.bat" on Windows or "flash-all.sh" for Linux users
    4. Boot into stock and ENABLE developer setting (the menu you get after SPAMMING 5-7 times on the "Build Number" in "Settings" and "About Phone"
    -- here you may use the phone to download the kernel zip for flashing afterwards. or use "adb sideload" later on.
    5. With ADB enabled, reboot to BOOTLOADER
    6. Get TWRP recovery from over here and flash it with "fastboot flash recovery twrp-3.3.1-0-angler.img"
    7. VOLUME UP or DOWN and choose "Recovery Mode"
    8. In recovery mode
    9. Either flash the kernel zip (if you downloaded in the phone before reboot), or go to "Advanced" and use "ADB Sideload"
    10. If you ended up with "ADB Sideload" open Terminal or "Minimal ADB" prompt (Windows) and flash the kernel with "adb sideload < file.zip >
    11. After flashing the kernel, you also would need root. We suggest using Magisk root which you may find over here
    And flash the latest stable release. Same method as earlier.

    12. Open "Magisk Manager" and search for "busybox" -- Install it and reboot again in order to activate it.
    13. Start installing apps, e.g Hijacker official link
    --- Nexmon and it's tools ain't a bad choice either, the WiFi SoC is BCM4358 and supported. Grab it over here
    14. A Terminal would also be useful here, grap it from NetHunter repo right about here
    15. The NetHunter App should also be in place. Direkt link
    16. zANTI from Zimperium is loaded with nmap with NSE scripts/plugins and is pretty nifty one. grab it right here!
    17. cSploit is available right here
    (it's getting outdated, but a few things work).

    [ Downloads ]
    https://github.com/kimocoder/android_static_tools/raw/master/nethunter_angler.zip

    [ SOURCE ]
    http://github.com/kimocoder/android_kernel_nexus6p
    The recommended toolchain for this kernel sources is gcc-linaro-5.4.1-2017.05-x86_64_aarch64-linux-gnu

    [ Tools ]
    wifite2 - https://www.github.com/kimocoder/wifite2 (newly added to Kali / NetHunter repos)
    Hijacker - https://github.com/chrisk44/Hijacker
    aircrack-ng - https://aircrack-ng.org
    Nexmon - https://github.com/seemoo-lab/nexmon
    Magisk - https://github.com/topjohnwu/Magisk
    NetHunter - https://gitlab.com/kalilinux/nethunter
    zANTI - https://www.zimperium.com/
    cSploit - http://wwwcsploit.org


    [ Social Media ]
    Follow me on Twitter

    [ Credits ]
    @flar2
    @binkybear
    @jcadduono
    @aircrack-ng
    @nathanchance @nexmon
    @chrisk44
    @NetHunter
    @Re4son
    kriswebdev at GitHub
    2
    Oh, it's been 2 months since I try to get the nexus 6p to work normally.

    I tried updating to android 8.0 / 8.1, do a clean install and repeat the instructions for android 7.1.2 ...
    Now I have 8.1 with the kernel from the post above.
    Hijacker, all the same problems remained + Bluetooth stopped working and Hijacker crashes at startup.

    What am I doing wrong?

    We have just released new official NetHunter images for Android 8.1 & LOS 17.1:

    https://www.kali.org/news/kali-nethunter-updates/

    They include injection support for ath9k, rtl8192cu, rtl8812au, rtl8814au, rtl8821au, rt3070

    We are about to start a new thread for this release. It'll be up in a couple of days.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone