[KERNEL][OP3T] FrancoKernel

Status
Not open for further replies.

franciscofranco

Recognized Developer
Dec 9, 2010
24,725
136,397
0
Carcavelos
Same issue here. Clean install of oos, install kernel and no wifi. I see the module where you listed it above but looks like its not loaded.
Can you re-download the Kernel through my server please? I re-uploaded again with a small script change. Please clear your browser cache first, don't want you to download a cached old .zip. Thanks.
 

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
Works fine on my device.

Can you re-download the Kernel through my server please? I re-uploaded again with a small script change. Please clear your browser cache first, don't want you to download a cached old .zip. Thanks.
Flashing. Really? I could be downloading an older zip if I don't clear cache? That's.. interesting.

---------- Post added at 04:55 AM ---------- Previous post was at 04:54 AM ----------

That's weird. It might be some F2FS bug. I'm on the latest code version of the filesystem and I already suggested OP to update F2FS too. I'm guessing a bit though, but messages not saving to disk is weird.
Oh that's probably the issue. eng.stk said he used the OP sources; you're using the latest. Somehow that doesn't happen on the stock kernel though.
 

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
WTF... what happens if you try to do this on adb shell:
Still now wifi here as well. Running the command.
I'm a bit scared, there's another issue. My data is getting derped now. Some of my apps got uninstalled and some of my app data got wonky after the kernel flash. F2FS?
 

pvillasuso

Senior Member
Apr 16, 2007
1,673
706
143
Dunno if this is gonna help
At some point when I was trying to make this work , I went to recovery and tried to wipe in order to restore a twrp backup ... but the data partiton got corrupted : it was showing something like /data/franco... in red letters ( should have taken a screenshot )
I had to run the repair file system tool ( that comes with twrp ) to get if fixed :(
 

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
Dunno if this is gonna help
At some point when I was trying to make this work , I went to recovery and tried to wipe in order to restore a twrp backup ... but the data partiton got corrupted : it was showing something like /data/franco... in red letters ( should have taken a screenshot )
I had to run the repair file system tool ( that comes with twrp ) to get if fixed :(
Yeah I got the same thing while reflashing kernel. Data for some app not found or corrupted in red text.
 

pvillasuso

Senior Member
Apr 16, 2007
1,673
706
143
Still now wifi here as well. Running the command.
I'm a bit scared, there's another issue. My data is getting derped now. Some of my apps got uninstalled and some of my app data got wonky.
This !!!!
I didnt get there , but read my previous post , makes sense
Maybe thats why I lost root at some point :eek:
 

franciscofranco

Recognized Developer
Dec 9, 2010
24,725
136,397
0
Carcavelos
Still now wifi here as well. Running the command.
I'm a bit scared, there's another issue. My data is getting derped now. Some of my apps got uninstalled and some of my app data got wonky after the kernel flash. F2FS?
What happens after you run that insmod command?

Dunno if this is gonna help
At some point when I was trying to make this work , I went to recovery and tried to wipe in order to restore a twrp backup ... but the data partiton got corrupted : it was showing something like /data/franco... in red letters ( should have taken a screenshot )
I had to run the repair file system tool ( that comes with twrp ) to get if fixed :(
Doubt that's the Kernel, could easily be TWRP's ****. F2FS code is straight from the stable channel from Linux, there's no ****ery.
 

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
What happens after you run that insmod command?



Doubt that's the Kernel, could easily be TWRP's ****. F2FS code is straight from the stable channel from Linux, there's no ****ery.
Did I do this right? Output doesn't make sense. It said "not root" , so I tried it with root as well.

About the red text and data thing, that never happened before with TWRP while flashing other Roms and kernels or backup or restore.
 

Attachments

pvillasuso

Senior Member
Apr 16, 2007
1,673
706
143
About the red text and data thing, that never happened before with TWRP while flashing other Roms and kernels or backup or restore.
Same here , never had a problem before with the OP3T using twrp

What I don´t get is why I manage to finally flash it and run it without issues and you can´t, if we followed the same steps :confused:
 

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
Same here , never had a problem before with the OP3T using twrp

What I don´t get is why I manage to finally flash it and you can´t, if we followed the same steps :confused:
What are you talking about? I was able to flash it. The problems are no wifi, and data is getting derped. Apps get uninstalled and app data is lost when I flashed the latest kernel that was uploaded.
@franciscofranco I see this everytime i boot into TWRP now. The red text mentions speedtest; that's the app that's getting uninstalled. (that was the only app I installed after flashing your kernel).

Re flashing stock ROM and Tyranus kernel (seems to be the only bug free kernel right now) for now so I can go to sleep. I'm sure the other kernels will get better soon though, like Franco said, new device. Then I'll have a new problem, choosing which kernel to flash from all the cool ones. I don't even have enough knowledge about Android to compare and see which one is better and why. :(
 

Attachments

Last edited:

pvillasuso

Senior Member
Apr 16, 2007
1,673
706
143
What are you talking about? I was able to flash it. The problems are no wifi, and data is getting derped. Apps get uninstalled and app data is lost when I flashed the latest kernel that was uploaded.
@franciscofranco I see this everytime i boot into TWRP now. Re flashing stock ROM and Tyranus kernel for now so I can go to sleep.
Chill Bro
I edited sorry , missed the part about running it without issues
 

franciscofranco

Recognized Developer
Dec 9, 2010
24,725
136,397
0
Carcavelos
What are you talking about? I was able to flash it. The problems are no wifi, and data is getting derped. Apps get uninstalled and app data is lost when I flashed the latest kernel that was uploaded.
@franciscofranco I see this everytime i boot into TWRP now. The red text mentions speedtest; that's the app that's getting uninstalled. (that was the only app I installed after flashing your kernel). Re flashing stock ROM and Tyranus kernel (seems to be the only bug free kernel right now) for now so I can go to sleep.
Weird about that red text on /data. I'll revert F2FS upstream bring-up I guess. Sorry.
 
  • Like
Reactions: knpk13

knpk13

Senior Member
Dec 11, 2015
2,090
1,205
193
Chill Bro
I edited sorry , missed the part about running it without issues
Haha, I'm calm as always. I was just confused. I edited too.

Weird about that red text on /data. I'll revert F2FS upstream bring-up I guess. Sorry.
Thanks! Wonder what the problem was with the latest F2FS. Was having more problems, so restoring backup. It's bedtime for me though, so no testing for me until tomorrow. :silly:
 
Last edited:
Status
Not open for further replies.