• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[KERNEL][ROOTED][PIE] Performance Enhanced Overclock Kernel

Search This thread

BXM500

Senior Member
Dec 4, 2010
112
19
Has anyone managed to get it work on 8.2.3?

When I flash the latest 1.5.1 kernel I don't get the root. Meaning the rootfan 1.3 app won't apply the overclock settings.
When I flash the latest Magisk 23 to get the root - I will lose the 1.5.1 kernel.

Catch 22?
 
Jan 21, 2012
19
4
Boise
  • Like
Reactions: mr.wrinw

toddre

Member
Aug 18, 2007
23
2
I was having a hard time with getting magisk to work on mine, so once I did I wrote up a little tutorial to root on 8.2.3. Basically download boot-magisk23.0.img then flash in fastboot.

fastboot flash boot boot-magisk23.0.img

Root tutorial for 2017 Nvidia Shield 8.2.3
Interesting, I had no luck getting root on 8.2.3. The boot image you posted was created with Magisk? Have not tried your image but the best I was ever able to get was a loop. Will post a follow up after investigation.
 
Jan 21, 2012
19
4
Boise
Interesting, I had no luck getting root on 8.2.3. The boot image you posted was created with Magisk? Have not tried your image but the best I was ever able to get was a loop. Will post a follow up after investigation.

Yes, the boot.img that I patched with Magisk was pulled from the Nvidia developer firmware, so it should work on 2017 version Shield running on 8.2.3
 

toddre

Member
Aug 18, 2007
23
2
Yes, the boot.img that I patched with Magisk was pulled from the Nvidia developer firmware, so it should work on 2017 version Shield running on 8.2.3
Anyone else having any LUCK?? Still no luck for me. I have been rooting two of these 2017 Shield's for years and have never had a problem in the past. I will have a go with my second unit since I only used my primary unit as a test bed rooting 8.2.3, didn't see any reason to try on the second. Not really a big deal since having root is not very important to me anymore as in the past.
 

Don_Pachuco

Senior Member
Jan 25, 2014
142
18
Milwaukee
So I only read the first page on this, but does this, or any rom for the shield P2571, work as a one click type thing, or what do you have to do to flash a shield? Also, anything newer in terms of Android version or what have you?
 

beatLeo

Senior Member
Nov 2, 2013
85
13
So, is it possible to use the kernel on 8.2.3 on nstp 2015? Please, i would like your answers.
 

beatLeo

Senior Member
Nov 2, 2013
85
13
Ok, i'll do it. I've been waiting so long to root and improve my shield. I have a 2015 pro. But i need a recovery image for 8.2.3, just in case i breake my shield. Does anybody knows where can i find a recovery image?
 

beatLeo

Senior Member
Nov 2, 2013
85
13
By the way, is this ok? My benchmarks are way below the one some people have put here. And i always tought my shiled tv pro 2015 was a litle bit better because it has a 500 gb ssd M.2. And by the way, how can i choose vulkan on 3DMark? i don't find the option to choose.
 

Attachments

  • 3DMark_20211201_224828.png
    3DMark_20211201_224828.png
    547.3 KB · Views: 29
  • Geekbench 5_20211202_002218.png
    Geekbench 5_20211202_002218.png
    94.3 KB · Views: 29

xd4d3v

Senior Member
Jun 18, 2009
701
63
It's anyone maintaining this? I'd love for the kernel to include the USB tv tuners. That was abandoned a long time ago as far as I know
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    And now with android 11 rolling, is someone going to make this kennel for this version?
  • 32
    The latest kernel, R1.5, is for Shield experience 8.0.1. Supported Shield TVs include all 2015 and 2017 models. The 2019 models are not supported. To install, simply flash rootfan_kernel_r1,5.zip using this twrp https://drive.google.com/open?id=1934405D1S0lv52jZMqS-Zny62RIzGWSi. Features include 2.22 GHz CPU overclock, 1.23 GHz GPU overclock, 1866 Mhz RAM overclock, disabled verity, permissive selinux, and completely customizable fan settings. Magisk is also included for root access. All of the settings in this kernel are modifiable using my Shield Tools V1.3 app, so make sure to download that too. Enjoy the kernel and leave any feedback that you may have :)

    R1.5.1 Beta Info
    The R1.5.1 beta aims to fix the magisk modules problem and the bootloop issue that effects some 2017 (darcy) Shield TVs. As I don't have a 2017 Shield TV, I can't test this. Let me know if it works and if you're still having problems and want to help then follow the the instructions in this post to provide a debug log https://forum.xda-developers.com/showpost.php?p=80774055&postcount=188.

    Note: If you only want root, just install the latest magisk canary release. It works fine on 2015 and 2017 Shield TVs now.
    If you're still using oreo / 7.2.3 then use the original shield tools app and the stuff in this post https://forum.xda-developers.com/showpost.php?p=80110657&postcount=18


    Kernel Sources: https://github.com/rootfan/

    Standard Disclaimer: You're responsible for what you do to your devices, so don't blame anyone else if something goes wrong :good:
    Changelog:
    R1.1:
    Prerooted with magisk
    Selinux is permissive by default

    R1.2:
    GPU Overclock up to 1.23 GHz
    Boot frequencies are default and must be adjusted manually (using my app) to overclock
    Ondemand and interactive governors added. Interactive is default
    (debug feature) Serial console over ttyUSB0
    First release of shield tools, an app to help tune this kernel. Shield Tools does not work with earlier releases

    R1.3
    First release for pie
    Fully customizable fan settings
    Shield tools updated to V1.1 with fan controls and changes needed for pie
    Vendor and system verity are disabled
    System as root is removed to support Magisk.

    R1.3.1
    Use kernel modules again to fix some bugs such as USB issues.

    R1.4 / Shield Tools 1.2.1
    Kernel updated from 4.9.140 to 4.9.162
    1866 MHz RAM Overclock (Improves graphics performance significantly)
    Power throttling added by Nvidia in the pie release has been removed
    RAM control added to Shield Tools
    Shield Tools saves settings and applies them on boot now
    Shield Tools 1.2.1 fixes fan settings for 2017 shields.

    R1.5 / Shield Tools 1.3
    Kernel updated with Nvidia's latest rel-32-r7 sources
    Many more selectable RAM frequencies
    RAM voltage is slightly increased at frequencies above 1725 MHz
    New installation method that doesn't modify the system or vendor partitions
    Standby frequency reset issue fixed (actually fixed in Shield Tools 1.2.2)
    Kernel version is 4.9.140 again, but the sdcard bootloop issue is gone
    3
    @SkOrPn, upgrading Magisk should work fine with R1.4. I upgraded directly from Magisk Manager without issue. The problem you had seems to be that Shield Tools was denied root access. If you have any further problems make sure that Shield Tools has been granted root permission in Magisk Manager. @urkelz, I haven't seen the cpu overclock reset when coming out of standby. If it's an issue that others are having I'll look into fixing it.

    Magisk Rooted / Overclockable Boot.img
    Below you'll find a fastboot flashable magisk rooted overclock kernel. Extract the zip and fastboot boot the image to see if it works. If all goes well, you can flash it. Hopefully this will make the installation process easier for those that have had problems. You cannot update Magisk when using this version though and you may need to install the Magisk Manager app seperately. Also, as I only have the 2015 shield pro, you'll have to let me know if it works on the other models. @[email protected], go ahead and give this a try. You don't need a mouse for it.
    3
    I was under the impression magisk is root and kernal is for overclocking totally separate. I think once I read through the thread again the kernal is for overclocking and it is separate but only works on 7.2.3 guess I totally missed it I swear I've read this thread 10 times now. So root works on 8.0 but kernal only on 7.2.3. Can anyone confirm please.
    Yes, as it says on the main thread.

    kernel is part of the boot.img
    So both zip's contains a kernel, one of them has an edited kernel containing overclocks, other one dosnt.
    Both are rooted with magisk.

    The one for 7.2.3, is overclocked and rooted.
    The one for 8.0 is rooted.
    3
    @dfl and @imoldchen I've been working on an overclock kernel for 8.0. The kernel is basically ready to go, but I want to provide full fan control which will require some additions to the shield tools app. Hopefully I'll be able to get something out soon. @snake218 if you're on full android oreo and not pie, your best bet is to use the zip and twrp provided in this post https://forum.xda-developers.com/showpost.php?p=80110657&postcount=18. The problem is that you need the shield tools app to enable overclocking, and that is designed for android tv so it may not work on the full android that you're using.
    3
    Thank you so much for this! The performance increase is amazing on Shield 2015.

    For questions regarding Compatibility: Check that the first five digits of your kernel version under System-> Info match with the one you are about to flash (4.9.140-xxxxxxxxx), that should work, I am on Shied TV 8.2.2 .

    Widevine (Netflix etc.) is not affected.

    Flashing instructions:

    1. Boot to fastboot ( adb reboot bootloader )
    2. Unlock bootloader - this will wipe ALL of your data ( fastboot oem unlock )
    3. Reboot and reenable developer options
    4. Boot to twrp ( fastboot boot your/twrp/image.img
    5. Via MTP place the Kernel in the shields /sdcard
    6. With mouse flash the kernel using the gui
    7. Boot the device
    8. Install Shieldtools.apk ( adb install path/to/your/shield-tools.apk
    9. Launch Shield tools and grant root permissions permanently
    10. Tweak your settings
    11. Enjoy your overclocked Shield!

    I have maxed out all settings and it is working great, additionally I changed the fan settings for >70°C to max speed, since then I don't get any freezes.


    I have tested one game of which I knew performs badly on stock shield settings (Mario Kart WII on luigi circuit) and Dolphin MMJR, on stock Kernel. With all performance enhancing tweaks the max game speed on the first map is 78%, native Wii resolution.
    Using the same conditions with maxed out kernel and performance governor the max game speed goes as high as 92% - when there is not too much action going on on screen! It is definitly playable now though.

    On 720p Fps vary around 44 and 47 and the game speed is between 70% and 80%, looks nice, but feels slow.

    Sling Shot Extreme Open GL ES 3.1 on 3DMark gives 4438 points and Sling Shot on 3DMark gives 512 points, making it better than 95% than all other shields according to the stats.

    Thank you very much for this development.