[Kernel] SEtweak - insecure ADB, ext4, NTFS, overclock, USB OTG - updated 24th July

Status
Not open for further replies.
Search This thread

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
First custom kernel for Xperia Play, built from SE's sources.

SEtweak is based on Sony Ericsson 3.0.1.A.0.145 sources. You need 3.0.1.A.0.145 FW to eliminate problems!

Donation thread.

Features: NTFS support - still buggy, ext4 support, insecure adb shell, USB OTG, bcm4329 driver included in kernel image (separate module not required).

Future plans:
* USB HID driver to use phone as USB game controller.
* add su binary and Superuser.apk for auto-rooting

Version: RC0 - hopefully all bugs are fixed. If tests show everything is OK, I can move to gamepad HID ;)

Instructions:
* Unlock bootloader
* fastboot flash boot /path/to/boot.img
* To return to stock kernel, use this: http://forum.xda-developers.com/showpost.php?p=14821537&postcount=17

Download here: http://www.mediafire.com/?ivb9mvt9s396m

Blagus, FreeXperia team
 
Last edited:

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
To restore back, make loader.sin+kernel.sin flash bundle and flash it... I think I'll make one just in case... ;)
 

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
While you do it, make a tutorial so that we can do that package too, and relay the instructions :)

Simple... take flash bundle for 3.0.1.A.0.145 FW. Open with zip archiver. Take loader.sin and kernel.sin, open FlashTool, Bundle creation, navigate to extraction folder, take loader and kernel sin images and upload ftf bundle here.
 

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
Uploaded first release... in "stock" folder you have kernel unbrick package - make flash bundle and flash it. I couldn't because in Linux I can't run FlashTool...
 

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
Leave that. I'll switch to Windows, now flash this and test it ;)
 

svenk919

Senior Member
Oct 12, 2008
418
62
Enschede
After reboot in the notification screen it gives the message it's safe to remove the sd card and I can't copy anything to it. Rebooting and trying again.

After reboot it still tries to have you remove the SDcard and it's still not accessible. Also the last_ksmg file seems gone after this second reboot :confused:
 
Last edited:
  • Like
Reactions: Blagus

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
After reboot in the notification screen it gives the message it's safe to remove the sd card and I can't copy anything to it. Rebooting and trying again.

But kernel works? Can you go to system info and say what does it say under kernel version? Test BT, Wi-Fi, calls, etc.
 

svenk919

Senior Member
Oct 12, 2008
418
62
Enschede
Was about to flash back the standard stuff. Boot time is impressive btw, from the start of the bootanimation it takes 8 seconds to get to the lock screen (I have a minimal of bloatware, removed most of that but this seems faster then before).

3g data Does work.
calling over gsm does work.
Camera doesn't. (directly gives error in pop-up screen)
When trying to turn on wi-fi it just says error in the button (no pop-up screen)
Bluetooth seems stuck on turning on.

Will test some more in service menu.

Kernel version: 2.6.32.9-Blagus
[email protected] #1

:)

Edit: Service menu says that the camera is not connected when testing the back camera, when testing the front camera it just gives a black screen.

Service menu seems to get stuck when turning on bluetooth to... reboot needed.

SD card status in service menu is unmounted.
 
Last edited:
  • Like
Reactions: Logseman and Blagus

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
Thanks a lot! Exactly as expected, Wi-Fi and BT problems... luckily, basic phone functionality works... I'm really happy about this, plus the satisfaction of seeing "[email protected] #1" in kernel build :p

Edit: after full test, reboot the phone and cat /proc/last_kmsg > /data/local/tmp/log.txt, then adb pull /data/local/tmp/log.txt and put here.
 

svenk919

Senior Member
Oct 12, 2008
418
62
Enschede
Flashing files back but it seems to be stuck at flashing kernel.sin:

17/056/2011 21:56:09 - INFO - Start Flashing
17/056/2011 21:56:09 - INFO - ER="R9A021";DATE="20110128";TIME="11:49:00";
17/056/2011 21:56:09 - INFO - Flashing loader
17/056/2011 21:56:11 - INFO -PROT_VER="03";DATE="20110217";TIME="15:47:00";VER="R4A066";CXC="1234-5769";TYPE="S1_LOADER";UNIQUE_DEV_ID="DCA207C3D8672C37B5CF94204C71E3209443D622";SEC_LOCK_STATUS="LOCKED";OTP_DATA="4B6D7100471404C81504042800847199B001002000000000";IMEI="35730204066248";AID_VERSION="0004";EROM_AID="0001";LOADER_AID="0001";SW_AID="0001";CUST_AID="0001";SIM_LOCK_AID="0001";HWCONF_AID="0001";PROD_ID="0001";ACTIVE_LOADER_AID="0001";MEMDEVS="02:00:002C:00B3:0000:00002000:00020000:00000800:00000040,03:03:0003:5344:0080:0003B598:00010000:00000200";MAN_ID="002C";DEV_ID="00B3";SIN_VER="0001";AID_TAMP="NOT_TAMPERED";MAX_PKT_SZ="00010000";AUTH_LEVEL="NONE";AUTH_MET="0001";CARD_PRESENT="YES";CARD_SIZE="16GB";CARD_DATA="UHJvZE5vPTEyNDktNzE5MQ1Qcm9kUmV2PVIzQQ1Db3BpZWRCeXRlcz0xNDcxOTU4MjkzDUNvcGllZEZpbGVzPTE1MjQwDUNvcGllZERpcnM9ODQNT3JkZXI9OTAxNTg2OC0xMA0=";LOADER_ROOT="S1_Loader_Root_773f";EROM_ROOT="S1_EROM_Root_d601";SW_ROOT="S1_SW_Root_883f";CUST_ROOT="S1_Cust_Root_9603";SIM_LOCK_ROOT="S1_SL_Root_c422";HW_CONF_ROOT="S1_HWConf_Root_08af";BIM_STATE="DISABLED";
17/056/2011 21:56:11 - INFO - Flashing kernel.sin

For like 4 minutes now :(
 

Blagus

Inactive Recognized Developer
Jun 10, 2010
1,323
1,046
Hmm... I think I've packed some wrong kernel image... do you have 2.3.3 flash files on your PC - either in ftf bundle, or you upgraded via SEUS?
 
  • Like
Reactions: svenk919

svenk919

Senior Member
Oct 12, 2008
418
62
Enschede
Took the kernel.sin and loader.sin from the UK .145 firmware and made a new tft with that. All seems to be working now :)

Attached the working stock kernel and loader ftf for others.

Edit: after flashing back I could copy the file to my SD card. Will PM it.
 
Last edited:
  • Like
Reactions: Blagus

svenk919

Senior Member
Oct 12, 2008
418
62
Enschede
Flashed your kernel again but now there is no last_ksmg after first boot. Also adb can't find my device, usb debugging is enabled :/

Root explorer works though. Will try another reboot.

Edit: still not there after reboot :( is the normal ksmg of any use?
 
Last edited:
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    First custom kernel for Xperia Play, built from SE's sources.

    SEtweak is based on Sony Ericsson 3.0.1.A.0.145 sources. You need 3.0.1.A.0.145 FW to eliminate problems!

    Donation thread.

    Features: NTFS support - still buggy, ext4 support, insecure adb shell, USB OTG, bcm4329 driver included in kernel image (separate module not required).

    Future plans:
    * USB HID driver to use phone as USB game controller.
    * add su binary and Superuser.apk for auto-rooting

    Version: RC0 - hopefully all bugs are fixed. If tests show everything is OK, I can move to gamepad HID ;)

    Instructions:
    * Unlock bootloader
    * fastboot flash boot /path/to/boot.img
    * To return to stock kernel, use this: http://forum.xda-developers.com/showpost.php?p=14821537&postcount=17

    Download here: http://www.mediafire.com/?ivb9mvt9s396m

    Blagus, FreeXperia team
    3
    alpha2 coming!
    Changelog:
    * kernel renamed to SEtweak
    * NTFS support revised, debugging enabled
    * Wi-Fi fixes - still will go through a test before release
    * force module loading and versioning disabled (was enabled in alpha0 and alpha1)
    * bcm4329 module for Wi-Fi
    2
    Was about to flash back the standard stuff. Boot time is impressive btw, from the start of the bootanimation it takes 8 seconds to get to the lock screen (I have a minimal of bloatware, removed most of that but this seems faster then before).

    3g data Does work.
    calling over gsm does work.
    Camera doesn't. (directly gives error in pop-up screen)
    When trying to turn on wi-fi it just says error in the button (no pop-up screen)
    Bluetooth seems stuck on turning on.

    Will test some more in service menu.

    Kernel version: 2.6.32.9-Blagus
    [email protected] #1

    :)

    Edit: Service menu says that the camera is not connected when testing the back camera, when testing the front camera it just gives a black screen.

    Service menu seems to get stuck when turning on bluetooth to... reboot needed.

    SD card status in service menu is unmounted.
    2
    In next release I'll investigate NTFS issue. Maybe it's not made for SD cards, or simply I accidentally disabled in in kernel config :p
    Also, I'm looking at overclocking, and Wi-Fi fixing. Camera is on a small hold until I fix Wi-Fi (it's more important than camera).
    1
    are u sure those ones are for Play/Arc/Neo?

    cause X10 GB FW is numbered 3.0.1.G.0.75


    i think they are for the new Xperias

    The F version should be for the arc also: http://developer.sonyericsson.com/wportal/devworld/downloads/download/301f0131tarbz2?cc=gb&lc=en

    And you know better then me if it can be used for the xperia play then.