[KERNEL] -> tegra-3.18_unified_dragon_kernel_11_v201218

Search This thread

bbawden

Member
May 14, 2010
48
2
Pls install latest bootloader via fastboot.

Pls unzip the Update.Zip package and install boot.img via fastboot.

Pls install TWRP 3.1.0-2 via fastboot

Reboot into recovery via hardware keys - not into system in between.

Restore your last backup.

You may install supersu at this point.

Reboot into system

Thanks for the quick reply. I'll try that and let you know.
:good:
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
Thanks for the quick reply. I'll try that and let you know.
:good:

I have added one point .. to clean your "old" stuff first.

- Pls install latest bootloader via fastboot.
- Pls unzip the Update.Zip package and install boot.img via fastboot.
- Pls install TWRP 3.1.0-2 via fastboot
- Reboot into recovery via hardware keys - not into system in between.
- Do "factory reset" in TWRP
- Restore your latest backup - data partition only !
- You may install supersu at this point.
- Reboot into system

Good luck !
 
  • Like
Reactions: Alxoom33

bbawden

Member
May 14, 2010
48
2
Here are the steps I did:
- fastboot flash bootloader bootloader-dragon-google_smaug.7900.50.0.img
- fastboot flash boot boot.img (the boot.img extracted from Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip)
- fastboot flash recovery TWRP_dragon_3.1.0-2.img
- power + volume dn to reboot to recovery
- TWRP factory reset
- TWRP restore backup of data partition
- reboot

Still get the hang on Google logo for over 1 hour
What can I try now? Is there a different zip I need to install?

Thanks
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
Here are the steps I did:
- fastboot flash bootloader bootloader-dragon-google_smaug.7900.50.0.img
- fastboot flash boot boot.img (the boot.img extracted from Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip)
- fastboot flash recovery TWRP_dragon_3.1.0-2.img
- power + volume dn to reboot to recovery
- TWRP factory reset
- TWRP restore backup of data partition
- reboot

Still get the hang on Google logo for over 1 hour
What can I try now? Is there a different zip I need to install?

Thanks

No need to wait for one hour.. maybe a few minutes.

Pls use n4f26t stock image and flash system.img and vendor.img via fastboot.

We need to get your system running first.
 

bbawden

Member
May 14, 2010
48
2
No need to wait for one hour.. maybe a few minutes.

Pls use n4f26t stock image and flash system.img and vendor.img via fastboot.

We need to get your system running first.

Hi

Do you mean the img files from AOSP_Update.ZIP_PixelC_Ryu_vendor_N4F26T.zip?

Thanks

ETA: Found the official stock image, so will use the img files from that.

---------- Post added at 12:13 PM ---------- Previous post was at 11:51 AM ----------

OK, I got ryu-n4f26t-factory-d05202a0.zip from https://developers.google.com/android/images and extracted system.img and vendor.img
I did:
- fastboot flash system system.img
- fastboot flash vendor vendor.img

It boots!

You are a champion.

So do I now go back to your post #422 to get my data partition restored?

---------- Post added at 12:16 PM ---------- Previous post was at 12:13 PM ----------

Hope I didn't get my hopes up too soon - it's still on the 4 animated circles. Going out for lunch now, so I'll see what state it's in when I return.

Thanks again for all your help.

---------- Post added at 12:35 PM ---------- Previous post was at 12:16 PM ----------

Yippee; circles have gone and it's booting into system now.
 
Last edited:

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
Hi

Do you mean the img files from AOSP_Update.ZIP_PixelC_Ryu_vendor_N4F26T.zip?

Thanks

ETA: Found the official stock image, so will use the img files from that.

---------- Post added at 12:13 PM ---------- Previous post was at 11:51 AM ----------

OK, I got ryu-n4f26t-factory-d05202a0.zip from https://developers.google.com/android/images and extracted system.img and vendor.img
I did:
- fastboot flash system system.img
- fastboot flash vendor vendor.img

It boots!

You are a champion.

So do I now go back to your post #422 to get my data partition restored?

---------- Post added at 12:16 PM ---------- Previous post was at 12:13 PM ----------

Hope I didn't get my hopes up too soon - it's still on the 4 animated circles. Going out for lunch now, so I'll see what state it's in when I return.

Thanks again for all your help.

---------- Post added at 12:35 PM ---------- Previous post was at 12:16 PM ----------

Yippee; circles have gone and it's booting into system now.

We still don't know the root cause of your problem ...

Pls check SHA256 checksum for the .zip file ...

135c5664a06ddb95f48d85787c256094c513755c10f25110f8d7e648560f06ae
*Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip


Ok ?
 

bbawden

Member
May 14, 2010
48
2
Hi

All looks good on the tablet. Booted into 7.1.1, and all installed apps are fine.
I just need to flash SU to get root back, and all will be good.

No idea what went wrong before, but the checksum of the zip I applied is 13 5c 56 64 a0 6d db 95 f4 8d 85 78 7c 25 60 94 c5 13 75 5c 10 f2 51 10 f8 d7 e6 48 56 0f 06 ae

---------- Post added at 02:43 PM ---------- Previous post was at 02:23 PM ----------

Had to reflash TWRP (as the process above removed it) in order to install SU but all looks good now.
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
Hi

All looks good on the tablet. Booted into 7.1.1, and all installed apps are fine.
I just need to flash SU to get root back, and all will be good.

No idea what went wrong before, but the checksum of the zip I applied is 13 5c 56 64 a0 6d db 95 f4 8d 85 78 7c 25 60 94 c5 13 75 5c 10 f2 51 10 f8 d7 e6 48 56 0f 06 ae

---------- Post added at 02:43 PM ---------- Previous post was at 02:23 PM ----------

Had to reflash TWRP (as the process above removed it) in order to install SU but all looks good now.
If you are not rooted the system is may removing custom recovery.
Like happened for you.

The process you did is valid for all ROM problems.
Always get back a good running state.

If you don't mind install the Update.zip package again ..
Normally there should be no issue.
Install SuperSU afterwards and reboot into system.

Cheers
 

bbawden

Member
May 14, 2010
48
2
If you are not rooted the system is may removing custom recovery.
Like happened for you.

The process you did is valid for all ROM problems.
Always get back a good running state.

If you don't mind install the Update.zip package again ..
Normally there should be no issue.
Install SuperSU afterwards and reboot into system.

Cheers

OK, so you'd like me to just install Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip and SU, to test it?
 

bbawden

Member
May 14, 2010
48
2
Yes, please .. should work for you too.

I first took a backup.

When I installed the zip, it rebooted to recovery. I tried to boot it again and it went to recovery again.
I did a wipe and install and it boot looped: not hanging like before, but totally rebooting.
But a restore of my backup got it all back OK.

Let me know if you want me to test anything else.
Cheers
 
Last edited:

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
im trying to install.the andri
oid 8 beta in twrp. after i flash it i flash super su and it boots back to recovery. do i jeed to flash bootloader too?
Yes .. Bootloader is not part of the zip.
Have seen it's version .50 like the beta 2.

Will need to check the packages again ... you face similar problems like above.
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
I first took a backup.

When I installed the zip, it rebooted to recovery. I tried to boot it again and it went to recovery again.
I did a wipe and install and it boot looped: not hanging like before, but totally rebooting.
But a restore of my backup got it all back OK.

Let me know if you want me to test anything else.
Cheers
Thanks for your testing ..
Have used the packages myself for long time without issues.

Made a few changes the last time .. will check the packages again.

Will come back to you ;)

Cheers
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
I first took a backup.

When I installed the zip, it rebooted to recovery. I tried to boot it again and it went to recovery again.
I did a wipe and install and it boot looped: not hanging like before, but totally rebooting.
But a restore of my backup got it all back OK.

Let me know if you want me to test anything else.
Cheers

I have tested your installation .. no issues at all.
Not able to reproduce your problems !

- Boot into TWRP 3.1.0-2
- Wipe System
- Install Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip
- Install SR3-SuperSU-v2.79-SR3-20170114223742.zip
- Reboot into system

Made some small modifications to the Update.zip files -> forced unmount of system before start of installation.
Have seen issues where SuperSU was installing in system mode and not systemless mode .. this could make problems too.

Pls download the Update.ZIP_PixelC_Ryu_system-vendor-boot_N4F26T.zip from onedrive folder directly to your device.
Pls have another try ... just wipe system before your start to install .. nothing else.

I wish I could replicate your issue ... :)
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
im trying to install.the andri
oid 8 beta in twrp. after i flash it i flash super su and it boots back to recovery. do i jeed to flash bootloader too?

Here as well .. can't replicate your issue on my device.
Pls download the Update.Zip from the onedrive folder again .. and have another try.

Thx
 

nigelhealy

Senior Member
Aug 3, 2012
1,540
444
Preston
I see the 7.1.2 full images are imminent as some OTAs out.

Just so I know, will I need to download and fastboot flash a new bootloader before the recovery zips? I have no idea what I'm on I've not flashed an official fastboot image for some months.
 

followmsi

Senior Member
Oct 10, 2013
4,084
12,233
I see the 7.1.2 full images are imminent as some OTAs out.

Just so I know, will I need to download and fastboot flash a new bootloader before the recovery zips? I have no idea what I'm on I've not flashed an official fastboot image for some months.
My update zip packages are the same format like all the time before.
Never included bootloader.

Yes, it's recommended to use the latest one .. version .50 now ?

It's part of the factory image .Zip file from Google.

EDIT: .. google released OTA only.. the factory images will follow soon .. :)
 
Last edited:
  • Like
Reactions: whoamigriffiths

Top Liked Posts