• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ KitKat 4.4.2 ] ROM for Micromax A116 [UNOFFICIAL]

Search This thread

hyperion70

Senior Member
Dec 7, 2013
243
734
Tula
[ KitKat 4.4.2 ] ROM for Micromax A116 [UNOFFICIAL]​

For A116, FLY IQ451, MYphone919i, Wiko Cink-5, Qmobile A600​


WARNING:
I or xda is not responsible for any kind of damage to your device. Please use it at your own risk!




Features:

Real Android 4.4.2
The new kernel Linux version 3.4.67
Compiled from Linaro GCC 4.9.2 Toolchain.
Modules are integrated into the kernel
Support for 4.4.x
SElinux suport


Bugs: NO BUGS




Changelog:

ROM based on AOSP 4.4.2, compiled from source.
In the assembly partially used MMX A109 official rom
Differences from v 0.8:
- Last Hyper-kernel
- Selection a ringtone for 2 SIM
- Launcher3 from Fly
- Power menu with reboot menu
- The new file manager
- SuperSU preinstalled
- GAPPs preinstalled
- Baseband V6.F1
- Many minor changes....

DOWNLOAD LINKS:

DevHost

YANDEX

Direct Download



How to install?
1. Download the ROM
2. Put the file on the SD card
3. Boot on TWRP Recovery
4. Make a backup of current rom using Recovery PhilZTouch or TWRP 2.7.0.0 or TWRP 2.8.0.0
5. Make a wipe Data / Factory Reset
6. Flashing the ROM
7. Restart the phone (WARNING: restart can be long …)







CREDITS:
@BazhinNN
@Cheshkin
@Vla425


Sources:

Kernel:
https://github.com/hyperion70/tinno89_wet_kk
Android: ALPS.KK1.MP5.V1.3_EASTAEON89_WET_KK

XDA:DevDB Information
[ KitKat 4.4.2 ] ROM for Micromax A116 [UNOFFICIAL], ROM for the Micromax A116

Contributors
hyperion70, Cheshkin
ROM OS Version: 4.4.x KitKat
ROM Kernel: Linux 3.4.x

Version Information
Status: Stable

Created 2014-11-01
Last Updated 2014-11-03
 

Attachments

  • Screenshot_2014-11-01-08-12-39.jpg
    Screenshot_2014-11-01-08-12-39.jpg
    125 KB · Views: 18,301
  • Screenshot_2014-11-01-08-13-03.jpg
    Screenshot_2014-11-01-08-13-03.jpg
    77.7 KB · Views: 17,830
  • Screenshot_2014-11-01-08-13-13.jpg
    Screenshot_2014-11-01-08-13-13.jpg
    156.1 KB · Views: 17,272
  • Screenshot_2014-11-01-08-13-23.jpg
    Screenshot_2014-11-01-08-13-23.jpg
    120.9 KB · Views: 17,266
  • Screenshot_2014-11-01-08-13-45.png
    Screenshot_2014-11-01-08-13-45.png
    103.2 KB · Views: 17,301
  • Screenshot_2014-11-01-08-22-19.png
    Screenshot_2014-11-01-08-22-19.png
    136.2 KB · Views: 17,817
Last edited:

zeu55

Senior Member
Dec 27, 2010
294
69
Front cam switch is missing.. however cam patch from discovery solves this.
 

Andy1911

Inactive Recognized Developer
Mar 1, 2014
630
941
Pune
@blackbeard please also can you update AOKP with latest device tree of Chris? Or Atleast Can You Merge the latest Omni Rom Patches so that we can get one more stable rom


Regards,
Andy
 

hgaaditya

Senior Member
Sep 23, 2013
78
7
Bangalore
Problems on SW16

@hyperion70 I tries installing this on my CHD sw16 and faced the following problems:

1) No second sim network,although first sim appeared fine.

2)No camera app in drawer,I couldnt open camera through any other alternative also.
 

sandebal1

Member
Oct 31, 2014
27
6
yes

Does the camera work correct in this ROM? It used to close itself without any error in the previous versions


yes, camera is ok

---------- Post added at 11:46 AM ---------- Previous post was at 11:34 AM ----------

ROM doesnot recognize Airtel 2g in both slots.
Any idea how to solve.
It however recognizes 3G Airtel network

---------- Post added at 12:03 PM ---------- Previous post was at 11:46 AM ----------

@hyperion70 I tries installing this on my CHD sw16 and faced the following problems:

1) No second sim network,although first sim appeared fine.

2)No camera app in drawer,I couldnt open camera through any other alternative also.

1) Both SIMs work. But if using Airtel sim, that slot needs to enabled with 3G mode
2) Camera app works like charm
 
  • Like
Reactions: hgaaditya

hgaaditya

Senior Member
Sep 23, 2013
78
7
Bangalore
@ Sandebal1 Bro thanks for the info.. I hadn't enabled 3g so that was the problem..
Actually I had this "can't connect to camera error." I tried almost all the roms on this thread.. Still the problem persists..
So i think that might have caused the camera bug.
Does anybody have any idea if the issue is software or hardware related..? ?
I did some research on the net and it says that the problem is a software issue but None of the solutions worked for me.. Might have to flash stock rom through sp tools..
 

sandebal1

Member
Oct 31, 2014
27
6
@ Sandebal1 Bro thanks for the info.. I hadn't enabled 3g so that was the problem..
Actually I had this "can't connect to camera error." I tried almost all the roms on this thread.. Still the problem persists..
So i think that might have caused the camera bug.
Does anybody have any idea if the issue is software or hardware related..? ?
I did some research on the net and it says that the problem is a software issue but None of the solutions worked for me.. Might have to flash stock rom through sp tools..

@hyperion70, could you please provide a solution. I am using dual sim and when I select my second sim as 3G for Internet, my 1st Sim Airtel has no network. I cannot always keep the airtel sim on 3G mode..

Please help:(:crying:
 

Andy1911

Inactive Recognized Developer
Mar 1, 2014
630
941
Pune
@ Sandebal1 Bro thanks for the info.. I hadn't enabled 3g so that was the problem..
Actually I had this "can't connect to camera error." I tried almost all the roms on this thread.. Still the problem persists..
So i think that might have caused the camera bug.
Does anybody have any idea if the issue is software or hardware related..? ?
I did some research on the net and it says that the problem is a software issue but None of the solutions worked for me.. Might have to flash stock rom through sp tools..
Bro... Its the hardware problem..... You must be having new hardware Phone...and camera bug is present in new hardware phones... So wait till bug is solved.
By The Way, Is The Minor Ui Lag Bug Fixed?

Regards
Andy
 
Last edited:

sandebal1

Member
Oct 31, 2014
27
6
Bro... Its the hardware problem..... You must be having new hardware Phone...and camera bug is present in new hardware phones... So wait till bug is solved.
By The Way, Is The Minor Ui Lag Bug Fixed?

Regards
Andy

Hi Andy,

Any idea with Airtel 2G bug? Cannot latch on to Airtel 2G network in both Sim slots
If 3G is enabled then, we can latch on to Airtel network or else cannot
Any patch/workaround?
 

sandebal1

Member
Oct 31, 2014
27
6
Try Flashing P19 Baseband and hope it solves ur issue :)

i HAD UPDATED TO 4.2.1 ...S9201_4.2_MP_F3F8_B1_IN_MMX_14_FLASHER_USER and then updated to MOLY.WR8.W1248.MD.WG.MPV6.F1,2013/07/11 18:42

If this is not P19 Baseband, could you please help with the link to download

---------- Post added at 03:05 PM ---------- Previous post was at 02:48 PM ----------

@hyperion70 I tries installing this on my CHD sw16 and faced the following problems:

1) No second sim network,although first sim appeared fine.

2)No camera app in drawer,I couldnt open camera through any other alternative also.

Flashed the below Baseband and the issue resolved for (1)
http://forum.xda-developers.com/attachment.php?attachmentid=2977778&d=1413779812
 
  • Like
Reactions: MrMoon

Top Liked Posts