[KITKAT] [4.4.4] CyanogenMod for Samsung S6310

Search This thread

NV-Dev

Senior Member
May 7, 2015
145
283
cyanogenmod-logo.jpg


Hi guys

After working a long time it has finally managed to boot into CyanogenMod 11 4.4.4 KitKat for royss


  • Bugs
  • Audio (You hear very low, during a call , the other person does not hear you . )
  • Camera (is detected, but fail to connected)
  • Bluetooth
  • Offline charging

Releases:

  1. Alpha 1 [2015-09-07]
  2. Beta 1 [2015-09-18]
  3. Beta 2 [2015-09-21]
  4. Beta 3 [2016-02-11]
  5. Beta 4 [2016-02-15]

How to install:
  1. Make sure you have TWRP installed and backup
  2. Download the ROM.
  3. Place the ROM in your internal storage.
  4. Reboot to recovery.
  5. Make a backup (EFS, very important).
  6. Wipe Data, Dalvik Cache and Cache
  7. Flash the ROM.
  8. Optional- Flash gApps.
  9. Reboot and Enjoy.

Bug reporting:

https://github.com/CyanogenMod-S6310/bugs_report/issues

1) Visit the above link
2) Click on "New issue"
3) Enter title that explains the problem
4) Explain your problem very clearly with as much details as possible
5) Attach logs and screenshots (if needed)

Don't report a bug if it's already reported.
Don't report a bug if you:
1) have restored apps with Titanium Backup or similar software
2) are using any kind of task killer
3) are using any 3rd party tweak/hack

If you want to donate, you can do, thanks :D


XDA:DevDB Information
CyanogenMod 11, ROM for the Samsung Galaxy Young S6310

Contributors
NV-Dev
Source Code: https://github.com/CyanogenMod-S6310

ROM OS Version: 4.4.x KitKat
ROM Kernel: Linux 3.4.x
ROM Firmware Required: Stock ROM
Based On: CyanogenMod

Version Information
Status: Beta
Beta Release Date: 2016-02-11

Created 2015-09-10
Last Updated 2016-02-13
 

Attachments

  • Screenshot_2016-02-12-12-16-45.png
    Screenshot_2016-02-12-12-16-45.png
    133.9 KB · Views: 13,510
  • Screenshot_2016-02-12-12-16-52.png
    Screenshot_2016-02-12-12-16-52.png
    142.2 KB · Views: 13,443
  • Screenshot_2016-02-12-12-17-02.png
    Screenshot_2016-02-12-12-17-02.png
    52.7 KB · Views: 13,438
Last edited:

NV-Dev

Senior Member
May 7, 2015
145
283
Reserved

Code:
[LIST]
[*]Alpha 1 [2015-09-07]
- First release
[/LIST]

[LIST]
[*] Beta 1
- [COLOR="green"][B]Fixed RIL[/B][/COLOR]
- Overclocked kernel to 1.3Ghz
- New device-tree and vendor
- Fixed SELinux 
[/LIST]

[LIST]
[*] Beta 2
- [COLOR="green"][B]Fixed FC in some apps[/B][/COLOR]
- Use libwebcore instead of chromium (This fixes the force close applications)
- Fixed rotation
- Change bootlogo [HIDE][img]http://imgur.com/6Zh6x6el.png[/img][/HIDE]
[/LIST]

[LIST]
[*] Beta 3
- The MTP was arranged .
- The density is again 160DPI
- The camera is already recognized, but fails to connect .
- The Audio HAL has been updated and now Audio CAD is used (no change on errors of audio, as usual)
- It was fixed the FC equalizer .
- The browser works correctly. (Libwebcore is still used because it does not cause lags)
- Ramdisk has been modified so that the audio CAD work.
 -Ramdisk has been modified so the camera That was Recognized .
- audio_policy.conf was updated
Kernel:
- Add F2FS Support and enable it
- Add UHID Driver and enable it
[/LIST]
[LIST]
[*] Beta 4
- Updated device-tree
- Updated vendor
- Fixed mini bug on browser
- Merge new logo [HIDE][img]http://i.imgur.com/bPtUyKg.png[/img][/HIDE]
- Merge CMAccount in the source
[/LIST]
 
Last edited:

Mr,bluwe

Senior Member
Feb 19, 2015
255
261
Amman
Have you fixed the low audio bug? As on the previous build all the sound was coming only from the earpiece. .

Sent from my GALAXY Core Prime (G361H) using Tapatalk
 
  • Like
Reactions: eedam

weritos

Senior Member
May 3, 2012
510
2,238
Chelabinck
Audio (You hear very low, during a call , the other person does not hear you . )
Samsung GT I8552
Exactly the same problem ...
All the sound comes through the earpiece

Camera
Fix on the platform (msm7x27a)

You help me mo sound, and I in you launch the camera :eek:
 
  • Like
Reactions: h4r

Mr,bluwe

Senior Member
Feb 19, 2015
255
261
Amman
Can you please find a way to get dual SIM detectable even if one SIM worked that would be enough

Sent from my GALAXY Core Prime (G361H) using Tapatalk
 

NV-Dev

Senior Member
May 7, 2015
145
283
:)

Audio (You hear very low, during a call , the other person does not hear you . )
Samsung GT I8552
Exactly the same problem ...
All the sound comes through the earpiece

Camera
Fix on the platform (msm7x27a)

You help me mo sound, and I in you launch the camera :eek:

Contact me to discuss that. :)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 45
    cyanogenmod-logo.jpg


    Hi guys

    After working a long time it has finally managed to boot into CyanogenMod 11 4.4.4 KitKat for royss


    • Bugs
    • Audio (You hear very low, during a call , the other person does not hear you . )
    • Camera (is detected, but fail to connected)
    • Bluetooth
    • Offline charging

    Releases:

    1. Alpha 1 [2015-09-07]
    2. Beta 1 [2015-09-18]
    3. Beta 2 [2015-09-21]
    4. Beta 3 [2016-02-11]
    5. Beta 4 [2016-02-15]

    How to install:
    1. Make sure you have TWRP installed and backup
    2. Download the ROM.
    3. Place the ROM in your internal storage.
    4. Reboot to recovery.
    5. Make a backup (EFS, very important).
    6. Wipe Data, Dalvik Cache and Cache
    7. Flash the ROM.
    8. Optional- Flash gApps.
    9. Reboot and Enjoy.

    Bug reporting:

    https://github.com/CyanogenMod-S6310/bugs_report/issues

    1) Visit the above link
    2) Click on "New issue"
    3) Enter title that explains the problem
    4) Explain your problem very clearly with as much details as possible
    5) Attach logs and screenshots (if needed)

    Don't report a bug if it's already reported.
    Don't report a bug if you:
    1) have restored apps with Titanium Backup or similar software
    2) are using any kind of task killer
    3) are using any 3rd party tweak/hack

    If you want to donate, you can do, thanks :D


    XDA:DevDB Information
    CyanogenMod 11, ROM for the Samsung Galaxy Young S6310

    Contributors
    NV-Dev
    Source Code: https://github.com/CyanogenMod-S6310

    ROM OS Version: 4.4.x KitKat
    ROM Kernel: Linux 3.4.x
    ROM Firmware Required: Stock ROM
    Based On: CyanogenMod

    Version Information
    Status: Beta
    Beta Release Date: 2016-02-11

    Created 2015-09-10
    Last Updated 2016-02-13
    16
    L
    lesleyxxx15
    Stable 1

    Welcome
    To Stable 1!

    Bugs:
    - Video playback (Working on this)
    - Camera (Caused by the video playback bug)

    Changelog:
    - Updated CAD definitions (by @techyzen101), this fixes audio related bugs.
    - Updated kernel to support display-caf which is now being used (this broke video playback)
    - Offline charging now fully working (again @techyzen101)
    - Removed the camera binary to fix an issue with deep sleep
    - Updated BlueZ to 5.38 (thanks @NV-Dev)

    Current status:
    Trying to fix OMX (video playback) and will continue working on CM12+ if I do not get it fixed in two weeks.

    Download:
    Stable 1

    ROM is being maintained by @techyzen101
    13
    Reserved

    Code:
    [LIST]
    [*]Alpha 1 [2015-09-07]
    - First release
    [/LIST]
    
    [LIST]
    [*] Beta 1
    - [COLOR="green"][B]Fixed RIL[/B][/COLOR]
    - Overclocked kernel to 1.3Ghz
    - New device-tree and vendor
    - Fixed SELinux 
    [/LIST]
    
    [LIST]
    [*] Beta 2
    - [COLOR="green"][B]Fixed FC in some apps[/B][/COLOR]
    - Use libwebcore instead of chromium (This fixes the force close applications)
    - Fixed rotation
    - Change bootlogo [HIDE][img]http://imgur.com/6Zh6x6el.png[/img][/HIDE]
    [/LIST]
    
    [LIST]
    [*] Beta 3
    - The MTP was arranged .
    - The density is again 160DPI
    - The camera is already recognized, but fails to connect .
    - The Audio HAL has been updated and now Audio CAD is used (no change on errors of audio, as usual)
    - It was fixed the FC equalizer .
    - The browser works correctly. (Libwebcore is still used because it does not cause lags)
    - Ramdisk has been modified so that the audio CAD work.
     -Ramdisk has been modified so the camera That was Recognized .
    - audio_policy.conf was updated
    Kernel:
    - Add F2FS Support and enable it
    - Add UHID Driver and enable it
    [/LIST]
    [LIST]
    [*] Beta 4
    - Updated device-tree
    - Updated vendor
    - Fixed mini bug on browser
    - Merge new logo [HIDE][img]http://i.imgur.com/bPtUyKg.png[/img][/HIDE]
    - Merge CMAccount in the source
    [/LIST]
    10
    12023060_885144654898554_645701125_n.jpg


    12029090_885144668231886_78421105_n.jpg


    RIL is working now
    8
    My builds.

    • The MTP was arranged .
    • The density is again 160DPI
    • The camera is already recognized, but fails to connect .
    • The Audio HAL has been updated and now Audio CAD is used (no change on errors of audio, as usual)
    • It was fixed the FC equalizer .
    • The browser works correctly. (Libwebcore is still used because it does not cause lags)
    • Ramdisk has been modified so that the audio CAD work.
    • Ramdisk has been modified so the camera That was Recognized .
    • audio_policy.conf was updated

    Uploading build: remaining time 4 hours.