• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Klyde PX4 | PX5 | PX6 head units with MCU CSN2 | CSN2_D | CSN2_8600_D (Android 8/9/10

Search This thread

stanbpd

New member
Jun 8, 2021
2
0
Hello,

i bought following radio for my skoda fabia 3:

PX5
Build: 202104281111
Kernel: 4.19.111 #228 Tue 04 27 11:28:26 CST 2021
uboot-04 28 2021-10:34:43_M11 1280x720
MCU
CNS2_D_04282021_174043_V205
CPU: 64 bit 8 Core Cortex-A53 1.5 Ghz 2048MB
TDA7850

Witht this radio i got delivered an USB cable with 2 connectors, 1 for 3g / usb and the second one android phone or something like that. The problem is with music playback from an usb key, the key is scannned almost for a minute and afterwards the playback stop after 10 seconds, the song is not playing and it looks like that the radio is frozen, the SW also crashed once. Sometimes when i plug in the usb stick the screen flashes very quickly. When i unplug the usb key and switch to the radio application no sound is coming out of it, just volume up and down sounds when i try to lower the volume on the steering wheel. The only chance is to do a hard reboot of the radio. Any suggestions? Is this a SW or cable problem?
 

dnfm

Senior Member
Nov 24, 2009
73
16
Has anyone encountered slightly inaccurate GPS issues with their csn2?

Mine... Mostly works, but it seems to be consistently off by 10-20 metres.

This means navigation mostly works, but in a city where there are a lot of roads, it can get confusing when it randomly decides I'm one road over.

By comparison, I have my phone right beside the unit, and it never gets confused like the stereo does.
 

_yuzo_

Senior Member
Feb 15, 2016
358
182
Chernihiv
Has anyone encountered slightly inaccurate GPS issues with their csn2?
I have had. There could be a few reasons:
- weak connection on SMA connector. The antenna has power 3.3V. If SMA is not tighten, antenna doesn't work.
- wrong location of antenna. Sometimes antenna falls down inside the panel and have no chance to detect GPS signal. The best place is near backview mirror.
 

abdelmonem

Member
Jan 26, 2009
45
5
After a long trouble, I was able to upgrade from Android 9 to Android 10 finally

Note: Restored from the dead once

i used cable from mainboard direct other ways i get driver error , i get issues with windows 10, switch to windows 7 after , also USB 3 not useful
 

Attachments

  • 43646e5665.jpg
    43646e5665.jpg
    1.7 MB · Views: 27
  • 564654654.jpg
    564654654.jpg
    1.8 MB · Views: 27
  • 6547645764.jpg
    6547645764.jpg
    1.6 MB · Views: 29
  • 76986887.jpg
    76986887.jpg
    990.7 KB · Views: 28
Last edited:

pojwola

New member
Jun 14, 2021
3
0
hello please help me choose firmware and mcu update I have Radio Erisin 8791 PX5 with Fake Android 10 + DSP. auto with android, carplay. Mcu CSN2_D_07162020_090420 (Mon 08-17). Build # 20202007141126.kernel version uboot-07 02 17, cst 2020 Mon 08 17 64-bit 8-core bark-a53 1.5 GHz 4 GB of RAM I want to stay on Android 9




witam, pomóż mi w wyborze aktualizacji oprogramowania i MCU. Mam Radio Erisin 8791 PX5 z Fałszywym androidem 10 + DSP. auto z Androidem, carplay. Mcu CSN2_D_07162020_090420 (pon. 08-17). Kompilacja nr 20202007141126. wersja jądra uboot-07 02 17, cst 2020 pon 08 17
64-bitowy 8-rdzeniowy kora-a53 1,5 Ghz
4 GB pamięci RAM
Chcę pozostać na Androidzie 9
 

Attachments

  • IMG_1645.jpg
    IMG_1645.jpg
    2.3 MB · Views: 23
Last edited by a moderator:

ngviethoa

Member
Oct 17, 2020
43
0
issue on Mar 31st 2021 202103310921
- Bluetooth problem after update SW: crash bluetooth app
- NAVI button problem: can not load Navitel map data ( assinged Navitel to NAVI button ) google maps still ok. updated Navitel app still not change
 

abdelmonem

Member
Jan 26, 2009
45
5
issue on Mar 31st 2021 202103310921
- Bluetooth problem after update SW: crash bluetooth app
- NAVI button problem: can not load Navitel map data ( assinged Navitel to NAVI button ) google maps still ok. updated Navitel app still not change
i use this file on my device i didn't get any issue , before that i use latest MCU file , check MCU version

also from factory setting check Bluetooth module correct version
 

Attachments

  • 7698687.jpg
    7698687.jpg
    1.6 MB · Views: 32
  • 6547645764.jpg
    6547645764.jpg
    1.6 MB · Views: 33

pojwola

New member
Jun 14, 2021
3
0
witam, pomóż mi w nowej aktualizacji i MCU. Mam Radio Erisin 8791 PX5 z Fałszywym androidem 10 + DSP. auto z Androidem, carplay. Mcu CSN2_D_07162020_090420 (pon. 08-17). Kompilacja nr 20202007141126. wersja jądra uboot-07 02 17, cst 2020 pon 08 17
64-bitowy 8-rdzeniowy kora-a53 1,5 Ghz
4 GB pamięci RAM
Chcę pozostać na Androidzie 9
Help me
 

abdelmonem

Member
Jan 26, 2009
45
5
i used latest MCU version, maybe navitel problem
I already use Sygic because I’m in middle east but I try to download navitel for testing is working no issues as you can see in pictures but trying to reinstall
 

Attachments

  • B19D2CDB-D406-4EF3-9467-D98CD4BE33B1.jpeg
    B19D2CDB-D406-4EF3-9467-D98CD4BE33B1.jpeg
    1.5 MB · Views: 19
  • 253CCCEC-DB8A-477A-B778-8605D3CBCB1E.jpeg
    253CCCEC-DB8A-477A-B778-8605D3CBCB1E.jpeg
    1.7 MB · Views: 18
  • DB6EE58C-5BD7-4CBD-B98E-4BF214E0C243.jpeg
    DB6EE58C-5BD7-4CBD-B98E-4BF214E0C243.jpeg
    1.6 MB · Views: 18
  • 45A12213-3B3D-45AA-A9A2-55DCA2D671E3.jpeg
    45A12213-3B3D-45AA-A9A2-55DCA2D671E3.jpeg
    1.7 MB · Views: 17
  • 24F4791E-34C8-4929-A13B-B76CFE4B2DC7.jpeg
    24F4791E-34C8-4929-A13B-B76CFE4B2DC7.jpeg
    1.8 MB · Views: 16
  • 49AEFFCE-8C9D-4D6A-BA93-0BFA59BA7E42.jpeg
    49AEFFCE-8C9D-4D6A-BA93-0BFA59BA7E42.jpeg
    1.5 MB · Views: 21
Nov 2, 2020
14
0
Czy ktoś może mi powiedzieć, czy mogę moje radio aktualizować ? Jeśli tak, która aktualizacja będzie pasować do mojego radia?

AA0495B-A01 ND0294B-A01

PX5
Andr. 8.0.0
Nr.Ko. 201903151040
Wer. ją
4.4.103
MCU CSN2_03202019_103040

Bardzo proszę o pomoc
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Oh My Gosh, again a wrong resolution... Your unit is 800*480 while you updated with the file for 1024*600. Fix is there
    1
    so? is px5 or px6?


    the file is no longer available ....
    It’s for px5
  • 26
    This thread relates to MCU: CSN2_xxxxx, CSN2_D_xxxxx and CSN2_8600_D_xxxxx for PX4, PX5 and PX6 platforms


    This thread is a mirror of russian 4pda to cover more users/developers.

    All units are made by Klyde, but are sold under different brands.

    I've been looking for a simple way to donate me if this thread is useful for you, all the ways are collected in one post there

    The thread requires a new mainteiner. Details are there.

    Hardware specifications:

    • CPU: Octa-core PX5 1.5GHz Cortex A53 64 bits CPU
    • ROM: 16/32/64G
    • RAM: 2/4G
    • Resolution: 1024*600
    • Out Power: 4*45Watt
    • Operating System: Android 8/9
    • Radio Tuner/Audio Chip: NXP6686 / TDA7851
    • Built-In WiFi Module /Support External 3G Dongle
    • Features: Radio Tuner,Built-in GPS,MP3 Player,Bluetooth,Touch Screen,TV,Mirror link,Built-In Microphone,Support Steering Wheel Control,Support Can-Bus

    Useful tips
    Tag [Android 8] means that it applicable to Android 8 :), the same for [Android 9]. If there is no tag, it suits both versions.


    • Factory Settings password: 126
    • If you type 888 while opening Factory Settings, the Logo changing menu appears instead of Factory Settings. Logo1 replaces "Navigation system" picture, Logo2 replaces "android" picture. Logo2 is animated.
    • Developers mode password is 237
    • Password 927 opens menu, that helps to adjust screen brightens by changing VCOM value. You can set it between 1 and 100. Be careful with that!
    • [Android 8] How to get root: Use a rooting app, alternative link
    • [Android 9] How to root
      Warning! You should be careful with that as it can brick your device once you tried to update SuperSu. Do not update SuperSu binary or the SuperSU app!!! You will get bootloop if that is updated!!! Also you have to wait until the tool completes its job, otherwise you can get no sound. If you face the mentioned problems, just re-flash your device. BE CAREFUL!.
    • Starting from android 8 January firmware there is an option "OFF" for "Power off delay if ACC OFF". it allows to keep android in a sleep mode forever. Please note that it consumes around ~9-10mA in this mode. Powered off device uses 4.8mA only (twice less than sleeping mode).
    • How to get enter stock recovery: hold reset(power) button, wait until sensor buttons start blinking, release and immediately press the button again. See video
    • To adjust the back camera brightness, just tap the screen when the camera is active.
    • Set custom logo
    • Detailed device schema

    Known issues/limitations and fix/workaround for that
    • Lost wheel key settings and radio stations in case full power loss (yellow wire). Make sure that yellow wire is not disconnected when the car is stopped/locked.
    • Sound level is 10 (12) after reboot/sleep if you was listening louder; if it was less than 10 (12) stays the same. 12 appeared in Dec 11th firmware, it was 10 before that. Not topical starting from Dec 27th firmware, now you can define default sound between 12 10 and 20 in Car Settings-->Personal Settings. 10-20 is in Jan 17th firmware .
    • buzz in speakers caused by 433MHz alarm system and USB stick remounting.
    • small buzz caused by WIFI, observed in complete silence only. Not an issue if there are no connected devices.
    • There are lots of cases when wheel keys does not work at all. The reason is in wiring. Please study the head unit manual + car wiring scheme and put the needed wire to the correct connection shoe.
    • if you have canbus adapter and wheel buttons duplicate actions (i.e you pressed next track, but 2-3 tracks were switched, the same for sound level), just flash Jan 17 or newer firmware. Also it is possible to change wiring, but the firmware is much easier.
    • if you have canbus adapter and track switching is reversed (incorrect), just go to Factory Settings --> canbus and set keys_previous_next to change.
    • Bluetooth ODBII and hands-free (calls) does not work simultaneously. At the same time ODBII and BT Music works well simultaneously. Hardware limitation, no idea for now if that can be solved.
    • Voice dialing, voice search do not work on some devices. Fixed in May 8th firmware.

    1.PX5 Firmware.
    You can combine different firmware and MCU (I.e. take the pumpkin MCU + April firmware or vice versa). MCU from Android 8 is compatible with Android 9. Mind DSP only while updating MCU.

    The factory does not provide me with a changelog! Do not ask about it.

    Android 10.


    Fake Android 10.
    It is the same android 9 firmware, but with changed launcher, radio and Bluetooth app.
    Android 9.

    The link for the most recent firmware and MCU: with DSP and without DSP. _D_ in the MCU version means that it is for units with DSP.

    All available versions of MCU are on my Google drive.

    Firmware history and links:
    Android 8.
    The link for the most recent firmware and MCU: with DSP and without DSP. _D_ in the MCU version means that it is for units with DSP.

    All available versions of MCU are on my Google drive.

    Firmware history and links:

    2. PX6 Firmware

    Android 10.

    Android 9.

    3. PX5 Android 9 for 1 DIN units with MCU CSN2_8600_D
    The differences between this unit are on Russian 4pda

    Firmware 201911301053 + MCU CSN2_8600_D_11202019_162651 is located on Google Drive

    4. PX4 Firmware

    Android 10.

    The instruction how to upgrade is there

    The list of purchased devices

    Tested and compatible 3G/4G modems
    • ZTE MF622
    • ZTE MF825
    • Huawei e173
    • Huawei E352
    • Huawei E3272
    • Alcatel 410D
    9
    How to update firmware on the device (without changing android version)

    I know at least 3 methods how to do that :) Use USB Stick or SD card with FAT32 filesystem for android 8 or USB Stick ONLY for android 9.
    1.
    - put the firmware (kupdate.zip + update2.bin if you want to upgrade MCU) directly to USB stick or SD card,
    - insert it while the unit is running,
    - click OK once suggestion to update appears.

    2. The same as 1, but the last point is to start update from system settings

    3. Use it, if you have a brick (bootloop)
    - put the firmware (kupdate.zip + update2.bin if you want to upgrade MCU) directly to USB stick or SD card with FAT32 filesystem for android 8 or ONLY USB Stick for android 9.
    - power off the device, insert USB stick or SD card for android 8 or ONLY USB Stick for android 9.
    - press and hold power button and power on unit by switching on ACC in your car or enable power +12V on both red and yellow wire in case you doing that on the table. On some units use reset button instead.
    - once the update is started, release the button.

    WARNING! Firmware update will remove all your personal data and settings on the device!

    If you observe the error like "header and footer of kupdate.zip does not correspond signature", just try to upgrade form another USB stick/SD card.
    5
    Upgrade to real android 10

    There are 2 known ways how to upgrade to android 10.


    1. Disassemble your unit and do the same as described there using the files for PX5 or PX6 depending on your platform. Also there is an instruction with pictures in each archive.

    2. Without disassembling, but using windows laptop or tablet. Quite simple, but requires lots of checks and preparations. And in worth case scenario you will have to solder to the needed pins of coreboard.

    !!! The upgrade is possible on motherboards rev 1.4, 1.5.2 and 1.6 (quite possible that other revisions too, but we have not enough information for now). The mainboards of rev 1.2 require disassembling and soldering additional usb cable!!!

    In order to complete the upgrade we need:
    - strong desire to do that and be ready to disassemble unit in case of the failure or even purchase a new one.
    - USB type A male to type A male cable
    - Windows laptop or tablet

    Steps to do.
    1. Preparation
    - check the Bluetooth module that is configured in your unit: System Settings-->Factory Settings-->FUNC-->BT Mode. Note its model somewhere. That will be needed to restore the settings after the upgrade.
    - check if you can do an upgrade:
    -- install terminal emulator on your unit and run
    Code:
    dmesg | grep "USB device" | grep using
    and note the last time stamp
    -- plug USB stick to the first USB (on the panel or into an extender cable)
    -- run again
    Code:
    dmesg | grep "USB device" | grep using
    -- if you see something like
    Code:
    [ 4781.749803] usb 3-1: new high-speed USB device number 16 using usb20_otg
    you can use this USB and plug the head unit to your laptop via it using USB male type A to male type A cable. usb20_otg is vital
    -- if you see something like
    Code:
    1-1.3: new high-speed USB device number 5 using ehci-platform
    This USB can not be used!
    -- repeat the action for the second unit`s USB
    -- IF BOTH PORTS DOES NOT HAVE OTG YOU CAN NOT GO FURTHER UNTIL YOU SOLDER THE 3RD CABLE! The instruction is at the end of this post.
    - download PX5 or PX6 depending on your platform.
    - if you have a display with resolution 1280*720 , download a custom oem.img, it is suitable for both PX5 and PX6;
    - extract archive to root directore of drive C: You should have C:\px6_10.0_burntools\ or C:\px5_10.0_burntools\ folder;
    - install drivers from DriverAssitant folder;
    - in case of PX6 go to C:\px6_10.0_burntools\AndroidTool_Release_v2.71, for PX5 go to C:\px5_10.0_burntools\AndroidTool_Release_v2.71, edit config.ini, replace Selected=1 with Selected=2. That will enable English language for the program;
    - if you have 1280*720 display, put the custom file to rockdev\image folder and replace the old one;
    - backup all vital data on your head unit;

    2. Upgrade
    - run AndroidTool.exe
    - download and install this APK
    - run it and click "Go to Android10", the device will be rebooted and BRICKED. APK kills loader and boot partition!!!
    - connect your laptop and head unit via the discovered OTG USB
    - AndroidTool should reprt "Found one MASKROM device"
    - hit run button;
    - wait until the competition.

    The unit will be rebooted, data partition will be formated and the unit will be running andriod 10.

    3. Post upgrade
    - download the most recent firmware
    - put it on USB stick
    - do an upgrade using this USB stick

    Known issues and fixes
    1. Bluetooth KD6 does not work on android 10. Replace the module with IVT140 or RF210, maybe it will be fixed in new firmware. Fixed starting from 202011261850
    2. In some unique cases the rear camera does not work on android 10 (we suspect that it appears on old mainboard revisions without DSP). Fix is to revert to android 9 or maybe it will be fixed in new firmware. Fixed starting from 202010141730



    TIPs
    .
    Mainboards Rev 1.2 do not have USB OTG, so you have to solder the 3d USB cable. Just solder the USB wire to connector A if the mainboard. Pins 63 and 64. 63rd stands for D+, 64th corresponds D-. Do not forget about GND. +5V is not mandatory for upgrade, you can take it from rear connector H (check pin 5 or 10 there) and make fully working USB port.

    20818804.png

    photo_2020-09-13_14-36-50.jpg

    photo_2020-09-13_14-30-35.jpg
    4
    Upgrade from Android 8 to 9 WITHOUT disassembling.

    ALL YOUR ACTIONS ARE YOUR OWN RESPONSIBILITY!!! Nobody will send you a new core board in case of the failure! At least will not do that free of charge!

    0. All needed files are there.

    1. To perform the upgrade we need:
    - Strong desire to do that and be ready to purchase a new core board in case of total failure (~100$);
    - micro SD card slot in your unit. If the unit vendor gives details regarding the units without SD cards, I'll update this post;
    - USB stick (up to 16GB, to avoid possible problems) formatted in fat32;
    - micro SD card (again, please use not so big);

    2. Put the following things on USB stick:
    - MCU firmware that suits your device. I.e. update2.bin from the first message in thread with DSP or not depending on your unit)
    - Android 9 firmware from the first message. kupdate.zip, Again: Andriod 9!!!

    3. Do NOT plug USB stick to the unit for now, let`s make bootable SD card;

    4. On Windows PC run SDDiskTool and create bootable SD card. The manual inside of the archive, with the details, so I see to reasons to repeat it there. update.img from the archive is used there ~350Mb;

    5. Install "Android 8 upgrade 9.apk" into the unit, run it, click only the button in this application. The unit becomes a brick (temporary, till a success on step 9) - You will see only a black screen and lights on the buttons;

    6. Put SD card into a units slot, disconnect battery terminal of your car or power off the unit in some other way. Both red and yellow wires of unit should not have +12V on them !!!

    7. connect battery terminal.

    8. The unit is upgraded for the first time. Take a video of the process!!! Just in case if you fail and it will be needed to troubleshoot that. On this step you should see TWO errors of formatting metadata. YES, there should be TWO errors!! and formatting error for system.

    Video of attempt.
    The final screenshot.


    9. Disconnect and connect battery terminal one more time. The unit upgrades from SD card one more time Take a video of the process,just in case. this time there should be no errors with metadata and system!!! The last string should be "Doing Actions succeeded".

    Video of 2nd attempt.
    The final screenshot.


    10. Disconnect battery terminal, REMOVE SD card from unit, plug USB stick prepared on step 2.

    11. Connect battery terminal and the unit will complete the upgrade to Android 9.

    12. Once the upgrade from USB stick is done, the unit start running Android 9. All further upgrades will be done from USB stick without any additional actions

    Video of installing the firmware from USB Stick.

    13. FORMAT SD card on your PC, do not use it in unit until it is formatted, just to be safe.
    4

    I decompiled with the latest Jadx and found it will end all non-system processes, except for those in a hard-coded blacklist, which includes google maps. So it should work to move an app to system/priv-app or even system/app if it is desired to be sustained during sleep. There are apps which can do this for you on a rooted system though I have never tried them. Apparently it gets more complicated if the app to be made a system app includes libraries and I don't know if the automated systemizer apps do this for you. In my case it would be nice if Maps restarted where it left off so I may go ahead and try editing the smali.

    FYI the relevant code is below:
    It comes from com.my.manager.McuManager in MyCarService.apk. According the the manifest it was compiled with Android 9.

    Update: I was not able to successfully rebuild a properly working apk. :(

    2nd Update: With apktool set to not use aapt2, it seems to work. I commented out the call to the below function, and now Google Maps resumes directly to navigation. Somehow it didn't do the trick to remove Maps from the blacklist. :)

    Code:
     private void killAllNoSystemProcess() {
            try {
                getAvailMemory(this.mContext);
                PackageManager mPackageManager = this.mContext.getPackageManager();
                Intent mainIntent = new Intent("android.intent.action.MAIN", null);
                mainIntent.addCategory("android.intent.category.LAUNCHER");
                List<ResolveInfo> apps = mPackageManager.queryIntentActivities(mainIntent, 0);
                ActivityManager am = (ActivityManager) this.mContext.getSystemService("activity");
                for (ActivityManager.RunningAppProcessInfo amProcess : am.getRunningAppProcesses()) {
                    int kill = -1;
                    Iterator<ResolveInfo> it = apps.iterator();
                    while (true) {
                        if (!it.hasNext()) {
                            break;
                        }
                        ResolveInfo appInfo = it.next();
                        boolean flag = false;
                        if ((appInfo.activityInfo.applicationInfo.flags & GlobalDef.CVBS_DEFALUT_BRIGHTNESS_7181) != 0) {
                            flag = true;
                        } else if ((appInfo.activityInfo.applicationInfo.flags & 1) == 0) {
                            flag = true;
                        }
                        if (amProcess.processName.startsWith(appInfo.activityInfo.packageName)) {
                            if (flag) {
                                kill = 1;
                            } else {
                                kill = 0;
                            }
                        }
                    }
                    if (kill == -1 && amProcess.importance > 200) {
                        kill = 1;
                    }
                    Log.d(TAG, amProcess.processName + "<<kill:" + kill + ":" + amProcess.importance);
                    if (kill > 0) {
                        am.forceStopPackage(amProcess.processName);
                    }
                    for (String s : KILL_SYSTEM_APP) {
                        am.forceStopPackage(s);
                    }
                }
                getAvailMemory(this.mContext);
            } catch (Exception e) {
                Log.d(TAG, "killAllNoSystemProcess:" + e);
            }
        }