General Latest ROW march update for TB-J706F solved my Netflix Widevine L1 problem.

Search This thread

melones22

Member
Apr 1, 2022
23
14
no problem! it took me a lot of time to figure out everything since it's the first time i'm using adb and stuff, but i'm so happy with the final result :d
Actually I wrote a "complete guide" to achieve this, every download link is on here :)
 
  • Like
Reactions: frogduck

billyx1

Senior Member
May 25, 2012
229
75
GT-i9250
Google Nexus 10
Nope, bootloader locked is a guarantee that nothing has been changed so it wouldn't make much sense.
The opposit is true, that would be the best option. I had that in good old days with my Nexus 10.
You can lock the bootloader so it is not possible to boot with a external image to access your data and on the other hand it was possible to unlock the bootloader by a switch from inside the running system.

@blagoon52 Is this the most recent ROM? Any important updates in the ROMs there within the last year?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    if anyone needs a guide to get bootloader+twrp+root without having a headache (i haven't been able to found latest update rom file online so I dumped boot.rom myself) :

    0. Dowload , unzip and rename img file to twrp.img https://www.mediafire.com/file/wdpxfr5t2z4mrye/TWRP-3.4.2B-1208-LENOVO_TBJ706F.zip/file
    1. Enable OEM unlock in developers settings
    2. Reboot in bootloader (adb reboot bootloader)
    3. In bootloader enter :

    Code:
    fastboot flashing unlock

    and answer yes when you're ready
    WARNING: UNLOCK BOOTLOADER WILL WIPE YOUR DEVICE!!!!!
    4. Run LMSA/RSA rescue to update your ROM as well as grab boot to patch
    5. Do initial setup. DO NOT RESTORE
    6. Install Magisk
    7. Enter fastboot and enter :

    Code:
    fastboot flash recovery twrp.img

    8. Reboot to TWRP (Vol up + Vol down + Power)
    9. Get in shell (adb shell) and enter dd if="/dev/block/bootdevice/by-name/boot_b" of="/sdcard/boot.img"
    12. Reboot and open Magisk, hit Install and select your boot.img freshly dumped
    13. Transfer patched img to your pc and rename it to patched_boot.img
    14. Go back to fastboot, enter :

    Code:
    fastboot flash boot patched_boot.img

    15. Reboot and add riru and safety net fix on Magisk (you have to reboot 2-3 times)
    16. Run safety net check and it should pass. If not, enable Magisk Hide and try again
    17. Wipe Play Store and Google Play Services and reboot
    18. Restore and add app onto hide list if the app detected root

    Troubleshoot :
    - TWRP will ask for a password if your device has pin/pattern to unlock, disable it to get access to user data
    - wtf why my touch screen is glitched after going to TWRP? idk it's odd but just reboot and it'll be fixed
    - Play store not installing apps? Format your SD card to external storage
    - Can't install Netflix and other apps claiming to be uncompatible ? add play store in magisk hide then clear play store & google play services cache/data

    (modified guide from https://forum.xda-developers.com/t/...-if-running-android-11.4374645/#post-86108685)
    1
    Only to inform that after updating the row rom with march update, my problem with Netflix not working with widevine L1 was solved.

    Before the update I had to install an old Netflix version (7.8) in order to work in full hd.
    1
    Only to inform that after updating the row rom with march update, my problem with Netflix not working with widevine L1 was solved.
    Full HD is not working anymore in any version and this OTA (220312) does not contain any fix for Netflix, according to Lenovo technicians.

    You are only seeing L1 and it's the same I can see with my tablet not updated but if you try to play test patterns you will see that definition played is 960x540.

    We need to wait for the next OTA for a fix.

    Is there still the "join Lenovo experience program" notification everytime tablet is restarted with this OTA?
    1
    Ad blocking works with NetGuard, but if you want to have fun messing around (I totally understand the feeling) I would suggest to:
    • Unroot and lock bootloader again
    • Make a full backup with QFIL or edl
    • Unlock again and install a GSI rom
    • Have fun
    1
    Great, I was looking for a guide like this for rooting since I may do it later on with my p11 pro, thanks!