• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lawnchair and the Java "path must be convex" error

Search This thread

DrWu

Senior Member
Feb 10, 2015
106
3
My new Fire HD 8 2018 makes the fifth device I've flashed LineageOS to and it was by far the least exasperating experience of the five. Unlocking, rooting and the flashing all were remarkably-drama free, unlike all of the previous four, and I am very happy with the way it turned out. I even managed to get a Smali patch for signature spoofing created and flashed in under an hour and on the first attempt, and it works a charm.

I'd read that the Fire HD wasn't exactly a powerhouse tablet but it's replacing an eons-old Kindle Nook HD that I also had LOS on (and which is now an ex-Nook), and the Fire runs like it has twice as many 1.3 GHz cores as the Nook ... because it does. The only fly in the ointment is the Lawnchair launcher. I run close to 60 apps and I'd got them all installed (and in some cases, configured) before I noticed that Lawnchair crashes every time I try to sweep an app's icon from the drawer onto the home screen. It also causes the Babbel language tutorial app to crash every time I try to start it (which doesn't happen if I switch to the Trebuchet launcher).

And regardless how it comes about, it always throws the same error message:

Code:
java.lang.IllegalArgumentException: path must be convex

By that time it was too late to determine if maybe one of my pet apps was contributing to the error or if the same would have happened from a clean install, so I re-flashed the ROM to investigate. And wouldn't you know it, it even happens with a clean install.

The version of Lawnchair that came on the LOS ROM is 2.1-2626. The ROM is LOS 15.1, Android 8.1.0.

For the timebeing I have Trebuchet enabled but in the short time that I used Lawnchair I'd got to liking it. I found it intuitive to use and had some customizing features that I appreciated. So my question is, is my time better spent with:

A) installing older versions of Lawnchair to see it they're more stable,
B) trying my hand at troubleshooting the Java "path must be convex" error, or
C) altogether abandoning Lawnchair and contenting myself with another launcher?

Thank you for your time.