General LE2123_11.C.61 Update in Germany

Search This thread

danizwam

Member
Oct 5, 2009
47
5
Münster
Finally OP released C62 as full zip and I flashed it without issues. I have no major complains. All seem to be working as before.
How could you flash LE2123_11_C.62 without flashing the pending incremental update?

I have the following issues:

- I downloaded the full update, but i cannot install it, due to the pending incremental C.61 update
- I wanted to unroot, and reroot after updating. Therfore, I unzipped the C.62 update file, dumped the payload.bin to get the boot.img, but it's only ~69MB big. My current boot.img from C.47 is 192MB big. I don't want to update without able to reroot, due to a corrupt or false boot.img.

Can you help me?
 

sshriss

Member
Jan 25, 2013
19
14
Sofia
How could you flash LE2123_11_C.62 without flashing the pending incremental update?

I have the following issues:

- I downloaded the full update, but i cannot install it, due to the pending incremental C.61 update
- I wanted to unroot, and reroot after updating. Therfore, I unzipped the C.62 update file, dumped the payload.bin to get the boot.img, but it's only ~69MB big. My current boot.img from C.47 is 192MB big. I don't want to update without able to reroot, due to a corrupt or false boot.img.

Can you help me?
I did the following while being on c47.

1. downloaded the c62 full 4gb zip via Oxygen Updater.

2. Then uninstall -> restore images in magisk.

3. Flashed the zip via system update apk without rebooting

4. Then go to Magisk and Install to inactive slot (as usual after OTA).

If you restart and loose root you can follow the procedure on the main rooting thread. There you can find rooted and stock boot imgs

PS: If you face Gmail sync issues. You can try shutdown the phone for 5 min then start it.
 
Last edited:

danizwam

Member
Oct 5, 2009
47
5
Münster
I did the following while being on c47.

1. downloaded the c62 full 4gb zip via Oxygen Updater.

2. Then uninstall -> restore images in magisk.

3. Flashed the zip via system update apk without rebooting

4. Then go to Magisk and Install to inactive slot (as usual after OTA).

If you restart and loose root you can follow the procedure on the main rooting thread. There you can find rooted and stock boot imgs

PS: If you face Gmail sync issues. You can try shutdown the phone for 5 min then start it.

Thank you!

I have never used the "system upate apk", but i managed it to start it with the activity launcher and i'll give it a try.

Right now, i am backing up my device ;)
 

danizwam

Member
Oct 5, 2009
47
5
Münster
I managed to update and root again, but it was, as always if i update, a pain in my ass...

After updating and flashing to inactive slot, i stuck in a bootloop.
Presumable caused by an Magisk Module which i could no longer deactivate, because my root was gone :(
First i thought, the boot.img in the ROOT-Thread caused the bootloop, because it was for 25.1 and i got 25.2 installed. But my own patched boot.img does not work either.

Then i tried to uninstall Magisk via TWRP but the sideloaded "uninstall.zip" installed Magisk and not uninstalled it...

I searched the net, flashed images and summoned deamons, when i stumbled over an adb command, to remove all modules via shell: "adb wait-for-device shell magisk --remove-modules".

I installed Magisk 25.2 via TWRP, booted the device and started the adb command. When the boot animation startet, the command was exceuted, my device rebootet and i had root again... What an Odyssee..


:D
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    LE2123_11.C.61_ 1610_202206141855
    Finally made it to my device in Hamburg

    Screenshot_2022-07-14-21-07-25-91.jpg
    1
    I'm sure there is a way to change/switch the active/inactive slot with adb or fastboot. If so you can check what's going on on the inactive slot
    Thanks, I will check
    1
    I updated from C47 with this method:

    • I first updated magisk to 25.1 and downloaded the module universal safteynet fix 2.3.1
    • I disabled all modules in magisk and did a reboot
    • In magisk manager I uninstalled magisk and restored the boot image
    • I installed the C61 update in system settings (no oxygen updater or local update)
    • After installing I did NOT reboot but reinstalled magisk to inactive slot. Then I did a reboot
    • After the reboot I reactivated my modules