Question le2125_11_c.61 OOS12 root

Search This thread

TornSack

Senior Member
Jun 26, 2013
97
20
Did you go to try to direct install? I haven't actually tried C.61 yet, I've got stuff to do this weekend and can't have my phone in an experimental state when I'm trying to call and Uber to get around, so I can't test it myself.
That's the problem. I boot the patched boot.img and I don't have a DIRECT INSTALL option in Magisk Mgr 25.1 Stable. Magisk Mgr doesn't see the phone as rooted (after booting or flashing the patched boot.img). My only install option in Magisk Mgr is to patch a saved boot.img file, which I've done, and flashed via fastboot, and rebooted, and still no Magisk Install option.

I can't figure out why Magisk won't see root when booting the posted patched C.61 boot.img.
 

TornSack

Senior Member
Jun 26, 2013
97
20
Can someone else post their LE2125 OOS C.61 Global boot.img
That's the problem. I boot the patched boot.img and I don't have a DIRECT INSTALL option in Magisk Mgr 25.1 Stable. Magisk Mgr doesn't see the phone as rooted (after booting or flashing the patched boot.img). My only install option in Magisk Mgr is to patch a saved boot.img file, which I've done, and flashed via fastboot, and rebooted, and still no Magisk Install option.

I can't figure out why Magisk won't see root when booting the posted patched C.61 boot.img.
 

TornSack

Senior Member
Jun 26, 2013
97
20
Thanks for posting. Still not working for me. Fastbooted to your patched image and still getting Magisk Installed:N/A. I must have something else going on.

For others who run into this. I uninstalled Images, updated from LE2125_11_C.48 to LE2125_11_C.61 via OTA, then rebooted (without reinstalling images...oof). After rebooting, I was unrooted. Now, even when I fastboot boot a Magisk patched C.61 boot.img, I get "Installed:N/A" in the Magisk Mgr app and therefore am not given the option to "direct install" Magisk to re-root. Maybe user error, maybe a Magisk issue.

When the full ROM comes out I'll reflash, fastboot the patched boot.img, and give it another try.
 

tswb

Senior Member
Dec 16, 2012
224
22
Thanks for posting. Still not working for me. Fastbooted to your patched image and still getting Magisk Installed:N/A. I must have something else going on.

For others who run into this. I uninstalled Images, updated from LE2125_11_C.48 to LE2125_11_C.61 via OTA, then rebooted (without reinstalling images...oof). After rebooting, I was unrooted. Now, even when I fastboot boot a Magisk patched C.61 boot.img, I get "Installed:N/A" in the Magisk Mgr app and therefore am not given the option to "direct install" Magisk to re-root. Maybe user error, maybe a Magisk issue.

When the full ROM comes out I'll reflash, fastboot the patched boot.img, and give it another ta

Thanks for posting. Still not working for me. Fastbooted to your patched image and still getting Magisk Installed:N/A. I must have something else going on.

For others who run into this. I uninstalled Images, updated from LE2125_11_C.48 to LE2125_11_C.61 via OTA, then rebooted (without reinstalling images...oof). After rebooting, I was unrooted. Now, even when I fastboot boot a Magisk patched C.61 boot.img, I get "Installed:N/A" in the Magisk Mgr app and therefore am not given the option to "direct install" Magisk to re-root. Maybe user error, maybe a Magisk issue.

When the full ROM comes out I'll reflash, fastboot the patched boot.img, and give it another try.
fastboot flash boot (img file) hit enter
 
  • Like
Reactions: aNGERY

TornSack

Senior Member
Jun 26, 2013
97
20
fastboot flash boot (img file) hit enter
I've done that, as well as "fastboot flash boot_a (img file)" and "fastboot flash boot_b (img file)."

I've clearly got some other problem. No matter what I do Magisk doesn't recognize the patched boot image. I've used the 2 files posted here with the same results.
 

tswb

Senior Member
Dec 16, 2012
224
22
I've done that, as well as "fastboot flash boot_a (img file)" and "fastboot flash boot_b (img file)."

I've clearly got some other problem. No matter what I do Magisk doesn't recognize the patched boot image. I've used the 2 files posted here with the same results.
reset phone to factory 2 times try it. that what i did. when u on home screen install magisk 25.1.
 

TornSack

Senior Member
Jun 26, 2013
97
20
I've done that, as well as "fastboot flash boot_a (img file)" and "fastboot flash boot_b (img file)."

I've clearly got some other problem. No matter what I do Magisk doesn't recognize the patched boot image. I've used the 2 files posted here with the same results.
Fixed. It was one of two things.
1) Used Windows PowerShell instead of Command Prompt to run fastboot commands
2) ADB uninstalled Magisk using the following 2 commands from PowerShell
adb wait-for-device shell magisk --remove-modules
(reboot)
adb uninstall com.topjohnwu.magisk
(reboot to fastboot)
fastboot boot [magisk patched boot.img]
(PROFIT - Direct install Magisk from Magisk Manager!!!)

* NOTE * This procedure DOES NOT generate BACKUP (original) boot.img for the UNINSTALL procedure, so make sure to create a back-up via ADB in PowerShell

# put stock boot.img into /sdcard/boot-stock.img

# get sha1
adb shell
su
SHA1=$(cat $(magisk --path)/.magisk/config | grep SHA1 | cut -d '=' -f 2)

# repack boot.img.gz
gzip -9f /sdcard/boot-stock.img

# restore backup
mkdir /data/magisk_backup_${SHA1}
mv /sdcard/boot-stock.img.gz /data/magisk_backup_${SHA1}/boot.img.gz
chmod -R 755 /data/magisk_backup_${SHA1}
chown -R root.root /data/magisk_backup_${SHA1}

VERIFY YOU CAN UNINSTALL BOOT IMAGES (and remember to REINSTALL via DIRECT)

Thanks to everyone for their support and boot images!
 

ChesterXXX

Member
May 21, 2015
15
3
Kolkata
Hi,

Thanks for replying. I was able to pull out boot.img from msm tool from my phone

Thanks for the reply though.
I tried that as well! But for some reason I got stuck. Basically here are the steps I tried.

Readback boot_b partition (my active slot) using msm
Patched it using magisk 25.1
Boot into bootloader
fastboot boot patched_boot.img

But at this stage the phone gets stuck showing a black screen with "fastboot mode" written in the center, under the OnePlus logo. I waited for 5 minutes to no avail. Had to force reboot using power button+vol up+down. And I don't get root in magisk! No idea why.

Eventually the EU image worked for me.
 

Rebel021

Senior Member
Sep 21, 2014
112
52
Cork
OPPO Find X2 Pro
OnePlus 8T
Hi
OnePlus 9Pro LE2123 EU C61
Contents:

le2125_11_c.61 OOS12 1.48 GB OTA​

boot.img

OPLocalUpdate_For_Android12.apk


I upgraded with this file I downloaded through Oxygen Updater
Uninstalled Magisk
Opened OPLocalUpdate app
Installed
Installed Magisk to inactive slot
Rebooted

I have Extracted the .img files if anyone needs one or 7
 
Last edited:
  • Like
Reactions: Steve0007

TheGhost1951

Senior Member
Feb 11, 2009
369
74
Garfield
OnePlus 9 Pro
That's the problem. I boot the patched boot.img and I don't have a DIRECT INSTALL option in Magisk Mgr 25.1 Stable. Magisk Mgr doesn't see the phone as rooted (after booting or flashing the patched boot.img). My only install option in Magisk Mgr is to patch a saved boot.img file, which I've done, and flashed via fastboot, and rebooted, and still no Magisk Install option.

I can't figure out why Magisk won't see root when booting the posted patched C.61 boot.img.
You don't flash the patched boot img, you use fastboot boot "name_of_patched_boot_img.img" and when the phone boots up, that is when the direct install should be available. Worst case senerio you may have to fastboot flash stock_boot.img boot system then go back to fastboot and boot from the patched_boot.img
 

TornSack

Senior Member
Jun 26, 2013
97
20
You don't flash the patched boot img, you use fastboot boot "name_of_patched_boot_img.img" and when the phone boots up, that is when the direct install should be available. Worst case senerio you may have to fastboot flash stock_boot.img boot system then go back to fastboot and boot from the patched_boot.img
Reread the post you're replying to. I clearly stated that I both booted and flashed the boot.img. Moreover, a few posts down you'll see the detailed explanation I provided on how I solved the issue.
 

Top Liked Posts