Legion Y700?

Search This thread


Senior Member
Aug 15, 2003
BTW, I keep reading that Lenovo might be releasing this tablet worldwide. If they do, the only difference would be software and not hardware right? BTW, thanks for the reply!
We keep hoping, but we don't know if they would tweak the hardware or not. The hardware in this tablet is pretty damn nice.


Senior Member
Apr 2, 2013
We keep hoping, but we don't know if they would tweak the hardware or not. The hardware in this tablet is pretty damn nice.
Ugh..... That's the only thing holding me back now. But the only issue I see could be with mobile connectivity which I'm not interested in. All I want to know is if I can use my stylus that I use with my tab 7+ and if the functionality works with gsi's. If so, I'll be buying by this weekend and retire my mi pad 4.


Senior Member
Aug 15, 2003
Super minor thing but...

I use my Y700 as my alarm clock (not only of course) and in ZUI13 the lock screen showed the next set alarm. In 14 if doesn't. Any way to change that?
  • Like
Reactions: fiocco


Apr 24, 2012
Ugh..... That's the only thing holding me back now. But the only issue I see could be with mobile connectivity which I'm not interested in. All I want to know is if I can use my stylus that I use with my tab 7+ and if the functionality works with gsi's. If so, I'll be buying by this weekend and retire my mi pad 4.
You should stick with Lenovo branded active pens that have been personally tested to work. On top of my head, these are precision pen 2 (2023 and earlier versions) and active pen 3.


New member
Jan 28, 2023
I updated my Y700 to ZUI 14. Everything seems working fine but when watching anything in Disney+ it's just show black screen. Does anyone know how to resolve this?


New member
Dec 7, 2013
Here's a stupid question, I've managed to get crDroid installed, version 8.1, how exactly do I update it to 9.1?

I tried to fastboot flash system on it but it threw error messages around file size, so I'm not quite sure how to proceed since TWRP isn't supported as well.

I'd appreciate if anyone could help out.


Jan 23, 2023


Jan 23, 2023
It's quite easy to unlock the bootloader and go back to ZUI 13 just read through the previous posts and you'll get there.

If anyone wants to stop further updates then you can disable (DO NOT UNINSTALL, ONLY DISABLE) com.zui.cores it also disables that annoying notification that you get every time you restart the tablet.
Hi bro

We're can I find this file. I can only find zuicoreservice in system apps. Thx!!


Jan 23, 2023
Hello. I updated to version 14.0.197 and my Google Play Store disappeared. I installed APK but when I open Google Play Store it says Error retrieving information from server. DF-DEFRH-01. How can I get the Google Play Store back?
Go to app management. Click the three dots upper right. Active google basic services


Senior Member
Oct 21, 2013
Xiaomi Poco F3
In my case no problem with Google Play, it works, but it seems games don't recognize me and my Games profil when I install games, while I'm already logged with my Google account - it should then automatically log-in with my Google games profile when I open a game.

Does anyone has any idea how to fix this?
You have installed google games app?
  • Like
Reactions: Fredwood


May 16, 2016
hello I ordered a lenovo legion y700 and I wanted to ask feedbacks for the people who has y700 for minimum one year ; does it still work good?
Do you know if we can change battery easily please? (can't find any teardown video).

I ask because I'd like know if it's durable (2 years minimum) and if we can repair it ourself, planning to unlock bootloader and install crdroid gsi on it


Jan 23, 2023
hello I ordered a lenovo legion y700 and I wanted to ask feedbacks for the people who has y700 for minimum one year ; does it still work good?
Do you know if we can change battery easily please? (can't find any teardown video).

I ask because I'd like know if it's durable (2 years minimum) and if we can repair it ourself, planning to unlock bootloader and install crdroid gsi on it
Yes but don't update zui 13


Jan 23, 2023
Does someone know how to install zui 14.0.231?

I can't place an update file in my device's root because I haven't got access. Most root folders are locked. The ones not locked I can't paste the update file in.

Maybe someone knows about a direct way to update 197? Thx guys!!


Dec 15, 2022
some user says after update y700 to zui14 lenovo pen is useable. they says there is pen menu in system settings app, and palm rejection and pen pressure works.. is this true? I was heard y700 doesnt support any pens

edit : Im using GSI, after flash zui14 vendor Pen works. true.
Hi, Does the pen work with crdroid?
  • Like
Reactions: droidbot1337

Top Liked Posts

  • 1
    Why Chinese rom and why the annoyance? lol I'm US user so if I do, can I switch it to English?
    Chinese ROM because there is no actual global ROM and your really don't want some reseller installing some random crap, you can just do that yourself when you get it. You can easily switch to english and install Google Play store on chinese ROM.

    Annoyance because the notification pulldown is a bit janky and notifications don't always seem to show up like I would expect. Plus every once in a while there will be something in Chinese you need to translate with another phone or take a snapshot and send to Google translate to see what it is telling you (aka new version released etc).

    Even with the above it is a super nice piece of hardware. I would love a real global ROM, but at the same time I am totally happy with the device.
    After some reading, I saw this from Aliexpress store:
    Global Firmware Lenovo LEGION Y700 Gaming Tablet

    1.Global ROM version, we need time to install the international version firmware for you.
    The international version of the firmware needs to pay attention to the following conditions:
    (1)In default :We have to open boxes to install Global Firmware ,which can support Multi-language , Google Play.
    (2)We will open the tablet and install the Global Firmware in the tablet for you.Every time you turn on this tablet--Lenovo Y700, the tablet will stay in the following page for about 10-25 seconds,Please press power key ,and then it will enter the OS successfully.If you mind it, please do not place order ,thanks for your understanding.
    2. The tablet does not support Legion gaming after installing the global firmware

    If there is no Global Rom, then what is Lenovo Official Store actually doing? Just installing Google Play and switching it to English, plus unlocking bootloader? The price is pretty enticing due to the sale but some details concern me.
    They are installing some other ROM I think, otherwise there would be no need to unlock the bootloader. Obviously (I hope) this is not a real 'Official Lenovo Store'. Again my advice if to get a sealed box. Others please chime in here..
    Like xnappo said: Chinese Rom is the way to go. Since your seller says it is not an option, you can do that yourself.
    On AliExpress, Lenovo Pro Business Store sell the Chinese firmware version.

    I ordered one from them a few weeks ago & it arrived sealed. Once it's powered on and the setup process starts there's an 'English' button in the top left corner iirc.

    After the setup was all done with, I used Google Lens on my phone to translate text that was still in Chinese.

    I'm only using it for PS2 emulation & Moonlight / Steam Link streaming though, so my use case is limited.

    If moist_line is planning on using it as an all-round tablet for gaming , browsing, tv streaming, etc... then there's a few hoops to jump through now and again going by what others have posted here in the past.
    moist_line said he messaged 'Lenovo Official Store', not 'Lenovo Pro Business Store'.

    And to confuse things even more, if you search for 'y700 128gb' on AliExpress, along with the above 2 stores there's also 'Lenovo Online Store', 'Lenovo Tech Online Store', 'Lenovo Smart Life Store', etc.. all selling the tablet.

    No wonder there's no copyright laws in China...
  • 5
    Okay. I have managed to do everything from combined insights. So, let me save you guys the trouble I had by writing my proces down (and for myself for the future).
    I came from the 'global rom'. And wanted to end with 13.1.578 ROOTED

    1. Download this file. It contains the stock firmware on 13.0.586. Unzip it, and find the recovery.img as we need it later.
    2. Upgrade all the way you like through OTA.
    3. Flash TWRP from here. Know that it is a 'faulty' version with only a line on top of the screen. And this vbmeta file. Place both files in your ADB folder.
    4. Use ADB to extact the boot.img from the version you are on.
    4.1 Boot into the bootloader (adb reboot bootloader).
    4.2 disable AVB (not sure this is necessary, but it worked for me) by sending the following commands:
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    fastboot erase userdata
    4.3 Instal TWRP by sending this command : fastboot flash recovery recovery.img (note that you use the name you gave your TWRP file)
    4.4 reboot in recovery mode (fastboot reboot recovery/manually on the tablet)

    Now the TWRP recovery should load, with only a line on top, and nothing else.

    4.5 In the TWRP recovery enter: adb shell (you should see a # appearing in the line)
    4.6 Send these commands out:
    dd if=/dev/block/bootdevice/by-name/boot of=/sdcard/boot.img
    adb pull /sdcard/boot.img stock_boot.img

    what this does, is extracting the boot.img of that specific version you are running, and placing a copy of it into your adb folder.
    4.7 send these commands to get back to the bootloader:
    twrp reboot bootloader

    5. Flash back the stock recovery. If you followed the guide, you have the stock recovery from step 1. Give it a fancy name, and place that file in your adb folder and sending this command:
    fastboot flash recovery yourfancyname.img
    fastboot reboot

    Now it may give some warnings and errors. It told me to do a factory wipe, wich was okay for me. After that the tablet starts normally. Stock firmware, but still on the same version I wanted.

    6. Now the easy part starts. The stock_boot.img you got in step 4.6, should be on your pc. After the inital setup on the tab, place that in your root folder. Download Magisk and install it on your tablet. When it is installed, click on 'install' and 'select and patch a file'. Select the stock_boot.img you moved to the root of your tablet. The patched file will be in your download folder. Transfer that patched file to your adb folder on the computer.

    7. Go into adb and boot the tablet into recovery mode (this should be the stock recovery again): adb reboot recovery.

    8. In recovery mode, go to fastboot. It'll say fastbootd on top.

    9. Enter this command: fastboot flash boot patched-file-of-magisk.img

    10. Restart the tablet. Congrats, you now have rooted your desired version.

    It might be to much info, but I wish I had these steps. It was late yesterday. Very late...So to save you the troubles, I present you my humble guide. If you have improvements in the steps or instructions, please let me know!!
    How did you manage to get pc mode back??
    Use this apk to switch between modes :D
    My device arrived with the bootloader already unlocked and everything is working fine on ZUI 13. I've spoofed a Pixel 6 Pro only on Netflix to get enabled HDR but Netflix worked good before I installed the module.
    Hello guys, would u recommend getting this tablet now or should i wait for newer v2 or something releasing in 2023 (actually i dont know if there is any talk about new one or no), TIA
    Haven't heard a peep about a new one, and honestly it is the ONLY 8 inch Android tablet in it's class right now, so not much choice.

    The hardware is superb. I do wish there were a real global ROM, but I am fairly happy with Zui 14.
    after spending hours I finally has latest zui 13 with magisk root and gltools for force 120 fps in shadowgun legend but now I need to backup everything and I wanted to know if it was possible to backup whole zui 13 despite not having full twrp?

    I have swift backup but if I backup all apps +data with system apps, then let's say I flash stock rom on another y700 :

    will I be able to restore all apps systems apps and data and patched boot.img with magisk please?

    If no, what would be correct way to backup at least apps +data +magisk and patched boot. img please?
    without proper TWRP swift/titanium is the only backup we can get, restoring from swift is limited, i dont think you can restore system apps, so restoring magisk or anything else seems impossible
  • 11
    Bricked Lenovo Y700? Follow this guide.

    Windows guide, might work for other aswell.

    I finally solved my problem with my Lenovo Y700 tablet being stuck in bootloop mode due to trying to flash Magisk boot with a mismatched firmware version. This resulted in the UI constantly crashing, and I could not connect to Wi-Fi, and other problems...
    I tried flashing back to stock with QFIL, which put the device in a bootloop. I will explain why later on.

    I also lost recovery mode due to trying to solve the problem, and now I was stuck with either showing the bootloader screen, or restarting the tablet, which brought me back to the bootloader.

    So the tablet was now genuinely useless. This is what I did to bring back the stock ROM and later flash to crDroid 8.10.
    Flashing boot.img, system.img or recovery.img was no luck.

    First off, there is no need to have unlocked "USB debugging" before your tablet bricked.
    Second, you don't need to have your "sn.img" file from Lenovo, you can unlock the bootloader using fastboot commands.
    Fastboot commands works on the bootloader screen, without having ADB connection.

    Start by downloading these four files:
    Platform tools r33.0.2
    Lenovo Y700 tablet stock ROM

    We'll start by unlocking your bootloader. You can do this from the bootloader screen. If you for some reason can enter recovery mode, enter fastboot.

    1. Connect your tablet to your PC.

    2. Open a terminal windows in the ADB folder. On Windows 11 this can be done by right-clicking inside the ADB folder and select "Open in terminal". If you don't have that option, try Shift + Right-click. If that doesn't work, you can always start the terminal by pressing Win + R, and type in "cmd" without citations. Now you have to navigate to your ADB folder by typing
    cd (here you'll type in the location of your ADB folder)
    Without the brackets.

    3. When located, type in
    fastboot devices
    You should see your tablet in the list.
    If not, try using another cable or USB port on your PC.

    4. Now type in
    fastboot oem unlock-go
    Restart your tablet, and it should now say "unlocked" under "DEVICE STATE" in the bootloader.

    5. Now you can start by installing the programs on your PC, QTPS, Qualcomm driver and platform tools.

    6. Extract ALL files from your stock ROM to the "bin" folder in QTPS location (usually C:\Program Files (x86)\Qualcomm\QPST).
    This will help with Sahara errors in QFIL.

    7. Open QFIL from your QTPS bin folder, it installs with QTPS. Don't worry if it shows "No Port Available", we'll get to that. Your configuration should look like this:


    Your main window should look like this:


    Don't worry about the "status" window.

    Hit "browse" in the "Programmer Path" window, and navigate to your QTPS bin folder. Select "prog_firehose_ddr.elf"
    Hit "Load XML", and navigate to your QTPS bin folder. Now, select ALL of the "rawprogram" files (my first mistake, I only selected the "rawprogram_unsparse0.xml" file on first flash)

    In the next window, select ALL of the "patch" files (my second mistake, I only selected the "patch0.xml file" on first flash).
    Without doing this, you will only flash a portion of the ROM, and not all of the partitions needed.

    8. Now it's time to reboot you tablet into EDL mode to be able to flash. Start your tablet by pressing VolUp + Power button.
    If you can't turn off your tablet when connected to PC, just select "Power off", and just hold the VolUp button as soon as the device vibrates and reboots, keep holding until the screen flickers and turns off.

    9. Now QFIL should detect the Qualcomm 9008 port. If not, hit "Select Port" and select the Qualcomm 9008 port.

    10. Hit the now available "Download" button, and the flashing should begin. Allow it to run its course, and it should reboot the tablet when done. Might take a while.

    If flashing won't start properly, you might have waited too long between entering EDL mode and hitting the "Download" button.
    If so, disconnect your device, which might now be "dead".

    Don't worry, you can fix this be holding VolUp + VolDown + Power button for a long time, say about a minute to be sure. Release the Volume keys some second before releasing the Power button.
    Hit the power button again, and the tablet should boot to bootloader screen again.
    Repeat the steps to enter EDL mode, and now hit the "Download" button in QFIL when it becomes available, don't wait too long.

    You're done!

    I recommend opening "Settings", enable "Developer" option, by pressing the "Build number" on the "About tablet" screen repeatedly until a pop-up appears saying "You are now a developer".
    Open "Developer options" and hit "Enable USB debugging", it will allow you to run ADB commands from your platform tools folder.
    If you want, you can again open the terminal in the platform tools folder and type
    adb devices
    It should now show your device in the list.

    Now you can uncheck the "OEM unlocking" in the "Developer options" which should let you get OTA updates when available.

    There are plenty of guides on how to flash different GSI's like crDroid, so I won't cover that here.

    Enjoy your tablet!
    Hi all.
    I just got this tablet yesterday.
    Language available on tablet are chinese and english maybe (morelocale2 could be useful)
    Google play services can be download directly from ZUI app store inside the tablet.
    Widevine L1.
    not sure about root or unlock bootloader (didn't use android device for a long time)
    I have flashed a lot of GSI on this tablet so far.
    Here is a summary of the bugs and other issues that I have noticed in them.
    ※All of them are Android 12L except for the ones without special notes.

    ①Corvus OS, Descendant OS, Cherish OS...Lock screen does not rotate. Probably because it is based on Google Pixel ROM. Corvus also does not have face unlock. The latest Corvus also added this.
    ②Ancient OS(Android 12.0)...Lock screen does not turn to landscape. Also, when I change the username or photo at the top of the settings, the settings app crashes. Also note that the settings app crashes if you change the username or photo above the settings.
    ③Proton AOSP...When I restarted to set up Magisk, the settings app repeatedly stops. Deleting app data and cache had no effect.
    ④Havoc OS(Android 11)...The startup logo does not appear in the first place and comes back to the bootloader.
    ⑤Superior OS...It started, but the FPS dropped extremely. I judged that it is difficult to use regularly.
    ⑥Pixel Experience…The screen is still not landscape. Also, it seems that it is not optimized for tablets any more than Descendant, and when I call the dock while launching an app(the feature of 12L), the icon looks like it has been split in half.
    ⑦All of NipponGSI...Like Havoc OS, it comes back to the bootloader. It may be a bad compatibility.
    ⑧Lineage OS…There was a switch "Rotate lock screen" in the settings. But I don't use it, because the "su" binary is still in the root file and can't delete it ,so interferes with SafetyNet.
    ⑨Arrow OS...This also allows the lock screen to be turned landscape and is also very light. Although the lack of face unlock is a demerit (LSPosed module didn't work→https://forum.xda-developers.com/t/11-universalauth-face-unlock-for-all-roms.4419343/).But there are few complaints for me. So I'm using it regularly.

    I'm sorry if it's hard to read because I'm not good at English. Thank you.
    Greeting Y700 users 😋
    I found an article regarding y700 with gsi
    but it is in japanese
    very detailed guide

    If you tried looking yourself its pretty easy to find. No one here owes you anything.
    Yep. The information is all in this thread.

    That said - we need our own forum :D

    Okay @alex4723717 , here are some important posts:
    91, 135, 226, 240, 264, 331, 343, 379