General Legion Y700?

Search This thread


Senior Member
Dec 29, 2007
Hmm, it's very strange GPU go to 670MHz only on Genshin.
All my games Fortnite, COD, PUBG, it's 305MHz.


Senior Member
Dec 29, 2007
there may be a trick to make the GPU work at 670MHz like Genshin perhaps with Game Mode of Android or like that ?

KonaBess (need root)

Last edited:


Jan 16, 2008
Can somebody who has latest zui14 installed, please confirm:

1) you don't have any issues with tablet rebooting or not being able to launch certain apps.

2) after installing app "switch PC mode", which was provided on same xda thread before, you can turn on PC mode on the tablet, even if it is not connected to external monitor?


Senior Member
Aug 19, 2011
los angeles
Lenovo Legion Y700
I got tired of zui and the notification situation, plus app defaults I changed kept reverting. I decided to install GSI CrDroid 9.1 following the great SmartASW guide linked in this thread.
Overall it's great, though I'd like lockscreen and homescreen to auto-rotate. I've been reading about Magisk but it's been a long time since I was last switching ROMs and for some reason I don't yet feel confident enough to do it.

Does anyone have any more recent experience with other GSI ROMs? If so could you let me/us know if CrDroid is still the one to stick with or if something else is more polished? Other than the auto-rotate and auto-brightness I don't have many issues, just want to get as much "working" as possible.


Senior Member
Aug 19, 2011
los angeles
Lenovo Legion Y700
Can somebody who has latest zui14 installed, please confirm:

1) you don't have any issues with tablet rebooting or not being able to launch certain apps.

2) after installing app "switch PC mode", which was provided on same xda thread before, you can turn on PC mode on the tablet, even if it is not connected to external monitor?
I switched to CrDroid but for 1) on zui14 I had no issues with the tablet rebooting. I think it did it randomly one time not long after I updated to zui14 but that was all. I had no issues with any apps I installed.

2) I didn't install this so can't comment about it, sorry
  • Like
Reactions: nebo0919


Senior Member
Dec 29, 2007
I bet they have some boost option hard coded
It's working now but I don't now really how i do that, maybe enforced GPU Optimisation with GFX TOOLS for PUBG and BGMI
On Fortnite i have no lag now, the GPU change the frequency automatically 305 to 400, 441, 490, 525, 587 and 670MHz :)



  • Screenshot_2023-03-30-22-24-09-0904735267.jpg
    377.7 KB · Views: 29
  • Screenshot_2023-04-01-22-22-21-0126437605.png
    2.6 MB · Views: 16
Last edited:
  • Like
Reactions: lunatechhtc


Apr 30, 2015
Madison, WI
1.Between this post and lisamarie post all info required is already ok this thread l just start at beginning and work way throughout it otherwise heres a start
Post in thread 'Legion Y700?'

2.matter of opinion. Currently am still running CRDroid 12L ive not looked back.

3. This has been mentioned aswell in this thread on how to possibly do it, tho its not been reported as 100% working by everyone's that tried. Personally i havnt bothered to re-lock it, dont care about it being unlocked.

4 all these questions and answers are available in this thread yet again if you read it all.
Spend the time reading and you have all these answers plus more.

Hey mate, quick question. Everyone seems to point to Nazim's crdroid. Any idea why? I currently have his crdroid 8.9. while it's good, audio out via HDMI Isnt working which is a bummer and also OTA updates don't seem to be working. Due to my job I really need to be staying as up to date as possible on security patches. I don't really want to flash a ROM every few months either. This is leading me to want to install the official crdroid and got me wondering if there's a reason why everyone points to Nazim's build for the y700

Much thanks


Jan 23, 2023
Can somebody who has latest zui14 installed, please confirm:

1) you don't have any issues with tablet rebooting or not being able to launch certain apps.

2) after installing app "switch PC mode", which was provided on same xda thread before, you can turn on PC mode on the tablet, even if it is not connected to external monitor?
Rebooting? Send back. You are screwed.


Mar 14, 2011
San Miguel, Bulacan
yup, it's still 305 mhz in diablo immortal and it's laggy... i'm on still on stock rom and zui14. I cannot past on unlocking boot loader.. when i type fastboot oem unlock-go, it always says command unrecognized


  • 20230401_064130.jpg
    3.9 MB · Views: 17
  • Like
Reactions: fiocco
Legion Y700 Fastboot ROM release.
to run Flash, run Flash(fastbootd).bat with fastbootd.

Shop ROM(Global)
  • Like
Reactions: FIERA03


Senior Member
May 1, 2015
Sony Xperia 1 IV
Legion Y700 Fastboot ROM release.
to run Flash, run Flash(fastbootd).bat with fastbootd.

Shop ROM(Global)
The sweet part is boot.img is available so magisk patched to root is possible. I hope newest 14.0231 is released soon
Legion Y700 Fastboot ROM release.
to run Flash, run Flash(fastbootd).bat with fastbootd.

Shop ROM(Global)
You created it myself?


Senior Member
Dec 29, 2007
yup, it's still 305 mhz in diablo immortal and it's laggy... i'm on still on stock rom and zui14. I cannot past on unlocking boot loader.. when i type fastboot oem unlock-go, it always says command unrecognized
You turn on beast mode when you slide left on screen ? the boost GPU only working on beast.

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    All - It's been a long time since I posted anything here but chiming in on this tablet has warranted some comments. For background, I'm an early adopter of android and used to flash ROMS and such many, many years ago, in large thanks to the XDA community.

    I too have been on a long time search for a high peforming sub 10" Android tablet. After going through several my most recent one until the Y700 was the Samsung PM205 (Tab with Pen). Unfortunately, it seemed the best out there for a modern-ish form factor (Samsung has a tablet oriented for commercial use, I had that too, but it was an odd design but performance was good). The PM205 handled single app streaming just fine, and was very happy with it in that regard, but once I started a multitasking or even doing other simple things like doing a Google search while streaming, the tablet was awfully slow.

    I used the comments in this forum to pull the trigger on Legion Y700 stock Chinese version with 8GB RAM and 128GB storage. Great price on AliExpress (which I am slowly but surely becoming less hesitant of) at $290 OTD. It came in about a week to The U.S.

    I decided to post a comment because I just wanted to validate what everyone is saying. Keep in mind I only want English language, and will primarily use the tablet for streaming services, the occasional web browsing, racing games and as a reader. I used the translate camera app to switch the device to English once I got it.

    After I did basic setup, including installing the Play Store from the ZUI Store, I noticed that I could not install certain apps such as Netflix and Hulu ("Your device isn't compatible") . I did check to make sure I had Play Services active and that was there. I don't really want to side load anything at this time so I figured I would just use my browser for those services.

    Over the next half day 2 updates came in to the tablet, one probably a minor security update and then the major ZUI update. After that last update I did have server issues with the Google Play store, I un-installed it, re-installed, rebooted and it worked fine. Additionally low and behold I was able to now install Netflix and Hulu apps from the Google Play Store. Additionally, Chrome as my browser was now an option (from the store).

    So far any of the apps I use no longer have an issue. The new ZUI seemed to actually open up the tablet even more for at least this U.S. user.

    I have uninstalled or put to sleep any of the stock apps I could that don't translate to English. I did keep the ZUI store in case I need to load stuff in the future.

    I have tested most of my streaming services and games such as Asphalt and Need for Speed and this tablet is just dandy. It feels like it has 20x the performance of my other tablet (which is going bye bye).

    Anyhoo, it's got to still be the best consumer oriented sub10" Android tablet out there. I can see myself holding it for many years.
    A few notes on my experience with this tablet : I got it with the global rom and I wished to flash the stock rom and re-lock the tablet after to restore it in the original factory state :

    - Flashed the CN rom using this guide, it went fine. I used "adb oem edl" to enter EDL mode as the mehod with the buttons did not work for me
    - Re locked using "fastboot flashing lock" from the bootloader menu (vol+up), not the fastboot menu. (this driver was needed to "see" the tablet with fastboot)
    - The tablet was bricked (refused to boot after re-locking / some error messsage like "system corrupted / unable to boot" then after this it just kept going to the bootloader when turning on)
    - Unlocked the bootloader using "fastboot oem unlock-go"
    - Managed to flash again from EDL, to enter EDL again (took me a bit of time to figure this) I had to use "fastboot oem reboot-edl" from the bootloader
    - Starting over I did all the OTA updates up to ZUI14 "14.0.255 ST" (I received the updates even if the tablet bootloader is unlocked), then did a "Factory data reset" from the settings menu.
    - After this I attempted to lock again and... it worked. Not 100% sure if it's due to the Z14 OTA, the factory reset or both (I suspect the OTA).
    (I am keeping the "OEM unlocking" (allows the unlocking of the bootloader) option enabled in the developper options just in case I need to re-flash for some reason in the future)

    Hope this can help others,
    more locale 2 broke legion assistant in game to me
    Oh, that's why it's not opening anymore 😂 I don't use it but i was wondering why it's not working. Thx
    Lenovo Legion Y700 - full OTA (3,17GB) package zip of 14.0.255:

    finally changed my un-updatable global zui13 rom to cn zui14 rom. happy with the results so far.
  • 12
    Bricked Lenovo Y700? Follow this guide.

    Windows guide, might work for other aswell.

    I finally solved my problem with my Lenovo Y700 tablet being stuck in bootloop mode due to trying to flash Magisk boot with a mismatched firmware version. This resulted in the UI constantly crashing, and I could not connect to Wi-Fi, and other problems...
    I tried flashing back to stock with QFIL, which put the device in a bootloop. I will explain why later on.

    I also lost recovery mode due to trying to solve the problem, and now I was stuck with either showing the bootloader screen, or restarting the tablet, which brought me back to the bootloader.

    So the tablet was now genuinely useless. This is what I did to bring back the stock ROM and later flash to crDroid 8.10.
    Flashing boot.img, system.img or recovery.img was no luck.

    First off, there is no need to have unlocked "USB debugging" before your tablet bricked.
    Second, you don't need to have your "sn.img" file from Lenovo, you can unlock the bootloader using fastboot commands.
    Fastboot commands works on the bootloader screen, without having ADB connection.

    Start by downloading these four files:
    Platform tools r33.0.2
    Lenovo Y700 tablet stock ROM

    We'll start by unlocking your bootloader. You can do this from the bootloader screen. If you for some reason can enter recovery mode, enter fastboot.

    1. Connect your tablet to your PC.

    2. Open a terminal windows in the ADB folder. On Windows 11 this can be done by right-clicking inside the ADB folder and select "Open in terminal". If you don't have that option, try Shift + Right-click. If that doesn't work, you can always start the terminal by pressing Win + R, and type in "cmd" without citations. Now you have to navigate to your ADB folder by typing
    cd (here you'll type in the location of your ADB folder)
    Without the brackets.

    3. When located, type in
    fastboot devices
    You should see your tablet in the list.
    If not, try using another cable or USB port on your PC.

    4. Now type in
    fastboot oem unlock-go
    Restart your tablet, and it should now say "unlocked" under "DEVICE STATE" in the bootloader.

    5. Now you can start by installing the programs on your PC, QTPS, Qualcomm driver and platform tools.

    6. Extract ALL files from your stock ROM to the "bin" folder in QTPS location (usually C:\Program Files (x86)\Qualcomm\QPST).
    This will help with Sahara errors in QFIL.

    7. Open QFIL from your QTPS bin folder, it installs with QTPS. Don't worry if it shows "No Port Available", we'll get to that. Your configuration should look like this:


    Your main window should look like this:


    Don't worry about the "status" window.

    Hit "browse" in the "Programmer Path" window, and navigate to your QTPS bin folder. Select "prog_firehose_ddr.elf"
    Hit "Load XML", and navigate to your QTPS bin folder. Now, select ALL of the "rawprogram" files (my first mistake, I only selected the "rawprogram_unsparse0.xml" file on first flash)

    In the next window, select ALL of the "patch" files (my second mistake, I only selected the "patch0.xml file" on first flash).
    Without doing this, you will only flash a portion of the ROM, and not all of the partitions needed.

    8. Now it's time to reboot you tablet into EDL mode to be able to flash. Start your tablet by pressing VolUp + Power button.
    If you can't turn off your tablet when connected to PC, just select "Power off", and just hold the VolUp button as soon as the device vibrates and reboots, keep holding until the screen flickers and turns off.

    9. Now QFIL should detect the Qualcomm 9008 port. If not, hit "Select Port" and select the Qualcomm 9008 port.

    10. Hit the now available "Download" button, and the flashing should begin. Allow it to run its course, and it should reboot the tablet when done. Might take a while.

    If flashing won't start properly, you might have waited too long between entering EDL mode and hitting the "Download" button.
    If so, disconnect your device, which might now be "dead".

    Don't worry, you can fix this be holding VolUp + VolDown + Power button for a long time, say about a minute to be sure. Release the Volume keys some second before releasing the Power button.
    Hit the power button again, and the tablet should boot to bootloader screen again.
    Repeat the steps to enter EDL mode, and now hit the "Download" button in QFIL when it becomes available, don't wait too long.

    You're done!

    I recommend opening "Settings", enable "Developer" option, by pressing the "Build number" on the "About tablet" screen repeatedly until a pop-up appears saying "You are now a developer".
    Open "Developer options" and hit "Enable USB debugging", it will allow you to run ADB commands from your platform tools folder.
    If you want, you can again open the terminal in the platform tools folder and type
    adb devices
    It should now show your device in the list.

    Now you can uncheck the "OEM unlocking" in the "Developer options" which should let you get OTA updates when available.

    There are plenty of guides on how to flash different GSI's like crDroid, so I won't cover that here.

    Enjoy your tablet!
    New ota soon. I hope this fix all the issue
    Hi all.
    I just got this tablet yesterday.
    Language available on tablet are chinese and english maybe (morelocale2 could be useful)
    Google play services can be download directly from ZUI app store inside the tablet.
    Widevine L1.
    not sure about root or unlock bootloader (didn't use android device for a long time)
    I have flashed a lot of GSI on this tablet so far.
    Here is a summary of the bugs and other issues that I have noticed in them.
    ※All of them are Android 12L except for the ones without special notes.

    ①Corvus OS, Descendant OS, Cherish OS...Lock screen does not rotate. Probably because it is based on Google Pixel ROM. Corvus also does not have face unlock. The latest Corvus also added this.
    ②Ancient OS(Android 12.0)...Lock screen does not turn to landscape. Also, when I change the username or photo at the top of the settings, the settings app crashes. Also note that the settings app crashes if you change the username or photo above the settings.
    ③Proton AOSP...When I restarted to set up Magisk, the settings app repeatedly stops. Deleting app data and cache had no effect.
    ④Havoc OS(Android 11)...The startup logo does not appear in the first place and comes back to the bootloader.
    ⑤Superior OS...It started, but the FPS dropped extremely. I judged that it is difficult to use regularly.
    ⑥Pixel Experience…The screen is still not landscape. Also, it seems that it is not optimized for tablets any more than Descendant, and when I call the dock while launching an app(the feature of 12L), the icon looks like it has been split in half.
    ⑦All of NipponGSI...Like Havoc OS, it comes back to the bootloader. It may be a bad compatibility.
    ⑧Lineage OS…There was a switch "Rotate lock screen" in the settings. But I don't use it, because the "su" binary is still in the root file and can't delete it ,so interferes with SafetyNet.
    ⑨Arrow OS...This also allows the lock screen to be turned landscape and is also very light. Although the lack of face unlock is a demerit (LSPosed module didn't work→ there are few complaints for me. So I'm using it regularly.

    I'm sorry if it's hard to read because I'm not good at English. Thank you.
    Okay. I have managed to do everything from combined insights. So, let me save you guys the trouble I had by writing my proces down (and for myself for the future).
    I came from the 'global rom'. And wanted to end with 13.1.578 ROOTED

    1. Download this file. It contains the stock firmware on 13.0.586. Unzip it, and find the recovery.img as we need it later.
    2. Upgrade all the way you like through OTA.
    3. Flash TWRP from here. Know that it is a 'faulty' version with only a line on top of the screen. And this vbmeta file. Place both files in your ADB folder.
    4. Use ADB to extact the boot.img from the version you are on.
    4.1 Boot into the bootloader (adb reboot bootloader).
    4.2 disable AVB (not sure this is necessary, but it worked for me) by sending the following commands:
    fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
    fastboot erase userdata
    4.3 Instal TWRP by sending this command : fastboot flash recovery recovery.img (note that you use the name you gave your TWRP file)
    4.4 reboot in recovery mode (fastboot reboot recovery/manually on the tablet)

    Now the TWRP recovery should load, with only a line on top, and nothing else.

    4.5 In the TWRP recovery enter: adb shell (you should see a # appearing in the line)
    4.6 Send these commands out:
    dd if=/dev/block/bootdevice/by-name/boot of=/sdcard/boot.img
    adb pull /sdcard/boot.img stock_boot.img

    what this does, is extracting the boot.img of that specific version you are running, and placing a copy of it into your adb folder.
    4.7 send these commands to get back to the bootloader:
    twrp reboot bootloader

    5. Flash back the stock recovery. If you followed the guide, you have the stock recovery from step 1. Give it a fancy name, and place that file in your adb folder and sending this command:
    fastboot flash recovery yourfancyname.img
    fastboot reboot

    Now it may give some warnings and errors. It told me to do a factory wipe, wich was okay for me. After that the tablet starts normally. Stock firmware, but still on the same version I wanted.

    6. Now the easy part starts. The stock_boot.img you got in step 4.6, should be on your pc. After the inital setup on the tab, place that in your root folder. Download Magisk and install it on your tablet. When it is installed, click on 'install' and 'select and patch a file'. Select the stock_boot.img you moved to the root of your tablet. The patched file will be in your download folder. Transfer that patched file to your adb folder on the computer.

    7. Go into adb and boot the tablet into recovery mode (this should be the stock recovery again): adb reboot recovery.

    8. In recovery mode, go to fastboot. It'll say fastbootd on top.

    9. Enter this command: fastboot flash boot patched-file-of-magisk.img

    10. Restart the tablet. Congrats, you now have rooted your desired version.

    It might be to much info, but I wish I had these steps. It was late yesterday. Very late...So to save you the troubles, I present you my humble guide. If you have improvements in the steps or instructions, please let me know!!