• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lenovo E10 TB-X104F TWRP?

Search This thread

dobraeuyan

New member
Jun 15, 2021
1
0
It doesn't matter which ROM you flash, it never goes past the splash logo. I have tried the GSI of LineageOS, Resurrection Remix, AOSP Extended (All in Android Oreo, because Pie, Q and R are very big, and this tablet does not allow to install any ROM of more than 975Mb), for ARM A Only, and none works . Neither with the original boot.img, nor the one patched with Magisk. Not from ADB, not with TWRP. It just doesn't work (Fortunately it's easy to go back to stock with Lenovo's tool.). The most I have managed is to root it with the stock ROM. Many people have written that they could do it, but I can't, I have tried some guides but nothing achieved. Anyone who can provide me with the steps to flash a GSI ROM for this tablet?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Since Lenovo/Motorola added our E10 / TB-X104F to the recovery tool I decided to play around with hacking apart this awesome and terrible table. Long-story-short... you can unlock it using the normal FASTBOOT commands. A MAGISK modified BOOT.IMG does work which gave me full root access to the tablet. If people are interested I'll write up a guide... but a little bit of research on MAGISK and grabbing the Lenovo recovery tool will be your first step if starting from scratch.

    Next step is getting a recovery image. I'm currently looking into getting this tablet into the TWRP BUILDER queue, but at the time of this writing their queue is full.

    UPDATE: Just saw the TWRP BUILDER team has had everything on hold for over a month now. Guess I'll need to see about building this locally in my free time.
    1
    Ok, so i tried my best to follow this, tried multiple RR ditros and tried lineage as well, treble of course. and while i am not the most experienced at doing this ive done it enough times to know that something is up

    so if i just flash magisk bootfile to recovery than it does nothing

    if i flash any of the arm32 GSI's to system than i get a permanant LENOVO logo.

    if i flash any of the arm32 GSI's to recovery than they just wont install (to large error)

    if i flash an arm64 (i know that would be wrong but im just trying stuff at this point) than it just crashes to bootloader immediately

    I tried building my own magisk bootfile and using the one available on this chatboard. there are enough people on here that say it worked that i genuinely dont get why its not working.

    that said the assistant does fix the tablet but i would very much like to get root or a custom OS running on this. so can we get an explanation for why this isnt working? or a better guide.

    Also to any mods, if a better guide doesnt turn up in this chat you guys should probably kill this page, the guides on page 1 do not work correctly and are very misleading especially to beginners and i can imagine this leading to many bricked devices, if someone wants to prove me wrong and explain my error i will gladly accept me being inncorrect