• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lenovo S5 Pro - L58041 (Global) [2020.03.21]

Search This thread

lolsors

Member
Mar 25, 2018
6
1
Hello, I am currently stuck on the unlock the bootloader part.

I run the command
fastboot flash unlock sn,img
but its stuck on waiting for any device. I have already installed the drivers using the ones provided in the adb systemwide installation.

Any help would be much appreciated
 

Halwer

Senior Member
Aug 29, 2013
144
23
Vienna
Hi,

I am not completely sure about this, but try to run the command line as administrator. You can always do a ,,fastboot devices" command to check for the currently discovered devices. Did you enable the unlocking in the developer settings?
 

lolsors

Member
Mar 25, 2018
6
1
Hi,

I am not completely sure about this, but try to run the command line as administrator. You can always do a ,,fastboot devices" command to check for the currently discovered devices. Did you enable the unlocking in the developer settings?
Thank you for your help. After digging around a bit, i opened up device manager and saw that the phone was just listed as Android when in fastboot, so i simply did update drivers and changed it to the android bootloader interface driver. Now it connects and the thing send however i encounter another problem.

1628091886645.png


I can't take a photo of the phone screen right now but its on the Lenovo boot up logo with text on the top left saying press any button to shutdown
 

lolsors

Member
Mar 25, 2018
6
1
Sorry for double posting, but i have managed to do something, however now its just stuck on this even with administrator capabilities.
1628095305835.png


I now plan on reformatting the device then trying to unlock the bootloader. However, i also suspect this may be a driver problem.
 
Last edited:

Halwer

Senior Member
Aug 29, 2013
144
23
Vienna
I hate Windows for various reasons and this is one of them....

You can download a Linux Distribution from the Windows Store and try with that again. Before you do that you have to enable Windows Subsystem for Linux in the Control Panel. Did you try to run the cmd.exe as an admin? Yes, you might be right I also suspect a driver problem here.
 

lolsors

Member
Mar 25, 2018
6
1
So i have factory reseted my device, and instead of using WSL. I instead opted to put ubuntu on a live usb and work from there. but the problem is still the same: It is still stuck on sending 'unlock' (5 KB).
 

Halwer

Senior Member
Aug 29, 2013
144
23
Vienna
I found an other topic about the same issue: Topic

There are really just the same ideas we already mentioned, but trying a different USB port or cable sometimes solves problems.
 

lolsors

Member
Mar 25, 2018
6
1
I found an other topic about the same issue: Topic

There are really just the same ideas we already mentioned, but trying a different USB port or cable sometimes solves problems.
Thank you so much! I don't know why i didnt think of this, but I tried out on a different computer and it worked. Now i am running the crDRom11. Btw, I initially had issues with flashing the roms after following the instructions, though after i did a twrp uninstall of magisk-phh, it works flawlessly. I don't know if that is an actual issue or not.
 
  • Like
Reactions: Halwer

lowew31718

New member
Aug 12, 2021
1
0
Hello all, quick question here.
So, I've tried out Havoc-OS 4.5 the other day and android 11 seems to be working nicely with this phone. I am wondering if anyone had any luck with magisk rooting on 11? I tried the linked custom one but now stuck in bootloop, need to reflash boot.img from stock ROM I believe. I was going to try other Magisk versions later tonight after I fix this soft-brick.

Thanks in advance.
 

Halwer

Senior Member
Aug 29, 2013
144
23
Vienna
If it is not working with the official Magisk, maybe you could still try the Canary or the Beta channel. There are also so called ,,phh-magisk" versions, sometimes they work when other versions don't.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Welcome to this little thread in which I'll provide every useful information about this device based on my and other users's experiences. If you know something, that I didn't mention, please reply to this thread in order to help out each other even more effectively. Thanks and pleasant reading!

    The Lenovo S5 Pro is a very decent mid-ranger with good specs and even better pricing. We all know, that chinese manufacturers tend to install bloatware on their products time to time. In our case, Lenovo didn't release a single update since 2018 Novemer to this device. It means, that it came out with Android 8.1 Oreo (2018 November Security Patch) and left untouched. This is even worse, than Meizu which is famous for it's neglecting policy of software updates for global users. Now, that we know all this, it's not a surprise, that we are here on our favourite developer forum.

    *** General information | Links | Downloads | Credits ***

    The official global firmware is now saved and available (thanks to our forum member nikosddesign) here: download & link to the post

    Everything you will possibly need (PC software, drivers, stock camera app, VoLTE modem etc...) is available in this Yandex Disk, you just have to navigate to each one. (Most of the content is in russian, since Yandex is the russian Google, but it's not hard to find the files you'll need).

    The previous links and the following tutorials are only available, because suninterbru (from 4pda forums) and radiationofthenation provided these informations and the tutorials, also so much thanks to everybody on the 4pda forums, who provided useful information and files, большое спасибо!

    Even though the bootloader unlock, TWRP install and rooting should not cause data loss, be careful and create a backup. You can back up only your files and data or your whole ROM, it's up to you.

    Please note, that after you've unlocked your bootloader, everytime your reboot or turn on your phone a warning will pop up during the boot process for about 1 second. On Android 9.0 Pie vendor the message pops up for about 5 seconds. The warning is about the side effects of modifying the system software and it also says, that it is not recommended to store any personal data on your device anymore. Please ignore this message, since it's only popping up, because manufacturers usually don't like, if you modify your device.


    Pro tip: If you keep pressing your power button for a little longer you can skip the alert and boot faster.




    *** Bootloader unlock ***

    Please note, that your warranty will become invalid/void after you unlock your bootloader or root your device.

    0. In your device's developer settings enable bootloader/OEM unlock and USB debugging.
    1. Visit the official ZUI bootloader unlock website.
    2. Enter your IMEI1 number in the first field. (You can find your IMEI numbers in Settings\About or in the dialer enter: *#06#).
    3. Enter your serial number in the second field. (You can find your serial number in the fastboot menu). The one in the settings is not good in this case! (To access the fastboot menu, turn off your phone, then press the power button and after you see your screen light up, immediately press the volume down (-) button or while it's turned on and USB Debugging is enabled, simply type in the terminal/cmd ,,adb reboot bootloader").
    4. In the next field enter your email adress. (Please note, that Tutanota won't work, Gmail is recommended or other not secure email providers).
    5. Enter the verification numbers in the last field.
    6. Tick the checkbox.
    8. Click on the blue button.
    7. Now check your inbox and/or spam folder, because Lenovo just sent you your custom sn.img, only for your phone.
    8. Save the sn.img to your PC and install ADB drivers system-wide. (Thank you Snoop05 for your work)!
    9. Open a terminal/cmd on Windows. You should be in the same directory, where your sn.img file is, with the terminal. To change directories type ,,cd your directory goes here" and hit ENTER.
    10. Run the following commands:
    - adb reboot bootloader
    - fastboot flash unlock sn.img
    - fastboot oem unlock-go
    11. Congratulations! Your bootloader is now unlocked!



    *** TWRP Recovery ***
    1. Download the .img file from here.
    2. The steps are similar to the bootloader unlocking:
    - adb reboot bootloader
    - fastboot flash ,,downloaded" .img
    - After the flashing is done DON'T reboot to the system, instead navigate to the ,,Reboot Recovery or Recovery Reboot" option and select it. (Volume keys and power key - you know the drill) This will ensure, that the TWRP Recovery doesn't get ereased on reboot(s)!
    3. After you've successfully rebooted into TWRP, you should root your device with Magisk, to prevent the recovery erasure!



    *** ROOT ***
    1. The good old SuperSU is no longer in the picture, but don't worry a new player is in the game. Download Magisk from here. (Thank your for your work topjohnwu)!
    2. After you've downloaded the flashable .zip copy it to the main directory/root of your device.
    3. Reboot to TWRP.
    4. Click install, select the flashable .zip file.
    5. The installation process should start.
    6. Reboot, after finished.
    7. Check if Magisk Manager is installed or not, if yes tap and update it.
    8. If you did not succeed, please check the Magisk topic for solutions or reply to this thread.



    *** Factory reset | Stock ROM | Unbrick | LOST IMEI/PERSIST/EFS | QCN BACKUP/RESTORE ***

    !!! NEVER EVER TICK ,,ERASE ALL BEFORE DOWNLOAD" IN QFIL, OTHERWISE YOU WILL LOSE YOUR IMEI AND THE ABILITY TO CONNECT TO MOBILE NETWORKS !!!

    If you accidentally clicked on that option you will have to restore someone elses QCN backup. (It will not work, if you backup your own QCN and rewrite your IMEI and restore it, so do not waste your time with that)! Luckily, a member of the 4PDA forums published their qcn backup. (большое спасибо geepnozeex)! QCN backup for Lenovo S5 Pro. (I modified the link, because the original one is no longer valid)

    1. Download the linked QCN file.
    2. Make sure, that you are on one of the Stock ROMs, however the recommended ROM is this one.
    3. You will have to be rooted to put your device in diagnostics mode. To do that, follow this tutorial.
    4. You will have to edit the QCN file with HxD, in order to write your own IMEI into.
    5. Open the file with HxD and search for 08 8A 76 06 06 14 57 95 32. This is the IMEI 2. You will have to insert your IMEI 2 from the box here, but first you will have to convert it into Hexadecimal numbers.
    6. Convert your IMEIs into Hexadecimal numbers here.
    7. You will have to rewrite and insert your values insted of the previous one.
    8. Search for 08 8A 76 06 06 04 67 98 72. This is IMEI 1. Convert your IMEI 1 into Hexadecimal numbers, too and replace.
    9. Save the file (Ctrl + s)
    10. Open QFIL and click on Tools, then QCN Backup/Restore.
    11. Choose the QCN file, you wrote your IMEI into.
    12. Click on Restore QCN.
    13. There is a chance, that the process/progress bar won't finish till the end. No problem, just reboot to EDL mode through TWRP/Advanced and restore the recommended stock ROM.
    14. You should have everything working fine, now.

    To factory reset or unbrick your device, follow this tutorial on 4PDA. [Don't panic you don't have to know russian, just follow the instructions on the pictures! To see the pictures, click on the bold text.] ,,(спойлер (+) (Инструкция по прошивке)" ~ or ~ Download any of the previously linked STOCK ROMs to your device's main folder and flash them through TWRP. Most of them are in flashable .zip formats and should work well. A simple factory reset in TWRP is recommended before installing any of the ROMs, be careful this action will erease your data from your phone!


    (Please note, that most of the time you'll have to use the QPST/QFIL method, because the flashable .zip files always expect a specific vendor version, usually a lower one, so you can upgrade with flashable .zips, but possibly can't downgrade, so you have to use QFIL)!

    *** GSI custom ROMs ***

    Our device is arm64-aonly, so please only use according GSIs. Note, that I will link only those GSIs, which are booted successfully on my device!

    ~ phhusson's official GSI list: here
    ~ phhusson's AOSP GSI (Android Open Source Project): here
    ~ developerluke's ExpressLuke GSIs: here
    ~ eremitein's CAOS GSI Project: here
    ~ eremiten's LOSQ GSI Project: here
    ~ igors1974's Amber GSIs: here
    ~ tunasahinn's and yek4perf's Tunahan's GSI builds: here
    ~ mrsshunt3r's albus-gsi: here



    Note, that you should keep up with the developments and update your system, if needed! These are just a few GSIs, that I've tested personally on my phone, but you can always keep up with the latest news and try new GSIs out, thanks to phhusson's official GSI list!

    *** How to flash an Android 10 GSI ***

    1. Download the latest custom phh-magisk from here. (Thank you developerluke and phhusson)!
    2. Download the latest Disable_Dm-Verity_ForceEncrypt from here. (Thank you Zackptg5 and others)!
    3. Download your desired GSI.
    4. You can flash from an USB-OTG flash drive or from the storage of your phone. (I personally have a dedicated USB for this purpose).
    4.1 If you are coming from stock ROM you will most likely need to Format Data in this step, because the Disabler won't be able to decrypt the data and, that will cause a stuck at the boot logo!
    4.2 Reboot Recovery
    5. In TWRP perform a normal factory reset
    6. Flash Disable_Dm-Verity_ForceEncrypt. (Cache wipe is optional).
    7. Flash your GSI image.
    8. Format Data (Skip this step if you already did this in 4.1)!
    9. Reboot Recovery (Skip this step, too if you already did this in 4.2)!
    10. Flash Magisk-phh
    (11. Wipe cache/dalvik).
    12. Reboot System
    13. Enjoy!



    *** Possible GSI bugs ***




    Please note, that bugs can differ/vary on different GSIs, the numbers are not fully accurate!




    1. The default camera app will work, however it doesn't support HDR, panorama or portrait modes. It also can't record in 4K resolution. Freezing is also possible. ~ 50%
    2. First time, when you open the camera it'll stuck on loading, but after you go back and open it again it will work flawlessly. ~ 50%
    3. No audio/microphone during phone calls. ~ 15%



    *** Guaranteed GSI bugs***
    1. The infrared face unlocking will not work, only fingerprint authentication is working. ~ 100%
    2. You won't be able to charge your device while it's turned off, after you plug it in, it will automatically boot up. ~ 100%
    3. Auto brightness. ~ 100% (There is a fix for auto brightness below)!



    *** Camera fix (GSI) ***

    (If you get ,,serious camera error" or your camera freezes on HDR)

    1. Download a custom camera app, where you can manually adjust the ISO level.
    2. With OpenCamera, for example you have to adjust ISO to 800 and never above, because your camera will freeze!
    3. So, always keep ISO 800 or under. With these settings even HDR shots are working!



    *** Auto brightness (GSI) ***
    1. Download framework-res__auto_generated_rro.apk from this thread.
    2. Follow the instructions, which are described in this post. (You will need to have root to use ,,su" commands).
    3. Thank you MishaalRahman and kAs1m for the apk and the instructions!
    1
    Hello
    I HAVE a LOT of great news. I have the Official Global Firmware
    Lenovo L58041 8.1.0 android
    version 3.9.062ST
    I do not bring any responsibility for your mobile
    Whatever happens is at your own responsibility.

    If you are in what new version it would be good to downgrade the system.
    by 8.1.0 version (123rd last)
    The way you can install firmware image:
    With TWRP and the restoring Backup
    Device doesn't open and stuck to the logo.
    The best way to open the device is
    To install the image files from the TWRP folder
    system_image.emmc.win
    boot.emmc.win
    firmware._image.emmc.win
    vendor_image.emmc.win
    Screenshot_2019-12-21-01-15-04.pngScreenshot_2019-12-21-01-15-21.pngScreenshot_2019-12-21-01-15-26.png
    Screenshot_2019-12-20-18-51-24-0115933619.jpgScreenshot_2019-12-20-19-20-24-1744636722.pngScreenshot_2019-12-20-18-50-22-2138701841.jpgScreenshot_2019-12-20-18-50-13-1433906869.png
    Link: https://1drv.ms/u/s!AmS6Qb6r9_1Zmkomvm0On0zzWAoC?e=nkemke :good:

    sorry my bad english use traslator...
    1
    Hi nikosddesign

    Thank you for the backup of global rom.
    All working perfect except calls, no voice on calls...

    Sorry for my bad english



    Hello
    some times it happened to me too. i just went up on android 9 and restoring the backup boot,system, only.
    and if not.
    Flash 8.1 qpst and restored only the two partitios I mentioned
    1
    I'm having trouble installing TWRP. I unlocked the device, but it erased everything on the phone.

    When I try to install the img file, the image error appears:

    - FAILED (remote: Requested download size is more than max allowed)

    What can it be? :eek:

    s2ejgn

    Hi,

    If your phone is erased, then you can lose nothing, if you do a full QFIL restore and try again. The bootloader unlock shouldn't have erased your phone. It's strange.
    1
    When get at cmd fastboot device show me same 7 placees number.
    I dont know what I can do . Do you have some idea ?

    Please be careful and never post your unique IMEI number(s)! It is interesting, that you have a 7-digit number in your Fastboot menu. Have you tried to input the one from the settings? You have to find the other serial number, I think it is under the ,,IMEI information".