Lenovo TAB S8-50 - Stock Firmware ROM/Root and Support

Did you find this thread useful?

  • Total voters
  • Poll closed .
Search This thread
Jun 14, 2020
Euréka! I tried to install update from inserted SD card and it worked! Dolby digital works again perfectly! I will test stability of this build and I will post my observations. Would someone be interested in uploading the whole package (1 GB)? I dont know whether it is legal but I have the zip file in my computer.

Hello could you please send me the update file or upload it on google drive and send me the link ?


Senior Member
Aug 15, 2006
Since I've updated to Android 5 on this tablet WiFi keeps dropping (shows connected but nothing is connected to internet). Only way to het it to work is by turning Wi-Fi off then on, then it works and stopa again. Anyone having those issues?


Senior Member
Jan 25, 2012
Last edited:


Mar 8, 2020
I've booted Windows 10 Setup; Clonezilla Vivid; and a Port of Ubuntu Trusty, I'm hoping that now that works slowed down i'll have more time to play.

Unfortunately at the moment you need to switch between Android and Windows 8.x boot mode in order to boot Windows or Linux ; hopefully a bootloader that supports the factory android images will be possible at some point.

Micro Connectors USB OTG
iHome 7 Port USB 2.0 Hub - Black

not legend sorry

Please note I went through a few otg-cables and hubs before i found a combination that worked.
show me photo with booting windows


Apr 21, 2021
Hi there, I know this is an old thread. But maybe after quite a time, TWRP can be installed permanently as a custom recovery on this tablet?


Apr 21, 2021
Here is link for S8 unlocker ;)

---------- Post added at 06:33 PM ---------- Previous post was at 06:33 PM ----------

@banmeifyouwant ;)
Sadly, this link and the download link in the first post of this thread are dead.
The googledrive-link from Miinto107 isn't available for download, cause google says, the "S8unlocker.exe" is virus infected. That's why you cannot download it.

@Minto107 Please reupload it somewhere else. Thank you.


Mar 8, 2020
Linux install


I'm trying install ubuntu for the tab.
I copied the ubuntu installer from the data partition, with adb. Partition type is vfat.
I run the installer grub from efi-shell. i'ts running fine, i can setting up localization, keyboard...
But it doesn't found the install media. The tablet detect the partition to ram. /dev/ram1,2...15 I'm trying mount it unsuccessfully.
I try load the driver, but it isn't help
Unfortunately the installer has minimal bash with busybox

Someone have idea how i mount the partition? Now the google isn't my friend. :(
Enter UEFI, connect flash drive and install it.


Senior Member
Apr 20, 2017
Not sure if it'll help someone but here I'll attach a bios dump file that I extracted from the bios flash using a programmer.


  • Lenovo Tab S8-50L Bios file.Bin
    8 MB · Views: 114


New member
Mar 27, 2023
Linux install


I'm trying install ubuntu for the tab.
I copied the ubuntu installer from the data partition, with adb. Partition type is vfat.
I run the installer grub from efi-shell. i'ts running fine, i can setting up localization, keyboard...
But it doesn't found the install media. The tablet detect the partition to ram. /dev/ram1,2...15 I'm trying mount it unsuccessfully.
I try load the driver, but it isn't help
Unfortunately the installer has minimal bash with busybox

Someone have idea how i mount the partition? Now the google isn't my friend. :(
hello dear, recently I planned to install Linux on my tab too, do you remember its process by any chance? would you mind if do a favour to me and guide me a little bit? I'll appreciate that 🙏


New member
Mar 27, 2023

Top Liked Posts

  • There are no posts matching your filters.
  • 64
    Lenovo TAB S8-50 - Stock Firmware ROM/Root/emp CWM Session, and Support

    Hi All,
    I have hard time to figure out since there's no dedicated thread for this tablet. I know you can find couple of posts related to this tablet here in XDA, but again I like all the info for this tablet in one page :D
    My idea here is put all together here in XDA forum, can't promise you that this will be ultimate guide for this tablet, but at least this may help you get started.

    By the way; there are 3 models of the TAB S8-50:
    • Lenovo TAB S8-50F (WiFi)
    • Lenovo TAB S8-50L (WiFi+ Data)
    • Lenovo TAB S8-50LC (WiFi+LTE (Voice)

    Lenovo Official Stock Firmwares
    Lenovo Official Stock Full ROM (TABS8-50F_140929)

    KitKat (Official or Users provided Firmwares)

    This is official full stock ROM that comes with device when you first open it (then gets several update patches after that).
    Download it and unzip it, you should see doc "how_to_download.docx", follow the instruction to flash firmware above. There's also Lenovo_TAB_S850_V1.0.1.msi for Windows drivers in case you needed.

    Update (official patch): Lenovo Official Stock ROM (S000143_140929_ROW_TO_SS000200_150121_ROW) - a big thanks to @KainXSS for getting this for us!
    Important: this is update zip that Lenovo pushed the device, it is NOT full ROM. It will most likely break the root, so use the root method here again to re-root once you got updated.

    Update (offical patch): Lenovo Official Stock ROM (S000164_141103_ROW_TO_S000185_141203_ROW)
    Important: this is update zip that Lenovo pushed the device, it is NOT full ROM. It will most likely break the root, so use the root method here again to re-root once you got updated.

    Lenovo Offical Stock ROM ( TABS8-50LC_141010) - a big thank to @tigr72 for providing this firmware

    Lollipop (Official or Users provided Firmwares) - Update 11/23/2015

    A big thank to both; @mac231us and @Shump for providing following information below -
    If you have questions, you may ask @mac231us, @Shump, @balika011, and @Minto107, I am sure they will be happy to help you out whenever they can, but be nice to them!

    Lollipop TWRP backup S8-50F_S000456_151016_ROW
    S8-50F http://forum.xda-developers.com/showpost.php?p=63598258&postcount=947

    @bailka011 Unlock Tool
    @Shump 's excellent explanation of how balika011 unlock tool works: http://forum.xda-developers.com/showpost.php?p=63716397&postcount=1085

    Updated flash tool;

    S8-50LC firmware version 151016 S000456 - thanks to @Minto107 for providing download link. If download link does not works, please ping @Minto107

    Root Methods

    Root (method 1): - - a big thank (спасибо) to Xakep @tigr72 at Lenovo-forums.ru
    This is for S8-50LC, but it works for S8-50F too. Download it your PC (windows only) and hook up your tablet to your PC, and double click on Root_S8-50LC_tab.exe, it should flash SuperSu and root your device.
    it is important that your device can be recognized by ADB command in order to root tool work (test your adb connection: adb devices, make sure it connects to your device)
    Check @Hash.H's post here for detail instruction; Official "How To" root Lenovo Tab S8-50

    Root (method 2):
    Check @bogdann8's post here - this method may come handy if you get new firmware upgrade and above method no longer works, then this may be another way to root;
    Lenovo S850 (ROW) Rooting (manual process)

    Installing Temp CWM Session

    Custom Recovery installing Temp CWM Session (method 1): --> don't use this, use method 2 CWM below
    Based on this Russian forum, this works for all variant of Lenovo S8-50L, S8-50F, etc. In fact, I tested and yes it does work.
    CWM Recovery for Lenovo S8-50F

    Instruction to install CWM:
    • Make sure that your computer is not connected to other Android phones
    • Make sure that you have installed the ADB driver for S8-50 tablet
    • Make sure that the tablet is turned on USB debugging
    • Connect the device to your computer via USB
    • Download IntelAndroid-FBRL_LF_Edition.7z file, unzip it on your PC's desktop, and run the program called launcher.bat
    • If all the conditions and requirements are met, once finalized, the program automatically closes, the tablet will automatically restart and boot into CWM Recovery, from there you can perform full-nandroid backup or any other stuff.
    • p.s: you need to repeat above steps each time you want to use CWM

    Custom Recovery installing Temp CWM Session (method 2):--> Use this CWM from @social-design-concepts
    If method 1 does not works for you, try @social-design-concepts Temp CWM session. See his thread for more info and instruction. I have tested this, it works. It seems like you can also restore your CWM nandroid backup with this, see @Lander00 post.
    Temp CWM Session by @social-design-concepts

    For Linux stuff - Tethered CWM and Phone Flash Tool:
    Please @Maheshwara 's post here:
    I also like to thank both @kandalph and @Maheshwara, sharing their finding and helping this community.

    How to flash stock firmware
    How to flash stock firmware using How to flash stock firmware tool:
    Follow this instruction if you like to flash full stock firmware to your device, please also http://lenovo-forums.ru for some additional info if you like.
    See post #90

    Additional Info
    Additional Info:
    Lenovo S8-50 tablet (Russian user forum)
    Use Google translate to translate - to download stuff from this forum, you need to register the forum.

    [Q] Lenovo S8 (S8-50) Tablet - Possible Support?
    Some useful discussing thread, go review it, there's some additional info there as well.

    P.s: The last firmware upgrade (build 141203) that Lenovo pushed changes tablet's default DPI 240 to 320. If you happened to get upgrade before root, re-root it and then modify build.prop's to ro.sf.lcd_density=240. The 240 is tablet native default DPI. There's no word when Lenovo officially fix this, see official lenovo user forum below:


    Update: ‎01-28-2015 11:06 AM
    Here's one of the stupidest respond from Lenovo Tech Support about their screwed up DPI - this simply tells you that they will keep 320 DPI for any new upcoming updates. Now, why they do this!?, we don't know nor they are giving any technical explanation, but we all know that original native DPI of this tablet is 240.

    Solution! Re: Tab s8-50 - Latest update changes resolution?
    ‎01-28-2015 11:06 AM

    At this time, the design for the S8-50 tablet image will be maintained at a DPI of 320.

    As noted in this discussion, there are several work-arounds available for customers who prefer a lower setting.

    Thank you to everyone who contributed to identifying the issue and the work-arounds.
    Amy Tupper
    Technical Resolution Lead, Pervasive Issues
    Lenovo US

    Increasing Headset Volume
    Increasing Headset Volume
    A few of you complain about how low the headset volume, to increase it a bit, see the instruction here in this post;
    Increasing Headset Volume Mode by me:p

    Additional Lenovo Apps
    Additional Lenovo Apps
    Here's some newest Lenovo apps (beta) that is not included in official firmwares. Some apps are updated, most likely included as final version upcoming firmware (depends on which region you are on).
    you already may have these apps, before installing, make sure you take a backup so that you can revert it back to original.

    More updated apps will be posted here...

    Using Xposed Framework
    Please note official @rovo89 's Xposed should support Intel x86 devices now. You may use that. Below is just some workaround from Asus thread x86 in case orginal Xposed thought some may find it useful.
    Do not try this if you don't know what you are doing or if you don't have full nandroid backup. This is related to Xposed apps for some x86 devices that causes soft-reboot and
    following is a work-around solution from ASUS thread (since it has x86 intel CPU). As I am not heavily using xposed apps, I have not tried this method.

    *** Install Xposed: Root is a MUST. USB debug turned on. Windows only and Driver for Intel and ASUS must be ready on PC.

    Step1: download xposed apk and install the apk. DO NOT RUN APP AND DO NOT INSTALL FRAMEWORK.
    Step2: Run command promt (Run / cmd). assume adb folder is on C:\ drive and you are now in C:\ADB
    Step3: Type following (or copy and paste)

    adb devices (make sure your phone show!)
    adb shell (hit Enter)
    su (hit Enter, then look on your phone and touch OK)
    echo 148 > /data/data/de.robv.android.xposed.installer/conf/jit_reset_offset (hit Enter)
    chmod 664 /data/data/de.robv.android.xposed.installer/conf/jit_reset_offset (hit Enter)

    Step4: Now go to app drawer and run Xposed which you installed earlier. Touch "Framework" and touch "Install/Update"
    DONE. Now install addons.​


    Remember and always keep in mind; just because I posted this thread out here does NOT mean I am your tech-support. This post provided as it is information only.
    However, you can still post your questions/issues here, and maybe I can or someone else can help you out, this is user driven community, so it is all about sharing and passing the knowledge to each others.
    If find some additional info, tricks, full official firmwares that's not posted here, lenovo apps, etc., please do let me know so I can post them here, so others can benefit as well.

    If you find this thread helpful, please click THANKS button:p
    Accessing the Lenovo TAB S8-50 UEFI Setup

    Accessing the Lenovo TAB S8-50 UEFI Setup :
    You will need the following in order to access and navigate the uefi setup :
    1. USB OTG Cable
    2. Powered USB Hub
      note : I tried 4 powered usb hubs and 2 usb-otg cables before finding a pair that work.
    3. efibootmgr binary here : View attachment efibootmgr.zip
      note : I did not port efibootmgr simply complied it from source found here.
    • Step 1. Extract the View attachment efibootmgr.zip somewhere on you computer and push efibootmgr32 to /data/local/tmp/
      adb push efibootmgr32 /data/local/tmp/efibootmgr
    • Step 2. start an adb shell and navigate to /data/local/tmp
      adb shell
      shell@S8-50F:/ $ cd /data/local/tmp
    • Step 3. as root change permission of efibootmgr
      shell@S8-50F:/data/local/tmp $ su
      root@S8-50F:/data/local/tmp # chmod 6755 efibootmgr
    • Step 4. using efibootmgr
      root@S8-50F:/data/local/tmp # ./efibootmgr -?
      ./efibootmgr: invalid option -- ?
      efibootmgr version unknown (fix Makefile!)
      usage: efibootmgr [options]
              -a | --active         sets bootnum active
              -A | --inactive       sets bootnum inactive
              -b | --bootnum XXXX   modify BootXXXX (hex)
              -B | --delete-bootnum delete bootnum (hex)
              -c | --create         create new variable bootnum and add to bootorder
              -D | --delete-by-label delete ALL boot entries with the same label
              -d | --disk disk       (defaults to /dev/sda) containing loader
              -e | --edd [1|3|-1]   force EDD 1.0 or 3.0 creation variables, or guess
              -E | --device num      EDD 1.0 device number (defaults to 0x80)
              -g | --gpt            force disk with invalid PMBR to be treated as GPT
              -H | --acpi_hid XXXX  set the ACPI HID (used with -i)
              -i | --iface name     create a netboot entry for the named interface
              -l | --loader name     (defaults to \elilo.efi)
              -L | --label label     Boot manager display label (defaults to "Linux")
              -n | --bootnext XXXX   set BootNext to XXXX (hex)
              -N | --delete-bootnext delete BootNext
              -o | --bootorder XXXX,YYYY,ZZZZ,...     explicitly set BootOrder (hex)
              -O | --delete-bootorder delete BootOrder
              -p | --part part        (defaults to 1) containing loader
              -q | --quiet            be quiet
                 | --test filename    don't write to NVRAM, write to filename.
              -t | --timeout seconds  set boot manager timeout waiting for user input.
              -T | --delete-timeout   delete Timeout.
              -u | --unicode | --UCS-2  pass extra args as UCS-2 (default is ASCII)
              -U | --acpi_uid XXXX    set the ACPI UID (used with -i)
              -v | --verbose          print additional information
              -V | --version          return version and exit
              -w | --write-signature  write unique sig to MBR if needed
              -@ | --append-binary-args file  append extra args from file (use "-" for stdin)
      root@S8-50F:/data/local/tmp # ./efibootmgr -v
      BootCurrent: 0000
      Timeout: 10 seconds
      BootOrder: 0000,0001
      Boot0000* EFI Hard Drive        ACPI(a0341d0,0)PCI(17,0)Controller(0)
      Boot0001* EFI Internal Shell    MM(b,fff68000,fff97fff)
    • Step 5. set next boot option / power off tablet
      note : originally i used efibootmgr -n 0002 for setup but after accessing the setup menu this this boot option was no longer available ?
      not sure what happened but maybe someone would be nice enough to post the output of efibootmgr -v for me.
      root@S8-50F:/data/local/tmp # ./efibootmgr -n 0001
      BootNext: 0001
      BootCurrent: 0000
      Timeout: 10 seconds
      BootOrder: 0000,0001
      Boot0000* EFI Hard Drive
      Boot0001* EFI Internal Shell
      root@S8-50F:/data/local/tmp # reboot -p
    • Step 6. Connect USB OTG cable , powered USB Hub, and keyboard to the tablet and power on.
    • Step 7. Exit the EFI Shell by typing exit then hit Enter
    • Step 8. Scroll down to Device Manager then hit Enter - Hit Enter again to select System Setup
    • Step 9. Scroll down to boot and hit Enter
    • Step 10. We need to disable UEFI Fastboot in order to be able to access the setup and boot manager directly from the keyboard.
      Scroll down to fastboot and hit Enter arrow up and select disable and the press Enter the hit F4 to save changes.
    • Step 11. Hit Esc to return to the Main Setup Menu, Scroll down to Commit Changes the hit Enter, Hit Enter to confirm changes and the device will reboot.
      You can now access the UEFI Setup by hitting F2 when powering the tablet on, or you can access the boot manger by pressing F7

      In order to boot a traditional Linux distribution or Windows you need to change the OS Selection from Android to Windows 8.x tne the Boot Setup in the UEFI Setup menu.

    These instructions are awful.
    My custom kernel now in stable stage.:cool:
    Fully working, but the camera.
    I'm looking forward to someone's camera fix.:angel:

    (It's time to start CM12.1 or CM13 development!)
    Downgrade from LP 5.0 to KK 4.4


    Since some of you been asking for full translation and files uploaded from Russian Lenovo forums, here it is.

    This is not my guide, original site: lenovo-forums.ru
    Thanks for VVizard for this guide. Im not responsible for any damage to your equipment. You need to understand what you're doing.

    Latest Phone Flash tool version here

    Downgrading procedure:
    1. Download stock firmware for your tablet. Either it is F, L or LC variants for Phone Flash Tool. This should be original, unmodified stock firmware, not TWRP backup or something.
    2. Download the archive TABS8-50_Otkat.rar. Extract this rar to original firmware folder. You need to copy and replace existing files. (Suggestion: You might want to have 2 copies of original firmware, one unmodified, another with this rar extracted, just in case of course)
    3. Run Phone Flash Tool
    4. Browse -> open the file from the firmware (step 2) -> pft_flash_lte_normal.xml (Dont mind if it says lte, if your tablet is F and you downloaded F firmware it will flash F)
    5. Turn off your tablet
    6. Enter Fastboot mode. Volume down (-) and power button.
    7. Plug tablet to PC, it should be detected by Phone Flash Tool.
    8. Click Flash
    9. If Phone Flash Tool shows FINISHED - in any way do not disconnect from a computer! Tablet still continues flashing on its own.
    10. After couple of restarts tablet should boot as normal.
    11. Finished. You can use your tablet with KK firmware now.
    12. Don't forget to set Region Code

    How to install 5.0 Again:
    Via OTA updates all over again, from version S000143

    The recovery of the tablet
    Perhaps you once wanted to downgrade from 5.0 to 4.4 - and now the tablet doesn't work, error like Boot failed: EFI Hard drive and tablet load Bios but does not start. A little instruction.
    1. Downlaod repair_Bios.rar and unzip it to the root of any drive.
    2. Run Phone Flash Tool (version 5.2.4)
    3. Browse -> open the file from the archive -> flash.xml
    4. Turn off the tablet
    5. Hold volume buttons (both) and the power button. The tablet should go into Fastboot Starting...
    6. Plug tablet to PC, Phone Flash Tool should detect it (Some issues have been reported when plugging into front USB ports, USE ONLY BACK USB PORTS)
    7. Click Flash
    • Since my tablet is S8-50F, after repair_Bios.rar in droidboot it was determined as S8-50LC. Don't worry, after a full flash everything will fall into place everywhere and will be determined correctly.
    • During the firmware repair_Bios.rar long "does nothing". Do not worry, just wait.
    8. The firmware should pass successfully, the tablet itself will boot in FASTBOOT MODE.
    9. Use Downgrading procedure to get back to stock KK firmware.
    10. Read all instructions carefully
    11. Flash a manual roll back from LP 5.0 to KK 4.4.

    After 8th paragraph do not turn off Tablet, let it stay in Fastboot Mode until you figure out how to downgrade!

    I Hope it will be useful to someone as it was for me.

    PS. After downgraded to KK i updated to LP via OTA again. LP build is terrible, even Youtube is lagging after clean installation, everything is buggy, im thinking going back to KK until lenovo releases more OTA's or someone manages to build CM for it :)
    I'll do my best ;) we will see if it will succeed ;)

    Wysłane z mojego GT-I9305 przy użyciu Tapatalka