• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lenovo TB-8504F Wlan Inactive After Updating to 8.1

Search This thread

RobinGill

Member
Jul 22, 2008
21
0
Hi,

I updated this tablet using Lenovo Smart Upgrade Assistant - update to TB_8504F_USR_S001019_1909091114_Q12000_ROW seems fine except my Wifi/WLAN is totally dead.

If I turn it on, it looks turns back to off quickly, but never actually turns on, and sometimes tablet hangs for a while sometimes when I try to turn wifi on.

I saw a previous post where someone also had this problem and solved it by flashing a modded ROM then flashing the stock ROM and Wifi worked again (with a strange MAC address after that procedure)

But I am stuck because the option to enable OEM Unlocking in Developer Options is greyed out - underneath it says to Connect to the internet or contact your carrier.

I have tried unlocking via ADB but this does not work either.

If I go into settings, WLAN Preferences, it says my MAC Address is 02:00:00:00:00:00 which seems to match other people with this problem.

I tried installing a terminal emulator, "ip link show" returns request send failed: Permission denied, "ip link" says I have:
1: lo:
2: duumy0:
3: [email protected]:

I don't have wlan0 or wlan1, and lo/dummy0/[email protected] did not show the 02:00:00:00::00:00 address.

Please does anyone have any ideas for me?

If I cannot get wifi working, is there any way I can connect to internet using USB to my PC?
 
Last edited:

adazem009

Senior Member
I eventually found a version of QFIL that works (part of the QPST package) https://droidfilehost.com/download/download-qpst_2-7-480/

I found a ROM https://drive.google.com/file/d/1C1Fd5m7BMLqrhURAj0kWdqeiZGIuU95k/view (password: https://firmware247.com)

It seems to have downgraded, but now when it starts, I get the screen where I can choose location, and after a few seconds it reboots.
Please try to format data (if you don't have important data in the device) and reboot. If that doesn't help, download latest firmware (S001031). You can also try a custom ROM. Below are links to them:

LineageOS 16.0 (Android 9)
LineageOS 17.1 (Android 10)
Resurrection Remix OS (Android 10)
crDroid (Android 10)
 
  • Like
Reactions: RobinGill

RobinGill

Member
Jul 22, 2008
21
0
Please try to format data (if you don't have important data in the device) and reboot. If that doesn't help, download latest firmware (S001031). You can also try a custom ROM. Below are links to them:

LineageOS 16.0 (Android 9)
LineageOS 17.1 (Android 10)
Resurrection Remix OS (Android 10)
crDroid (Android 10)

Thanks for the reply.

Unfortunately I can't load any custom ROM's because my bootloader is locked.

I downloaded twrp-3.2.3-0-tb_8504x.img and renamed that to recovery.img and put in the folder with the rest of stock ROM and reflashed the downgraded stock ROM (TB-8504F_S000029_170518_ROW_QFIL) but same problem, and I still have normal recovery, not TRWP so I can't load custom ROM's.

Any chance you can please share a link to S001031 please to see if that helps?
 

RobinGill

Member
Jul 22, 2008
21
0
I just tried flashing stock ROM TB_8504F_USR_S130004_1902221150_Q12000_SCP and now OEM Unlocking is not greyed out, but I'm still stuck with Android Recovery instead of TRWP. Hopefully will have fun tomorrow.
 
Last edited:

RobinGill

Member
Jul 22, 2008
21
0
Ok, today installed TWRP 3.3.1-0 and tried various ROM's but still no luck:

crDroidAndroid-10.0-20210731-TB8504-v6.20 Boot logo loop

RROS-Q-8.6.9-20210519-TB8504-Unofficial Boots but no wifi or bluetooth
RROS-Q-8.7.1-20210726-TB8504-Unofficial Boots but no wifi or bluetooth

lineage-16.0-20200319-UNOFFICIAL-TB8504 Boot logo then rebooting to TWRP
lineage-17.1-20210408-UNOFFICIAL-TB8504 Boot logo then rebooting to TWRP

All current official firmwares for TB8504F:
TB_8504F_S110006_181015_YZ Boots but no wifi or bluetooth
TB_8504F_S140008_190215_UK Boots but no wifi or bluetooth
TB_8504F_USR_S120010_1901181601_Q12000_HFT Boots but no wifi or bluetooth
TB_8504F_USR_S130004_1902221150_Q12000_SCP Boots but no wifi or bluetooth
TB_8504F_USR_S001019_1909091114_Q12000_ROW Boots but no wifi or bluetooth

Anyone got any ideas for me?
 

RobinGill

Member
Jul 22, 2008
21
0
Damn, somehow ended up with tablet bricked and now I have 900E Diagnostics connection. Trying to use a deep flash cable to get it into EDL mode but doesn't seem to work for me.
 

RobinGill

Member
Jul 22, 2008
21
0
Deep flash cable didn't work.

Found a Yourtubr clip about changing the Qualcomm driver from 900E to 9008 - didn't work.

But found a video on the internet that got me out of trouble.


In the clip it says to leave the battery unplugged - that did not work for me. I needed to short the test points, plug in USB, then connect battery and it's flashing again in 9008 mode.

After flashing I had to disconnect and reconnect the battery to get it to boot normally.

Looks like I will be back where I was a day or two ago.
 
Last edited:

RobinGill

Member
Jul 22, 2008
21
0
Interesting - when I recovered using TB_8504F_S110006_181015_YZ I now have wifi again - I'm not sure if I'm going to just leave it like this or play around further.
 

Top Liked Posts