• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Lenovo tb-8504x help!

Search This thread

Sakhard

Member
Mar 25, 2019
5
1
Hello!

I got this tablet (lenovo tab 4 8 (tb-8504x)) from friend of a friend, who already was trying to install custom rom and recovery to this tablet. So I'm at the situation where I have no idea how bad this tablet has been messed up. At the moment I can open fastboot and twrp recovery. I tried to find stock image to this tablet, but for some reason I can't find any (or can't search good enough). I tried recovery with Lenovo Rescue and Smart Assistant, but recovery always fails for some reason. I also tried to install Lineage OS from this thread, but as a result I'm looking at never ending boot sequence of Lineage OS. I have done exactly as thread said:

- I flashed twrp from this thread and it's working
- I wiped cache, data and system from twrp
- I installed Lineage OS from first thread with adb sideload
- I also tried install Lineage OS with gapps nano

Result is that the Lineage OS wont boot and I has no recovery / stock images to this tablet.

Any help or ideas would be more than welcome! :):coffee:
 
Last edited:

Sakhard

Member
Mar 25, 2019
5
1
Here is logs from adb Sideload after installing Lineage OS

--------------
Updating partition details...
...done
Full SELinux support is present.
MTP Enabled
Starting ADB sideload feature...
Installing ZIP file '/sideload/package.zip'
Warning: No file_contexts
Target: Lenovo/TB-8504X/TB-8504X:8.1.0/OPM1.171019.019/8504X_S001031_191204_ROW:user/release-keys
detected filesystem ext4 for /dev/block/bootdevice/by-name/system
detected filesystem ext4 for /dev/block/bootdevice/by-name/system
script succeeded: result was [1.000000]
Formatting Cache using make_ext4fs...
Wiping Dalvik Cache directories...
-- Dalvik Cache Directories wipe complete!
---------------

From adb at PC, result code was: Total xfer: 1.01x