• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

Lenovo Z90-7 (VIBE SHOT) - International (ROW) ROM, multilanguage, GAPPS

Search This thread

mr.mrcn

Senior Member
Jul 28, 2014
806
2,083
Lhasa
Hi Indigo, Can I ask you where you buy your Vibe SHot? I have the same problem and I was thinking that some resellers that install GAPPS then block the OTA updates (I don't know how!!!) to avoid that next OTA will remove GAPPS and thei bloatware!!
I bought mine from Eto. You?
And tho whom that succeed the OTA upgrade, where did you buy your V.Shot?

PS
I try to istall the OTA from original build: VIBEUI_V2.5_1518_5.169.1_ST_Z90-7 (I never install international rom via Miflash)

This update is ONLY for international S118! You have to flash S118 first.
 

indigo888

Senior Member
Dec 20, 2011
151
46
Moscow
I try also to download from another link, but same result: arrived to 49% ->fails!
the same 49% for you?

I found my device lost download mode now.It only vibrates,switching on and connecting only in MTP/PTP modes to PC. Did factory reset-no luck.Tried to install in recovery original 1527.qsb version- got error.:banghead:
 

Attachments

  • 1437863446868.jpg
    1437863446868.jpg
    79.6 KB · Views: 630

mr.mrcn

Senior Member
Jul 28, 2014
806
2,083
Lhasa
No, you don't understand - volume up + power doesn't work for Z90a40. You have to use ADB command, as I wrote, to get to download mode. Then you can flash Z90-7 firmware.
 

mr.mrcn

Senior Member
Jul 28, 2014
806
2,083
Lhasa
Turn on the phone, let system to start., connect usb cable. Then execute 'adb reboot edl' - phone will reboot in download mode and you will be able to flash chinese or ROW version again (by miflash).
 

indigo888

Senior Member
Dec 20, 2011
151
46
Moscow
No, you don't understand - volume up + power doesn't work for Z90a40. You have to use ADB command, as I wrote, to get to download mode. Then you can flash Z90-7 firmware.

I'm talking about only volume up button to enter download mode connecting to PC via USB. When I'm trying to connect in this mode phone simply switching on.This is a problem.
 

mr.mrcn

Senior Member
Jul 28, 2014
806
2,083
Lhasa
Volume up + plug USB does not work for Z90a40 - how many times do i have to explain it? Instead you have to use adb command to get to download mode.
 
Last edited:

indigo888

Senior Member
Dec 20, 2011
151
46
Moscow
Volume up + plug USB does not work for Z90a40 - how many times do i have to explain it? Instead you have to use adb command to get to download mode.

Where should I run adb command?In google search?:eek:

---------- Post added at 10:25 PM ---------- Previous post was at 10:16 PM ----------

Did you try 'adb reboot edl' and then run miflash? This way you can return to chinese version.

This way I'll return to use my Nexus 6 instead this piece of enovo...:D
 

Top Liked Posts

  • There are no posts matching your filters.
  • 32
    Date: 2015.07.01
    Bootloader: unlock method unknown
    Custom recovery: none

    International (ROW) firmware: Z90a40_USR_S118_1505272046_Q2020131.4_ROW_qpst
    Update: Z90a40_USR_S208_1507141216_Q2020131.4_ROW_OTAFull
    Credits to:
    http://club.lenovo.com.cn/lefen/bbs/forum.php?mod=viewthread&tid=223254&extra=page%3D1
    http://club.lenovo.com.cn/thread-888477-1-1.html

    I've tested it - it works. Multilanguage (look at screenshot - not all languages), GAPPS, no chinese bloatware. NO ROOT.

    SD card must be removed during flashing!

    Flashing procedure:

    1. Download:
    - Miflash: Miflash_140509.zip
    - firmware version S118: Z90a40_USR_S118_1505272046_Q2020131.4_ROW_qpst.7z
    - update to version S208: Z90a40_USR_S208_1507141216_Q2020131.4_ROW_OTAFull.zip

    Link: https://drive.google.com/folderview?id=0B8CarqWdS9gZfmthcGxKQ2R3YUZCMWhjMWRVTFJZTFJ5dEFsVE51R1M1M3R4em5jTHVDeFU&usp=sharing

    2. Disable driver signature enforcement:
    Windows 8: http://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/
    Windows 7: http://www.sabrent.com/support/knowledgebase.php?article=14

    3. Install Miflash program.

    4. Flash new ROM:
    - unzip downloaded file with the firmware
    - turn off the phone
    - hit VOL + and plug USB cable (phone will vibrate once)
    - in Device Manager (Control Panel) new COM port should appear: Qualcomm HS-USB QDLoader 9008
    - run Miflash, you should see appropriate COM port
    - browse folder with downloaded firmware
    - click 'flash' and wait (about 180s)
    - disconnect USB cable, hit POWER key for about 10s (phone will vibrate)
    - phone will restart and load new system. It takes some time - and if it hangs, please hit POWER again for 10s, it will reboot again and it should proceed

    5. Update to version S208:
    - download file Z90a40_USR_S208_1507141216_Q2020131.4_ROW_OTAFull.zip, rename it to 'update.zip'
    - copy to phone memory or SD card
    - reboot to recovery (turn off the phone, hit vol +- and hit power)
    - install update package (it will take some time), reboot (first start will take few minutes)

    6. (Optional) Reflash or return to chinese version:
    - in ROW version it is impossible to enter download mode with VOL+ and plug USB cable - you can do this only with ADB command
    - turn on the phone, let the system start
    - plug USB cable, make sure ADB Debugging is ON
    - execute ADB command: 'adb reboot edl'
    - phone will restart in download mode
    - now you can run Miflash

    :)
    6
    @bjorni @ivass

    Here is the guide. REMOVE MICRO SD CARD AND SIM CARDS! Before flashing i advise you to backup EFS! I wrote few post back how to do that.

    1. Disable driver enforcement by running the following commands in cmd.exe
    bcdedit -set loadoptions DISABLE_INTEGRITY_CHECKS
    bcdedit -set TESTSIGNING ON
    then reboot the machine
    if you are on windows 7 than u can do this and when machine si rebooting pres F8 and choose disable driver signature something like that.

    2. Enable developer options by pressing build number fast 5 times in settings - about
    Than enable USB DEBUGGING

    3. Install Lenovo driver 1.1.13, qualcomm driver and newest QPST: https://drive.google.com/open?id=0BzCXnezrYPPdZGM2RGlEcHJZOGc

    4. Install adb from here https://forum.xda-developers.com/showthread.php?t=2588979

    5. Now plug in phone to computer, it will ask to authorize computer, than in cmd type adb devices to identify your phone, or you can go direct adb reboot edl. Now your phone is in 9008 port for flashing.

    6. Open QPST - QFIL

    7. Unpack rom to root of C drive and name it something short for example 363 or 1625

    8. In QFIL choose PORT 9008 if it is not chosen already, than FLAT BUILD, than for programmer path choose prog_emmc_firehose_8936.mbn from rom folder, than load xml and choose rawprogram and patch xml it will go automaticaly you will see. Here is the youtube video for instructions with qfil: https://www.youtube.com/watch?v=4Wj39e1Ss0o

    9. click DOWNLOAD and wait. When it is finished unplug phone and hold long power button for restart and enjoy.

    Download link for 363: https://mega.nz/#!jIZjBToK!oZ96t3ju4EoI0W16AX2kft2bd22_M3WOqUvpkg5UYJM

    Download link for 1625: https://drive.google.com/file/d/0B5n...JnSm1kTjg/view

    Download link for unlocked and cleaned 1625: https://yadi.sk/d/d3fGrACW337yhr

    Unlocked 1625 is missing theme center which i can upload and google calendar sync i will upload also. For TWRP installing i will write another post, its quite easy i wrote before.
    5
    Ok this is my impression about this roms.

    I testet CM 13, CM 14.1, Miui, RessurectionRemix
    FlymeOS i was unable to flash (problem is chinese non-hlos)

    ALL ROM FLASHABLE ONLY FROM CHINESE TWRP (chinese twrp is much stable than Russian)

    CM 13 (Android 6.0.1) - ROM is ok, work good without any major bugs but rom only have two laguages ENG nad CH. Gapps not included. Xposed 85,86 work normal, afther flashing rom you need go back in TWRP and flash SuperSu. You can donwload SuperSU or flash integratet SuperSU in TWRP. Also Gapps you can download and flash or just install Google apps you need for corect work and install like normal app.
    I recommended to download Link2SD app open app and give 'SuperSU premmission' and go back on 'home button' - this is how app to stay in recent app, WHY? Because afther flashing GAPPS on some roms 'google setup wizard' dosent work corectly and you will be stack in SETUP (for me wirelles dosent wont to start and i can go forward to set Google accoun) Now you can press left button and open last recent apps and in Link2SD disable 'setup wizard' - I recommend this for all chinese rom!

    CM 14.1 (Android 7.1.1) - Before flashing you need to wipe 'dalvik/chache-chache-data-system. Now you will be able to flash new Android system.
    - Rom have two bugs 1. browser is buggy 2. MISSED IMEI (some peoples says they dosent lost IMEI) I try 3x times to flash, reflash always i lost IMEI.
    I try to recover IMEI vich some tools but unsucesfull and than give up and back to MM.
    - Rom is fast, everithing work great and is multilanguage. Xposed work, SuperSU and battery in better than on Lenovo stock roms.
    If you can recover IMEI and you like CM rom (close to Nexus) i recommend this rom.
    Bloatware - NO .
    Boot time is aboud 1-2 minutes :)

    MIUI8 (Androdi 6.0.1) - This rom works fantastic but you must be carefully. On this wersion 6.12.13 Xposed dosent work. I try flash v65,86 and 87 and MIUI edition (downloaded wich this rom)
    - SuperSU is integrated in system in Security app and you can flash another SuperSU if you want - come wich rom.
    - For changing system apps you can delete only chinese apps (Use Link2SD app - RootExplorer dosent work only tou can go in TWRP mount system and than go in File Manager in TWRP and delete apps) wich named in chinese, not apps like ''miui wallet, miui video, miui pay and similar''
    Boot time for rom is about 15-20 min.
    Good news is you can flash this rom afther 1621,1625 nd S363 like OTA-in TWRP not in System update. Dont need to wipe anything! You dont lost anything of data and apps only Play Store but you just need to dowlnoad PlayStore app from web and instal. Also download last GooglePlay Services and update. If some apps dosent wont to opet just reinstal app.
    Battery on this rom is fantastic. Mabey i notice is 'ram management' - mabey on VibeUI is better but i'm not sure...
    Bloaware - some chinese apps like Baidu, and similar...
    Now i'm using this rom.

    ResurrectionRemix (Android 6.0.1) - For flash this rom you need to wipe all (dalvick cache,cache, data, system)
    - This rom is AWESOME! Is close to Nexus or CM but is better, much better!
    - Rom works fantastic. Battery is great, but i only 1,2h have for test.
    - Rom is multilanguage (all languages) and rom is STABLE!
    - Is full of customization and you can change almost everithng! Almost you dont need Xposed. You have integratet in system some Xposed modules like ''boot start apps'' and stuff like that... Themes is like for CM, same theme engine.
    Gapps is not included but you can go back in recovery and flash or just install like normal app, apps you need.
    Bloatware NO - is clean and rom is FAST, almost to fast :) Unforunatelly i forgot to test Benchmark test.
    - SuperSU also work and when you flash in TWRP you will se SuperSU options in 'Settings'' (I DONT SEE THIS FEATURE ON ANY ROM)
    This is most stable rom i ever tested/flash on this phone.
    - All apps works great vithout any bugs.

    If you like stock android but you want customization features this rom is for you. Personally, I am seriously considering to take it to the this ROM.

    Unfortunately I do not have 4G SIM card, so I could not test network. :(

    I hope i help some of you for choose stable or rom you like for your VibeShot.

    ---------- Post added at 01:54 PM ---------- Previous post was at 01:42 PM ----------

    Links:
    cm 14.1 two version
    https://yadi.sk/d/JrU19eCG33mKv6
    https://yadi.sk/d/tOiFOkNuyokhw
    CM 13
    https://yadi.sk/d/FlY8LPCnyB22p
    Mokee 7.1.1
    https://download.mokeedev.com/?device=zoom
    Miui8 6.12.13
    https://yadi.sk/d/_6M02nC533jxPn
    ResurrectionRemix
    https://yadi.sk/d/ZeIPzL3P33mDhw
    FlymeOS
    https://yadi.sk/d/VDLriZWv33mKQv
    5
    Ok. This is the ultimate guide to unbrick any lenovo vibe shot (because I have bricked and unbricked it numerous times)

    Option 1:
    If you have bricked with chinese rom than its easy> go to recovery> navigate to power off> plug usb cable and press volume +> your phone should be in qualcomm 9008 mode. Use qfil or miflash.

    Option 2:
    you have bricked your phone from row rom , than you will have qualcomm 9006 mode.

    To enter in 9008 you will have to do it like this:
    Step 1: Open miflash (download s074 rom and unpack it) as if you are about to flash it

    Step 2: go to recovery and navigate to power off

    Step 3: start hitting power button like crazy (like 3-5 times a second) and if lucky you will hear sound before the lenovo sign appear. You will have 10 seconds before phone restarts
    (If the device manager is open you will see 9008 mode)

    Step 4: Switch immeditely to miflash press f5 (refresh) and you will se com_1-10.
    Then press flash and voila you are about to flash new rom

    Option 3:
    use LENOVO SMART ASSIST from official site, navigate to repair (model z90a40, hw code 10) you will be offered to download s363 rom, download it and before flash, you will have to repeat steps in option 1 or 2 to enter 9008 mode, and the flashing will begin immeditely.

    Option 4: via fastboot you can enter in 9008 mode on some models if you type
    fastboot reboot-edl
    Option 5:
    If yiur phone is fully bricked (won't turn on, no lenovo logo, no vibration, device manager sees it as usb_bulk or something) than you need to open it and use TEST POINTS (see post 944)

    Ps. I RECOMMEND S074 ROM AS INITIAL rom for unbricking, because after you flash it you could always enter 9008 mode with ease, just by pressing volume + and power.

    Good luck to you all[emoji1] [emoji1] [emoji1] [emoji1] [emoji27] [emoji27] [emoji27]
    4
    Problem SOLVED.
    After a short research I have:
    1. unplugged battery, and connected mainboard to PC with USB cable,
    2. Short for few secs. GREEN jumper called HS_9008 (CPU powered without FLASH IC),
    3. Using MiFlash started flashing S118 STOCK ROM (brake point after loading image into RAM),
    4. Enabled 9006 mode using YELLOW jumper (init of PSU driver start and power up rest of HW)
    5. Again started flashing the same ROM with MiFlash (previous attemp timed out - it's ok)
    6. Unplugged USB cable, connected battery, and watching UART's output (115200,8,N,1).

    z90_repair_emmc.jpg

    Format: Log Type - Time(microsec) - Message - Optional Info
    Log Type: B - Since Boot(Power On Reset), D - Delta, S - Statistic
    S - QC_IMAGE_VERSION_STRING=BOOT.BF.3.0.C8-00006
    S - IMAGE_VARIANT_STRING=SAAAANAAA
    S - OEM_IMAGE_VERSION_STRING=nj-bs6
    S - Boot Config, 0x000000e1
    S - Core 0 Frequency, 0 MHz
    B - 1587 - PBL, Start
    B - 3619 - bootable_media_detect_entry, Start
    B - 126484 - bootable_media_detect_success, Start
    B - 126490 - elf_loader_entry, Start
    B - 127507 - auth_hash_seg_entry, Start
    B - 127746 - auth_hash_seg_exit, Start
    B - 146537 - elf_segs_hash_verify_entry, Start
    B - 227142 - PBL, End
    B - 233111 - SBL1, Start
    B - 296551 - pm_device_init, Start
    B - 296673 - row samsung 3+32 detected
    B - 300730 - row_pm_ddr_ncp_buck_set_voltage
    D - 14731 - pm_device_init, Delta
    B - 319548 - boot_flash_init, Start
    D - 30 - boot_flash_init, Delta
    B - 323574 - boot_config_data_table_init, Start
    D - 12261 - boot_config_data_table_init, Delta - (0 Bytes)
    B - 340380 - CDT version:3,Platform ID:8,Major ID:0,Minor ID:0,Subtype:1
    B - 346175 - sbl1_ddr_set_params, Start
    B - 350841 - cpr_init, Start
    D - 4392 - cpr_init, Delta
    B - 357307 - Pre_DDR_clock_init, Start
    D - 244 - Pre_DDR_clock_init, Delta
    D - 0 - sbl1_ddr_set_params, Delta
    B - 368958 - pm_driver_init, Start
    D - 6801 - pm_driver_init, Delta
    B - 385489 - clock_init, Start
    D - 122 - clock_init, Delta
    B - 395707 - Image Load, Start
    D - 21136 - QSEE Image Loaded, Delta - (483616 Bytes)
    B - 416874 - Image Load, Start
    D - 427 - SEC Image Loaded, Delta - (2048 Bytes)
    B - 424011 - sbl1_efs_handle_cookies, Start
    D - 396 - sbl1_efs_handle_cookies, Delta
    B - 431849 - Image Load, Start
    D - 11804 - QHEE Image Loaded, Delta - (68336 Bytes)
    B - 443683 - Image Load, Start
    D - 12780 - RPM Image Loaded, Delta - (154860 Bytes)
    B - 456493 - Image Load, Start
    D - 20008 - APPSBL Image Loaded, Delta - (483532 Bytes)
    B - 476593 - QSEE Execution, Start
    D - 61 - QSEE Execution, Delta
    B - 482296 - SBL1, End
    D - 251473 - SBL1, Delta
    S - Flash Throughput, 104000 KB/s (1195708 Bytes, 11407 us)
    S - DDR Frequency, 796 MHz
    Android Bootloader - UART_DM Initialized!!!
    check_lcd_id status_up = 0,status_down = 0
    MSENSOR_i2c_read addr 0x1 data0x5
    [1460] QUP: I2C status flags :0xc1343c8
    [1460] QUP: I2C status flags :0xc1343c8
    [1470] QUP: I2C status flags :0xc1343c8
    [1470] QUP: I2C status flags :0xc1343c8
    max77819_i2c_read addr 0x18 max77819_i2c_read data 0x8c
    max77819_i2c_read addr 0xe max77819_i2c_read data 0xc2
    max77819_i2c_read addr 0x2 max77819_i2c_read data 0xc3
    [1700] battery voltage is 3900 ocv is 3880,therhold is 1000
    max77819_i2c_read addr 0x34 max77819_i2c_read data 0x62
    [1710] charging status = 0x62
    max77819_i2c_read addr 0x37 max77819_i2c_read data 0x5c
    [1720] current 0x37 register = 0x5c
    max77819_i2c_read addr 0x34 max77819_i2c_read data 0x62
    [1730] charging status = 0x62
    max77819_i2c_read addr 0x2 max77819_i2c_read data 0xc3
    [1730] battery voltage is 3900 mv
    max77819_i2c_read addr 0x40 max77819_i2c_read data 0x80
    [1740] charger 0x40 = 0x80
    max77819_i2c_read addr 0x34 max77819_i2c_read data 0x62
    max77819_i2c_read addr 0x99 max77819_i2c_read data 0xef
    max77819_i2c_read addr 0x98 max77819_i2c_read data 0xf2
    max77819_i2c_read addr 0x9b max77819_i2c_read data 0x80
    max77819_i2c_read addr 0x99 max77819_i2c_read data 0x0
    max77819_i2c_read addr 0x98 max77819_i2c_read data 0xf2
    [1780] Not able to search the panel:

    panel_id = OTM1902C_1080P_CMD_PANEL
    max77819_i2c_read addr 0x9b max77819_i2c_read data 0x80
    [2370] KEY_VOLUMEDOWN pressed
    [2740] image_decrypt_signature2
    [5610] fdt end:0x21e308be rkm shadow buf base:0x21e31000 lk ptr:0x21e32000 log_buf ptr:0x21e34000
    [5620] rkm_init_lk_log_buf: current_lk_log_addr=0x8f6687c4, len=0x4096
    [5750] rkm find kernel log buf header at 0x21189000
    [5760] rkm backup kernel log buf from 0x2120e6c0 to 0x21e34000,len=524288
    [6050] rkm_log:lk buf size=4096, kernel buf size=524288
    --Uart Ready--
    NO SN, Please write