Let's try and solve the Honor / Huawei 'missing notification' problem

Search This thread

paulobrien

Senior Member
Nov 6, 2003
5,279
7,316
Norwich
www.MoDaCo.com
I suspect most of us have seen the issue with 'missing notifications' on Honor / Huawei devices. When you add an app to the protected apps list, make sure the various battery and startup optimisations are disabled, do everything you can... still the system seems to shut the app down and notifications don't happen.

Why? I don't think anyone knows yet.

The problem seems to be mitigated in some cases by moving the app manually to the /system partition, but this doesn't always work I don't think - for example Hangouts sometimes misses notifications for me and that's a system app. There's another nuance too - why do some apps not appear in the protected apps list (e.g. gmail)? That's not technically any different to Hangouts... is there a whitelist in the ROM somewhere?

Now I have my custom ROMs and deodexed ROMs, I'm going to be having a good poke around so hopefully we can fix this once and for all for all Honor / Huawei devices, but it would be super useful for anyone to contribute their findings so we can try and establish a pattern of behaviour while I look for clues.

Cheers all. :)

P

PS: Topic also mirrored here at MoDaCo
 
Last edited:

adxuser

Senior Member
Mar 11, 2014
176
33
Hi Paul, very nice to see how much you contribute to Honor 7 community...

Your topic is on-point, just wanted to start thread alike.
Yes, from very quick research these problems are common to all? Huawei, not only H7
Anyway I am a newbie to my H7 and a novice at EMUI, I am also not even a hobbyist programmer. But will try to help.

ps. could you look here? http://forum.xda-developers.com/showpost.php?p=66407836&postcount=6
I had similiar thoughts on, this time - Google, not EMUI 'whitelist' - Ignore optimisations
 

dws199xda

Member
Jan 20, 2016
19
1
I had a problem with Tasker continuously being killed in Lollipop even though I marked it as a protected app, but I found that the issue only occurred if I used the "Smart" Power Plan, since switching the "Performance" plan the issue appears to have been resolved. I now see the same issue with Whatsapp on MM and have again selected the same plan to see if that solves the issue also
 

paulobrien

Senior Member
Nov 6, 2003
5,279
7,316
Norwich
www.MoDaCo.com
I had a problem with Tasker continuously being killed in Lollipop even though I marked it as a protected app, but I found that the issue only occurred if I used the "Smart" Power Plan, since switching the "Performance" plan the issue appears to have been resolved. I now see the same issue with Whatsapp on MM and have again selected the same plan to see if that solves the issue also
So I'm making some good progress digging around with this. I've had some interesting feedback suggesting that this is less of a problem in 'Performance' mode than 'Smart', but it is still an issue. Interested to hear thoughts on that.

App closure behaviour seems to be managed in 3 places on device...
  • in Marshmallow doze (this obviously isn't the cause of our issues)
  • in HwPowerGenieEngine3 (com.huawei.powergenie)
  • In HwSystemManager (com.huawei.systemmanager), also known as the 'Phone Manager' app
Sure enough, disabling the latter 2 packages seems to make notifications work 100%, but there are other things hooked into the Phone Manager app, so disabling it completely is a bit of a blunt instrument, it'll be better to try and tweak the behaviour, which is what I'm looking at now.

If anyone has clear*notification issues they can replicate and there*use to help me test fixes, please post below.

P
 
Last edited:

donimo

Member
Apr 30, 2014
22
1
Small question for everyone having notification problems. When you look into the "automatic launch records" menu in Phone Manager, are these Apps with problems listed as restricted or as allowed? Aquamail and WhatsApp are working fine for me even with smart Power plan
 

EGneets

Member
Nov 26, 2008
23
3
Which android version are you running?
I am now on the final version of Android 6 and my notifications are finally working flawless. (I got a EU Honor 7 running PLK-L01C432B330 - EMUI 4.0)
 

donimo

Member
Apr 30, 2014
22
1
After 330 Update I got some problems, especially with WhatsApp. After checking auto start menu I recognized WhatsApp autostart was disabled and aquamail was not listed in this menu, I activated both before. Both were listed as restricted in the records menu. So they wanted to work but system blocked them. I turned it back on and aqua got the menu back after reinstall.
 

donimo

Member
Apr 30, 2014
22
1
I will try pm plus upload later, you can also try to download it from aptoide store.
After installing PM PLUS and it's two plugins start the Phone Manager, swipe to the right, open APP AUTO LAUNCH and you can see the apps with their permissions. By clicking the clock symbol located right top you can see the past recorded launchs and if they were restricted or allowed.

Sry for bad english
 

admisi

Senior Member
Apr 23, 2005
264
39
I find that I keep notifications active on those particular apps by clicking on the square for the running apps, and then pulling down on the window of that app, which will highlight a lock above it, that way it is never closed. Survives a reboot as well. In other words the opposite of sliding up to close the app.

Sent from my PLK-L01 using XDA-Developers mobile app
 

admisi

Senior Member
Apr 23, 2005
264
39
1461103473022.jpg

Screenshot of lock

Sent from my PLK-L01 using XDA-Developers mobile app
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    I suspect most of us have seen the issue with 'missing notifications' on Honor / Huawei devices. When you add an app to the protected apps list, make sure the various battery and startup optimisations are disabled, do everything you can... still the system seems to shut the app down and notifications don't happen.

    Why? I don't think anyone knows yet.

    The problem seems to be mitigated in some cases by moving the app manually to the /system partition, but this doesn't always work I don't think - for example Hangouts sometimes misses notifications for me and that's a system app. There's another nuance too - why do some apps not appear in the protected apps list (e.g. gmail)? That's not technically any different to Hangouts... is there a whitelist in the ROM somewhere?

    Now I have my custom ROMs and deodexed ROMs, I'm going to be having a good poke around so hopefully we can fix this once and for all for all Honor / Huawei devices, but it would be super useful for anyone to contribute their findings so we can try and establish a pattern of behaviour while I look for clues.

    Cheers all. :)

    P

    PS: Topic also mirrored here at MoDaCo
    2
    So I've made some changes on the Honor 7 to these power optimisations with a view to sorting this out. You can test in the latest release of MoDaCo Custom ROM (r4.1).

    P
    2
    Hi there. I did a full reset, wiping SD card and internal storage. I have downloaded all apps again via playstore... Over night WhatsApp Stopps notification again, and there was only one message to notify.... So now I'm on a B370 Rom and I've the issue again -_-

    I don't know what I can do. Every day I have to restart the phone, sometimes 2 times

    Gesendet von meinem PLK mit Tapatalk
    Did you:

    - add it to the protected apps (settings > advanced > battery manager > protected apps)?
    - lock it in the RAM management screen (press the square in navigation bar, pull down WhatsApp)?
    - give it permission to ignore battery optimizations (settings > apps > advanced > ignore battery optimizations > allow WhatsApp)?
    - give it permission to remain active after screen off (settings > apps > WhatsApp > battery)?
    - set power plan to performance mode (settings > advanced > battery manager)?

    With all the above settings it should work. It is unbelievable though that there are 5 settings that have effect on notifications. Huawei really made a mess of this and I hope they sort it out in EMUI 5.0, but I doubt it considering how long this has been going on.
    1
    Have you tried a factory reset since upgrading to LP? I did have quite a few issues myself after upgrading from 5.0 to 6.0 but all those issues were solved after performing a factory reset. I tried getting help in the beta forums but the only suggestion I got was 'do a factory reset' :rolleyes:. It did work though, but it took me a day to get everything set up again.
    Hi, I did a factory reset, but restored with back up app and someone told me, that isn't good... Maybe today in the evening I do a reset and install all apps again from play store, without restoring with huawei backup....

    Thanks for the hint! I will report!

    Gesendet von meinem PLK mit Tapatalk
    1
    Can you share the apk? It says it's not available in my country (Hungary)... :crying: :confused: I don't know why.

    Do u have Emui 4 or above?
    When u have, this app won't work anymore.

    When not:
    http://cloud.tapatalk.com/s/5787ecf2cfbec/PM Plus.apk

    Greetz

    Gesendet von meinem PLK mit Tapatalk
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone