LG G2 Stuck on download mode showing weird message

Search This thread

NimaKh80

New member
Aug 16, 2022
2
0
Hey, so the problem with my LG g2 started when it randomly got stuck boot looping. it was never rooted and it was not customized in any form. i had updated the android to lolipop when it came out and it was working just fine for 7+ years.
when it got stuck in bootloop it would sometimes randomly boot and stay on for 2 or 3 hours and then again would go back to bootlooping. thought it could be a software problem so i tried installing frimwares (stock lolipop with higher version) with both lg repair tool 2014 and lgup. installed the dll for lgup, extracted dll from KDZ as well. installed the latest lg drivers and nothing would happen. i could eventually install the firmware with lg repair tool 2014 for once since it would get stuck at 4% and give me an error. after the successful install of new firmware the phone booted up and worked for a few hours and again bootloop happened. so thought maybe i should downgrade the firmware to kitkat. this time i was able to install it via lgup. it restarted the phone and while restarting it finished the installation. then it got stuck to download mode. its on download mode even if its not plugged to the computer. the weird part is that when i click the up and down button at the same time it will give me a message. the message saying "if you want.." in red. and it have to be on download mode and unplugged to show this message.
here is the image:
photo_2022-08-16_21-25-10.jpg


so first problem is that the phone would bootloop and now it's stuck in download mode with the weird message. any help or ideas would be appreciated.
Edit: lgup performed the second installation (kitkat) and after that i realized it rooted the device as well.
 
Last edited: