LG G3 D855 - Cannot Connect to Any WiFi (only Saved state)

Search This thread

romeotango

Member
Feb 2, 2009
19
0
Hi!

I just flashed old G3 with LineageOS 18.1

Everything works just fine until today. It suddenly stopped connecting to WiFi and won't connect anymore.
I tried flashing CyanogenMod 14 but the problem persists.

So everytime I tried connecting to WiFi, it only shows "Connecting...." then "Saved"

Did I just broke something here? Tried searching the forum but i have no luck either.
(I've tried following this thread too, still failed)

Anybody has experienced this before?
 

romeotango

Member
Feb 2, 2009
19
0
Tried this but didn't see any MID Settings, cannot uncheck / generate anything. Only REFRESH.

so install android Marshmallow than follow these steps:

1- on dial pad : *#546368#*855# (855 is for D855 and so)
2- find and click SCV Menu
3-click on CRCWIZARD Test
4-click the tab Auto MID
5- uncheck IMEI in MID settings
6- click generate to generate your new MAC's
7- click MID write
8-Click Refresh to be sure that you changed MAC adress
9-Rebbot phone to take effect!
 

Pinarek

Member
Jan 31, 2016
39
3
MD
Hey Friend.

It doesn't have to be your device, it's the Lineage 18.1.

it was the same for me... "only saved" but no connection possible.

The LAN didn't work for me even after the successful installation.
No 2.4 Ghz and no 5 Ghz, although password etc. was all 100% correct.

My AVM Fritzbox 6660 Cable is set to WAN WPA2/WPA3.
I need to change that to only WPA2 CWP option, only then could my LG-G3-D855 with Lineage 18.1 use it successfully.

It's the fault of the Lineage programmers !!! something like that simply shouldn't happen with an Android 11.

I had previously installed the old Fulmics 6.9 on the LG G3 D855 and there were no problems with the Fritzbox 6660 Cable and FritzOS 7.29 installed on it, neither in 2.4 nor in 5 Ghz.

Only this LineageOS 18.1 requires the old WPA2 CWP encryption on the Fritzbox 6660 Cable. Ok, so there are no disadvantages for other devices that I still have, such as iPad and iPhone etc. they can also handle the WPA2 CWP.

Still, isn't it okay that such a well-developed Android 11 can't do WPA2/WP3, or is it just LineageOS 18.1 that doesn't? Can the original Android 11 work with it ??