• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LG G3 D858HK Discussions

Search This thread

sweettaniyaa

Senior Member
Apr 5, 2011
177
25
30b modem is know to have problems if you're not on stock boot and / or system. You'll find some posts about that. The best way is to have 20c (Lollipop) modem with 30b rpm and tz partitions. Let me know if you need those in a flashable zip.

I am not sure if mine is 30b modem. I have attached a screenshot of my phones software version details with this post. Could you please at it and check if that is the issue. I would need those files if that would resolve the issue. would you also provide me with the link to step by step guide to get it done. Thanks.
 

Attachments

  • Screenshot_2017-03-08-18-24-32.png
    Screenshot_2017-03-08-18-24-32.png
    226.1 KB · Views: 203

rk2612

Senior Member
Mar 30, 2010
153
41
I am not sure if mine is 30b modem. I have attached a screenshot of my phones software version details with this post. Could you please at it and check if that is the issue. I would need those files if that would resolve the issue. would you also provide me with the link to step by step guide to get it done. Thanks.

The baseband code shows which modem you've got installed. Comparing it to mine, it seems you're on 20c, which works fine with stock MM. That means the issue is with either Fulmics or some other conflicting app.
 
  • Like
Reactions: sweettaniyaa

olegfusion

Senior Member
Sep 24, 2011
821
315
30b modem is know to have problems if you're not on stock boot and / or system. You'll find some posts about that. The best way is to have 20c (Lollipop) modem with 30b rpm and tz partitions. Let me know if you need those in a flashable zip.

Hello. Is it possible to get ZIP file to flash via TWRP with your recommendation files? I tried different modems with crdroid 7.1.1, but experienced same issue (SIM slot 2 is empty, after several reboots it may start working again!). D858HK here. I had this issue in stock 6.0.1, however never happened at 5.1.1 stock.

After I flashed crdroid custom ROM through 5.1.1 stock, the issue started again. Please give us a file with your recommendation of bootloader/modem combination. Thanks a lot!
 

rk2612

Senior Member
Mar 30, 2010
153
41
Hello. Is it possible to get ZIP file to flash via TWRP with your recommendation files? I tried different modems with crdroid 7.1.1, but experienced same issue (SIM slot 2 is empty, after several reboots it may start working again!). D858HK here. I had this issue in stock 6.0.1, however never happened at 5.1.1 stock.

After I flashed crdroid custom ROM through 5.1.1 stock, the issue started again. Please give us a file with your recommendation of bootloader/modem combination. Thanks a lot!

The modem partitions I use with my LG-G3-D858HK are placed at (https://drive.google.com/file/d/0B1esAouAQMvXaU1RT014ZkFibG8/view?usp=sharing) and I have a stable connection on both SIMs.

I use the MM 30b boot image (patched for SELinux premissive and bumped). And I use the stock system image extracted from official MM 30b KDZ and have stripped out some of the LG and Google bloatware. Haven't upgraded my bootloader or other firmware partitions since LP.
 

olegfusion

Senior Member
Sep 24, 2011
821
315
The modem partitions I use with my LG-G3-D858HK are placed at (https://drive.google.com/file/d/0B1esAouAQMvXaU1RT014ZkFibG8/view?usp=sharing) and I have a stable connection on both SIMs.

I use the MM 30b boot image (patched for SELinux premissive and bumped). And I use the stock system image extracted from official MM 30b KDZ and have stripped out some of the LG and Google bloatware. Haven't upgraded my bootloader or other firmware partitions since LP.

Many thanks for archive. I try it now, additionally clean dalvik/art cache and cache partition.

update. didn't help, same issue. After reboot sim slot 1 only works. after second reboot sim slot 1 show empty sim too, but I can call from first SIM. After third reboot both SIM works. After fourth reboot again all fine, until I go to settings and switch any of settings. After switching, for example, default SIM for call to "choose always", after reboot it will be only SIM slot 1 in work state.
 

rk2612

Senior Member
Mar 30, 2010
153
41
Many thanks for archive. I try it now, additionally clean dalvik/art cache and cache partition.

update. didn't help, same issue. After reboot sim slot 1 only works. after second reboot sim slot 1 show empty sim too, but I can call from first SIM. After third reboot both SIM works. After fourth reboot again all fine, until I go to settings and switch any of settings. After switching, for example, default SIM for call to "choose always", after reboot it will be only SIM slot 1 in work state.

Seems to suggest that the problem is with your boot / system images.
 

olegfusion

Senior Member
Sep 24, 2011
821
315
Last time ever .. ... Did you manage to solve your problem? How?

What I tried:
1. flash back to stock 5.1.1, the problem is solved.
2. root => twrp => flash crdroid 2.3 => problem exists again. It means it's not modem or bootloader related.
3. flash stock 6.0.1 => problem exists in stock ROM without any modifications.
4. flash back to 5.1.1 from 6.0.1 stock ROM => problem doesn't exist.
5. I also tried to flash your ZIP, didn't help.
:rolleyes:

Probably some ril libs problem, but who knows. I am not the phone owner (it's not around me everytime), but I would like to try to find out how fix it.

By "last time ever" I mean that I flash a lot of different phones and I don't remember such annoying things at other devices last several months.
 
Last edited:

olegfusion

Senior Member
Sep 24, 2011
821
315
More search.

[–]stevenpurwadipura 5 points 8 months ago
Guys, i found a fix for this. I just figured out this trick, so i don't know if this is a real fix or just a luck. Go to settings - apps - choose option - configure apps - modify system settings - choose option - show system - select NETWORK - change it into 'No'. Then restart your phone.
I restart my phone and it detects my SIM again. But as I said, I'm not too sure if this is really a fix or just a luck.
permalinkembedparent

I wanna try it, but can't figure out how deal with it in crdroid ROM. Any help what exactly happen at this suggestion?
 

sweettaniyaa

Senior Member
Apr 5, 2011
177
25
The baseband code shows which modem you've got installed. Comparing it to mine, it seems you're on 20c, which works fine with stock MM. That means the issue is with either Fulmics or some other conflicting app.

I have tried doing different things like disabling firewall, Changing network selection from automatic to manual, etc. still no luck. do you think base-band V30 would work better? worth trying? are there any files that I can use to flash that? Can you post the link if you do? Thanks :)
 

L.C.M

Member
Jan 31, 2017
8
1
G3 get hot on all stock base Roms you need to try AOSP . Try our new ROM lineage for g3ds hope you enjoy it with no issues of high temperatures.

---------- Post added at 06:06 PM ---------- Previous post was at 06:04 PM ----------

LineageOS thread link and hopefully share updates on weekly basis.

https://forum.xda-developers.com/showthread.php?t=3521420

I had tried this rom. But I only can browse the internet for 3 to 4 hours.

---------- Post added at 03:20 AM ---------- Previous post was at 03:04 AM ----------

---------- Post added at 03:21 AM ---------- Previous post was at 03:20 AM ----------

I have tried 3 roms, Fulmics, Lineage & stock kdz. And I had also disable the root firewall. But only one sim card is working. And I found that there are many unknown application running in the background and these services will spend my data rapidly.
 
Last edited:

Neerijus

Member
May 15, 2012
20
0
Hi, guys, I have a problem with LG G3 858HK.
Sometimes (once/twice a day) phone loses all signal, tries to connect, connects and loses signal again, again connects, loses and so on, and so on. It’s not only data, it loses mobile signal as well. And it happens in all kinds of areas, even where signal is full 4G. Usually nothing helps, except switching the phone off/on again or pulling the battery. Sometimes when switching it off while having this issue, it wouldn’t switch on again pressing power button. Again, opening it up and pulling the battery helps. Sometimes only connecting wifi/ disconnecting wifi helps.
Phone is running rooted android 6.0 (tried few ROMS, rooted/non-rooted - same thing). I tried everything to solve it: factory reset, changing sims, running with one sim, running with 2 sims, un-rooting, rooting again, multiple ROM's, tried all kinds of settings - nothing helps. The issue is probably with the phone. Sadly, warranty is expired.

Video of the issue: https://www.youtube.com/watch?v=qq7_jm0-Hp8

The signal in the area where video was captured is really good, full 4G normally.
Anyone got any idea what could be wrong with it?
Any help would be appreciated. Thanks.
 

yobolegend

Member
Oct 24, 2016
48
8
Hi, guys, I have a problem with LG G3 858HK.
Sometimes (once/twice a day) phone loses all signal, tries to connect, connects and loses signal again, again connects, loses and so on, and so on. It’s not only data, it loses mobile signal as well. And it happens in all kinds of areas, even where signal is full 4G. Usually nothing helps, except switching the phone off/on again or pulling the battery. Sometimes when switching it off while having this issue, it wouldn’t switch on again pressing power button. Again, opening it up and pulling the battery helps. Sometimes only connecting wifi/ disconnecting wifi helps.
Phone is running rooted android 6.0 (tried few ROMS, rooted/non-rooted - same thing). I tried everything to solve it: factory reset, changing sims, running with one sim, running with 2 sims, un-rooting, rooting again, multiple ROM's, tried all kinds of settings - nothing helps. The issue is probably with the phone. Sadly, warranty is expired.

Video of the issue:

The signal in the area where video was captured is really good, full 4G normally.
Anyone got any idea what could be wrong with it?
Any help would be appreciated. Thanks.



Did you try this ROM its working on me Lg G3 D858HK...

https://forum.xda-developers.com/lg-g3/development/rom-unofficial-crdroidv1-5-t3521420
 

sweettaniyaa

Senior Member
Apr 5, 2011
177
25
Hi, guys, I have a problem with LG G3 858HK.
Sometimes (once/twice a day) phone loses all signal, tries to connect, connects and loses signal again, again connects, loses and so on, and so on. It’s not only data, it loses mobile signal as well. And it happens in all kinds of areas, even where signal is full 4G. Usually nothing helps, except switching the phone off/on again or pulling the battery. Sometimes when switching it off while having this issue, it wouldn’t switch on again pressing power button. Again, opening it up and pulling the battery helps. Sometimes only connecting wifi/ disconnecting wifi helps.
Phone is running rooted android 6.0 (tried few ROMS, rooted/non-rooted - same thing). I tried everything to solve it: factory reset, changing sims, running with one sim, running with 2 sims, un-rooting, rooting again, multiple ROM's, tried all kinds of settings - nothing helps. The issue is probably with the phone. Sadly, warranty is expired.

Video of the issue: https://www.youtube.com/watch?v=qq7_jm0-Hp8

The signal in the area where video was captured is really good, full 4G normally.
Anyone got any idea what could be wrong with it?
Any help would be appreciated. Thanks.


So I recently flashed TWRP and then fulmics on my D858HK 32GB from the stock kitkat. With the latest fulmics, the phone is not able to keep a steady LTE or 4G connection. It drops everytime it tries to make a connection. My guess is that its some sort of firmware issue. Could someone please help me out with a solution. Thank you.

This is the same issue that I am facing on my phone but unfortunately I did not find any solution. At times it also happens when I am on 3g and a phone restart fixes it. I think, if we first flash the stock LG MM ROM using the LG tools and then flash Fulmics after a wipe would fix this issue. Haven't got the time to try it. Been too busy. But you can try and let me know what happens.
 

Neerijus

Member
May 15, 2012
20
0
This is the same issue that I am facing on my phone but unfortunately I did not find any solution. At times it also happens when I am on 3g and a phone restart fixes it. I think, if we first flash the stock LG MM ROM using the LG tools and then flash Fulmics after a wipe would fix this issue. Haven't got the time to try it. Been too busy. But you can try and let me know what happens.

Im getting same problem with stock MM as well..
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Marshmallow v6.0 for LG-D856/857/858/858HK

    Decided make new post because need make so much changes!

    Known bugs:
    1. Not working 64GB SD cards, smaller cards work perfect
    2. Some users report that Bluetooth not Switch ON over Quick Menu. OFF works. Ovr Sytem menu Bluetooth works (I dont had on my D858HK)
    3. Some users report that camera have so much noise and not all menu options not show up (I dont had on my D858HK)
    4. No connection with android wear clocks (different models reported)

    5. USB OTG works, but you cant install at connected device programs, you must copy these to internal disk or sd.


    First for all!

    1. Make nandroid backup over TWRP
    2. Make backup of any personal information (conact list, SMS, Photos, Music and etc)


    If you kill your phone when you make bottom steps then all responsibility goes only for you! My guide is only for knowledge base.

    Version: v.6.0
    For models:LG-D856/857/858/858HK

    Link to original forum thread

    You must have:
    1. Lollipop 5.0.1 installed
    2. Root
    3. TWRP recovery v2.8.5.1


    Installation over recovery by zip file
    Wipe data, cache and dalvik!!! Then start install!

    1. Install M-856-8.zip on recovery (dont reboot yet!!!)
    2. Install Patch-6.0Mm.zip over recovery <- IT NEEDED FOR WORK WIT DUAL SIM!!!
    3. After install over recovery both zip files make reboot
    4. Before reboot TWRP asks about installation SuperSU, install it with swipe!
    5. After you get working phone on left top corner you see icon that SuperSU need to be updated. Accept it and make choice over PlayStore (Not over recovery!). PlayStore opens and make update
    6. After update SuperSU over PlayStore again SuperSu icon show that it need to be updated over normal or recovery method. This time make choice to recovery and phone itself goes to recovery and make update
    7. If phone going to TWRP and it get start loop, then just pull out battery and start normally phone again. And make previous step (6.) again. With same problem second time just pull out battery, start phone to recovery and install SuperSU v2.46 zip

    In this ROM dpi changed (not by me) to 560. Normal is 640. You can change it inside build.prop at 530 to 640, depends at your needs.

    All this take about 10 min.


    Download
    Download ROM M-856-8.zip
    Download Patch Patch-6.0Mm.zip


    Additional stuff
    If you dont have TWRP v2.8.5.1 installed then you can do next:
    1. Download D858_TWRP_2.8.1.0.apk and install it normally
    2. Go to recovery and install update twrp-2.8.5.1_d858-bumped.zip

    For unknow reason I uploaded SuperSU v2.46 zip (for insallation over recovery) here too


    Service menu can be opened with *#546368#*XXX# (replace XXX with your phone model number)


    Please dont make mirrors!

    Ask persmission over PM to copy this information! If you like then dont forget :good: Thanks button
    5
    "Bumped" TWRP 2.8.4.0 for D858 (and D858HK)

    Hi Friends,

    I found a newer version of TWRP (custom recovery) from the Chinese forum again, from here (click me!). It's version 2.8.4.0. I tried "bumping" it using the instructions from this thread: click me!

    Here is the file, already "bumped": click me!

    Based on the Chinese thread, it was designed for the D857 and D858. I tried it on the D858HK (since I assume that the only difference between D858 and D858HK is the Google Apps already built-in) and it worked!

    P.S.: I shared my findings to the appropriate "bump" threads: click me! and me too! to give due credit to its creators.
    5
    My feedback:

    Worked fine so far (tried for a week). I personally feel it's better than the stock firmware (Marshmallow) as the Phone and Messaging apps retained the "dual" buttons when making a call or sending SMS. The stock/official Marshmallow firmware no longer retained this feature (that was already there during Lollipop/Kitkat). You will have to "switch SIM" whenever you want to change the SIM card to use for calling/texting.

    Plus: if you are coming from Lollipop which you already have (presumably) rooted, with Busybox, and TWRP-installed, you get to retain them. :)
    Phone and Messaging apps with "dual" button for 858НК_30а
    Update for TWRP.
    screenshots: https://drive.google.com/folderview?id=0B99GLucn_oGINkM5OGZfMzFHMjA&usp=sharing
    download: https://drive.google.com/file/d/0B99GLucn_oGIc1d5ZVRld1BSX00/view?usp=sharing
    5
    D858HK Rooting Guide Android Lollipop

    HI Friends,

    Here's the rooting guide (Android Lollipop) for the D858HK.

    http://forum.xda-developers.com/lg-g3/general/guide-update-to-lollipop-root-bumpd-twrp-t3048845

    This is based from the procedure in @autoprime's thread of manually flashing the firmware. I just added an extra step from his tutorial to "bump" the boot.img and therefore, keep custom recovery (TWRP) as well.

    For those with other LG G3 variants who want to try this, please do share your results, LG G3 variant, and Android version (5.0.1 or 5.0.2).