• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

LG-G3 VS985 boot certification verify error (Boot loop)

Search This thread

kd1966

Member
Jun 23, 2012
13
1
I did search my terms and didn't come up with anything close to my situation, which is this: I got this phone in 2013, rooted it successfully, but was never able to get TWRP flashed properly, but I was happy with the root, so I sort of ignored the TWRP thing. Now I am getting a replacement phone, LG-V20 VS995 next week, so I decided yesterday to tinker around again with TWRP, as I wanted to put this on the V20.
On the G3 when I flashed(Or so I thought) TWRP and rebooted to recovery, I would get an error message (Very small) in the top left of the screen, then would disappear and I would have to pull the battery to reset and then it would boot fine back to the OS, but not to TWRP.
I made sure I had/have the updated Windows LG drivers, ADB, etc.... and I could see my G3 in Windows properly, the internal device and the microSD, I even pulled up the terminal emulator on the G3 while attached to the PC and ran an ID command I think, successfully. I pulled up a CLI in Windows in my ADB directory and my G3 device showed up as well. Then I tried flashing TWRP, first using Flashify; I started with an older version, like 2.8.6, but it didn't seem to work, so I started going towards the newer versions, but still, Flashify kept saying they failed to flash. So I tried the official TWRP app, and it seemed to be doing the same thing. So I went back to review what I had already done, then disconnected my phone from the PC, rebooted normally and tried again with the TWRP app. I think I was successful with one of the newer versions, 3.1.x so I did the reboot after it said it was successful, but I got that boot error message again, then blank screen and red/blue flashing lights; removed battery and replaced, powered on for normal boot and back in the phone OS again. I checked some YT videos on flashing TWRP on VS985 and it appeared I was doing everything correctly, but then I saw this one video that stated to use the Vol+ and Pwr button (I guess I thought when I selected "boot to recovery" the phone was going to do that automatically), then once you see the LG logo, release the Pwr button, then continue to press the Pwr button all while still holding the Vol+ button down, and then you would go into Recovery mode.
His next words sort of came as a shock - you had to select the option to reset your phone to factory defaults, and THEN, and IF you were successful flashing TWRP, it would take you to TWRP. I thought about this and and decided to do another TWRP flash, and if successful, would try this method. I did and I was able to get into the stock recovery menu, and I did see the option to "Reset phone to factory defaults", but decided just to cancel and went back to the phone OS, and that worked. Later on, I decided to try the "Reset" option on another phone boot, but I've now run into a different issue/error. When I boot the phone, I immediately get the error message (The boot certification verify error), and no matter how many times I remove the battery or for how long, each time the phone boots, I get this error message. The only thing I have been able to do is get into the Hardware Key Control Mode using Vol+Vol-Pwr and just continuing to press them. No matter what option I choose, either Cancel, Mode On, or Mode Off, the phone immediately reboots to the error message; it's like it's stuck in the Recovery boot mode somehow. I'm not sweating it too badly, as I've got a V20 coming next week and I have a work cell I can use for important things, but has anyone run into this type of thing? The way it is now, I cannot view the phone on my PC and cannot seem to get past this boot certification verify error.:eek::confused:
EDIT: I am now able to consistently boot into the System Recovery by way of Vol+Pwr button held down until the SR menu shows. HOWEVER, no matter what choice I select, phone reboots and I get the "Boot certification verify" error................ oh well, at least I got an email that my V20 is coming this Thursday.
EDIT: I must be somewhat dyslexic, as the method to get to the SR menu is VOL- (Not Vol+) and Pwr button held down until SR menu entry. Sorry about that
EDIT: I've also seen the "fix" where you remove the back cover, battery, and then remove the top plastic cover over the battery/power/volume, then also remove the metal shield. This is the point where it gets confusing; the author(s) want you to "ground" 2 of the contacts, but it's not clear which ones they are referring to, even with the screenshot, and I'm not electrical engineer, so not exactly sure what they mean by grounding. As I'm getting a replacement tomorrow, I decided not to even explore this technique, although I did dissassemble the phone down to removing the metal plate, so I could try and see if I could figure out what they were talking about (I couldn't). Gotta say, I've had my G3 for over 7 years and for the most part, really loved it; it came in handy during home power outages when the Internet (Cable) went out.
 
Last edited: