LG G4 H811 on LineageOS 14.1 (Android 7.1.2) does not support VoLTE

Search This thread

symnok

Member
Jan 25, 2019
11
1
I installed official LineageOS 14.1 build on my LG G4 H811 (T-Mobile USA). Everything looks good except the fact that VoLTE does not work with T-Mobile/T-Mobile MVNOs SIM cards (on this phone VoLTE shouldn't work with non-T-Mobile SIMs).

Corresponding settings are OK, but when I place call, connection drops from LTE to H or H+ (which is 3G).

Considering sunset of 3G in USA and small 2G coverage of T-Mobile it limits the usage of this phone.

Any idea how to re-enable VoLTE on this device?

The phone is rooted with installed TWRP.

Thank you.
 

Exabyter

Senior Member
Mar 11, 2017
233
109
I came here today looking for info about the possibility of a newer ROM on my H811 that supports VoLTE too.

My device has been on LOS 14.1 for several years, but I rarely use it.

The prognosis doesn't look good, though. Probably the source code that supported VoLTE was never released for it, and/or the carriers are blacklisting the IMEIs for VoLTE.

I posted a question about this on the thread for unofficial HavocOS / A11 for the G4. Waiting to see if I get an answer.
 

symnok

Member
Jan 25, 2019
11
1
I came here today looking for info about the possibility of a newer ROM on my H811 that supports VoLTE too.

My device has been on LOS 14.1 for several years, but I rarely use it.

The prognosis doesn't look good, though. Probably the source code that supported VoLTE was never released for it, and/or the carriers are blacklisting the IMEIs for VoLTE.

I posted a question about this on the thread for unofficial HavocOS / A11 for the G4. Waiting to see if I get an answer.
I expect H811 to be compatible only with T-Mobile VoLTE at the first place. AT&T and Verizon are blacklisting this model. I do not know what EU, CA and UK carriers policy regarding VoLTE.