• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LG V30 lag

Search This thread

CrossDonut

Member
Oct 15, 2021
6
1
Hi Everyone,

My v30 have been lagging for quite some time and didn't bother to find out what is going on. So I recently factory reset but it still feel quite lag in term of surfing net and playing mlbb. May I know what should I do or what do you guys suggest ?

LG stock Android
Model: LG-H930DS
Android version: 9
Kernel version: 4.4.153
Software version: V30c-SEA-XX

Thank You
 

blackhawk

Senior Member
Jun 23, 2020
6,421
2,082
Try a network reset.
Clear system cache.
Install Karma Firewall and see if an app or service is hogging the bandwidth.
 

CrossDonut

Member
Oct 15, 2021
6
1
Try a network reset.
Clear system cache.
Install Karma Firewall and see if an app or service is hogging the bandwidth.
Hi Blackhawk,

sorry that I didn’t mention clearly what kind of lag I’m experiencing. The lag I’m facing is not internet but the scrolling of internet and playing games frame rates not smooth. I see on YouTube that some people do use v30 to play games with smooth frame rates while my is set to the lowest quality in game but still lag.
 
  • Like
Reactions: blackhawk

blackhawk

Senior Member
Jun 23, 2020
6,421
2,082
Try clearing the system cache.
Try a hard reboot.
A 3rd party app might have alter hidden settings.
Was the change coinciding with a recent app install/uninstall?
Sometimes even after uninstalling the app the setting change remains.
If that's the case a factory reset may be needed... if you get tired of chasing it.
What's ram usage look like? Are any apps or services using excessive ram? Or shouldn't be there?
Play with it.
 

CrossDonut

Member
Oct 15, 2021
6
1
Try clearing the system cache.
Try a hard reboot.
A 3rd party app might have alter hidden settings.
Was the change coinciding with a recent app install/uninstall?
Sometimes even after uninstalling the app the setting change remains.
If that's the case a factory reset may be needed... if you get tired of chasing it.
What's ram usage look like? Are any apps or services using excessive ram? Or shouldn't be there?
Play with it.
Hi Blackhawk,

I have tried factory reset 3 times. But still lag. My mobile is always free 1.6gb out of 4.0gb. I’m not sure what apps is hogging or causing the lag. I have tried uninstall some of the bloat ware that come with it like the telco apps, Deezer , google office.
 

blackhawk

Senior Member
Jun 23, 2020
6,421
2,082
Hi Blackhawk,

I have tried factory reset 3 times. But still lag. My mobile is always free 1.6gb out of 4.0gb. I’m not sure what apps is hogging or causing the lag. I have tried uninstall some of the bloat ware that come with it like the telco apps, Deezer , google office.
Meh, factory resets are best used very sparingly like after a major firmware update, malware or OS is damaged. If the firmware is suspect at this point a reflash serve a better purpose.
Your ram usage sounds nominal.
What's the SOT like?

Install DevChek and examine the hardware etc.
Is it using excessive battery/cpu cycles at idle?
Install Karma Firewall, it's freeware and uses almost no battery.
You need to try to isolate the cause.
 

CrossDonut

Member
Oct 15, 2021
6
1
Meh, factory resets are best used very sparingly like after a major firmware update, malware or OS is damaged. If the firmware is suspect at this point a reflash serve a better purpose.
Your ram usage sounds nominal.
What's the SOT like?

Install DevChek and examine the hardware etc.
Is it using excessive battery/cpu cycles at idle?
Install Karma Firewall, it's freeware and uses almost no battery.
You need to try to isolate the cause.
Hi Blackhawk,

Battery wise looks ok. CPU cycles, I'm not sure how to see. How do I do a reflash of os ?

Thank you so much for helping me. Really appreciate.
 

blackhawk

Senior Member
Jun 23, 2020
6,421
2,082
Hi Blackhawk,

Battery wise looks ok. CPU cycles, I'm not sure how to see. How do I do a reflash of os ?

Thank you so much for helping me. Really appreciate.
DevChek. Load Karma Firewall and use it's logging feature to it what apps are accessing the internet and how often.

Maybe something is goofed up with the internet connection settings due to changes on the carrier side. Access point names is as far as I've had to play with that.
 
Last edited:

CrossDonut

Member
Oct 15, 2021
6
1
Hi BlackHawk,
My phone start to work slightly better after I block some of the apps connection. But lagging is still there when I play graphic intensive. Phone doesn’t feel hot while playing game or maybe it’s cpu/gpu throttling.

Thank You for your advice. I will continue to observe the phone condition.
 

blackhawk

Senior Member
Jun 23, 2020
6,421
2,082
That's strange. Did you do any firmware updates*?
Is it internet connection related maybe ie online games?
Have the carrier do a network reset on their end.
Make sure the access point names are correct.
Double check all connection settings.

Maybe try replacing the sim card, handle like a stick of ram. They are susceptible to ESD damage, a failure maybe delayed or partial. They are dirt cheap but can cause a lot of trouble if not handled properly. Very few people handle them correctly. Like ram sticks they're nearly 100% good when they leave the factory until the end user gets them...


*Maybe the firmware got corrupted or the update was a dud, try reflashing to the same original rom.
 

CrossDonut

Member
Oct 15, 2021
6
1
That's strange. Did you do any firmware updates*?
Is it internet connection related maybe ie online games?
Have the carrier do a network reset on their end.
Make sure the access point names are correct.
Double check all connection settings.

Maybe try replacing the sim card, handle like a stick of ram. They are susceptible to ESD damage, a failure maybe delayed or partial. They are dirt cheap but can cause a lot of trouble if not handled properly. Very few people handle them correctly. Like ram sticks they're nearly 100% good when they leave the factory until the end user gets them...


*Maybe the firmware got corrupted or the update was a dud, try reflashing to the same original rom.
I'm not sure how to reflash the ROM. Do I find the apps on desktop and use it to reflash it ? Sorry I'm quite green in this area/field.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Try a network reset.
    Clear system cache.
    Install Karma Firewall and see if an app or service is hogging the bandwidth.
    Hi Blackhawk,

    sorry that I didn’t mention clearly what kind of lag I’m experiencing. The lag I’m facing is not internet but the scrolling of internet and playing games frame rates not smooth. I see on YouTube that some people do use v30 to play games with smooth frame rates while my is set to the lowest quality in game but still lag.