• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

LG V40 bootloader unlock & root

Status
Not open for further replies.
Search This thread

elcocolo50

Senior Member
Mar 31, 2010
292
84
Hi.. I download this one but I cant flash with Lgup and I thisnk this is for Verizon wireless..the LGUP give me error on 4% thanks ..I need version 1.15 of lgup

Sent from my AT&T LM-V405 using Tapatalk
 

lowridincrew,

Senior Member
Jun 24, 2011
456
69
Cleveland
LG V40
Samsung Galaxy A71 5G
I can ensure you that US UNLOCKED firmware works on Sprint V40, I flash it to everyone course it is bloatware free. Also I do full system backup in case of official unlock will be done later.

Why do you want Verizon fw? What features do you need?
90% that voice via up (internet calling) will not work.

Thinking of getting a Sprint V40 but the IMEI is financed. I want to use it on T-Mobile. Is it possible that unlocked firmware/bootloader unlock unlocks the sim card slot?
 

nitephlight

Senior Member
Mar 16, 2012
275
100
Why do you want Verizon fw? What features do you need?
90% that voice via up (internet calling) will not work.

hey @Vlaaad - loving this new phone, thanks again for your assistance with root and Pie flash :good:

this isn't exactly a problem, but i wonder whether some Verizon features are missing. i don't think they have worked since the Pie flash, but these things aren't terribly important, just minor inconvenience:

1. my GF has been complaining recently that the call quality from my end seems to be poor compared to before. i have a solid (not perfect) LTE signal in my room, but i am suspicious that VolLTE is not being engaged. is there any way to test that VolLTE / HD Calling is truly working?

2. Visual Voicemail: or actually regular voicemail notifications at all. when i receive a VM now, i get no notification, just an SMS message with carrier code. under Phone > Call Settings > Voicemail, Service simply says "My Carrier".





some possible thoughts on this:
  1. Current firmware simply does not support these VZW carrier features?
  2. SIM card? i had hot swapped the nano SIM from my Pixel 3 into v40. i will try to get a new one properly activated at the VZW store.
  3. Debloated ROM? maybe there is some obnoxious Verizon system app that is required for these functionalities?


thanks for any thoughts input you (or anyone else) may have!
 
Last edited:

vbenkovskyy

Senior Member
Feb 12, 2011
205
61
hey @Vlaaad - loving this new phone, thanks again for your assistance with root and Pie flash :good:

this isn't exactly a problem, but i wonder whether some Verizon features are missing. i don't think they have worked since the Pie flash, but these things aren't terribly important, just minor inconvenience:

1. my GF has been complaining recently that the call quality from my end seems to be poor compared to before. i have a solid (not perfect) LTE signal in my room, but i am suspicious that VolLTE is not being engaged. is there any way to test that VolLTE / HD Calling is truly working?

2. Visual Voicemail: or actually regular voicemail notifications at all. when i receive a VM now, i get no notification, just an SMS message with carrier code. under Phone > Call Settings > Voicemail, Service simply says "My Carrier".





some possible thoughts on this:
Current firmware simply does not support these VZW carrier features?
SIM card? i had hot swapped the nano SIM from my Pixel 3 into v40. i will try to get a new one properly activated at the VZW store.
Debloated ROM? maybe there is some obnoxious Verizon system app that is required for these functionalities?



thanks for any thoughts input you (or anyone else) may have!
Yes, Voice over ip is not supported by us unlocked firmware. Need to go back to stock to support it again
 
Last edited by a moderator:

TheMadScientist

Recognized Contributor
Unlock itself can't cause this issue. Issue can be in boot.img or EU rom, flashed to kerean model, which is not compatible.

i got it unlocked. first boot img bootlooped so wifi is working randomly.
can detect 1 sim card out of 6 I do notice that first setup seemed to be Chinese or something and i had to set as US..
I also notice I see insert a Usim Not insert Sim card.
Using radio switcher app Shows radio ass powered off and cant turn on..... In network settings I see under network type LTE only,Automatic and all the rest but no matter what I select I see network type 22 I have in all my years never seen this as well

I am not a total noob :silly::p:p:p I know a lot I would like to think I have had issues in the past with devices set nv or ruim only settings in DFS CDMAtool and have fixxed similar issues

When I insert the one detected Sim i see my number no network siganal, I make a call and it ends in take off airplane mode error,Despite it not being on Also on call end screen shows a quick msg of Radio powered off...

Maybe a GCF issue i just got started Itll be fun once I can get the hidden menus to work and get the DIAG port open
 

vbenkovskyy

Senior Member
Feb 12, 2011
205
61
i got it unlocked. first boot img bootlooped so wifi is working randomly.
can detect 1 sim card out of 6 I do notice that first setup seemed to be Chinese or something and i had to set as US..
I also notice I see insert a Usim Not insert Sim card.
Using radio switcher app Shows radio ass powered off and cant turn on..... In network settings I see under network type LTE only,Automatic and all the rest but no matter what I select I see network type 22 I have in all my years never seen this as well

I am not a total noob :silly::p:p:p I know a lot I would like to think I have had issues in the past with devices set nv or ruim only settings in DFS CDMAtool and have fixxed similar issues

When I insert the one detected Sim i see my number no network siganal, I make a call and it ends in take off airplane mode error,Despite it not being on Also on call end screen shows a quick msg of Radio powered off...

Maybe a GCF issue i just got started Itll be fun once I can get the hidden menus to work and get the DIAG port open
Install stock rom FOR YOUR REGION and stock unrooted boot img.
 
  • Like
Reactions: TheMadScientist

TheMadScientist

Recognized Contributor
TWRP works only on Pie. Switch to download mode and flash all partitions except laf and abl

I used the twrp thread in V40 and I got twrp to boot, I think Im softbricked right now but havnt looked into that either
So Im new to this System A/B stuff. How can I confirm what firmware and How can I reflash US As of right now I have no signal and device is unusable in that aspect. Wifi is working ok now I always get the real winners
 

vbenkovskyy

Senior Member
Feb 12, 2011
205
61
I used the twrp thread in V40 and I got twrp to boot, I think Im softbricked right now but havnt looked into that either
So Im new to this System A/B stuff. How can I confirm what firmware and How can I reflash US As of right now I have no signal and device is unusable in that aspect. Wifi is working ok now I always get the real winners
If I were you I'd checked IMEI, flashed original Korea rom via Download mode. If no download mode I would flash it using root dd command in terminal or used partitions manager app to flash it from system. Or if you have eng abl (fastboot) you can boot or flash laf directly. Pm me on telegram if you need more details or quick replies
 
  • Like
Reactions: cityneversleepz
Status
Not open for further replies.

Top Liked Posts