Lineage 16.0 unofficial TESTING

Search This thread

randomblame

Recognized Developer
May 18, 2009
2,710
18,009
This is an early build current bugs:
audio is not great
youtube does not play
fingerprint sensor is broken
encryption untested
avb disabled
selinux in permissive
eng build for ease of debugging and logging will cause slow downs and red boarders
etc

This is incompatible with the modem from Android Q it will break sensors and cause boot to fail. If coming from Q flash a different modem via fastboot

This is for testing and demonstration only
https://www.androidfilehost.com/?fid=6006931924117882490

Device tree:
https://github.com/randomblame/android_device_xiaomi_cepheus

build instructions: you need my tree, my kernel, and you need the sm8150 hals. https://review.lineageos.org/c/LineageOS/android/+/248513 you also need my modified media hal : https://github.com/randomblame/media-caf_sm8150.git


Kernel source:
https://github.com/randomblame/android_kernel_xiaomi_sm8150

6LUcrAKLZbvRqpnqydstchu8Ho4dW696KiojkRmvPZ4gtH04xXBlo1Hqcr2t2p_kNHS63p65cF7MlUCNjjByL3Kg58PT7mBAHjs1zKHy3dFQbf7ZmgItfVOHNvYnk0sl79U7RG7_NATe0kcc0R7ZJ7Oc2_m0Y9JWDP-xuZfnlD4Um8KqLxvwtjEzNoZUfu2ZyTUP1RnXSj2sYaAKEw2QDru7_aXWIUE7Pf-1fBkPhrllYYoJp0uB5NQVdbnIddpYdkitHlI7LLOl019CkgaAUQBNB4Y0MY6sCO77FA5asBfZLb-zsjklUsETxt9ay5T8TaFNpGIMOI9KcC1gBfCQtpMleN-2VBZhOKpoi_oUPLC2PgJR_Gus6Bn57fW1Vd5eYQfgu1I3cXRqy8AqOM3ee80RpyDNLqyQya-UYJYxfQE4xXDdXLINT5lqFNVIRZX9CTFnoNJU2bAJRJymqYT223aBo-1N2B7Zacs2VbdHDLPFxtErLb8wOIUbTiRTt9h9nqeJK8ASEwRGAtBRLGPjtJYO-0AIf1CUoBG6G7hFgJf9y7WOYWpRoW5Y7P_mdF0u-fNH0HfWzI_txXaUJLCHLdEvgDZE_tkgdsb2T1sUtzpb6AHbyKgS-IaUsLEWCcoHZQgXvv-56XBLX8iiuIT-jSN8JsAa3z4=w325-h704-no
 
Last edited:

Kollachi

Senior Member
Aug 24, 2013
2,175
992
Osnabrück
That's amazing! I think it won't take a long time and the other devs will start building too. Let's see what happens in future! Im very happy now. :)
Thank you Kelsi for your hard work. I guess this will be the new thread I press reload every hour. :D
 

Top Liked Posts

  • There are no posts matching your filters.
  • 79
    This is an early build current bugs:
    audio is not great
    youtube does not play
    fingerprint sensor is broken
    encryption untested
    avb disabled
    selinux in permissive
    eng build for ease of debugging and logging will cause slow downs and red boarders
    etc

    This is incompatible with the modem from Android Q it will break sensors and cause boot to fail. If coming from Q flash a different modem via fastboot

    This is for testing and demonstration only
    https://www.androidfilehost.com/?fid=6006931924117882490

    Device tree:
    https://github.com/randomblame/android_device_xiaomi_cepheus

    build instructions: you need my tree, my kernel, and you need the sm8150 hals. https://review.lineageos.org/c/LineageOS/android/+/248513 you also need my modified media hal : https://github.com/randomblame/media-caf_sm8150.git


    Kernel source:
    https://github.com/randomblame/android_kernel_xiaomi_sm8150

    6LUcrAKLZbvRqpnqydstchu8Ho4dW696KiojkRmvPZ4gtH04xXBlo1Hqcr2t2p_kNHS63p65cF7MlUCNjjByL3Kg58PT7mBAHjs1zKHy3dFQbf7ZmgItfVOHNvYnk0sl79U7RG7_NATe0kcc0R7ZJ7Oc2_m0Y9JWDP-xuZfnlD4Um8KqLxvwtjEzNoZUfu2ZyTUP1RnXSj2sYaAKEw2QDru7_aXWIUE7Pf-1fBkPhrllYYoJp0uB5NQVdbnIddpYdkitHlI7LLOl019CkgaAUQBNB4Y0MY6sCO77FA5asBfZLb-zsjklUsETxt9ay5T8TaFNpGIMOI9KcC1gBfCQtpMleN-2VBZhOKpoi_oUPLC2PgJR_Gus6Bn57fW1Vd5eYQfgu1I3cXRqy8AqOM3ee80RpyDNLqyQya-UYJYxfQE4xXDdXLINT5lqFNVIRZX9CTFnoNJU2bAJRJymqYT223aBo-1N2B7Zacs2VbdHDLPFxtErLb8wOIUbTiRTt9h9nqeJK8ASEwRGAtBRLGPjtJYO-0AIf1CUoBG6G7hFgJf9y7WOYWpRoW5Y7P_mdF0u-fNH0HfWzI_txXaUJLCHLdEvgDZE_tkgdsb2T1sUtzpb6AHbyKgS-IaUsLEWCcoHZQgXvv-56XBLX8iiuIT-jSN8JsAa3z4=w325-h704-no
    32
    Sorry I've been MIA for a bit I've had some serious life issues lately. I did make sure to share all of my source so others could get it working and hopefully when things calm down for me I will be back ?
    17
    new build up with updated kernel and vendor image built in
    17
    Ok guys here's my experience,
    I was on ROS, with the Chinese recovery, changed that to the recommended one, flashed rom with full wipe, not storage, flashed the universal encryption disabler as I'm decrypted and wanna keep it that way, flashed open gapps nano, reboot recovery, flashed latest magisk, boot was quick, I was glad to see the lineage logo, setup rom reboot in recovery flashed a few magisk modules including vanced YouTube and stereo mod, YouTube only playing audio no video, rom is lacking all the things OP mentioned, I loved the speed its thunder fast, stereo mod working perfect, all apps restored with TB with no problems, cam taking still pictures but not video, phone got restarted on trying to make video, gcam xtreme takes pics but can't save them, no video, I could have carried on using it but no in-call audio. Both sims working 4g working, sms send/recieve working, notifications working as they should. Rom has lots of potential, good work OP keep it up, cheers buddy
    16
    Hi all,

    Got it working on my device.

    Running nice, few setup needed corrections for AOD which i just enabled, brightness and saftynet pass.

    Notification lights just fixed.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone