Lineage 17.1 *UNOFFICIAL* for FIH (SAT/SS2/HH1/HH6/HD1/DRG)

heineken78

Senior Member
Mar 3, 2009
2,556
1,786
183
Kiev
www.mediafire.com
I have just flashed vendor from LOS17-aquos-s2-s3-unofficial-161119.zip but unfortunately it doesn't seem to work yet. I'm currently using Havoc3.0. Is there anything that would be needed from either boot or system images in order to fix it?

From what I have read on 4PDA, there was someone who made NFC work on Android Pie with the LineageOS17 libnfc-nxp.conf. At the moment I will remain on Android 10 though as it seems to work better.
Its not a GSI thread! Its a spam about GSI here.
Currently flashed 17.11.19 FULL and Havoc 3.0 works!
 

Archcy

Member
Nov 30, 2018
16
6
0
I don't use NFC and bluetooth, so every hardware works fine for me.
Camera:works | 4G/LTE:works | Video/GPU:works | sensors:work | type-c devices/earphone:works
WIFI :works, In default mode , wifi settings will use random MAC option. If your router is set to authenticate device by MAC, you should pay attention to that.
Bluetooth:Not Tested,sholuld works | NFC:Not Tested,sholuld works
All bugs I met are from LOS upstream.
Sometimes, few system Apps will show ANR,but I can't reproduce these bugs.
 
  • Like
Reactions: heineken78

rav3n_pl

Senior Member
Sep 16, 2011
483
128
0
Wojcieszyce
ubezpieczdziecko.pl
Installing GAPPS causes error messages...
Will wait till it works correctly.
Also Trust is nagging:
- it is possible te set selinux to be enforcing out of box?
- please sign builds ;]

Magisk 20.1 will work properly there? They not have anything about working on Andorid Q (10)?
 

Archcy

Member
Nov 30, 2018
16
6
0
Installing GAPPS causes error messages...
Will wait till it works correctly.
Also Trust is nagging:
- it is possible te set selinux to be enforcing out of box?
- please sign builds ;]

Magisk 20.1 will work properly there? They not have anything about working on Andorid Q (10)?
What error did you meet? Which version did you install?
You'd better install 'nano',because pixel launcher in gapps won't work.
If it dosen't help, try latest opengapps here:https://sourceforge.net/projects/opengapps/files/arm64/beta/
I haven't try Magisk on my phone,but according to Magisk's changelog:https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445
- [MagiskInit] [2SI] Support non A/B setup (Android 10)
- [MagiskInit] [2SI] Support 2-stage-init for A/B devices (Pixel 3 Android 10)
It should support android 10.
 

jokolom

Member
Aug 6, 2019
14
2
0
Installing GAPPS causes error messages...
Will wait till it works correctly.
Also Trust is nagging:
- it is possible te set selinux to be enforcing out of box?
- please sign builds ;]

Magisk 20.1 will work properly there? They not have anything about working on Andorid Q (10)?
Gapps might fail to install if there's no space remaining in /system. Try expanding the partition in TWRP if this is the problem. Magisk 20.1 works perfectly on Android Q and this ROM.
 

xixuluo

Member
Dec 29, 2018
21
6
0
LEGAL
https://lineageos.org/legal/
You flash this ROM on own risk!


XDA:DevDB Information
Lineage 17 *UNOFFICIAL* for Sharp Aquos S2, S3 (SAT/SS2/HH1/HH6)
Multi ROM from sources supporting Sharp Aquos 4/64 -SS2/C10, Sharp Aquos S2 6/128 -SAT, Sharp Aquos S3 -sdm630 (HH1/HH6).

Contributors
heineken78
ROM OS Version: Android 10
ROM Kernel: Linux 4.x
ROM Firmware Required: Minimum update installed 2130WW/CN -for S2. For S3 - D350KR
Based On: Lineage 17
Recovery: TWRP included.
Device sources:here

Gapps: No. Alternative install. " Nano" recommended.
Data Encryption:two hals chosen automatically for s2 or s3. Data is encrypted. Bug: TWRP don't recognize pin pattern
Do not: use boot(twrp) or vendor with other older/stock roms.



Version Information
Status: Beta
Beta Release Date: 2019-11-03

Created 2019-11-03
Last Updated2019-11-17



Change log:


17-11-2019
Update Android 10.0.0_r11


16-11-2019
-kernel fix: some hw models of s2 recognized as SG1
leds and vibration fix for s3.
-SystemUI compatibility for s3.


15-11-2019
-supports Sharp Aquos S3 models -HH1 and HH6!
-Los up-to-date

05-11-2019
-kernel updated to 4.4.194 (caf LA.UM.8.2.r1-04800-sdm660.0)
-CAMERA: latest camera vendor blobs Q from 2060 Nokia PL2 (test option prop persist.cam.dv=(PL2/B2N/C1N) for camera hal)
-PERFORMANCE: PERF 2.0 fixed
-LINEAGE: current Lineage updates from mainstream(not much)
-SOUND: revert to stock soundtrigger
-VNDK rebuild with Q rules
-added many enhancements in build.props


03-11-2019
First release


Installation
1. First time
Enter twrp or from fastboot and flash images: boot, system, vendor. Reboot back recovery and format data. Install Gapps same time (as option).Reboot to new system.

2. Next updates/upgrades
Enter twrp and flash new images. If you had installed Gapps, flash same zip file o gapps. Reboot to system.

Bugs:
-Minor LOS bugs.
-You will find may be
love your works
 

rav3n_pl

Senior Member
Sep 16, 2011
483
128
0
Wojcieszyce
ubezpieczdziecko.pl
What error did you meet? Which version did you install?
You'd better install 'nano',because pixel launcher in gapps won't work.
Latest nano beta gapps.

Gapps might fail to install if there's no space remaining in /system. Try expanding the partition in TWRP if this is the problem. Magisk 20.1 works perfectly on Android Q and this ROM.
It is installing w/o any errors.

Attached screen and logcat.
 

Attachments

Archcy

Member
Nov 30, 2018
16
6
0
Latest nano beta gapps.


It is installing w/o any errors.

Attached screen and logcat.
Just ignore that warning.
You can setup system and use Google play without any problem.
Every time you boot your phone, you will see that warning,just ignore that.

If you use SS2 with some Project Treble/GSI ROMs before,U will see the warning ,too.
 

iiandrusii

Member
May 6, 2018
37
9
0
2 days on LOS17-aquos-s2-s3-unofficial-171119
Everything works fine (i don't use NFC).
Magisk 20.1 - ok
Gcam - no
GAPPS (10.0 pico Beta) - ok
Antutu (high performance) - 107095 pts
Antutu (balance performance) - 106288 pts
Antutu (economic performance) - 83292 pts
Battery SOT 5h15min (10% battery left)
No % battery on status bar (you can install some battery status apk).
I'm staying on this rom. Im waiting for working gcam.
:good::good::good:
 

cuciu70

Senior Member
Apr 29, 2014
97
9
28
seveso
Hello everyone! I'm interested in buying this smartphone.?
The version currently on sale is S2 c10, which if I am not mistaken, supports the 20 band.
My question is: is it necessary to do some sort of unlocking of the bootloader like on xiaomi?
I have android stock being the installation of the recovery twrp Can it be done without problems?
Forgive my questions? But frankly I didn't think this gem still had support?
And this is a pleasant surprise?
I ask because here we talk about s2!
Am I in the right place?
 
Last edited:

jokolom

Member
Aug 6, 2019
14
2
0
@heineken78, thank you once again for your great work in bringing us LOS 17.

Am trying to get fingerprint navigation working in LOS 17 without much luck so far.

The default is:
- LONG TAP=BACK works.
- SHORT TAP is some sort of ENTER. If SHORT TAP on say the launcher screen, it highlights an item. SHORT TAP again and it selects it.

Editting /vendor/user/keylayout/uinput-fpc.kl does not change things.

Any chance of debugging the LOS17 finger print sensor codes so can get them working for navigation?

Thank you
I once had the same problem. When there is an error within the formatting or something deems as an error, it will use default action (which is highlighting items). Sometimes it might be a simple typo that causes the error. When it happened to me, I first restored the original file to fix it, then remodified it, rebooted and then it worked correctly.
If you want, I can test your combinations to see if they work on my device.

have installed https://www.xda-developers.com/google-camera-port-hub/
PMGC_7.0.009_ConfigsVersion_V3
Works 100%
I can confirm this version of the camera works for me as well, with HDR+, Night sight and such :good:

Hello everyone! I'm interested in buying this smartphone.
The version currently on sale is S2 c10, which if I am not mistaken, supports the 20 band.
My question is: is it necessary to do some sort of unlocking of the bootloader like on xiaomi?
I have android stock being the installation of the recovery twrp Can it be done without problems?
Forgive my questions But frankly I didn't think this gem still had support
And this is a pleasant surprise
I ask because here we talk about s2!
Am I in the right place?
Depending on the Android version of the phone it's easier or harder to unlock. You will indeed need to unlock bootloader. Worst case scenario (Android 8+), you should be able to unlock using an unlocking service. Check out the first post on https://forum.xda-developers.com/android/general/sharp-aquos-s2-ss2-sat-thread-t3761071), you will find instructions on how to unlock and what to do after in order to flash custom ROMs.
 
Last edited:
  • Like
Reactions: cuciu70