Lineage OS 7.1.1: Unable to send SMS messages

Search This thread
Sep 28, 2013
Hello all,

I flashed my girlfriend's Sprint S5 with Lineage OS recently without a hitch, all services working perfectly. We ended up traveling, so she went to Sprint to set up a temporary international roaming plan. Everything was completely as expected abroad. When we got back, her phone would not send SMS messages.

We tried the usual airplane mode and such, and to no avail. Assuming something was wrong with the network configuration from travelling, we reset network settings. Didn't work. I then decided to just do a full wipe and re-flash of Lineage OS. Still doesn't work. I then resorted to going back to the stock TouchWiz ROM from Sprint. At that point, under the stock ROM, SMS were sending. Out of curiosity, we flashed back Lineage OS, and SMS will again not send. We noticed that if the SIM card is removed, SMS will send, but the phone would not be able to access 4G LTE. We also confirmed with Sprint that there are no restrictions on the account.

What could be causing this to occur only on custom Roms? Do we need to do a PRL update? If so, how does that work on stock Android?

Thanks in advance!


Senior Member
May 28, 2016
I'm using LOS 7.1.1 20170207 kltespr nightly, LTE SMS can only receive, sending doesn't work. Only 3G SMS works.

Things I noticed:

Settings -> About Phone -> Status -> IMEI Information. When on 3G, all information is displayed here, when on LTE, only IMEI and IMEI SV is displayed, there's no PRL/MIN/MEID/ICCID anywhere, not even disabled or greyed out, just hidden completely.

ICCID also shows DUMMY_NV_ICC_SERIAL instead of the actual ICCID.


Senior Member
Aug 4, 2011
Same experience for me, I've been trying to find a workaround for over a month with no success. Alternative text messaging apps seem to work, but I don't trust 3rd parties with my SMS.
Jan 7, 2015
Unable to send SMS

Which third party SMS app are you getting to work? Besides Google voice I have had no luck with any third party app?


New member
Apr 18, 2011
I'm having the same issue. I'm on Resurrection ROM which is based on Lineage. Since update I can't send SMS at all other than via Google Voice. I can receive SMS and I can send/receive MMS.

I did find that if I change to 3g only for my network settings, I can send SMS. But then of course I don't get LTE data speeds for everything else. So the issue for me at least is tied specifically to LTE. Wondering if there is an APN or other setting I can change that would fix this but so far no luck finding anything.


New member
Jul 6, 2017
I've run into the same problem or similar. If I set my preferred network type to GLOBAL then I can send and receive SMS/MMS messages but I'm forced to either Roaming LTE or 3G. It's often stuck in 3G after a drive for any distance. If I force it to LTE, then SMS/MMS stops working and I can't place or receive calls either but the network will show up as LTE and Sprint.

To get there from Settings Home -> More (under Wireless and Networks) -> Cellular networks -> Preferred network type -> Choose Global.

Sometimes I can force it back to LTE but roaming if I switch temporarily to LTE then once it connects switch back to Global. Occasionally I have to put it in airplane mode to get the radios to reset and connect but some combo of switching network type and ending up in global and switching into and back from airplane will do the trick.

YMMV of course.


Senior Member
Dec 11, 2011
one way I fix it temporarily is to:
cell networks - carrier settings, let it crash
go in again and let it find your carrier
once connected, make a phone call at least to get it ringing
I can then make sms mms.

it's a rediculous work around but it works for me every time


Jul 26, 2017
SMS Sending Problem with Lineage 14.1 (31.07.2017)

I'm not able to send sms from SIM 1 but can send sms from SIM 2 in Lenovo A6020a46 (2GB) on Lineage 14.1 (31.07.2017).
The same SIM is working good in another roms and Calling + Internet are working properly.

After dialing *#*#4636#*#* in Phone Information - SMSC Refresh then it appeared "Phone no.", 456 and I pressed Update.
But there was no process for saving or updating. Then I reentered in Phone Information but SMSC Shows blank.

What to do??? anybody help in this matter will be immensely appreciated.

Dilpreet Sidhu


New member
Jan 21, 2019
To fix this issue with having LTE signal and sending SMS at the same time you have to open EnginneringMode app (or *#*#3646663#*#*) and check 'Sms over Sgs support' in Misc Feature Config tab.

Deleted member 8425317

Doesn't work because nothing comes up entering the code. Any idea?
Last edited by a moderator:


New member
Dec 17, 2018

there is an option in network settings (enhanced 4G LTE mode for comunications etc) i disabled that option and messaging works fine now. before unchecking this option i could only send sms only with phone on 3g mode, now it works fine. i think this option is for hd voice calls via 4g lte.


Dec 28, 2021
I see this is an old problem and I´m having the same problem. I can receive SMS, but I can´t send.

But to add to that, I couldn´t connect at all with my previous carrier and changed carrier after which I can use data, call and send SMS. I still can´t receive SMS.

Top Liked Posts