[LINEAGE-OS][STABLE.V4.1][7.1.2][UNOFFICIAL]14/02/2020[all variant]OMSv7

karameji

New member
May 15, 2020
1
0
0
Hello. I have e2203 and eternal boot. All of three steps from instruction have done success. I see the logo with a circle and part of a circle and that's it all.
p.s. sorry for my english)
 
Apr 3, 2018
6
2
0
Belo Horizonte
Oh my God!

You're the best!!! I haven't seen that this version was out yet!

I always believed in you, and that you can! Yes, it took a little time but what could we think? What could we want? Were you our employees? Were you developers from Sony? No, you weren't! And you did this anyway!

I don't know if posts like this follow the rules! But I just need to say thanks and congratulations for your work. Hit the "Thanks!" button is not enough! (I'm sorry! It should be already hit but at that time I didn't know about 'Thanks' and 'thread rating')
I'm still using that version with "unstable" camera (which is a great work!) and I will try this latest version as soon as I can.

Thank you very much!!!

[Edit]
I've posted here about my D2212 that was dead by a lightning struck. Because of your great work (and my first succesful rom flashing) I bought a new D2212 one (it is very cheap now) to use as a backup phone (and sometimes as the main phone xD).
[/Edit]
 
Last edited:

Italord

Member
Jul 18, 2018
8
2
0
You're the best!!! I haven't seen that this version was out yet!

I always believed in you, and that you can! Yes, it took a little time but what could we think? What could we want? Were you our employees? Were you developers from Sony? No, you weren't! And you did this anyway!

I don't know if posts like this follow the rules! But I just need to say thanks and congratulations for your work. Hit the "Thanks!" button is not enough! (I'm sorry! It should be already hit but at that time I didn't know about 'Thanks' and 'thread rating')
I'm still using that version with "unstable" camera (which is a great work!) and I will try this latest version as soon as I can.

Thank you very much!!!

[Edit]
I've posted here about my D2212 that was dead by a lightning struck. Because of your great work (and my first succesful rom flashing) I bought a new D2212 one (it is very cheap now) to use as a backup phone (and sometimes as the main phone xD).
[/Edit]
Onde você conseguiu achar um D2212 novo e por quanto amigo? Meu antigo D2212 era meu aparelho secundário e acabei dando ele pra minha sobrinha, mas estava querendo adquirir um novo para fazer alguns experimentos e tbm mantê-lo como aparelho secundário, caso o preço esteja agradável atualmente.
 
Apr 3, 2018
6
2
0
Belo Horizonte
Onde você conseguiu achar um D2212 novo e por quanto amigo? Meu antigo D2212 era meu aparelho secundário e acabei dando ele pra minha sobrinha, mas estava querendo adquirir um novo para fazer alguns experimentos e tbm mantê-lo como aparelho secundário, caso o preço esteja agradável atualmente.
Cara, encontrei no Mercado Livre mesmo. Estava na faixa de R$200,00 novo, sem uso e sem contar o frete. Já tem quase 1 ano isso. Você precisa dar uma minerada lá porque tem gente tentando vender ele a R$400. Na época que eu comprei meu primeiro, foi 370 novo no Ponto Frio, alguma promoção.
 
Apr 3, 2018
6
2
0
Belo Horizonte
Can't add Google account anymore

Hey guys! I've finally installed the v4 and I'm very satisfied! Everything works in my D2212.

But since I started using this version I can't login into Play Store or add google account. I just put the email and click 'Next' and the app shows a message that means "Something went wrong. Try again." (literal translate from portuguese). It shows this message instead of asking for the password.

I've searched about the problem and found some information about PlayProtect and certified devices. It seems that recently Google started not recognizing Custom ROMs as 'certified devices'.
I followed this steps from here (with Device ID and registering the GSF) but it still didn't work.

Is anybody having problems with this? Should we try the alternatives to Gapps?

Thanks!
 

rmnhg

Senior Member
Jan 22, 2015
190
234
83
Madrid
Hey guys! I've finally installed the v4 and I'm very satisfied! Everything works in my D2212.

But since I started using this version I can't login into Play Store or add google account. I just put the email and click 'Next' and the app shows a message that means "Something went wrong. Try again." (literal translate from portuguese). It shows this message instead of asking for the password.

I've searched about the problem and found some information about PlayProtect and certified devices. It seems that recently Google started not recognizing Custom ROMs as 'certified devices'.
I followed this steps from here (with Device ID and registering the GSF) but it still didn't work.

Is anybody having problems with this? Should we try the alternatives to Gapps?

Thanks!
Hey! I'm glad that you enjoy our ROM!

Thanks for reporting this error.
When I read your message I noticed the same was happening to me. I could not login to any Google account from both GAPPs or from any other app, like browsers. It was like Google refused to log I'm because a security issue.
Besides that, as I was already logged in with my main Google account, everything was working fine.
I updated GAPPs and the same was happening, but today I tried again to log in and it now allowed me to log in from both GAPPs and browsers. Play Store still detects the device as an unauthorized device, but it looks like Google now allows our device to log in again because a change in its servers.
I'm not sure if this problem was an issue that they have fixed or a temporary change in their login system which prevented us to log in because it was not passing Safety Net or because it was unauthorized.

So you may try again to log in and now it could work as before.

Thanks again for reporting and regards.
 
Last edited:
Apr 3, 2018
6
2
0
Belo Horizonte
Hey! I'm glad that you enjoy our ROM!

Thanks for reporting this error.
When I read your message I noticed the same was happening to me. I could not login to any Google account from both GAPPs or from any other app, like browsers. It was like Google refused to log I'm because a security issue.
Besides that, as I was already logged in with my main Google account, everything was working fine.
I updated GAPPs and the same was happening, but today I tried again to log in and it now allowed me to log in from both GAPPs and browsers. Play Store still detects the device as an unauthorized device, but it looks like Google now allows our device to log in again because a change in its servers.
I'm not sure if this problem was an issue that they have fixed or a temporary change in their login system which prevented us to log in because it was not passing Safety Net or because it was unauthorized.

So you may try again to log in and now it could work as before.

Thanks again for reporting and regards.
Alright!

Yes! I updated opengapps and now it works again!
Thank you very much!
 

guigui974

New member
Jan 27, 2021
1
1
1
Hello,
just a message to thank a lot @rmnhg and @infus38 for their work, this ROM works perfectly on my D2203. I was previously on a 4.4.4 18.5.C.0.19 tweaked stock ROM and I had to flash the stock bootloader with Flashtool prior to install the LineageOS zipfile (see infus38 message).
This ROM is smoother than the 4.4.4 tweaked one and I can install again apps which were not available for Android 4.4.4 from the store.
Thanks again for keeping my phone almost up to date !
 
  • Like
Reactions: infus38

AnonFilly

New member
Hi, I'm testing an Xperia E3 model is D2203 here since Tuesday, and that's a good occasion to test LineageOS on it, since i abhor Google as much as Apple. It's branded by Orange France but it's unlocked from all networks, put my simcard in which is from another operator, "free" (almost). So, it's rooted, unlocked and all. placed a few calls, all fine.

I tried to follow the OP's instructions the best I could so :
- put the LineageOS flamingo edition zip on a SD
- put the boot.bin and
>FAILED (remote: Command not allowed)
so I tried another method, using to flash it from Android itself using TeamWin's software, which is good, I admit.
>get it to flash
>success!
>reboot
>nothing happens no matter how I try to initialize it.

>Fastboot connection works so I'm trying my best by all means to flash it from a PC
>Xperia confirmed a brick

>sim card is back into my blackberry Q10.

Regardless, congrats for this port, still investigating what went wrong and why I get that communication error, might be a driver conflict, gonna test it all using my linux box, or at worse force drivers using Zadig on windows. voila, voila.
I'm surprised Sony even provides software and such drivers and unlocking methods for devs/FOSS stuff.

Edit : reverted to a stock flash. my biggest issue on many windows machines from XP to 10 so far remains the fastboot command returning "failed, command not allowed". I'll try other methods when I have time. I think I will try it all using flashtool.
 
Last edited:

infus38

Senior Member
Nov 28, 2015
271
444
103
Hello,
just a message to thank a lot @rmnhg and @infus38 for their work, this ROM works perfectly on my D2203. I was previously on a 4.4.4 18.5.C.0.19 tweaked stock ROM and I had to flash the stock bootloader with Flashtool prior to install the LineageOS zipfile (see infus38 message).
This ROM is smoother than the 4.4.4 tweaked one and I can install again apps which were not available for Android 4.4.4 from the store.
Thanks again for keeping my phone almost up to date !
Hey, just wanna say that we didn't left yukon (in fact we even booted tianchi and seagull on nougat as well few months ago) but giving time to this project along side of school ain't easy for us. Anyway, happy new year guys (kinda late lel)