• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

LineageOS 16.0 | 19.04.2020 | Shield blobs

Search This thread

rathoddeep

Member
Feb 15, 2020
6
0
Issue is not getting resolved. Facing the same.

- Tried updating the script of the version "lineage-16.0-20191206-UNOFFICIAL-mocha" there was only 1 line which had a "asset". I removed it and zipped it again to run.

- Tried downloading multiple files from different PC's, just to check if the one i have downloaded is not corrupted one.

No luck so far. Stucked at : Error 7

Updated pricess ended with error: 7
Error installing zip file '/sdcard/lineage-16.0-20191206-UNOFFICIAL-mocha.zip
Updating partition details.
..done.

:( any help ?

Still struggling and my tablet is dead since then. any help will be appreciated. Looking forward for it.
 

rathoddeep

Member
Feb 15, 2020
6
0
Make sure your device is charged. Keep pressing power button for at least 30 seconds,release it and just one time press the power button.Hope the device restarts.

my device is booting up, there is no issue with the same, however i am not able to install the rom. :( It gives me error 7, i tried renaming the script as well, but not luck.
 

b4imetu

New member
Feb 9, 2020
2
1
Got plans of LineageOS 17?

Hi! Have you got the plan to develop LineageOS 17.0 / 17.1?
I really appreciate your work and want it to go further.
btw, when will Stable LineageOS 16 with Video Playback Hardware Acceleration come out?
I will always check this site hoping to see your updates!:)
 

ghost45

Senior Member
Nov 10, 2012
1,481
1,148
[email protected]
@Artemka2008,
i have tried too many times to compile e decompile the lineage os to try to understand the reason why the camera is not working....but nothing!
I have made almost 10 roms with base os lineage....but everyone do not have access to the camera but inside seems everythings ok..camera app..libs..and so on...
Why? what is the mistake?
i think that in the framework there isn't an istruction to have access to the camera ....
the only one that run correctly is the 11/09/2018 ....
One question....how to add to this rom the patch to upgrade to the security level to 2019 almost...
thanks
 
Last edited:
  • Like
Reactions: txesterfield

kuag

Member
Jun 18, 2019
25
0

kuag

Member
Jun 18, 2019
25
0
Sound Crackling is a major issue, unable to use as a media consumption device, however display artifacts can be corrected by using hw overlay in developer options, please do something about the sound please, thanks for the update ?
The sound problem has been solved

---------- Post added at 07:52 AM ---------- Previous post was at 06:56 AM ----------

the ROM was updated
The power consumption of watching video is twice that of 7.12
 

Arsenious

Member
May 26, 2016
47
13
Installation succeeds but fails to boot.

HI, I followed the instructions to the word, merged partitions, installed tos and recovery linked, then installed the ROM and gapps. The install succeeds for both gapps and rom and I cleared dalvik after gapps and reboot to system. LIneage boot animation shows but then tab crashes to power off state. What should I do now @Artemka2008?
P.S I didnt get option of choosing primary partition as 1 and I didnt flash shieldblobs as this rom is after nov 2018.

EDIT: Got it to boot with a workaround. Installed the 2019 release then dirty flashed this march release over it. Booted all fine but got a couple of warnings that build is signed with public keys and SElinus is not enforcing. Will update about performance. Anyway thanks for the work on the ROM!
 
Last edited:

Arsenious

Member
May 26, 2016
47
13
Getting Error Code 7 while installing on Mi Pad. Don't want to change the update-script. Any particular reason, its giving a compatibility check failure for Mi Pad? Additionally, zip verification while, installing is failing as well. Would appreciate a quick response, thanks!!!

You will get the error 7 if you use any other TWRP recovery version even if its for Mi Pad. Just use what OP has linked and you wont get the error. I was stuck on this error too because I was using the latest 3.3.1.0. and not what OP linked.

---------- Post added at 05:02 AM ---------- Previous post was at 04:39 AM ----------

I had previously installed 14.1 and this one works just similar to it, doesn't feel much like I'm using a newer android version. But I do appreciate the effort that goes into keeping our Mi Pads alive and I thank everyone who work on it.:good:
I'll list my experience so far -
1. There is weird screen artifacting issue which can be "patched" by ticking the "disable HW overlay" option in Dev Settings. Its manageable but the settings resets itself with every reboot so will have to use tasker I guess.

2. Screen brightness is quite low for resolution of the screen but its same for all shield blob ROMs.

3. Trebuchet needs a revamp/overhaul. Its still stuck in the Nougat age and theres no "feel" of using a Pie ROM except the settings menu. I installed LAWNchair for the time being and running on pico Gapps.

4. Wifi signal strength needs to be checked, its usually 1 bar lower than other devices in the house and bluetooth stutters while using along wifi say watching youtube. It even disconnected once when I was playing a game. :confused:

5. Yes, the battery life is low, needs work.

6. I don't usually use the speakers much but I've seen the Dirac sound option in Pixel Experience roms helps quite a bit, maybe could port that feature into here :)

Okay I've said enough xD.
 

dekar92

New member
Mar 27, 2020
1
0
For those who are having issues installing the rom and getting error 7 try this:
- put the rom zip in the device
- extract only the boot.img and put it in the device
- go to twrp
- install - image - boot.img - as boot
- reboot to twrp again
- wipe to factory reset
- install rom zip
- cry of joy :_)
 

sinjurocks

New member
Apr 27, 2015
1
0
Pls help

My banking app says my system is rooted and cant proceed, may be as this is a testing rom . Any methods to byepass and use the app ? Pls help:(
 

coolman1234

Member
Jul 16, 2019
16
5
Thank you for the rom! Thanks to you she lives on.

---------- Post added at 01:59 PM ---------- Previous post was at 01:49 PM ----------

I have some pbs in my game (freeze). I go to option developer and i put on the option Désactiver superpos.mater. After that no freeze in my game. all is good.
 
  • Like
Reactions: jean marc

Top Liked Posts

  • There are no posts matching your filters.
  • 34
    LineageOS 16.0

    Requirements:
    1) active system1
    2) merged system partition
    3) BRAIN, READING SKILL and presence of basic knowledge about firmware (in the absence need learn to independently)

    Instruction
    1) download TosForPSCI-0.1.zip
    2) unzip TosForPSCI-0.1.zip
    3) download recovery-03.11.2018
    4) go to fastboot mode
    5) execute command: fastboot flash tos your path to tos.img
    6) execute command: fastboot flash recovery your path to recovery-03.11.2018.img
    7) reboot to new recovery(u can execute fastboot reboot holding vol+ button)
    8) if you are on previous LineageOS 16.0 build then you may install the ROM without wipes. If you're not, make full wipes then
    9) install current LineageOS 16.0 build
    10) reboot to the system

    Sources
    Device
    Kernel
    Vendor

    Changelogs

    19.04.2020

    system:
    - the latest security patch
    - fixed graphical glitches
    - minor fixes

    22.03.2020

    system:
    - the latest security patch
    - fixed Vulkan
    - fixed OMX
    - fixed UI microlags(it may cause graphical glitches)

    07.12.2019

    The first public build



    Broken:
    - Cameras

    Download:
    ROM folder
    Last build

    XDA:DevDB Information
    LineageOS 16.0, ROM for the Xiaomi Mi Pad

    Contributors
    Artemka2008
    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.10.x

    Version Information
    Status: Testing

    Created 2019-12-07
    Last Updated 2020-04-19
    13
    the ROM was updated
    12
    the ROM was updated
    3
    You're THE man!
    Wonderful help!

    What about help concept on forums?!?
    Friend...go to Google to find some cats memes, it's better than your presence here! [emoji12][emoji8]

    Inviato dal mio MI 9 utilizzando Tapatalk

    Your first attempt should be to google a problem, if you can't find the solution then ask in a forum. That's what forum is for.