LineageOS 16.0 Android 9 for GT-N8000 GT-N8010 GT-N8013 GT-N8020 FINAL VERSION EOL

Search This thread


Senior Member
May 2, 2020
hi thanks for all you do for our old samsung tablet; I installed lineage os 16 in the n8000 version and the battery does not last at all, I leave it at 100% at night and off the next day it is at zero, to someone who can tell me if it is solved in some way. The battery worked well before so I rule out that this is the one that is failing. Thanks and sorry for the google translation, although in my English it would be worse.
I have the same issue. Html6405 said he is working on a fix, hopefully it gets fixed soon! 🙂
  • Like
Reactions: c-ale


Senior Member
Nov 23, 2005
weird... I have n8000 but I dont see that problem on my tablet. the only problem that I see with it is the charging bar when the tablet is shutdown during the charging...


Senior Member
May 2, 2020
I discovered something about that battery drainage issue. It would seem adding a Sim card and then use it properly after that remove it. And poof the battery drainage issue is gone somehow? Thought I should write this down in case it's helpful for fixing this bug.


Jun 26, 2021
Descubrí algo sobre el problema del drenaje de la batería. Parecería agregar una tarjeta SIM y luego usarla correctamente después de eso, retírela. ¿Y poof, el problema del drenaje de la batería se ha ido de alguna manera? Pensé que debería escribir esto en caso de que sea útil para solucionar este error.
Gracias, intentaré ver si funciona

Gelson Silva

New member
Jul 12, 2021
Samsung Galaxy Note 10.1
O meu instalou a ROM de boa pelo TWRP, mas não consigo instalar os GAPPS, sempre da o ERRO 20, alguém consegue me ajudar?

Translation: Mine installed the ROM good by TWRP, but I can't install the GAPPS, always the ERROR 20, can anyone help me?
Last edited by a moderator:


Senior Member
Sep 28, 2007
Moto G 5G
Like HTML6405 said, wipe everything, Install the ROM, then before rebooting, install the gapps, and then reboot. This combination works. Do not put the multiple zips to flash together. Do not reboot between the ROM and the gapps.


Recognized Developer
I have an N8013, and I have no access to the internal storage.

Anyone else have this issue and know of a fix?

Edit: Fresh install latest build of LOS 16 BTW. I used the latest TWRP and Latest Magisk as well.
Maybe a selinux rule is missing, it alway's would be good to provide me a log, otherwise I can't fix it.


Recognized Developer
Hi html6405,
You are probably busy with new update for the rom but I was wondering can this "dual-boot" rom thingy work with this rom and Android 11 Rom or Android Revolution HD? And if it does, will updates for the roms broke it? If you can look at 'em and figure it out, that would be awesome!
I don't know, I was never playing around with a dual boot patcher, but I only know that a user is doing this with LOS16 succesfully.
It could be, that you have to modify much by your own.

Sep 9, 2019
Hi, I installed 23th april version on my NT8000. It works well (@html6405 good job!) but some videos shown via browser (e.g. Chrome) or certain apps (e.g. Discovery+) after a few seconds appear on a green background and with big "square boxes"



There are software decoding issues with for example decoder and YV12 pixel format,
this could be hwcomposer related, I can't fix this yet.

Hi, is there any way I can help you to fix this problem? It's really annoying.. :-(



Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @html6405 Thank you for excellent job! Lineage 16.0 works fantastic on my N8010! I flashed it myself for the first time and everything works better then expected, stable and fluid.
    Just wanted to tell the others who are interested that the device is fast with (original) battery lasting for hours of video. The device shows that it is certified. YouTube works, Netflix and HBO MAX also. I have downloaded Sketchbook and FlipaClip to try S-pen and it works without problem. Regarding stream TV video apps I have noticed that some channels have broken picture if the battery is on the power saving mode.
    The only problem I have encountered so far is that some channels at our local TV streaming app MAXTV2GO (developed by T-com) have broken picture, like the tiles with horizontal lines (probably some codec issues?). Other channles on the same app work fine, and the third work good if the battery saving mode is turned off...
    Hi all
    Having problems trying to flash Magisk 26.1. No matter if I flash from TWRP or if I patch the boot.img, and then flash boot.img, no success.
    Is there any problem with Magisk and this ROM?
    Thank you
    yeah u gotta install this kernel that @html6405 made

    just flash in twrp
    The kernel suggested seems not compatible with my device (GT.N8020)
    Any suggestion?
    oh, i think there was an older version in the thread for gt-n8020 but the headphone jack wasnt working

    if you dont want a new kernel you could install magisk 24.1
    oh, i think there was an older version in the thread for gt-n8020 but the headphone jack wasnt working

    if you dont want a new kernel you could install magisk 24.1

    Do not waste time with this, but if you manage to remember which was the thread, I will be grateful. Meanwhile, I think I will be able to manage using 24.1
  • 65
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    here you can find my LineageOS 16.0 for the Samsung Galaxy Note 10.1.
    At first I want to thank @forkbomb444, @rINanDO, @ChronoMonochrome and all the others who are working on the exynos 4 devices, you deserve it.

    I'm working nearly every day to improve our N80xx devices and here you get a already stable version.

    Here you can see what's working / not working:

    N8000, N8010, N8013, N8020:
    Video playback (HW/SW)
    OTA Updates
    RIL N8000, N8020
    GPS, not sure if completely
    Tethering via USB, WIFI and Bluetooth
    consumerir transmitter
    • Main camera sometimes can't take a picture in full resolution, you could simply reopen the app and retry, or you lower the resolution.

    N8000 Rom
    N8010 / N8013 Rom
    N8020 Rom

    If you're having problems with decoding some videos (blurried),
    this is mostly because the avc hardware decoder gets configured wrongly.

    You can disable it with my magisk module:

    If you are going to use Gapps,
    I recommend to use the pico package!
    For the others, you can use microG if you want, I've enabled signature spoofing.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.


    If you don't like it, reboot into recovery and type the following command:
    You could use a gps.conf from for your location and replace /system/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.

    Wanna improve your sound configs?
    Now you can use my app to access all boeffla sound configurations.

    XDA:DevDB Information
    [ROM][9.x][N8000/N801x/N8020][STABLE] LineageOS 16.0, ROM for the Samsung Galaxy Note 10.1

    Source Code:

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.3.0
    Based On: LineageOS

    Version Information
    Release Date: 2020-12-15

    Created 2020-10-26
    Last Updated 2022-04-20
    Update 15.12.2020:
    • programmed button in language and input settings to enable / disable pointer icon.
      (like we had it in previous lineage versions)
    • replaced icon with original smaller one from stock rom
    Only via OTA.
    Update 07.12.2020:
    • included 60Hz camera parameter
    • fixed screen cast
    • partly reverted Nov. 24th update, hope that the charging bug is gone now
    • improved auto brightness
    • included GPS fix improvement suggestion in initial post
    Hey, I just installed this to n8005 and you saved me from buying a new tablet. It works beyond my expectations. This is 8+ years old device after all. You are also helping environment too. Companies should do what you are doing instead of removing chargers to protect the environment. You seriously deserve donation. Have a nice day
    I'm sorry people,
    because I've created a new domain wifi related,
    it made some existing rules uneffective.

    I'm working hard to run selinux without any neverallow rules (I'm nearly there) to provide the best security.

    To get wifi working again, type with your PC or terminal emulator:

    adb shell (only with PC)
    setenforce 0

    and wifi will work again, there will be another update today with the new fixes.