LineageOS 16.0 Android 9 for GT-N8000 GT-N8010 GT-N8013 GT-N8020 FINAL VERSION EOL

Search This thread


Aug 17, 2021
If you have bitgapps installed, OTA(over the air) system updates are broken. If you install a system update with bitgapps, it will not work and you need to clean reflash (wipe and flash) the whole ROM . It is already mentioned by @html6405 before.
what then would allow wifi to work on my device? i remember trying other gapps and wifi never worked....and i need this update cos stylus pointer is removed.


Recognized Developer


Aug 17, 2021
The stylus pointer is not removed in this update, the possibility to disable it exists already for a long time.

Really? If you're flashing gapps then your wifi is lost?

A logcat would be great, you could use the syslog app to extract it.
My bad, guys . I just realised that their are later updates below on the download link page....was using the initial release.....flashed the latest update (not OTA) with pico....and its all good
  • Like
Reactions: LR7875


Apr 7, 2020
20210810 can't download to internal storage? Prompts for SD card. Is there an option to use internal? Blue button does nothing.thanks


  • Screenshot_20210823-221922_Chrome.png
    115.2 KB · Views: 26


Apr 7, 2020
Storage is checked. But when you hit the 3 dots and go to all permissions, under storage there is read the contents of your sd card/ modify or delete the contents of your sd card.


Dec 9, 2010
I am unable to install microsoft edge browser from playstore error says not compatable with this version of android does anyone have any idea why.


Recognized Developer
Sorry. Will the actual reason be that google play version Microsoft edge supports arm64 64bit operating system only? Our tab is 32 bit processor.
I have heard news like google play store forcing app developer to use only 64 bit before.
Some person already asked for this, I think that he was able to sideload the apk, I don't know what's the reason on google play store.
Sorry. Will the actual reason be that google play version Microsoft edge supports arm64 64bit operating system only? Our tab is 32 bit processor.
I have heard news like google play store forcing app developer to use only 64 bit before.
Instead of using Edge Browser (aka Microsoft spyware) perhaps you should try out Vivaldi. It has more features like adblocking and theming, and it supports 32 bit devices.
  • Wow
Reactions: LR7875

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    @html6405 Thank you for excellent job! Lineage 16.0 works fantastic on my N8010! I flashed it myself for the first time and everything works better then expected, stable and fluid.
    Just wanted to tell the others who are interested that the device is fast with (original) battery lasting for hours of video. The device shows that it is certified. YouTube works, Netflix and HBO MAX also. I have downloaded Sketchbook and FlipaClip to try S-pen and it works without problem. Regarding stream TV video apps I have noticed that some channels have broken picture if the battery is on the power saving mode.
    The only problem I have encountered so far is that some channels at our local TV streaming app MAXTV2GO (developed by T-com) have broken picture, like the tiles with horizontal lines (probably some codec issues?). Other channles on the same app work fine, and the third work good if the battery saving mode is turned off...
    Hi all
    Having problems trying to flash Magisk 26.1. No matter if I flash from TWRP or if I patch the boot.img, and then flash boot.img, no success.
    Is there any problem with Magisk and this ROM?
    Thank you
    yeah u gotta install this kernel that @html6405 made

    just flash in twrp
    The kernel suggested seems not compatible with my device (GT.N8020)
    Any suggestion?
    oh, i think there was an older version in the thread for gt-n8020 but the headphone jack wasnt working

    if you dont want a new kernel you could install magisk 24.1
    oh, i think there was an older version in the thread for gt-n8020 but the headphone jack wasnt working

    if you dont want a new kernel you could install magisk 24.1

    Do not waste time with this, but if you manage to remember which was the thread, I will be grateful. Meanwhile, I think I will be able to manage using 24.1
    Hello, I have the same problem, I have loaded the modem.tar without being able to solve it, I tried going back to the version of the original operating system of the tablet and the card works fine and reads the imei of the tablet without problem,
    I also tried to install the different versions of lineage os that there are for the N8000 and the same thing happens with all of them, so I stopped trying and only use it connected to Wi-Fi.
    Once i flashed N8000 rom to my N8000 tablet. Never tried the sim card because 3G network was terminated by govt.

    But then my device gets very hot on standard usage. Log shows that the sim slot is continously searching for signal even the sim card is not loaded.

    OP then suggests me to flash N8010 TWRP and then flash N8010 rom to my N8000. All went good.
  • 65
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    here you can find my LineageOS 16.0 for the Samsung Galaxy Note 10.1.
    At first I want to thank @forkbomb444, @rINanDO, @ChronoMonochrome and all the others who are working on the exynos 4 devices, you deserve it.

    I'm working nearly every day to improve our N80xx devices and here you get a already stable version.

    Here you can see what's working / not working:

    N8000, N8010, N8013, N8020:
    Video playback (HW/SW)
    OTA Updates
    RIL N8000, N8020
    GPS, not sure if completely
    Tethering via USB, WIFI and Bluetooth
    consumerir transmitter
    • Main camera sometimes can't take a picture in full resolution, you could simply reopen the app and retry, or you lower the resolution.

    N8000 Rom
    N8010 / N8013 Rom
    N8020 Rom

    If you're having problems with decoding some videos (blurried),
    this is mostly because the avc hardware decoder gets configured wrongly.

    You can disable it with my magisk module:

    If you are going to use Gapps,
    I recommend to use the pico package!
    For the others, you can use microG if you want, I've enabled signature spoofing.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.


    If you don't like it, reboot into recovery and type the following command:
    You could use a gps.conf from for your location and replace /system/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.

    Wanna improve your sound configs?
    Now you can use my app to access all boeffla sound configurations.

    XDA:DevDB Information
    [ROM][9.x][N8000/N801x/N8020][STABLE] LineageOS 16.0, ROM for the Samsung Galaxy Note 10.1

    Source Code:

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.3.0
    Based On: LineageOS

    Version Information
    Release Date: 2020-12-15

    Created 2020-10-26
    Last Updated 2022-04-20
    Update 15.12.2020:
    • programmed button in language and input settings to enable / disable pointer icon.
      (like we had it in previous lineage versions)
    • replaced icon with original smaller one from stock rom
    Only via OTA.
    Update 07.12.2020:
    • included 60Hz camera parameter
    • fixed screen cast
    • partly reverted Nov. 24th update, hope that the charging bug is gone now
    • improved auto brightness
    • included GPS fix improvement suggestion in initial post
    Hey, I just installed this to n8005 and you saved me from buying a new tablet. It works beyond my expectations. This is 8+ years old device after all. You are also helping environment too. Companies should do what you are doing instead of removing chargers to protect the environment. You seriously deserve donation. Have a nice day
    I'm sorry people,
    because I've created a new domain wifi related,
    it made some existing rules uneffective.

    I'm working hard to run selinux without any neverallow rules (I'm nearly there) to provide the best security.

    To get wifi working again, type with your PC or terminal emulator:

    adb shell (only with PC)
    setenforce 0

    and wifi will work again, there will be another update today with the new fixes.