• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LineageOS 16.0 Android 9 for GT-N8000 GT-N8010 GT-N8013 GT-N8020

Search This thread


Recognized Developer
Jan 15, 2016
For RAM it's probably better to tweak LMK, because Z-RAM kills performance.
I'm with you on that, you know what, I will remove the swap on my device and test it with high RAM consuming apps etc.
If it will pass, I will remove it for all.
I just have to take care whats best for all users.
Last edited:
I had the best stability with pegagsusq in my tests.

I had a really bad battery experience with ondemand, but everybody can change the default governour with kernel aduiator for example.

This is why I've set the value to 16000 MHz.

I had this in the early stages, but people wanted that I unlock higher frequencies.
Some devices run more stable with higher values, some not, I wouldn't recommend it.

Well, people claimed because of running out of RAM and I had many last_kmsg's because of that, it was necessary, maybe not for everybody, but for most.
Maybe we would be safe if I set the device to low_ram, but then some functions would be missing like pip,
multiuser support etc.
It's not easy to make a ROM perfect for everybody ;).

For this you will have to modify the ramdisk and delete

swapon_all /fstab.smdk4x12

in the init.target.rc.

Also, you could delete the

line in the fstab.
Modifying these files in FX File Manager with root did not work.
The ****ty settings return upon reboot.

Having to fork the ROM to fix it would suck on my 3 mbps or worse internet.


Recognized Developer
Jan 15, 2016
I've tested the device now without swap and if I filled the RAM up, it become partly unresponsive.
As a workaround, I've set the swappiness to the minimum, doesn't look so bad with that.
RAM usage is very low, but my device is almost always unresponsive with Z-RAM enabled, 100 swapiness, pegasusq. CPU is often at high usage as well. The worst stutters occur when attempting to switch apps. Battery drains pretty quick too.

With swapiness at 20, it's much more responsive... but still lags and stutters a lot, and that's also with the performance governor and deadline set instead of cfq (cfq is fine but i prefer deadline, since it gives more performance), and a more aggressive LMK.

Setting LMK more aggressive keeps the RAM from filling up as much, and also keeps more resources freed up for the CPU. Less programs running, less CPU usage.

Pretty much any device would become somewhat unresponsive if the RAM is filled, but having to constantly compress and decompress software (especially with an older weaker CPU like we have) will result in more stutters, even in general use.


  • Screenshot_20211028-083642_Settings.png
    34.3 KB · Views: 22


Senior Member
Mar 11, 2012
hello friend,
i installed "twrp-3.5.0_9-0-n8000.img" with odin, then facotry reset with your insturoduction install "lineage-16.0-20211007-HTML6405-n8000" and Gapps "open_gapps-arm-9.0-pico-20211028" and i got google play force close.
im triyed to insall Gmicro and apk of google strore and its same..


Recognized Developer
Jan 15, 2016
hello friend,
i installed "twrp-3.5.0_9-0-n8000.img" with odin, then facotry reset with your insturoduction install "lineage-16.0-20211007-HTML6405-n8000" and Gapps "open_gapps-arm-9.0-pico-20211028" and i got google play force close.
im triyed to insall Gmicro and apk of google strore and its same..
Restart from zero (do also the wipes) and try an older gapps package, some people reported problems with the most recent version.
  • Like
Reactions: gtrs36


Mar 16, 2013
I've been running this firmware for a few weeks now and it works very well. There is one issue that I keep running into. I use the tablet for music and use a Bluetooth page turning pedal that sends keystrokes when a button is pressed. It pairs fine and turns the pages in my music app as expected. After a music session (often two or more hours) I turn the pedal off and recharge the tablet.

When I next go to use the pedal, the tablet claims the pedal is connected but keystrokes aren't reaching the app. I have to forget the pedal and pair again to get things working. With the old stock (4.4.2) firmware, the pedal reconnected correctly each time.

Any thoughts?


Mar 16, 2013
I tried all of those before I resorted to forgetting the device and repairing. Just to check, I tried these ideas again but no change.

One thing I noticed is that, even though the tablet says the pedal is connected, the two little dots that usually appear one each side of the BT symbol when a device is connected are not displayed. If I forget and repair, the dots appear as expected. After disconnecting by either turning the pedal or the BT off, it's back in the state where it says it's connected but isn't really.


Recognized Developer
Jan 15, 2016
If I forget and repair, the dots appear as expected. After disconnecting by either turning the pedal or the BT off, it's back in the state where it says it's connected but isn't really.
Hmm ok, I will try to check if my device is reconnecting BT devices and maybe I can find the reason.

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Does the S-pen works? N8020?
    Hello, is there a way how to turn off the mouse pointer acceleration?
    No, only the S-Pen hovering, but I will replace the mouse pointer with the S-Pen icon in the next update.
    format as portable storage !
    Hello, I´ve been using this ROM on several GT-N8010s for few days and so far it has been very reliable. I have, however, found a bug which I tested on all three devices with this system - when I charge the device and it is turned off I cannot switch it on and use it. It just shows the icon of charging but won´t boot the system unless I unplug it. Not a big deal, I can always charge it at night, then unplug and use, or charge while using it. Thanks anyway for a great job!
    Peguei um Sandisk e tava tentando adicionar arquivos via janela esquecendo que não era compatível etc

    Então formatei a unidade usando FAT32 e coloquei de volta no Tablet, mas não consigo ver nas configurações. Além disso, quando eu abro as configurações de armazenamento, ele continua travando. dizendo que as configurações continuam parando

    estava funcionando antes de eu ter esse cérebro peido, mas não consigo fazer a mesa pegar as cartas?

    Eu quero adicionar arquivos do PC ao SanDisk no tablet, mas como posso fazer com que o Tablet reconheça o sandisk agora ou alguma sugestão

    Formats in exFAT, mine worked like that.
    Went into settings and storage and forget SD card and could now access it
    I'm not sure what the problem was exactly, maybe you've formated the sd card as a storage expansion the first time?
  • 42
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    here you can find my LineageOS 16.0 for the Samsung Galaxy Note 10.1.
    At first I want to thank @forkbomb444, @rINanDO, @ChronoMonochrome and all the others who are working on the exynos 4 devices, you deserve it.

    I'm working nearly every day to improve our N80xx devices and here you get a already stable version.

    Here you can see what's working / not working:

    N8000, N8010, N8013, N8020:
    Video playback (HW/SW)
    OTA Updates
    RIL N8000, N8020
    GPS, not sure if completely
    Tethering via USB, WIFI and Bluetooth
    consumerir transmitter
    • Main camera sometimes can't take a picture in full resolution, you could simply reopen the app and retry, or you lower the resolution.
    • GPS sometimes looses the sattelites, after this error occur's reopen completely your navigation app.

    If you are going to use Gapps,
    I recommend to use the pico package!
    For the others, you can use microG if you want, I've enabled signature spoofing.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.


    You could use a gps.conf from https://app.box.com/s/w57s1v1n3hie7l5lk28i for your location and replace /system/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.
    XDA:DevDB Information
    [ROM][9.x][N8000/N801x/N8020][STABLE] LineageOS 16.0, ROM for the Samsung Galaxy Note 10.1

    Source Code: https://github.com/html6405

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.3.0
    Based On: LineageOS

    Version Information
    Release Date: 2020-12-15

    Created 2020-10-26
    Last Updated 2021-10-07
    Update 15.12.2020:
    • programmed button in language and input settings to enable / disable pointer icon.
      (like we had it in previous lineage versions)
    • replaced icon with original smaller one from stock rom
    Only via OTA.
    Update 07.12.2020:
    • included 60Hz camera parameter
    • fixed screen cast
    • partly reverted Nov. 24th update, hope that the charging bug is gone now
    • improved auto brightness
    • included GPS fix improvement suggestion in initial post
    Hey, I just installed this to n8005 and you saved me from buying a new tablet. It works beyond my expectations. This is 8+ years old device after all. You are also helping environment too. Companies should do what you are doing instead of removing chargers to protect the environment. You seriously deserve donation. Have a nice day
    I'm sorry people,
    because I've created a new domain wifi related,
    it made some existing rules uneffective.

    I'm working hard to run selinux without any neverallow rules (I'm nearly there) to provide the best security.

    To get wifi working again, type with your PC or terminal emulator:

    adb shell (only with PC)
    setenforce 0

    and wifi will work again, there will be another update today with the new fixes.