• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LineageOS 18.1 [R] [11] (Unofficial) Mi Pad 4 Plus (clover)

Search This thread

Wizballs

Senior Member
Nov 15, 2011
138
81
Brisbane
Try to edit build.prop :
Remove path vendor.rild.libpath (vendor.rild.libpath=/vendor/lib64/libril-qc-hal-qmi.so -> vendor.rild.libpath=)

And also add this line :
ro.carrier=wifi-only
ro.radio.noril=true
I added the ro.carrier & ro.radio lines, and there is no vendor.rild.libpath entry. Still getting these entries in the log tho (repeats over and over):
Happy to try any suggestions - thanks. And can post any other logs if anyone wants.

dmesg:
[ 74.627267] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 74.847777] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 75.623563] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 75.851212] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 76.625841] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 76.852324] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 77.629948] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 77.851352] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.102022] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.104028] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.633037] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 79.109133] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 79.635664] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 80.111131] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 80.638295] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 81.116825] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 81.640170] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 82.118574] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)

logcat
08-12 06:21:36.242 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:36.712 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:36.714 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:36.714 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:36.717 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:36.717 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
08-12 06:21:37.238 W/HidlServiceManagement( 2265): Waited one second for [email protected]::IRadio/slot1
08-12 06:21:37.239 I/hwservicemanager( 607): Since [email protected]::IRadio/slot1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:37.240 I/HidlServiceManagement( 2265): getService: Trying again for [email protected]::IRadio/slot1...
08-12 06:21:37.244 E/init ( 0): Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:37.244 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:37.716 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:37.717 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:37.718 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:37.722 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:37.723 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
08-12 06:21:38.240 W/HidlServiceManagement( 2265): Waited one second for [email protected]::IRadio/slot1
08-12 06:21:38.241 I/hwservicemanager( 607): Since [email protected]::IRadio/slot1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:38.242 I/HidlServiceManagement( 2265): getService: Trying again for [email protected]::IRadio/slot1...
08-12 06:21:38.246 E/init ( 0): Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:38.246 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:38.720 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:38.721 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:38.722 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:38.724 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:38.725 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
0
 

hydelezz

Senior Member
Oct 2, 2017
58
19
My Mi pad 4 plus get bootloop from latest build (ten times success), OTG not working tho.
 

sabar_op

Senior Member
Jun 30, 2010
302
624
Xiaomi Mi Pad 4 Plus
I added the ro.carrier & ro.radio lines, and there is no vendor.rild.libpath entry. Still getting these entries in the log tho (repeats over and over):
Happy to try any suggestions - thanks. And can post any other logs if anyone wants.

dmesg:
[ 74.627267] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 74.847777] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 75.623563] init: Control message: Could not find 'android.har[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 75.851212] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 76.625841] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 76.852324] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 77.629948] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 77.851352] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.102022] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.104028] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 78.633037] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 79.109133] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 79.635664] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 80.111131] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 80.638295] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 81.116825] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 81.640170] init: Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
[ 82.118574] init: Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)

logcat
08-12 06:21:36.242 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:36.712 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:36.714 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:36.714 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:36.717 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:36.717 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
08-12 06:21:37.238 W/HidlServiceManagement( 2265): Waited one second for [email protected]::IRadio/slot1
08-12 06:21:37.239 I/hwservicemanager( 607): Since [email protected]::IRadio/slot1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:37.240 I/HidlServiceManagement( 2265): getService: Trying again for [email protected]::IRadio/slot1...
08-12 06:21:37.244 E/init ( 0): Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:37.244 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:37.716 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:37.717 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:37.718 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:37.722 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:37.723 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
08-12 06:21:38.240 W/HidlServiceManagement( 2265): Waited one second for [email protected]::IRadio/slot1
08-12 06:21:38.241 I/hwservicemanager( 607): Since [email protected]::IRadio/slot1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:38.242 I/HidlServiceManagement( 2265): getService: Trying again for [email protected]::IRadio/slot1...
08-12 06:21:38.246 E/init ( 0): Control message: Could not find '[email protected]::IRadio/slot1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:38.246 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::IRadio/slot1": error code: 0x20
08-12 06:21:38.720 W/HidlServiceManagement( 4208): Waited one second for [email protected]::ISecureElement/SIM1
08-12 06:21:38.721 I/hwservicemanager( 607): Since [email protected]::ISecureElement/SIM1 is not registered, trying to start it as a lazy HAL.
08-12 06:21:38.722 I/HidlServiceManagement( 4208): getService: Trying again for [email protected]::ISecureElement/SIM1...
08-12 06:21:38.724 E/init ( 0): Control message: Could not find '[email protected]::ISecureElement/SIM1' for ctl.interface_start from pid: 607 (/system/bin/hwservicemanager)
08-12 06:21:38.725 W/libc ( 607): Unable to set property "ctl.interface_start" to "[email protected]::ISecureElement/SIM1": error code: 0x20
0

Try to add and edit it in build.prop of vendor partition/folder.
 
  • Like
Reactions: Wizballs
Jun 17, 2021
34
2
Please detail what you found. Ambiguous comments make it difficult to replicate, and also potentially highlight something bad that is not necessarily there.
I did detail in post #707.anyway: after clean install (as I do with all ROMs that I test) I scanned with Avast and Malwarebyte software.
Avast found a malware on a sistem app: "Provider Certificate System"
 

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Update new rom lineage-18.1-20211102-UNOFFICIAL-clover-eas.zip with changelog :
    - October security patch
    - remove miui cam to get rom working without gapps.

    Note : it need to remove miui cam apk from existing installed rom before installing this rom to get working or the easy ways is format data before flash this rom.


    I put separate thread for LineageOS 19
    3
    All works fine except night light and reading mode.

    Will check it later, need to go back to 18.1.
    2
    I have the latest update installed, everything works fine except the night light and the reading mode. Are you going to continue updating this version to fix these bugs or are you going to focus on version 19.0? Thank you!!

    Managed to dirty flash to this over the Sept release. Everything is work fine except I lost the night light no matter if I turn it on or off manual, the screen will remain as without night light.

    Any idea what is going on?

    The only change Sept -> Oct is removing miui camera and upstream update of lineage source.
    It may because of lineage source update, can someone try to use permissive and rooted kernel and check it whether those issue is working? And send me the log please? I can't check it as my device is running android 12...need to backup, format and restore data to downgrade to android 11, and I have no time to do it...
    2
    Just to be sure:
    I definitely have to remove miui cam apk bevore installing the new rom EVEN if I want to use gapps? Or is it possible to flash without removing miui cam and installing gapps the way it was before this build?

    Yes...you have to do it otherwise there will be some issue in the snap cam.
    2
    I did a dirty flash over September and so far it is all fine for the things I do.
  • 31
    LineageOS 18.1, see this link

    Installation instructions :
    - Download the zip(s).
    - Install latest TWRP for clover
    - Perform a backup of your current ROM (optional)
    - Wipe dalvik/cache (upgrade from lineageos 18.1) and wipe system/data if upgrade from other rom.
    - Flash ROM.
    - Flash GApps (NikGApps is recommended) is a must.
    - Optional: Flash latest Magisk for root.

    Everything should work.

    Source :
    sdm660
    17
    New update : lineage-18.1-20210412-UNOFFICIAL-clover.zip. see 1st post for the link.
    - April build security patch
    - EAS kernel integrated (fingerprint and touchscreen looks ok).
    - Update blobs gps, wfd, ril, and wifi.
    - Safetynet fix integration and change fingerprint to clover. Thanks to @pndwal
    - etc (see common tree in sdm660 source).
    15
    New update for LOS18.1 and PE11 dated on 20210312 (see 1st post for the link) with March security patch.
    14
    New update : see 1st post for the link
    - September security patch.
    - Add support for app signature spoofing (not tested).

    I also upload new kernel 4.4.283 for anyone who want to try it.
    13
    FWIW, I've used MagiskHide Props Config Magisk module to change Xiaomi Mi 6X fingerprint (xiaomi/wayne/wayne:8.1.0/OPM1.171019.011/V9.5.11.0.ODCCNFA:user/release-keys) to Xiaomi Mi Pad 4 China (Xiaomi/clover/clover:8.1.0/OPM1.171019.019/V10.1.1.0.ODJCNFI:user/release-keys) from MHPC repo.

    Either value works fine to pass safetynet along with Universal SafetyNet Fix module. 👍 PW

    Yes...just try it and it pass the safetynet...and build new rom along with some updates in blobs and integrate it with EAS kernel...

    I am waiting update April security patch to release the rom.