• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LineageOS 18.1 [R] [11] (Unofficial) Mi Pad 4 Plus (clover)

Search This thread

kuskro

Senior Member
Sep 6, 2009
366
322
Anyone tried pairing a bluetooth keyboard to LOS 18.1?

The keyboard paired successfully to my phone and win10 laptop, but not Mipad4 Plus with LOS 18.1.

It connects but drops connection shortly after. Wonder if anyone has a fix?

Edit: The new keyboard has trackpad as well, wonder if it makes any diff
Mine is working good but it has not trackpad.
 

Kefwar

Member
Mar 9, 2018
5
0
I just managed to install 18.1 (20210807) without GApps (which I don't need or want) by going via a 17.1 clean install. So far it looks like everything is working, except encryption. If I try to enable it I get stuck in bootloop before it can even start the process, or so ut seems. I have also tried turning encryption on in 17.1 and then upgrading to 18.1, but it won't boot. After searching this thread, it looks like this is a known
issue. Are there any plans to get this issue resolved? For me at least, this is an important feature to avoid people getting the data if it is stolen.
@sabar_op could you perhaps have a look at this issue. I also get a bootloop when enabling encryption.
A clean installation of 18.1 with NikGApps core and Magisk installed.
 

rbn78

Member
Sep 3, 2021
7
2
Hello, i have install 18.1 (20210807) with NikGApps and without Magick.
I have a bootloop.... As I see in this forum I forget to patch the firmware.
Can i do it with TWRP and fw_clover_miui_MIPAD4_9.8.29_6647b25a58_8.1 ?
Or does I do with xiami tools ?
Thanks for your help.
PS : Nice job @sabar_op
 

GregEden

Senior Member
Feb 6, 2020
102
48
Melbourne
No effect . the boot is always unstable.
You do not need to patch firmware. If you have TWRP installed and functional then it should just work. But you do need the newest TWRP for Clover.
twrp-3.5.2_9-0-clover.img

 

jimmy123322

Senior Member
I'm not really understand whats the problem...as my prev post said that it's working in my device...
Or you can send the log after do that.
He means this gesture - https://drive.google.com/file/d/1FvUO94pC4O-5Nhh3rPN4PsSEF84-T3GN/view?usp=drivesdk

This gesture work in portrait orientation, but it doesn't work in landscape orientation. This gesture work good in previous android versions. But i think this is impossible to fix it in 11 version.

P.S. Can you demonstrate how this gesture works on your tablet? Of course if it's not hard for you. Thank you!
 
Last edited:

rbn78

Member
Sep 3, 2021
7
2
No effect . the boot is always unstable.f
You do not need to patch firmware. If you have TWRP installed and functional then it should just work. But you do need the newest TWRP for Clover.
twrp-3.5.2_9-0-clover.img

Thanks. I already have it....... Never mind, i save two versions (one is bootable, the may version) and re install if boot loop.
 
  • Like
Reactions: GregEden

Affana

New member
Nov 21, 2018
2
0
I downloaded LOS 18.1 (latest: august) and set selinux permissive for Dolby Atmos to work. But after setting the selinux to permissive the tablet is bootlooping. (Hint: if i put the charger on its booting normally). Is there any fix for permissive?
 

rbn78

Member
Sep 3, 2021
7
2
I confirm what I said : It is important to upgrade the Firmware.

For me : From 660_EN-PACK-1.186426.1.191687.1 to the last (see previous post) => It solve Bootloop and lot of trouble.

For interesting person, here is my method :
- From TWRP install the Chinese ROM and boot to it,
- Try to upgrade the firmware (failed in my case, no wifi and no firmware option)
- Flash again TWRP because the Chinese ROM erase the bootloader and boot to it
- Install the Firmware ZIP FILE (Here, i have a /data error but anyways the upgrade is good)
- Erase the internal storage and install Lineage OS.:giggle:

I try to restore an NANDROID backup of LineageOS but it always boot to the "FastBoot Mode".
If anyone succeed in, i am interesting.
 

rbn78

Member
Sep 3, 2021
7
2
I am starting to test your last Lineage OS ROM....

The finger print unlock the tablet (good) but no possible with bank app.

Also, I compare to my Samsung phone (android 11) where there is the option "facial recognition".
It is nice to unlock all just by opening the cover.
I don't find it (may be it is a mistake from me)

I will tell you if anymore....

PS : Except that, really nice ROM
 

Top Liked Posts

  • There are no posts matching your filters.
  • 14
    New update : see 1st post for the link
    - September security patch.
    - Add support for app signature spoofing (not tested).

    I also upload new kernel 4.4.283 for anyone who want to try it.
    11
    New update : 20210920 see 1st link for the download.

    Changelog :
    - update graphic and ril blobs
    - update thermal hal
    - update camera hal
    - experimental kernel using westcoast (seems stable). If facing issue, use prev kernel.
    - fix issue no ril (not tested)
    - update fstab to enable encryption (not tested)
    - others.
    4
    Dirty flash over August, clear cache/dalvik. Restart and no problems so far and Playstore is certified.
    thanks Sabar
    2
    Clean install and all works great on MI PAD 4 (not Plus)... installed GAPPS Pico and all great working flawlessly.

    Then I did however encountered a boot loop after enabling encryption. I saw other folks with same issue.
    Any clues of what this can be?

    Problem is that I cannot get out of it...

    I am using the latest TWRP 3.5.2 and still kinda stuck in boot loop... I did a backup of all partitions before the encryption and did a restore after that... no luck... then I wiped system partition > factory reset > davlik/cache and then installed again the latest 20210920 but I am still stuck at boot loop...

    Any ideas on how to get out of here? I have a backup of all partitions.
    Well I was able to fix the problem myself... was pretty tough!

    Had to install chinese version of MIUI ROM via Fastboot but because Fastboot was always rebooting it could not flash everything.. so Data partitions was not there... then create /data manually via fastboot and then reflashed LOS 18.1.... then restored the backup on /system and /data. Then I had to remove the lockscreen.db file since pin locking was not unlocking... was really painfull...

    All in all, encryption is not working and is a really pain to put back everything working again. I recommend not to put anything sensitive to your tablet as the files can be accessed via TWRP or even accessed via the tablet itself by removing the lockscreen.db file from /data/system... Is really unsafe to use the tablet in this situation.
    2
    When I installed Android 11, I can't post a video on Instagram, is there a solution?

    Have you try with Sept ROM?
    Send me the log.
  • 29
    LineageOS 18.1, see this link

    Installation instructions :
    - Download the zip(s).
    - Install latest TWRP for clover
    - Perform a backup of your current ROM (optional)
    - Wipe dalvik/cache (upgrade from lineageos 18.1) and wipe system/data if upgrade from other rom.
    - Flash ROM.
    - Flash GApps (NikGApps is recommended) is a must.
    - Optional: Flash latest Magisk for root.

    Everything should work.

    Source :
    sdm660
    17
    New update : lineage-18.1-20210412-UNOFFICIAL-clover.zip. see 1st post for the link.
    - April build security patch
    - EAS kernel integrated (fingerprint and touchscreen looks ok).
    - Update blobs gps, wfd, ril, and wifi.
    - Safetynet fix integration and change fingerprint to clover. Thanks to @pndwal
    - etc (see common tree in sdm660 source).
    15
    New update for LOS18.1 and PE11 dated on 20210312 (see 1st post for the link) with March security patch.
    14
    New update : see 1st post for the link
    - September security patch.
    - Add support for app signature spoofing (not tested).

    I also upload new kernel 4.4.283 for anyone who want to try it.
    13
    FWIW, I've used MagiskHide Props Config Magisk module to change Xiaomi Mi 6X fingerprint (xiaomi/wayne/wayne:8.1.0/OPM1.171019.011/V9.5.11.0.ODCCNFA:user/release-keys) to Xiaomi Mi Pad 4 China (Xiaomi/clover/clover:8.1.0/OPM1.171019.019/V10.1.1.0.ODJCNFI:user/release-keys) from MHPC repo.

    Either value works fine to pass safetynet along with Universal SafetyNet Fix module. 👍 PW

    Yes...just try it and it pass the safetynet...and build new rom along with some updates in blobs and integrate it with EAS kernel...

    I am waiting update April security patch to release the rom.