LineageOS 19.1 (Android 12L) for GT-N8000 GT-N8005 GT-N8010 GT-N8013 GT-N8020 BETA

Search This thread
1664417236553.png

this almost happen when i install LOS 16.0 - 18.1

but i dont have problem with LOS 14.1 20201217-HTML6405-n8010
by the way hi @html6405 :cool:
 

Alexfs

Senior Member
Oct 7, 2014
143
74
Hey,
Everything OK my friend. It's just a curiosity, is that you as a developer have more news. How is the development of Lineage for Android 13 going? I saw that there is already a lot of GSI running around but nothing official.
 

html6405

Recognized Developer
  • Like
Reactions: Alexfs
This could be the problem, is your IMEI and SN known with any other ROM?

You could try to flash back the the last stock ROM, check if it's working there and if yes,
start from zero, reflash TWRP + LineageOS.
already fix the SN issue. and log in my google account i test the youtube. and i notice the struggle while playing video from 480 - 1080. maybe ill wait for another update to give it a try
 

javilepe

Member
Jul 6, 2016
15
2
good evening,
I have followed all the steps that come to install Magisk and later be able to activate Zygick but it is impossible. If I install the ZIP from the initial post Zygick does not appear and if I update it tells me that there is no magisk installed.

But well, apart from that, my main problem has been when connecting a bluetooth keyboard, with the Lineage 16 it worked perfectly, but now it connects well, but when I press the keys it does not write. only if I press the "i-I" key, '5' appears and if I press the "l-L" key, '3' appears.

Do you know what could be happening?

Thanks!! You are doing a good job.




Spanish ( My language ):
buenas tardes,
He seguido todos los pasos que vienen para instalar Magisk y más tarde poder activar Zygick pero es imposible. Si instalo el ZIP del post inicial no aparece Zygick y si actualizo me dice que no hay magisk instalado.

Pero bueno, a parte de eso, mi principal problema ha sido al conectar un teclado bluetooth, con la Lineage 16 funcionaba perfectamente, pero ahora se conecta bien, pero cuando pulso las tecla no escribe. solo si pulso la tecla "i-I" aparece '5' y si pulso la tecla "l-L" aparece '3'.

¿Sabes que podría estar pasando?.


Gracias!! Estás haciendo un trabajo magnifico.
 
Last edited:

Alexfs

Senior Member
Oct 7, 2014
143
74
good evening,
I have followed all the steps that come to install Magisk and later be able to activate Zygick but it is impossible. If I install the ZIP from the initial post Zygick does not appear and if I update it tells me that there is no magisk installed.

But well, apart from that, my main problem has been when connecting a bluetooth keyboard, with the Lineage 16 it worked perfectly, but now it connects well, but when I press the keys it does not write. only if I press the "i-I" key, '5' appears and if I press the "l-L" key, '3' appears.

Do you know what could be happening?

Thanks!! You are doing a good job.




Spanish ( My language ):
buenas tardes,
He seguido todos los pasos que vienen para instalar Magisk y más tarde poder activar Zygick pero es imposible. Si instalo el ZIP del post inicial no aparece Zygick y si actualizo me dice que no hay magisk instalado.

Pero bueno, a parte de eso, mi principal problema ha sido al conectar un teclado bluetooth, con la Lineage 16 funcionaba perfectamente, pero ahora se conecta bien, pero cuando pulso las tecla no escribe. solo si pulso la tecla "i-I" aparece '5' y si pulso la tecla "l-L" aparece '3'.

¿Sabes que podría estar pasando?.


Gracias!! Estás haciendo un trabajo magnifico.
Use Cygisk, it worked well for me: https://cygisk.github.io/
 

goritomi

New member
Aug 30, 2009
3
0
already fix the SN issue. and log in my google account i test the youtube. and i notice the struggle while playing video from 480 - 1080. maybe ill wait for another update to give it a try
Hello!
I have the same problem! How did you fix it?
Thank you in advance for your answer.
Sincerely,
Ati
 
Hello!
I have the same problem! How did you fix it?
Thank you in advance for your answer.
Sincerely,
Ati
STEP 1:
just go to TWRP.
go to mount check the efs
and go back to menu choose advanced
then go to file manager then choose efs
then go to FactoryApp then find the serial_no
then copy to sd card to edit it via notepad in your computer or laptop
then put the serial no of your own device. (you can see it in the lowerback rightside
the S/N R34XXXXXXX and then save)
then copy it and save it to SDcard.
STEP 2:
then repeat the process TWRP
go to mount check the efs
then go to andvanced
file manager then copy the serial_no in your SDcard the one you edit in computer or laptop
( idk where you put it but it must be in SDcard)
go to FactoryApp and paste it there. then restart your device.

Note: you will know that you success once you can sign in your google account
 

javilepe

Member
Jul 6, 2016
15
2
Hmm maybe a wrong layout?
Did you checked the keyboard settings?
I dont know....
Tonight I will try to install the latest TWRP and start all the steps again.

I tried various keyboard combinations and some language settings, but none of them worked.

In any case, I'll try to do it all again tonight and if it doesn't work I'll try to generate a LOG to see what could be happening.

Thanks!


Spanish:
No sé....
En esta noche, intentaré instalar el último TWRP y empezaré de nuevo todos los pasos.

Probé varias combinaciones de teclado y algunas configuraciones de idiomas, pero ninguna funcionó.

de cualquier manera, intentaré esta noche hacerlo todo de nuevo y en caso de no funcionar te intento generar un LOG a ver que podría estar pasando.

Gracias!
 

goritomi

New member
Aug 30, 2009
3
0
STEP 1:
just go to TWRP.
go to mount check the efs
and go back to menu choose advanced
then go to file manager then choose efs
then go to FactoryApp then find the serial_no
then copy to sd card to edit it via notepad in your computer or laptop
then put the serial no of your own device. (you can see it in the lowerback rightside
the S/N R34XXXXXXX and then save)
then copy it and save it to SDcard.
STEP 2:
then repeat the process TWRP
go to mount check the efs
then go to andvanced
file manager then copy the serial_no in your SDcard the one you edit in computer or laptop
( idk where you put it but it must be in SDcard)
go to FactoryApp and paste it there. then restart your device.

Note: you will know that you success once you can sign in your google account
Hello!

Thank you very much!
This serial number method is works, but the IMEI number is also missing.
I'll try put back the IMEI with EFT pro.
This ROM is very good, but i don't need the root state.
720p videos also stutter a bit.
A quick panel volume adjustment would also be nice. :)
Trying to get Netflix to work.
Thank you, html6405 for your great work, and i'll waiting the next releases!

Best regards,
Ati
 

javilepe

Member
Jul 6, 2016
15
2
¡Hola!

¡Muchos gracias!
Este método de número de serie funciona, pero también falta el número IMEI.
Intentaré volver a poner el IMEI con EFT pro.
Esta ROM es muy buena, pero no necesito el estado raíz.
Los videos de 720p también tartamudean un poco.
Un ajuste rápido del volumen del panel también estaría bien.:)
Intentando que Netflix funcione.
¡Gracias, html6405 por su gran trabajo, y esperaré los próximos lanzamientos!

Saludos,
ati
Hi, if you want to try stores like aptoide, aurora... if not, you can try this version of Netflix, it's the one I used on Chinese androidtv, but it's for tablets Netflix_v5 .3.1_HD.apk

I don't know if you can put links to apks directly, if you can't, someone tell me and I'll remove the link or have an administrator remove it.

All the best.

Spanish:
Buenas, si quieres probar con tiendas como aptoide, aurora... si no, puedes probar esta versión de Netflix, es la que yo usaba en androidtv chinas, pero es para tablets Netflix_v5 .3.1_HD.apk
No se si se pueden poner enlaces a apks directamente, si no se puede, que alguien me diga y quito el enlace o que algún administrador la retire.

Un saludo.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Still a bit lost with regards on how to get Magisk 25.2 running.

    I have tried:
    - Removing 24.1 (using it's built-in uninstaller)
    - Making sure no traces of /data/adb are left
    - Flashing 25.2 from recovery

    But no-luck so far.
    Make sure that the ramdisk is not patched from previous Magisk.

    It would be the best to flash my stock boot.img before running Magisk 25.2 installer.
    (Or try to install the ROM again, data/adb must be deleted, otherwise old Magisk will flash itself.
    1
    I guess the problem is then the already patched "boot.img", because I see it reported by the Magisk 25.2 installer when running it from the recovery.

    Thanks. I will then carry on.
    1
    Ok ... Magisk 25.2 running. No removal of /data/adb or clean installation is needed. What "I" have needed:

    - Updating to Magisk 25.2
    - Extracting the stock boot.img from the lineageos 19 .zip image
    - Tell Magisk 25.2 to install by patching boot.img
    - Install the patched boot.img using TWRP ...

    This all seemed useless until I realized that in the Lineageos 20 thread there was a new kernel posted. My N8000 was on the "new" 3.01. The new kernel posted in the sister thread was alread 3.4.

    Latest kernel flashed ... and Magisk works, retaining the Modules already installed under 24.1. This last point is critical if a "real" working Playstore was already installed.

    Summary: the real key for the entire process was having installing the 3.4 kernel 3.4

    Best regards
  • 25
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    *
    */

    Hi,

    here you can find my version of LineageOS 19.1 for our Samsung Galaxy Note 10.1 devices.
    At first I want to thank @rINanDO and @ChronoMonochrome for all your work which helped me a lot.

    This is a BETA build, also on the LineageOS side, so don't install it if you want a complete and stable rom and don't report my already listed bugs!

    When you have BitGapps installed, you have to reflash them after every update!


    Here you can see how far everything is working for now.

    N8000, N8010, N8013, N8020:
    • Boot
    • Bluetooth
    • Audio
    • Graphics
    • Cameras
    • Sensors
    • GPS
    • Wifi
    • USB
    • Video playback (HW/SW)
    • Tethering via USB, WIFI and Bluetooth
    • consumerir transmitter
    • Stylus with gestures and hovering icon
    • RIL
    • sec_keyboard docking station
    • much more...
    • Random reboots
    • Long screenshot
    • SD-Card can't be formatted as internal storage, this will cause a bootloop
    If you don't like it, reboot into recovery and type the following command:
    I would recommend to use microG instead of BitGapps,
    here you can find the installation instructions:
    1. Download Magisk 24.1 and flash it via TWRP (yes, flash the APK file), reboot
    2. Open Magisk and update the App (and do a reboot if it's asking)
    3. Enable Zygisk in Magisk
    4. Download and install microG installer in the Magisk manager, reboot
    5. Download and install safetynet-fix in the Magisk manager, reboot
    6. Check with a safetynet checker app and you should pass :)

    If you plan to use a sim card in your device, I would recommend to disable the pin code before with another device.
    In some cases the sim card becomes unusable while typing in the code.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.

    donate

    Wanna improve your sound configs?
    Now you can use my app to access all boeffla sound configurations.

    XDA:DevDB Information
    [ROM][12.x][N8000/N801x/N8020][BETA] LineageOS 19.1, ROM for the Samsung Galaxy Note 10.1

    Contributors

    html6405
    Source Code: https://github.com/html6405

    ROM OS Version: 12.x S
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information
    Status:
    Beta

    Created 2021-11-18
    Last Updated 2022-09-23
    10
    Good news , new kernel for Magisk 25.2 and A13 is finished, there will be an update soon :)
    6
    Update 25.06.2022:
    • Synced with latest LineageOS sources
    5
    Update 15.03.2022:
    • Switched to Android 12L :love:, attention, this could not work with your existing gapps! (https://sourceforge.net/projects/nikgapps/ will work)
    • Removed OMX.SEC.AVC.Decoder for now, it has problems with many videos, which regenerated after a minute, thats a killer for some short videos.
    • Hopefully improved screen lightning bug
    A clean installation is recommended.
    5
    Update 23.11.2021:
    • Fixed Bluetooth
    • Brought Livedisplay entry in settings back
    • Fixed partly Tethering