LineageOS 20.0 (Android 13) for GT-N8000 GT-N8005 GT-N8010 GT-N8013 GT-N8020 ALPHA

Search This thread


Senior Member
Jun 1, 2013
Update 06.03.2023:
  • Synced with LineageOS sources from February
Thanks for the update!
install died after a maybe 50 uses. One day it just went into an endless boot-loop, tried numerous hard-shutdowns, clearing cache didn't help, clearing cache and dalvik didn't help.

I've wiped [ cache, dalvik, system, data, internal-storage ] then installed
Strange that does not work
But I installed
and it's working well.

Amazing that you managed to fix the sleep issue in the kernel, looking forward to seeing it in action.
Amazing that you upgraded the kernel as well. I'm looking forward to trying Linux Deploy! (as per my guide on page 7)

I bought your Exynos 4 Kernel manager. I didn't really need it, but wanted to support you. Thanks!
Last edited:


Senior Member
Feb 23, 2008
Hi, using html6405's old Slim Rom for some time now on the device, now I found it suddenly in a bootloop last week. Things happen, but now booting to TWRP 3.4 (working fine), everything I want to do there (wiping, installing, ...) ends with errors mostly claiming "Read-only file system". So I'm unable to wipe, update TWRP and of course the ROM... any ideas?

Booting in download mode and using Odin, I get this:
<ID:0/005> Odin engine v(ID:3.1401)..
<ID:0/005> File analysis..
<ID:0/005> Total Binary size: 7 M
<ID:0/005> SetupConnection..
<ID:0/005> Initialzation..
<ID:0/005> Get PIT for mapping..
<ID:0/005> Firmware update start..
<ID:0/005> NAND Write Start!!
<ID:0/005> SingleDownload.
<ID:0/005> recovery.img
<ID:0/005> FAIL!
<ID:0/005> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
Last edited:
This work is really great and I'm loving the update!
However, I really need a helping hand.

I can't get the magisk work.
I tried following to
Flash via twrp (app not installed after restart)

Then i tried installing the magisk app manually
But it shows Installed:N/A
Then the SuperUser and Module is Grayed out.

I have tried the other lineage releases but is unsuccessful.

I really need this to work and pass the safety so I can use banking apps.

The apps detecting the device as rooted
It's actually rooted as I get prompt when I installed Root Explorer.

I hope some can guide me to get Magisk installed successfully.

Thank you!


New member
Mar 31, 2023
Hello friends 🖐
I have some questions
1- what the languages supported?
2- if install LineageOs , I can work with Spen ?
3- lineage Os stable? install version 20 or 19 ?
4- lineageos 20 for 2013 version?
Last edited:


New member
Apr 2, 2023
Magisk shows Installed: N/A whatever version I flash or installed.

I think this is the old problem with kernel, it probably supports only the Magisk 23.0 version, and the partial support of Android 13 was added only to Magisk 25.0. That is, the new OS on the old kernel will not support Magisk.

Read the first and second pages.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    well ig its goodbye guys, i got my tab s6 lite yesterday and installed official lineageos on it. i will miss this community, which i love a lot, but it is time to move on from my note 10.1
    i think hdmi out only worked on older versions of lineageos (lineage 16)
    Same with lineage-16.0-20220109-HTML6405-n8010. HDMI does not work. It seems like the screens I tried to connect recognize something when I connect the Samsung ep-3phpbe HDMI device to the screen, but still shows "no signal". Probably a driver problem or the driver for hdmi out is not included in Lineage?

    Does somebody has an idea how to proceed?
    Does somebody has an idea how to proceed?
    This uses proprietary code, which has stopped working since Android 7.
    Message x2; Message x3; Message x4;

    It's a popular question, no one blames you for repeating it :D
    Just wanted to bring the answers from the developer as an answer to your question.
  • 24
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    here you can find my version of LineageOS 20 for our Samsung Galaxy Note 10.1 devices.
    At first I want to thank @rINanDO and @ChronoMonochrome for all your work which helped me a lot.

    This is a ALPHA build, also on the LineageOS side, so don't install it if you want a complete and stable rom and don't report my already listed bugs!

    Here you can see how far everything is working for now.

    N8000, N8010, N8013, N8020:
    • Boot
    • Bluetooth
    • Audio
    • Graphics
    • Cameras
    • Sensors
    • GPS
    • Wifi
    • USB
    • Video playback (HW/SW)
    • Tethering via USB, WIFI and Bluetooth
    • consumerir transmitter
    • Stylus with gestures and hovering icon
    • RIL
    • sec_keyboard docking station
    • much more...
    • Random reboots
    • Long screenshot
    • SD-Card can't be formatted as internal storage, this will cause a bootloop
    • Network monitoring because of missing eBPF support
    If you don't like it, reboot into recovery and type the following command:
    I would recommend to use microG instead of BitGapps,
    here you can find the installation instructions:
    1. Download Magisk 24.1 and flash it via TWRP (yes, flash the APK file), reboot
    2. Open Magisk and update the App (and do a reboot if it's asking)
    3. Enable Zygisk in Magisk
    4. Download and install microG installer in the Magisk manager, reboot
    5. Download and install safetynet-fix in the Magisk manager, reboot
    6. Check with a safetynet checker app and you should pass :)

    If you plan to use a sim card in your device, I would recommend to disable the pin code before with another device.
    In some cases the sim card becomes unusable while typing in the code.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.


    Wanna improve your sound configs?
    Now you can use my app to access all boeffla sound configurations.

    XDA:DevDB Information
    [ROM][13.x][N8000/N801x/N8020][BETA] LineageOS 20.0, ROM for the Samsung Galaxy Note 10.1


    Source Code:

    ROM OS Version: 13.x T
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information

    Created 2022-11-02
    Last Updated 2023-03-06
    Update 06.03.2023:
    • Synced with LineageOS sources from February
    Update 15.01.2023:
    • Synced with latest LineageOS sources
    • Set swappiness back to 100
    • Fixed SamsungDoze
    • Fixed stylus gestures
    • Moved to 3.4 kernel for n8000 and n8010
    • Fixed dock / undock behavior for docking stations
    everything working fine at my end.
    I'm using LOS20 + Magisk+BigGapps Magisk module. the setup quite stable and performance is usable.