LineageOS 20.0 (Android 13) for Mi Pad 4 Plus

Search This thread

appman1234

Senior Member
Jun 5, 2012
382
133
This rom works perfectly on my Mi Pad 4 without plus.
BTW, I set the dpi (smallest width) in developer options to 600.
Many thanks to sabar_op's excellent effort!!
 

Mc_carra

New member
Dec 30, 2011
1
0
With the last lineage of this post, I experience a terrible lag in the function of sending screen to TV. With my cell phone (miui) this function works perfectly. does anyone else have this problem?
 

Argaricolm

Member
Oct 15, 2022
9
4
Installed 10.11.2022 version. Everything wiped before install. Can't install any apps because all internal memory 64GB is full with "system".
Update: Forgot to format data before first start.
Update2: Again got bootloop (worked fine from monday till today).
 
Last edited:

azz_kikr

Senior Member
Oct 23, 2010
162
14
Anyone can confirm if the decoding of hevc 10bit is working on this ROM? Was an issue on A12 releases. (For example in Plex )
 

puetzfu2001

New member
Apr 1, 2017
2
0
Can anyone please help me to install TWRP 4.19 ?
I have tried 2 ways:
1) Install image file from old TWRP (3.7.0_9-6) to the recovery partition
2) Install via ADB/Fastboot with "fastboot flash recovery TWRP-name"
In both cases the installation runs without any error.
In both cases the system reboots into the old TWRP.
When I try to boot from the installation directly into TWRP (Fastboot reboot TWRP-Name), the same result:
Boot into the old TWRP.

Is the new TWRP 4.19 a prerequiite for LOS20 ?
 

puetzfu2001

New member
Apr 1, 2017
2
0
I just realised that the TWRP file name still shows the numbe of the "old" TWRP.
Does this mean that the new TWRP (4.19) mboots up showing the name (3.7.0_9) of the old one?
So, I amy have no problem at all?
I didn't try to install LOS20 yet.
 

turopolje

Member
Dec 16, 2014
48
7
zagreb
Can anyone please help me to install TWRP 4.19 ?
I have tried 2 ways:
1) Install image file from old TWRP (3.7.0_9-6) to the recovery partition
2) Install via ADB/Fastboot with "fastboot flash recovery TWRP-name"
In both cases the installation runs without any error.
In both cases the system reboots into the old TWRP.
When I try to boot from the installation directly into TWRP (Fastboot reboot TWRP-Name), the same result:
Boot into the old TWRP.

Is the new TWRP 4.19 a prerequiite for LOS20 ?
4.19 for kernel 4.19
 

GregEden

Senior Member
Feb 6, 2020
328
132
Melbourne
I just realised that the TWRP file name still shows the numbe of the "old" TWRP.
Does this mean that the new TWRP (4.19) mboots up showing the name (3.7.0_9) of the old one?
So, I amy have no problem at all?
I didn't try to install LOS20 yet.
That is correct. It just shows as 3.7.0_9-3 on mine when I go into TWRP. But I most definitely installed the 4.19 version. You should be good to go.
 

pndwal

Senior Member
Please run Sensor Test app... (Simple hardware tester / identifyer... there are many similar ones on Play Store)...

What do you see in Info for Accelerometer and Gyroscope?... Mine both show vendor = Bosch and Tests show good data. (... Tilt soccer game works 🙂)...

Sensor hardware is often most affected by water damage... I lost Accelerometer, Gyroscope, Compass, and Magnetometer in my Xiaomi RN8T after dunkin' phone... Everything else still works fine...

Sadly I discovered these sensors are on main board in RN8T so can't repair... (Other sensors are on sub boards and are available for RN8T.)... I don't know where Accelerometer and Gyroscope (likely in same Bosch chip) are located in Mi Pad 4 variants...

Hopefully these sensors are detected... If not it doesn't necessarily mean physical damage... , could be vendor/firmware issue etc as has been mentioned... PW
 

GregEden

Senior Member
Feb 6, 2020
328
132
Melbourne
My Google One VPN will not connect. WiFi connects.

Fixed - I just stopped Google One, wiped the storage, then uninstalled the app. Then rebooted and put it back and now it is working.
 
Last edited:
I'm currently using the latest version (lineage-20.0-20221214), but I can't do a clean install. I can do a dirty flash though.

For some reason I can't "Format" when I wipe with TWRP 3.6.2_9-0. Do you have any solutions?

When I wipe, I get a message like it's not mounted. But I don't know how to solve this.

ADD:
I updated the TWRP(twrp-4.19-3.7.0_9-clover-20221113-0854.img by pix106) and it resolved the issue.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    Latest update, see 1st post
    2
    Thank you for your kind reply. I have never worked with magisk modules before. Does my device have to be rooted to install GS RAM Drive?
    I think you have to read some relevant posts before doing any modifications to the ROM.
    Yes, using magisk module = magisk installed = rooted.
    For your information, I have installed the following:
    1) Magisk v25.2-delta-6
    2) Universal SafetyNet Fix v2.4.0 - for passing safetynet
    3) systemless hosts - for AdAway
    4) God Speed Mode - GS Ram Drive v7 - for 6GB swap (max. up to 20GB and I think 6GB is enough)
    Good luck and enjoy your journey :)
    1
    Will this work evwn withiut installing/passing through the 3.10 i have been reading on the thread?

    EDIT:

    ive b::n readimg the entire 10 pages of this thread and saw an instruction saying you need to install firmware 310 or something (or is it lineage-20.0-20221003-UNOFFICIAL-clover.zip?) But somehow i cqnt find the link to it.

    Installing the latests version outright is a bad idea and just throws me back to TWRP.

    Can someone point me to the right direction? Somehow OP doesnt have the link to the "base ROM we need to install before applying the latest builds. 😊
    This is how I installed this ROM:

    Format data before installing the Pix106 TWRP. This is to prevent any encryption problems as it is based on 4.19 kernel.

    Flash latest version of ROM and your GApps package from SD card or via OTG.

    Format data again. I don't think I did this but others have and it won't do any harm.

    Reboot
    1
    OK, I get it now, thanks again.
    Another question, if I may:
    Is it possible, in this ROM version, to extend RAM by getting some memory from internal memory?
    Is there an option for that in the settings, somewhere, or in the developer options section?
    Yes, you can install some magisk module alternatively. For instant, I am using GS Ram Drive magisk module to get 6GB swap memory for my Mi PAD 4 w/o plus. The device becomes very smooth!
    1
    Finally the syatem booted! Thank you! I did the wipes wrong. Lol. On the newest version of recovery i mentioned thwre was a button for wipe data. I never saw it before. Lol. So i wiped system and wiped data then flash..now it's booting! 😍😍😍
  • 24
    Latest rom lineage-20.0-20230109-UNOFFICIAL-clover.zip :
    - January 2023 Security update
    - 4.19 Nyx Kernel
    - OSS cam HAL
    - Migrate to Xiaomi power AIDL HAL and common sdm660 powerhint
    - Build QTI thermal HAL
    - Switch to S62Pro blobs
    - Switch to original clover graphic firmware
    - Build Livedisplay

    Download

    Installation instructions :
    - Perform a backup of your current ROM (optional)
    - Use latest 4.19 TWRP created by pix106: (TWRP)
    - Perform clean install from TWRP (factory reset, format data and wipe system)
    - Flash ROM
    - Flash GApps (optional).

    Keep in mind that some LineageOS features have not been completed yet.

    What's working:
    - All hardware

    What's not working:
    Let me know.

    Source : https://github.com/LineageOS
    Kernel : clover
    Device tree : sdm660
    11
    Latest update, see 1st post
    9
    Latest rom, 1st post.
    New changelog:
    - Desember security patch
    - Build Livedisplay
    7
    Latest rom, check 1st post.
    6
    Latest update....see 1 post. Now device is certified in playstore.