• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Question LineageOS: "Can't load Android System" on first boot.

Search This thread
Oct 10, 2021
8
0
My new Xiaomi Poco X3 Pro is showing an error screen after some time, like in this post:
https://forum.xda-developers.com/t/cant-load-android-system-lineageos.4314035/

It reads "Can't load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data stored on this device"

This happened so far:

I just unlocked the boot loader of my new phone after week of waiting.

I followed the official lineage instructions to install the OS: https://wiki.lineageos.org/devices/vayu/install

Everything worked including the sideloading via db.

I downloaded those two files for the LineageOS-Site:
- Recovery via fastboot: lineage-18.1-20211203-recovery-vayu.img (recovery works, I can still boot into recovery)
- System via adb: lineage-18.1-20211203-nightly-vayu-signed.zip

I also added Gapps via adb: "open_gapps-arm64-11.0-nano-20211204.zip"

Both adb transfers exited successfully.

After the first error screen
- I tapped Try again,
- When the error occurred again, I tapped "Factory data reset," but the error still occurred. The phone is new, no user data is on the phone.
- I booted into recovery and reset all the data I could. When I tap "Format system partition" it throws an error "E: Failed to open /dev/block/dm-0: No such file or directory. System wipe failed."
- Then I repeated the adb sideload. The error occurs again.
- I removed the SIM card, as someone in the forum suggested this could be a problem source. The error still occurs.

What can I do now?

----

Update [2021-12-05 Sun 20:09]

It seems to be a Problem with the GApps Version.

What I did Try so far is:
- Install 03-12-LOS and latest GApps via LOS recovery (didn't work)
- Install 03-12-LOS and latest GApps via TWRP recovery (didn't work)

- install LOS Build from 26-11-2021 without GApps (works)
- Install LOS Build from 26-11-2021 with latest GApps (didn't work)
- Install LOS Build form 26-11-2021 with GApps from 25-11-2021 (works)
 
Last edited:
Oct 10, 2021
8
0
Thanks for the Idea. At the moment it has not solved the problem.

This is what I did:

- Flash TWRP
Code:
fastboot flash recovery TWRP-3.5.2-vayu-Nebrassy-2.img

- copy lineage-18.1-20211203-nightly-vayu-signed.zip and "open_gapps-arm64-11.0-nano-20211204.zip" to the Poco device
- install via "install" option, wipe cache at the end of installation
- Format files (via "Wipe" -> "Format Data" -> type "yes")
- Reboot

After some time of the animated Lineage OS logo, the phone reboots into TWRP.

To me this seems very similar to the Lineage recovery before.

Any ideas what could be wrong?
 

k3lcior

Senior Member
Feb 23, 2011
4,609
2,206
Kraków
Moto G5
Xiaomi Poco X3 Pro
You probably wiped System or Vendor partition or something, you are not supposed to do that.
Most likely you have to reflash MIUI now first. Make sure it's atleast version 12.5.X.X.
Flashing instructions are really simple, this apply to all ROM's.

FIRST INSTALL?:
  • Remove any fingerprint, PIN, or password in MIUI
  • Unlock the bootloader
  • Transfer ROM to internal storage
  • Install any suitable recovery
  • Flash ROM zip file
  • Do a data wipe in recovery (format data)
  • Reboot to the system, wait and enjoy
FLASHING UPDATES?:
  • Download via OTA Updater and let it automatically install; OR
  • Download an update, transfer to internal/external storage (always check file sha256)
  • Flash ROM zip and reboot.
Do not wipe anything else or add any additional steps. (maybe except Gapps if ROM doesn't have them included)

ps.
In first post there is no mention if you did Format Data or not and when you did it. Like i said before - you have to Formata DATA AFTER flashing ROM . Not before.
This happened so far:

I just unlocked the boot loader of my new phone after week of waiting.

I followed the official lineage instructions to install the OS: https://wiki.lineageos.org/devices/vayu/install

Everything worked including the sideloading via db.

I downloaded those two files for the LineageOS-Site:
- Recovery via fastboot: lineage-18.1-20211203-recovery-vayu.img (recovery works, I can still boot into recovery)
- System via adb: lineage-18.1-20211203-nightly-vayu-signed.zip

I also added Gapps via adb: "open_gapps-arm64-11.0-nano-20211204.zip"

Both adb transfers exited successfully.
 
Last edited:
Oct 10, 2021
8
0
In first post there is no mention if you did Format Data or not and when you did it. Like i said before - you have to Formata DATA AFTER flashing ROM . Not before.
I followed the LOS Install Guide: https://wiki.lineageos.org/devices/vayu/install But this procedure does not seem to bee the cause (see below).

  1. Download the LineageOS installation package that you would like to install or build the package yourself.
    • Optionally, download an application package add-on such as Google Apps (use the arm64 architecture).
  2. If you are not in recovery, reboot into recovery:
    • With the device powered off, hold Volume Up + Power. When Xiaomi/POCO/Redmi splash appears, release Power and keep pressed Volume Up until recovery appears.
  3. Now tap Factory Reset, then Format data / factory reset and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage, as well as format your cache partition (if you have one).
  4. Return to the main menu.
  5. Sideload the LineageOS .zip package:
    • On the device, select “Apply Update”, then “Apply from ADB” to begin sideload.
    • On the host machine, sideload the package using: adb sideload filename.zip.

Okay so this is what I did (the part that works):

- I downloaded the latest possible stock ROM from https://www.xda-developers.com/down...ut-several-xiaomi-redmi-mi-poco-devices/#vayu The fastboot ROM is more than 5GB.
- Extract the file "vayu_eea_global_images_V12.5.3.0.RJUEUXM_20211015.0000.00_11.0_eea_05cc38de43.tgz"
- then connect the phone via USB cable in fastboot mode and:
Bash:
cd ~/Downloads/vayu_eea_global_images_V12.5.3.0.RJUEUXM_20211015.0000.00_11.0_eea

/bin/bash ./flash_all.sh
- The default MIUI starts flawless, as it dit the first time I turned on the phone. So far so good.

What didn't work:
1. I installed the LOS Recovery again and flashed the OS and Gapps. Only after that I did step 3 - formating. The result ist the same bootloop as in the beginning.

2. I flashed the stock MIUI ROM again (which woks fine). Then I flashed TWRP, transfered the OS and GApps file and installed. I did not wipe anything, just used "format data" like above.

In both cases the OS does not start. After a while displaying the LOS-logo the phone reboots to recovery.

What did work:
I downloaded lineage-18.1-20211126-nightly-vayu-signed.zip, one version before the latest verion and the corresponding recovery lineage-18.1-20211126-recovery-vayu.img

I flashed only the OS, and no GApps -- and it launched successfully. Installing with the latest GApps failed again.
 
Last edited: