Link2SD, Apps2SD not working on rooted H440 Marshmallow. Solution: ext3 format.

Search This thread


Dec 22, 2010
São Paulo
Since the unlocked bootloader and TWRP recovery made possible to root marshmallow on H440 and its variants I got interested in doing it myself.

Last weekend I did it and started to reconfigure the device with my preferred apps and one of them is Link2SD, since I have lots of apps.

The first thing that I noticed was that Link2SD giving an error of not being able to write on the second partition (ext4). I came to a guide from techmagus, that partially solved my problem. I used Apps2SD, partitioned my card, it worked, I could move apks to the second partition, but always I would get a message about "corrupted SD card" and on camera the option to record pictures and movies to the SD card wasn't available. :confused:

From the guide:

Q: Can I partition in Linux or Windows?

Yes. However, there is a chance that Marshmallow will show a “corrupted SD card” message. It is not corrupted, the SD card detection algorithm of Marshmallow is stricter (or different) than the previous Android versions. When it reads an SD card, it was expecting something but found it not. Continue as usual, the ext4 partition is working as intended.

Yes, the partitions are ok, but not working as I would like.

Looking for more info I found that the new feature of marshmallow, adopted storage, uses an encrypted ext4 partition to give more memory to install apks, a little like Link2SD and Apps2SD would work.

So I thought that before MM the ext4 partition was "invisible" to android and now, since it can use ext4 for it's own purposes, it's not invisible any more. Since the partition isn't encrypted, an error is flagged.

If I could hide my partition it would be a solution. I just don't know how to do it or even if it is possible. The next option? Format the second partition to an "invisible" format. The H440n can use ext2, ext3 and ext4 for partitioning, so let's try ext3 and... problem solved :)

Using ext3 for the second partition Apps2SD could create it's scripts, the “corrupted SD card” message is gone and the camera re-enabled the option to store pictures on the SD card. Since Link2SD appears to have troubles writing the startup scripts (people are instructing to use Apps2SD to first install the scripts then using Link2SD after that...) on MM I didn't tested it, but it should work as intended.

Last edited: