"Local update" to A13, no audio

Search This thread

jewnersey

Senior Member
Jul 25, 2010
1,740
600
I bought a cheap OP8P that was stuck in bootloop and recovered it (MSM tool to reflash A11, then local update to A13). The phone is working fine, but I there is no sound output. This applies to calls and all videos/music. NewPipe spits this error out when I try to play a video:

Code:
{"user_action":"play stream","request":"Player error[type=ERROR_CODE_AUDIO_TRACK_INIT_FAILED] occurred while playing https://www.youtube.com/watch?v=HggVVPy0Ma4","content_language":"en-AU","content_country":"AU","app_language":"en_AU","service":"YouTube","package":"org.polymorphicshade.newpipe","version":"0.24.1","os":"Linux OnePlus/OnePlus8Pro/OnePlus8Pro:13/RKQ1.211119.001/Q.202209070412:user/release-keys 13 - 33","time":"2022-11-24 08:18","exceptions":["com.google.android.exoplayer2.ExoPlaybackException: MediaCodecAudioRenderer error, index=1, format=Format(null, null, null, audio/raw, null, -1, null, [-1, -1, -1.0], [2, 44100]), format_supported=YES\n\tat com.google.android.exoplayer2.ExoPlayerImplInternal.handleMessage(ExoPlayerImplInternal.java:566)\n\tat android.os.Handler.dispatchMessage(Handler.java:102)\n\tat android.os.Looper.loopOnce(Looper.java:240)\n\tat android.os.Looper.loop(Looper.java:351)\n\tat android.os.HandlerThread.run(HandlerThread.java:67)\nCaused by: com.google.android.exoplayer2.audio.AudioSink$InitializationException: AudioTrack init failed 0 Config(44100, 12, 44100)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.buildAudioTrack(DefaultAudioSink.java:2092)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink.buildAudioTrack(DefaultAudioSink.java:1070)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink.buildAudioTrackWithRetry(DefaultAudioSink.java:1049)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink.initializeAudioTrack(DefaultAudioSink.java:846)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink.handleBuffer(DefaultAudioSink.java:929)\n\tat com.google.android.exoplayer2.audio.MediaCodecAudioRenderer.processOutputBuffer(MediaCodecAudioRenderer.java:703)\n\tat com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.drainOutputBuffer(MediaCodecRenderer.java:1894)\n\tat com.google.android.exoplayer2.mediacodec.MediaCodecRenderer.render(MediaCodecRenderer.java:792)\n\tat com.google.android.exoplayer2.ExoPlayerImplInternal.doSomeWork(ExoPlayerImplInternal.java:989)\n\tat com.google.android.exoplayer2.ExoPlayerImplInternal.handleMessage(ExoPlayerImplInternal.java:490)\n\t... 4 more\n\tSuppressed: com.google.android.exoplayer2.audio.AudioSink$InitializationException: AudioTrack init failed 0 Config(44100, 12, 44100)\n\t\t... 14 more\n\tCaused by: java.lang.UnsupportedOperationException: Cannot create AudioTrack\n\t\tat android.media.AudioTrack$Builder.build(AudioTrack.java:1390)\n\t\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.createAudioTrackV29(DefaultAudioSink.java:2141)\n\t\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.createAudioTrack(DefaultAudioSink.java:2119)\n\t\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.buildAudioTrack(DefaultAudioSink.java:2084)\n\t\t... 13 more\nCaused by: java.lang.UnsupportedOperationException: Cannot create AudioTrack\n\tat android.media.AudioTrack$Builder.build(AudioTrack.java:1390)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.createAudioTrackV29(DefaultAudioSink.java:2141)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.createAudioTrack(DefaultAudioSink.java:2119)\n\tat com.google.android.exoplayer2.audio.DefaultAudioSink$Configuration.buildAudioTrack(DefaultAudioSink.java:2084)\n\t... 13 more\n"],"user_comment":""}

I have tried reinstalling the update but it didn't change anything.

Thoughts?
 
Last edited:

jewnersey

Senior Member
Jul 25, 2010
1,740
600
Update: I went back to instantnoodlep_15_O.34_210201.ops via MSM and still no sound via speakers. BT headphones work just fine. Don't have an adapter to test wired headphones though.

I also cannot play videos back smoothly? The first second is at a normal frame rate and then it stutters every 500 ms or so, and at a much lower frame rate. BUT when i switch to BT headphones, the video playback is normal, i.e., when the sound is not trying to output from the speakers

Might just be a hardware issue?
 
Last edited:

ShadoV90

Senior Member
Mar 5, 2017
271
96
Legnica
Update: I went back to instantnoodlep_15_O.34_210201.ops via MSM and still no sound via speakers. BT headphones work just fine. Don't have an adapter to test wired headphones though.

I also cannot play videos back smoothly? The first second is at a normal frame rate and then it stutters every 500 ms or so, and at a much lower frame rate. BUT when i switch to BT headphones, the video playback is normal, i.e., when the sound is not trying to output from the speakers

Might just be a hardware issue?
Ofc i can be wrong but...

It looks for me like failed configuration for speakers. Which is weird, because you restored it from msm... it makes no sense to me. BT headphones are working, because BT is playing using different config. IMO you should catch full logcat, to have better view at what happen when you're trying to play. What Audioflinger, mediaserver, audioserver want to do, and other things in system. I'm pretty sure it's software related somehow.
At which version of OOS are you right now?

EDIT: Hmm... maybe factory reset will do the job? I guess it will not harm to try.
I searched some in google, and it seems that this type of problem can occur in different devices, even Android TV.
So i suggest maybe first try to perform factory reset, and see if something will change.
 
Last edited:

jewnersey

Senior Member
Jul 25, 2010
1,740
600
Ofc i can be wrong but...

It looks for me like failed configuration for speakers. Which is weird, because you restored it from msm... it makes no sense to me. BT headphones are working, because BT is playing using different config. IMO you should catch full logcat, to have better view at what happen when you're trying to play. What Audioflinger, mediaserver, audioserver want to do, and other things in system. I'm pretty sure it's software related somehow.
At which version of OOS are you right now?

EDIT: Hmm... maybe factory reset will do the job? I guess it will not harm to try.
I searched some in google, and it seems that this type of problem can occur in different devices, even Android TV.
So i suggest maybe first try to perform factory reset, and see if something will change.
Thanks for replying. I should also mention that system sounds aren't working either- no audio output at all, even from earpiece. I found this post which sounds similar to my experiences with a similar log, as below: "audio_extn_sound_trigger_update_stream_status: invalid input device 0x". They solved their problem: "I think I fixed it, I just switched from one slot to the other. Maybe my firmware was only on one partition or something?"

The phone is currently on 15_O.34_210201: Build number 11.0.4.4.IN11AA. I am in Australia which I believe uses the Chinese version of the device? I tried to flash a different version (EU/Global) to see if it had to do with device related drivers, but I got an "Unknown target O2" error. Model in system says it is IN2020.

System update that is available is IN2025_11_F.13_2130_202211142346 which sends the phone into bootloop OR installs but crashes during setup.

Video when trying to play through speaker plays at ~1/4 speed. I completed a factory reset and then set it up without any account or network. Log is attached which consisted of me turning on the screen, opening YouTube, starting a video, then adjust volume.

I am not going to pretend like I know what I am doing with the logs but here are standout lines pertaining to those processes you mentioned:

Line 89091 and 95938
Code:
11-25 06:46:05.360  1010  2322 W AudioFlinger: write blocked for 804 msecs, 236 delayed writes, thread 13

Nothing from mediaserver

Repeated many times with another block
Code:
11-25 06:45:45.260   918 18317 I chatty  : uid=1041(audioserver) writer identical 10 lines
Code:
11-25 06:46:03.068   918 18317 D android.hardware.audio.service: ACDBFILE_MGR: Property for the pid 000133B7 not found
11-25 06:46:03.068   918 18317 D android.hardware.audio.service: [Data Manager]-> No data found
11-25 06:46:03.068   918 18317 D ACDB-LOADER: Error: ACDB_CMD_GET_PERSISTENT_AUDPROC_INSTANCE_COMMON_TABLE_SIZE returned -18
11-25 06:46:03.068   918 18317 D ACDB-LOADER: ACDB -> send_audproc_persist_table -18
11-25 06:46:03.068   918 18317 D ACDB-LOADER: Error: Invalid Audproc persist size = -18
11-25 06:46:03.068   918 18317 D ACDB-LOADER: ACDB -> audstrm_cal->cal_type.cal_data.cal_size = 20
11-25 06:46:03.068   918 18317 D ACDB-LOADER: ACDB -> GET_AFE_TOPOLOGY_ID for adcd_id 102, Topology Id 1000b909
11-25 06:46:03.068   918 18317 D ACDB-LOADER: ACDB -> AUDIO_SET_AFE_CAL cal_type[17] acdb_id[102]
11-25 06:46:03.068   918 18317 D ACDB-LOADER: ACDB -> send_hw_delay : acdb_id = 102 path = 1
11-25 06:46:03.068   918 18317 D audio_hw_primary: enable_audio_route: apply mixer and update path: spkr-vi-record
11-25 06:46:03.068   918 18317 D audio_route: Apply path: spkr-vi-record
11-25 06:46:03.070   918 18317 E audio_hw_tfa98xx_feedback: audio_extn_tfa98xx_start_feedback: pcm device tx id=32
11-25 06:46:03.082   918 18317 I audio_hw_utils: audio_extn_utils_update_stream_output_app_type_cfg Allowing 24 and above bits playback on speaker ONLY at default sampling rate
11-25 06:46:03.082   918 18317 E soundtrigger: audio_extn_sound_trigger_update_stream_status: invalid input device 0x0, for event 3
11-25 06:46:03.082   918 18317 D soundtrigger: audio_extn_sound_trigger_update_stream_status: uc_info->id 0 of type 0 for Event 3, with Raise=1
11-25 06:46:03.082   918 18317 I sound_trigger_platform: platform_stdev_check_and_update_concurrency: Received STREAM event, event type 3, usecase type 0
11-25 06:46:03.082   918 18317 D sound_trigger_platform: platform_stdev_get_capture_device: Device = 0x80000004
11-25 06:46:03.082   918 18317 D sound_trigger_platform: platform_stdev_get_capture_device: Available device = 0x80000004
11-25 06:46:03.082   918 18317 D sound_trigger_platform: platform_stdev_check_and_update_concurrency: dedicated path 0, reset backend 1, tx 0, rx 1, concurrency session allowed
11-25 06:46:03.082   918 18317 D audio_hw_utils: audio_extn_utils_send_app_type_cfg: usecase->out_snd_device speaker
11-25 06:46:03.082   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(0) new_snd_devices(0)
11-25 06:46:03.082   918 18317 D audio_hw_utils: audio_extn_btsco_get_sample_rate:Not a BT SCO device, need not update sampling rate
11-25 06:46:03.082   918 18317 I audio_hw_utils: send_app_type_cfg_for_device PLAYBACK app_type 69936, acdb_dev_id 15, sample_rate 48000, snd_device_be_idx 45
11-25 06:46:03.083   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(1) new_snd_devices(0)
11-25 06:46:03.083   918 18317 D audio_hw_utils: audio_extn_btsco_get_sample_rate:Not a BT SCO device, need not update sampling rate
11-25 06:46:03.083   918 18317 D DlbQdspGefDriver: eventCallback(): audio device 0x00000002 (sample rate 48000, channelMask 0x00000003, ACDB device id 15, app type 0x11130) becomes active!
11-25 06:46:03.083   918 18317 D DlbQdspGefDriver: setDevice(device=0x00000002): old device 0x00000002
11-25 06:46:03.083   918 18317 D ACDB-LOADER: ACDB -> send_audio_cal, acdb_id = 15, path = 0, app id = 0x11130, sample rate = 48000, afe_sample_rate = 48000
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> AUDIO_SET_AUDPROC_CAL cal_type[11] acdb_id[15] app_type[69936]
11-25 06:46:03.084   918 18317 D android.hardware.audio.service: Failed to fetch the lookup information of the device 0000000F
11-25 06:46:03.084   918 18317 D ACDB-LOADER: Error: ACDB_CMD_GET_AUDPROC_INSTANCE_GAIN_DEP_STEP_TABLE_SIZE Returned = -19
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> ACDB_CMD_GET_AUDPROC_INSTANCE_GAIN_DEP_STEP_TABLE, vol index 0
11-25 06:46:03.084   918 18317 D android.hardware.audio.service: Failed to fetch the lookup information of the device 0000000F
11-25 06:46:03.084   918 18317 D ACDB-LOADER: Error: ACDB AudProc vol returned = -19
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> AUDIO_SET_VOL_CAL cal type = 12
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> audstrm_cal->cal_type.cal_data.cal_size = 556
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> GET_AFE_TOPOLOGY_ID for adcd_id 15, Topology Id 1000b910
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> AUDIO_SET_AFE_CAL cal_type[16] acdb_id[15]
11-25 06:46:03.084   918 18317 D ACDB-LOADER: ACDB -> send_hw_delay : acdb_id = 15 path = 0
11-25 06:46:03.084   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(0) new_snd_devices(0)
11-25 06:46:03.084   918 18317 I msm8974_platform: platform_get_custom_mtmx_params: no matching param with id 0 ip_ch 2 op_ch 2 uc_id 0 snd_dev 2
11-25 06:46:03.084   918 18317 D audio_hw_primary: enable_audio_route: apply mixer and update path: deep-buffer-playback tert_i2s
11-25 06:46:03.084   918 18317 D audio_route: Apply path: deep-buffer-playback tert_i2s
11-25 06:46:03.084   918 18317 D audio_hw_primary: select_devices: done
11-25 06:46:03.086   918 18317 E audio_hw_primary: pcm_open_prepare_helper: cannot set hw params: Invalid argument
11-25 06:46:03.086   918 18317 D audio_hw_primary: disable_audio_route: reset and update mixer path: deep-buffer-playback tert_i2s
11-25 06:46:03.087   918 18317 E soundtrigger: audio_extn_sound_trigger_update_stream_status: invalid input device 0x0, for event 2
11-25 06:46:03.087   918 18317 D soundtrigger: audio_extn_sound_trigger_update_stream_status: uc_info->id 0 of type 0 for Event 2, with Raise=1
11-25 06:46:03.087   918 18317 I sound_trigger_platform: platform_stdev_check_and_update_concurrency: Received STREAM event, event type 2, usecase type 0
11-25 06:46:03.087   918 18317 D sound_trigger_platform: platform_stdev_get_capture_device: Device = 0x80000004
11-25 06:46:03.087   918 18317 D sound_trigger_platform: platform_stdev_get_capture_device: Available device = 0x80000004
11-25 06:46:03.087   918 18317 D sound_trigger_platform: platform_stdev_check_and_update_concurrency: dedicated path 0, reset backend 1, tx 0, rx 0, concurrency session allowed
11-25 06:46:03.087   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(0) new_snd_devices(0)
11-25 06:46:03.087   918 18317 I msm8974_platform: platform_get_custom_mtmx_params: no matching param with id 0 ip_ch 2 op_ch 2 uc_id 0 snd_dev 2
11-25 06:46:03.087   918 18317 D hardware_info: hw_info_append_hw_type : device_name = speaker
11-25 06:46:03.087   918 18317 D audio_hw_primary: disable_snd_device: snd_device(2: speaker)
11-25 06:46:03.087   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(0) new_snd_devices(0)
11-25 06:46:03.093   918 18317 D hardware_info: hw_info_append_hw_type : device_name = vi-feedback
11-25 06:46:03.093   918 18317 D audio_hw_primary: disable_snd_device: snd_device(229: vi-feedback)
11-25 06:46:03.093   918 18317 D msm8974_platform: platform_split_snd_device: snd_device(229) num devices(0) new_snd_devices(0)
11-25 06:46:03.093   918 18317 I soundtrigger: audio_extn_sound_trigger_update_device_status: device 0xe5 of type 1 for Event 0, with Raise=0
11-25 06:46:03.093   918 18317 D audio_hw_primary: disable_audio_route: reset and update mixer path: spkr-vi-record
11-25 06:46:03.095   918 18317 D soundtrigger: audio_extn_sound_trigger_update_stream_status: uc_info->id 53 of type 1 for Event 2, with Raise=0
11-25 06:46:03.095   918 18317 I soundtrigger: audio_extn_sound_trigger_update_device_status: device 0x2 of type 0 for Event 0, with Raise=0
11-25 06:46:03.145   918 14278 D audio_hw_primary: start_output_stream: enter: stream(0xec980010)usecase(1: low-latency-playback) devices(0x2) is_haptic_usecase(0)
11-25 06:46:03.145   918 18317 D audio_hw_primary: out_standby: enter: stream (0xec9864c0) usecase(0: deep-buffer-playback)
11-25 06:46:03.145   918 18317 D audio_hw_primary: out_standby: exit
11-25 06:46:03.145   918 14278 D audio_hw_primary: select_devices for use case (low-latency-playback)
11-25 06:46:03.145   918 14278 D msm8974_platform: platform_get_output_snd_device: enter: output devices(0x2)
11-25 06:46:03.145   918 14278 D msm8974_platform: platform_get_output_snd_device: exit: snd_device(speaker)
11-25 06:46:03.145   918 14278 I msm8974_platform: platform_check_and_set_codec_backend_cfg:becf: afe: bitwidth 24, samplerate 48000 channels 2, backend_idx 0 usecase = 1 device (speaker)
11-25 06:46:03.145   918 14278 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(1) new_snd_devices(0)
11-25 06:46:03.145   918 14278 I msm8974_platform: platform_check_and_set_codec_backend_cfg: new_snd_devices[0] is 2
11-25 06:46:03.145   918 14278 I msm8974_platform: platform_check_codec_backend_cfg:becf: afe: bitwidth 24, samplerate 48000 channels 2, backend_idx 0 usecase = 1 device (speaker)
11-25 06:46:03.147   918 14278 D audio_hw_extn: audio_extn_enable_hifi_filter: mixer_value set 0
11-25 06:46:03.147   918 14278 D msm8974_platform: platform_check_codec_backend_cfg:becf: updated afe: bitwidth 24, samplerate 48000 channels 2,backend_idx 0 usecase = 1 device (speaker)
11-25 06:46:03.147   918 14278 D msm8974_platform: platform_check_codec_backend_cfg:becf: afe: playback on codec device not supporting native playback set default Sample Rate(48k)
11-25 06:46:03.147   918 14278 I msm8974_platform: platform_check_codec_backend_cfg:becf: afe: Codec selected backend: 0 updated bit width: 24 and sample rate: 48000
11-25 06:46:03.147   918 14278 D audio_hw_primary: check_usecases_codec_backend:becf: force routing 0
11-25 06:46:03.147   918 14278 E msm8974_platform: platform_check_backends_match: Invalid snd_device =
11-25 06:46:03.147   918 14278 D audio_hw_primary: check_usecases_codec_backend:becf: (80) check_usecases curr device: speaker, usecase device: backends match 0
11-25 06:46:03.147   918 14278 D audio_hw_primary: check_usecases_codec_backend:becf: check_usecases num.of Usecases to switch 0
11-25 06:46:03.147   918 14278 D hardware_info: hw_info_append_hw_type : device_name = speaker
11-25 06:46:03.147   918 14278 D msm8974_platform: platform_split_snd_device: snd_device(2) num devices(0) new_snd_devices(0)
11-25 06:46:03.147   918 14278 D audio_hw_primary: enable_snd_device: snd_device(2: speaker)
11-25 06:46:03.147   918 14278 D msm8974_platform: platform_get_island_cfg_on_device:island cfg status on snd_device = (speaker 0)
11-25 06:46:03.147   918 14278 I soundtrigger: audio_extn_sound_trigger_update_device_status: device 0x2 of type 0 for Event 1, with Raise=0
11-25 06:46:03.148   918 14278 D audio_route: Apply path: speaker
11-25 06:46:03.148   918 14278 D hardware_info: hw_info_append_hw_type : device_name = vi-feedback
11-25 06:46:03.148   918 14278 D msm8974_platform: platform_split_snd_device: snd_device(229) num devices(0) new_snd_devices(0)
11-25 06:46:03.148   918 14278 D audio_hw_primary: enable_snd_device: snd_device(229: vi-feedback)
11-25 06:46:03.148   918 14278 D msm8974_platform: platform_get_island_cfg_on_device:island cfg status on snd_device = (vi-feedback 0)
11-25 06:46:03.148   918 14278 I soundtrigger: audio_extn_sound_trigger_update_device_status: device 0xe5 of type 1 for Event 1, with Raise=0
11-25 06:46:03.148   918 14278 D audio_route: Apply path: vi-feedback
11-25 06:46:03.148   918 14278 D soundtrigger: audio_extn_sound_trigger_update_stream_status: uc_info->id 53 of type 1 for Event 3, with Raise=0
11-25 06:46:03.148   918 14278 D audio_hw_utils: audio_extn_utils_send_app_type_cfg: usecase->in_snd_device vi-feedback
11-25 06:46:03.148   918 14278 E voice   : voice_is_in_call_rec_stream: input stream is NULL
11-25 06:46:03.148   918 14278 D msm8974_platform: platform_split_snd_device: snd_device(229) num devices(0) new_snd_devices(0)
11-25 06:46:03.148   918 14278 E audio_hw_utils: send_app_type_cfg_for_device: Could not get ctl for mixer cmd - Audio Stream Capture 32 App Type Cfg
11-25 06:46:03.148   918 14278 D msm8974_platform: platform_split_snd_device: snd_device(229) num devices(1) new_snd_devices(0)
11-25 06:46:03.148   918 14278 D ACDB-LOADER: ACDB -> send_audio_cal, acdb_id = 102, path = 1, app id = 0x11132, sample rate = 8000, afe_sample_rate = 8000
11-25 06:46:03.148   918 14278 D ACDB-LOADER: ACDB -> AUDIO_SET_AUDPROC_CAL cal_type[11] acdb_id[102] app_type[69938]
11-25 06:46:03.148   918 14278 D android.hardware.audio.service: ACDBFILE_MGR: Property for the pid 000133B7 not found
 

jewnersey

Senior Member
Jul 25, 2010
1,740
600
So I have been trying to flash these stock roms now. And also trying to flash to both slots.

The global version fails - after the first reboot to fastboot it gives me the "qualcomm crashdump mode" forcing me to MSM back to 11

The europe version seems to complete, but never boots into system, instead, returning to fastboot.
 

ShadoV90

Senior Member
Mar 5, 2017
271
96
Legnica
IN2020 seems it's china model. So maybe try to flash colorOS instead of oxygenos. Maybe (probably) firmware of 2020 is different than 2021(IN),2023(EU),2025(NA) models? I know these three models can be crossflashed, but idk if 2020 can be. Try to find original colorOS and flash it in msm if you can.
 

jewnersey

Senior Member
Jul 25, 2010
1,740
600
IN2020 seems it's china model. So maybe try to flash colorOS instead of oxygenos. Maybe (probably) firmware of 2020 is different than 2021(IN),2023(EU),2025(NA) models? I know these three models can be crossflashed, but idk if 2020 can be. Try to find original colorOS and flash it in msm if you can.
Yeah. I found this person: https://forum.xda-developers.com/t/no-sound-after-upgrade-to-andriod-11.4206467/

Same issue as me. Need to find Android 10 rom.

Update: Tried to MSM with instantnoodlep_15_O.21_200716.zip but having the same issue.
 
Last edited:

ShadoV90

Senior Member
Mar 5, 2017
271
96
Legnica
Oneplus 11.0.15.15 hydrogen os for oneplus 8 pro.
I forgot that earlier china system was hydrogen os, Europe/NA had oxygen os.
I found this thing from chinese oneplus site.
It is saying that's full rom, so maybe it will work? It's hydrogen os 11. I can't dind any 10.
Sincerely idk if normal packages can be msm'd.

Btw. I found in thread in repo of OxygenOS builds this (from OP Team): "IN2020 units are Chinese units running HydrogenOS out of the box that may be able to run OxygenOS after conversion via local update. They will however need to format /data and wipe cache to avoid bootloop."
 
Last edited: