• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[locked bootloader] Bootloop on stock firmware, cannot access EDL mode... Any tips?

Search This thread

WiiiLDFARMER

Member
May 28, 2012
32
0
Amsterdam
Hi guys,

I have a Mi 9T (DaVinci, model M1903F10G) which is in a bootloop state. Sometimes, the boot "succeeds" and shows an empty android screen with navigation buttons (below) and navigation bar (top), but touching the screen/buttons does not do anything, and after a few seconds the phone reboots again. Within the seconds that it is in the android screen, it also shows up as a MTP device in Windows Explorer, but the drive is empty and trying to copy anything to it gives an error. At other times, the phone does not even reach this Android screen.
I can reach the official bootloader and also fastboot. In both cases, phone is recognized by ADB (but no debug access...)

BTW, I bought the phone in this state to try and fix it, so I do not know how or when the problems started. I tried a lot of things to get it back to working:

1) I tried to reflash stock images via MiFlash, but since my bootloader is locked (and I cannot unlock it because I cannot get into MIUI to link my account to this phone) I get the error: FAILED (remote: Erase is not allowed in Lock State) (MiFLash log below)
Code:
NOTE: ALL SERIAL NUMBERS REMOVED AND REPLCAED BY ########
[21:31:08  3a143982]:MiFlash 2019.10.30.0
[21:31:08  3a143982]:idproduct: 53261 idvendor: 6353
[21:31:08  3a143982]:Thread id:11 Thread name:########
[21:31:08  3a143982]:image path:C:\Users\Jochem\Downloads\Xiaomi_Mi_9T_V11.0.1.0.PFJMIXM_20191028.0000.00_Global_9.0\Firmware
[21:31:08  3a143982]:env android path:"C:\Users\Jochem\Downloads\MiFlash20191030\MiFlash20191030\Source\ThirdParty\Google\Android"
[21:31:08  3a143982]:script :C:\Users\Jochem\Downloads\Xiaomi_Mi_9T_V11.0.1.0.PFJMIXM_20191028.0000.00_Global_9.0\Firmware\flash_all.bat
[21:31:08  3a143982]:Physical Memory Usage:2174976 Byte
[21:31:08  3a143982]:start process id 13812 name cmd
[21:31:09  3a143982]:info:$if exist C:\Users\Jochem\Downloads\Xiaomi_Mi_9T_V11.0.1.0.PFJMIXM_20191028.0000.00_Global_9.0\Firmware\images\anti_version.txt (for /F "delims==" %a in (C:\Users\Jochem\Downloads\Xiaomi_Mi_9T_V11.0.1.0.PFJMIXM_20191028.0000.00_Global_9.0\Firmware\images\anti_version.txt) do (set CURRENT_ANTI_VER=%a ) ) 
[21:31:09  3a143982]:info:$(set CURRENT_ANTI_VER=1 ) 
[21:31:09  3a143982]:info:$if [1] EQU [] set CURRENT_ANTI_VER=0 
[21:31:09  3a143982]:info:$for /F "tokens=2 delims=: " %i in ('fastboot -s ######## getvar anti 2>&1 | findstr /r /c:"anti:"') do (set version=%i ) 
[21:31:09  3a143982]:info:$(set version=1 ) 
[21:31:09  3a143982]:info:$if [1] EQU [] set version=0 
[21:31:09  3a143982]:info:$set anticheck="antirollback check pass" 
[21:31:09  3a143982]:info:$if 1 GTR 1 set anticheck="Current device antirollback version is greater than this pakcage" 
[21:31:09  3a143982]:info:$echo "antirollback check pass"   | findstr /r /c:"pass"   || 
[21:31:09  3a143982]:info:"antirollback check pass" 
[21:31:09  3a143982]:info:$fastboot -s ######## getvar product   2>&1  | findstr /r /c:"^product: *davinci"   || echo Missmatching image and device 
[21:31:09  3a143982]:info:product: davinci
[21:31:09  3a143982]:info:$fastboot -s ######## getvar product   2>&1  | findstr /r /c:"^product: *davinci"   || exit /B 1 
[21:31:09  3a143982]:info:product: davinci
[21:31:09  3a143982]:info:$fastboot -s 3a143982 erase boot   || 
[21:31:09  3a143982]:err:Erasing 'boot'...
[21:31:09  3a143982]:info:"Erase boot error" 
[21:31:09  3a143982]:err:FAILED (remote: Erase is not allowed in Lock State)
[21:31:09  3a143982]:err:Finished. Total time: -0.000s
[21:31:09  3a143982]:error:"Erase boot error" 
[21:31:09  3a143982]:process exit.
[21:31:09  3a143982]:flashSuccess False
[21:31:09  3a143982]:isFactory False CheckCPUID False
[21:31:09  3a143982]:before:flashSuccess is False set IsUpdate:True set IsDone True
[21:31:09  3a143982]:after:flashSuccess is False set IsUpdate:false set IsDone true

2) I tried to go into the official recovery mode and then reflash the original firmware (http://c.mi.com//miuidownload/detail?device=1700361) via MiPhoneAssistantBeta3.0. The reflashing procedure starts, goes to around 70% (on the device)/ 99% (on the computer) and then (within a second) jumps to a 100% on both device and computer. The device automatically restarts into the same state as before. The computer shows a green arrow with some chinese characters, so I guess it completed? However, the device is still in the same bootloop state after this. I tried this procedure with the Global Mi 9T rom, in which case the MiPhoneAssistant checks the firmware and says its okay. I also tried to do this procedure with the EEA (Europe) rom or the Russian ROM, in which case the MiPhoneAssistant checks the firmware and says it is not recognized. I do not know what the original firmware was, but I suspect it to be Europe or Global. Could this check failure mean that my phone can only take Global rom?

3) I noticed the phone is in sideload mode when I use the Mi Assistant option in the bootloader (as done above), so I tried to adb sideload an origianal rom package, but as soon as I give the command in adb, the phone reboots.

3) I tried to acces EDL mode by connecting disconnecting the battery, connecting the two EDL pins to each other (these https://postimg.cc/jCr3ZVs2) and then inserting the USB cable. However, my computer does not seem to recognize anything, and the device start blinking a Blue LED in the camera pop up (the one which normally shows charging). If i do not do anything with the EDL pins and then insert the USB cable (with battery disconnected), the blue led also starts to blink, so it looks as if this is some standard behaviour? Does anyone know if the phone should also blink when it is in EDL mode?
I must say that I have a laptop with only USB-c ports, so I connected the USB cable via a usb hub to my computer. I also tried to do the same procedure on an old (very slow) computer with USB 2.0 ports, but there again nothing seems to show up in Device Manager if I connect the device.
Is it correct that the device should at least show up (with whatever name) if I do not have the driver installed?

4) I tried to unlock the phone, but cannot because the phone is not linked to my Mi Account.

With that, I have tried all my ideas and was wondering if anyone knows how to get into EDL mode with this device, or if it is maybe nog possible at all (hardware error?) Or if anyone has another idea to get it back working?

Any help appreciated!


TTYL:
- phone in bootloop
- I can reach fastboot, bootloader and recovery (all official)
- tried flashing official firmware via miflash, not allowed because locked bootloader
- tried flashing official firmware via MiPhoneAssistantBeta3.0, flashing procedure seems to succeed, but phone has same problems afterwards
- tried to get into EDL mode, but cannot get into this mode
Any tips on what to try, or how to get into EDL mode?

Thanks!