[LOLLIPOP] Xperia AOSP Project

Gen1usw0rk

Senior Member
Jul 26, 2011
122
95
58
I have successfully built it

I have successfully built this rom using Linaro ToolChain
It's so smooth butit has many bugs till now like:-
* Screen brightness always full cannot change.
* Bluetooth share force close screen appearing all time
* No Automatic screen Rotation
* Camera is Broken
* No phone service

Maybe it's just me because I used Linaro.. Anybody successfully built it too??
I will try to build it again using regular gcc toolchain and see if anything changes.

EDIT : -
A ScreenShot of it:-
Screenshot_2014-10-20-22-02-22.png
 
Last edited:

tejaswi.rohit

Member
Dec 15, 2010
39
27
0
Mumbai
mcqcdtbootimg :(

I've been trying to build the ROM from sources. Downloaded everything required and started to compile.

I face a problem while making the boot.img . I understand we need to use mkqcdtbootimg instead of just mkbootimg. I downloaded the sources of mkqcdtbootimg from Sony's git repo and places it under /source/system/extras. Even after doing those steps I seem to face a problem. Am I doing something wrong ? I'm still a newbie in ROM development. Any help will be highly appreciated :)
 

Myself5

Recognized Developer
Mar 17, 2011
3,375
9,646
263
23
myself5.de
I've been trying to build the ROM from sources. Downloaded everything required and started to compile.

I face a problem while making the boot.img . I understand we need to use mkqcdtbootimg instead of just mkbootimg. I downloaded the sources of mkqcdtbootimg from Sony's git repo and places it under /source/system/extras. Even after doing those steps I seem to face a problem. Am I doing something wrong ? I'm still a newbie in ROM development. Any help will be highly appreciated :)
You need to place this source into external/mkqcdtbootimg of your source code and then compile it again.

Sent from my Xperia Z2 using Tapatalk
 

tejaswi.rohit

Member
Dec 15, 2010
39
27
0
Mumbai
You need to place this source into external/mkqcdtbootimg of your source code and then compile it again.

Sent from my Xperia Z2 using Tapatalk
Ah! Thanks :D Will do that. In the mean time I compiled it separately and replaced mkbootimg with it :p

P.S. If someone is facing trouble to compile mkqcdtbootimg make sure you have all your ssl libraries installed and linked properly in Ubuntu. I had to install this libssl-dev to get it to compile there was some linker issue without it in 14.04.
 
  • Like
Reactions: bluheart

Gen1usw0rk

Senior Member
Jul 26, 2011
122
95
58
I've been trying to build the ROM from sources. Downloaded everything required and started to compile.

I face a problem while making the boot.img . I understand we need to use mkqcdtbootimg instead of just mkbootimg. I downloaded the sources of mkqcdtbootimg from Sony's git repo and places it under /source/system/extras. Even after doing those steps I seem to face a problem. Am I doing something wrong ? I'm still a newbie in ROM development. Any help will be highly appreciated :)
Hi,
Actually you have to download it to system/core folder not system/extra..
Hope that works for you :)
lol late one...
 
Last edited:

tejaswi.rohit

Member
Dec 15, 2010
39
27
0
Mumbai
I have successfully built this rom using Linaro ToolChain
It's so smooth butit has many bugs till now like:-
* Screen brightness always full cannot change.
* Bluetooth share force close screen appearing all time
* No Automatic screen Rotation
* Camera is Broken
* No phone service

Maybe it's just me because I used Linaro.. Anybody successfully built it too??
I will try to build it again using regular gcc toolchain and see if anything changes.

EDIT : -
A ScreenShot of it:-
View attachment 2978806
I compiled the ROM successfully and I'm facing the same problems as you're. I didn't use Linaro tool chain. I guess it has something to do with the device drivers. Hope we get them fixed soon. The ROM is fluid though :D
 

infected_

Recognized Developer
Jul 12, 2008
5,830
14,118
263
Portugal
infectedbuilds.net
I have successfully built this rom using Linaro ToolChain
It's so smooth butit has many bugs till now like:-
* Screen brightness always full cannot change.
* Bluetooth share force close screen appearing all time
* No Automatic screen Rotation
* Camera is Broken
* No phone service

Maybe it's just me because I used Linaro.. Anybody successfully built it too??
I will try to build it again using regular gcc toolchain and see if anything changes.

EDIT : -
A ScreenShot of it:-
View attachment 2978806
I compiled the ROM successfully and I'm facing the same problems as you're. I didn't use Linaro tool chain. I guess it has something to do with the device drivers. Hope we get them fixed soon. The ROM is fluid though :D

it has to do with the blobs.... sony released sources for 4.4.2_r2... and the binaries also for 4.4.2, but AOSP is on version 4.4.4_r2 ... blobs are not compatible with current AOSP version...

so if you wanna build pure AOSP for sirius for ex (this device hasn’t even received 4.4.4 official), you have to compile 4.4.2, not 4.4.4 ..

regards
 

tejaswi.rohit

Member
Dec 15, 2010
39
27
0
Mumbai
it has to do with the blobs.... sony released sources for 4.4.2_r2... and the binaries also for 4.4.2, but AOSP is on version 4.4.4_r2 ... blobs are not compatible with current AOSP version...

so if you wanna build pure AOSP for sirius for ex (this device hasn’t even received 4.4.4 official), you have to compile 4.4.2, not 4.4.4 ..

regards
That totally makes sense. I shall switch my branch and try to compile again . Thanks :)

Update:
Downloaded 4.4.2 source and compiled the ROM again. The issues remain the same. I think the device drivers in the kernel need to be set right.
 
Last edited:

jerpelea

Senior Recognized Developer
Nov 7, 2006
7,455
40,144
263
Lund
sites.google.com
I've been trying to build the ROM from sources. Downloaded everything required and started to compile.

I face a problem while making the boot.img . I understand we need to use mkqcdtbootimg instead of just mkbootimg. I downloaded the sources of mkqcdtbootimg from Sony's git repo and places it under /source/system/extras. Even after doing those steps I seem to face a problem. Am I doing something wrong ? I'm still a newbie in ROM development. Any help will be highly appreciated :)

cd build && git cherry-pick 612e2cd0e8c79bc6ab46d13cd96c01d1be382139 && cd ..
will fix your error

br
J
 

jerpelea

Senior Recognized Developer
Nov 7, 2006
7,455
40,144
263
Lund
sites.google.com
it has to do with the blobs.... sony released sources for 4.4.2_r2... and the binaries also for 4.4.2, but AOSP is on version 4.4.4_r2 ... blobs are not compatible with current AOSP version...

so if you wanna build pure AOSP for sirius for ex (this device hasn’t even received 4.4.4 official), you have to compile 4.4.2, not 4.4.4 ..

regards
thats completely wrong
modem and camera blobs are missing
br
J
 

infected_

Recognized Developer
Jul 12, 2008
5,830
14,118
263
Portugal
infectedbuilds.net
thats completely wrong
modem and camera blobs are missing
br
J
glad you corrected me then, after @tejaswi.rohit ruled that out.. so ... where can we find these missing blobs? can we use themuppets repo for it?

ps: @jerpelea can you explain to me how can we build 4.4.4 for Z2 per ex, if the official stock 4.4.4 hasnt been released, and with it the blobs for 4.4.4..?
 
Last edited: