LOS 18.1 Miatoll network doesn't work

Search This thread


New member
Jun 27, 2022

For about a week now I am facing network problems for sending or receiving sms or phone calls since the last update of LOS 18.1 (june 18th).

I'm on Miatoll since about 2 months, tried to reset network, change preferences, etc... Sometimes *#06# gives me no IMEI so I searched this way, but sometimes I still have an IMEI but the network doesn't work anymore.

It works back when I reboot the phone for about 1 or 2 hours, sometimes less, then it stops working. Either I don't receive sms or I receive them one or two days later. I tried to change the default sms app but it didn't change, also tried to force the SMSC with my operators number without more results... I tried to change the SIM card from sim1 to sim2 with the same result. On another phone (Blackview on android) it works fine. Something weird is that mobile datas work fine most of the time even when I can't send/receive sms or phone calls, but sometimes are also bugged.
Also when the network doesn't work anymore, accessing networks settings just freeze and quit the settings app.
EDIT : When I try to call myself from another phone, it rings normally and goes to voicemail. Nothing happens on my LOS phone. Also, when network is bugged, when I try to call someone it doesn't ring, stays on the call screen. When I hang up its stuck on "hang up", the microphone stays activated and I can't stop it even by forcing the phone app to close. It finally stop after 30 seconds to 1 minute.

I searched through XDA and other forums, none of the solutions I found worked.

I guess I'll wait for the next update or, if it doesn't change anything I'll probably flash a previous rom.

Does someone knows what to do with it ?

Many thanks in advance

I hope it's understandable, I'm not native english. I'll edit the post or give more infos if needed.
Last edited: