• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

LOSQ/LiR - LineageOS 17.1/18.1-UNOFFICIAL-GSI

Search This thread

KAngelo

Member
Dec 20, 2016
18
1
Yes, on all builds and versions of GSI ROMs (AFAIK).
Edit: If you just upgrade to a newer version of Lir, the NFC will remain from the previous version.
Thx :)
One last thing.. can i turn off encryption with the script from LineageOS 16 thread? And is the correct order doing that, after i have intalled 18.1 and booted first time.
 

-Alf-

Senior Member
Sep 28, 2017
1,366
442
Huawei P9 Lite
Huawei P10 Lite
Thx :)
One last thing.. can i turn off encryption with the script from LineageOS 16 thread? And is the correct order doing that, after i have intalled 18.1 and booted first time.
I don't know which script you mean, but this method works on EMUI 9.1 & GSI ROMs
https://forum.xda-developers.com/t/data-decryption-on-emui-9-1.4319329/post-85478865
And is the correct order doing that, after i have intalled 18.1 and booted first time.
IMO flash Lir + NFC + script , then do a factory reset, but it's your choice. The only difference is the number of factory resets.
 
Last edited:
  • Like
Reactions: Fjord1

ToffeE_

Member
Aug 10, 2021
16
0
Screenshot_20210831-223916_Magisk_Manager.png
Screenshot_20210831-224223_设置.png
Successfully flashed into the system and rooted, thanks!! But is it normal to open the magisk pop-up window? There is still this pop-up window after resuming restart and opening magisk
 

-Alf-

Senior Member
Sep 28, 2017
1,366
442
Huawei P9 Lite
Huawei P10 Lite

-Alf-

Senior Member
Sep 28, 2017
1,366
442
Huawei P9 Lite
Huawei P10 Lite

ToffeE_

Member
Aug 10, 2021
16
0
Didn't faced a problem like this...
Try Magisk-v22 + Manager-22
https://mega.nz/file/9tskybJD#JdxlT1NO0EKMGClVEaPxCGWCZ9AJCs_hLoap4vljYng

https://mega.nz/file/F8lGiZDZ#1DeGGcxlgeM08n5g5CsmhoKoYZuOEDJQu_1yeHWX9oY

Make sure that ‘Stable’ is selected as Magisk’s update channel.

Or, try guide for A11
Look here
Update to latest v.23 (within the app) and try again
The magisk application was updated to 23.0 to fix it normally, thanks!
 

ChaosNicro

Member
Jul 29, 2015
5
0
Does Lir have the signature spoofing patches for microg by any chance. I would like to use it without full GAPPS and the patchers for R currently require magisk-hacks to work, which would cost me some security.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    supposedly those with system 8.0.0.046 as I read it is due to a corrupt compilation, which installs stolen phones.
    :D nonsense...
    how to backup the stock recovery
    - Download Recovery for EMUI 8.0
    - Flash it in fastboot , command:
    fastboot flash recovery_ramdisk RECOVERY_RAMDISK-ANE-OREO.img
    - fastboot reboot
    1
    fastboot oem get-build-number
    (bootloader) :ANE-LX3 8.0.0.152(C605)

    fastboot oem get-product-model
    (bootloader) ANE-LX3

    fastboot getvar vendorcountry
    vendorcountry: hw/la

    fastboot oem oeminforead-CUSTOM_VERSION
    FAILED (remote: The reason of failed input oem_nv_item error!)

    fastboot oem oeminforead-SYSTEM_VERSION
    (bootloader) :ANE-LX3 8.0.0.152(C605)

    Try one of the following service ROMs . Use dload method. Instructions can be found in ReleaseDoc folder in downloaded .zip package.
    https://androidhost.ru/Vnk

    https://androidhost.ru/Vnd

    https://androidhost.ru/2bCt
    1
    I finally managed to install lineageos 18
    Doing some tests, I thought that the calls did not work,
    this because it does not come with ringtones, alarms, notifications.
    so i add them manually and all good.

    I tried to install the GCAM and none of the apks I downloaded worked correctly.
    meh !! it is not a problem for me.
    But great was my disappointment to see that it does not have FM RADIO.
    I will try to find a solution to this, otherwise I will install lineageos 16

    View attachment 5417035View attachment 5417037View attachment 5417039
    FYI footej camera is a good enough replacement for gcam.
    1
    Hey, @-Alf-!

    Thank you a lot for your builds. I was able to install both latest LiR and crDRom (after some tweaking) on a Huawei P Smart 2018 (FIG-LX1 C432).

    I recently unlocked its bootloader and updated it to the latest supported stock version of EMUI9 (9.1.0.216). The problem is that it has a small system partition, only about 2.4GB. Looking around, I've found that that most GSI ROMs have multiple versions of the vndk files, so I manually deleted the ones the phone does not need (it uses vndk28 only) and then I could install and boot normally.

    I installed LiR first, but because I plan to use MicroG only and it does not support Signature Spoofing, I move to crDRom. I was the best experience out of box: I could enable NFC using your ZIP (I installed the files manually, but I was not able to fully test if it actually works so far) and even the fingerprint gesture to show the notification shade worked while all other Treble based ROMs didn't.

    There are a few small bugs, if I can help fixing them, please tell me how:
    1. No call or notification sounds: UI sounds work, like touch and camera sounds, but nothing else. Copying a backup I had to the internal storage worked (Alarm/Notifications/Ringtone folders). I can see the file in the system folder, I have no idea why they do not appear in the Sound Picker app;
    2. If I enable only the sound for the charger connect/disconnect events, it still vibrates (the option in the stock Settings is enabled);
    3. Calls work, but I think the signal icon does not display the strength value correctly;
    4. The stock camera app does not work with flash, but I think it is know bug for most Treble ROMs, I have not found a good replacement yet (tried Footej, HedgeCam2 and OpenCamera, I like OpenCamera more so far);
    5. The same goes for the FMRadio app, I was not able to install the stock app back due to some permission issue (maybe I need to sign the APK again).
    Again, thank you!
    Regards
    Hi,
    As you can see, LiR is not developed nor maintained by me . I just want to share my experience with you all.
    Then ask the autor :
    https://forum.xda-developers.com/t/unofficial-crdroid-r-mod-crdrom11.4269719/
    But I can answer some of the questions:
    3. https://forum.xda-developers.com/t/...reble-signal-level-path.4327961/post-85571203
    4. Use Footej camera 2-Premium
    Download
    5. FM Radio doesn't work on Kirin-devices.

    Regards
  • 6
    For those who want to try LineageOS 17.1/18.1-UNOFFICIAL-GSI . IMO stable enough to be used as your daily driver.

    LOSQ/LiR is not developed nor maintained by me!
    Credits: @eremitein

    Requirements: basically full stock EMUI 9.1, with stock recovery_ramdisk.

    Note: I prefer to install in fastboot mode, it's quick, easy and most importantly, safe.

    IMPORTANT! Before booting up the ROM, you will need to perform a factory reset in stock recovery!
    Install arm64-b.. only!

    1. LOSQ - LineageOS 17.1-unofficial-GSI
    with the GAPPS
    GAPPS
    without GAPPS
    Vanilla
    -----------------------
    LiR- LineageOS 18.1-unofficial-GSI
    Download

    2. Extract the ROM .img file from the compressed file.
    3. Flash extracted losq/lir... .img from fastboot , use command
    fastboot flash system (file_name).img
    4. Run command fastboot reboot, unplug your phone, when appears on screen yellow warning, press and hold for 3 sec Volume Up . In eRecovery select 'Wipe data/factory reset'.Reboot .

    NFC :
    https://forum.xda-developers.com/t/losq-lineageos-17-1-unofficial-gsi.4219291/post-84394147

    Magisk root (23.0):

    (Note: If you don't plan to use TWRP, simply install patched Recovery_ramdisk in fastboot mode. Run command
    fastboot flash recovery_ramdisk magisk_patched-23.img ),

    - download and install Magisk manager-23.apk:
    https://mega.nz/file/go0m2RiR#M5UTv6FPjWPtDaGPr-u2tpJMCwdf8uwnniZg69LiGfw

    - Install TWRP-9.1
    https://mega.nz/#!tkcTlATI!A8UJGPBGtxJbLcUOJoxCGJj5PFZXzCnjbb3OkwqKTP8
    over eRecovery (it's necessary on EMUI 9.1):
    - copy TWRP file to the SD card, and also copy to the SD card patched Recovery_ramdisk:
    https://mega.nz/file/lp1kHLxJ#htCMaPjSsg_dy0w_jNOft-t_DZRAPwhOvwy_Wr2cjX8

    - flash TWRP - run command
    fastboot flash recovery_ramdisk (TWRP's_name).img
    - boot into TWRP, select storage - SD Card, select "Install image", find TWRP-9.1.img file and mark eRecovery, swipe. Go back, find magisk_patched-23.img file, mark Recovery, swipe. Go back to the TWRP's main menu, select Reboot > Recovery. Done.
    Note: you then need to boot your phone every time via Recovery. It'll boot into android as normal but with root.

    To remove Magisk reinstall stock recovery_ramdisk via TWRP or fastboot , download Here

    How to boot into TWRP:
    - Turn off your phone, connect to the PC (or charger), then press and hold Power + Volume Up, device will reboot into eRecovery (= TWRP).

    How to boot into patched Recovery :
    - Restart your phone, when appears the yellow warning on the screen, press and hold Volume Up for ~ 2 sec,
    release the button and immediately press and hold again for ~ 2 sec. Repeat it 6-7 times, the device will reboot into Stock Recovery (you can perform Wipe cache or Factory reset).

    Tips:
    https://forum.xda-developers.com/t/treble-gsi-favorite-gallery-camera-and-file-manager.4246019/
    3
    Okay, I have enough gps to use that phone I think with google precision location. But I think if I had to daily dive a car I would get back to stock lol
    Hello, maybe I found how to fix GPS (I'm running Lir again :p ).
    I tried replace some files with default extracted from stock, and it worked :oops: .
    - Download files:
    1
    2
    3
    - Go root/system/etc
    - Replace gps.debug.conf with downloaded gps.debug.conf file
    - Copy to system/etc also second file gps.debug
    - Open system/etc/permissions and copy here android.hardware.location.gps.xml file.
    Restart.
    Screenshot_20210510-133144_GPS_Test.pngScreenshot_20210510-133201_GPS_Test.pngScreenshot_20210510-133229_GPS_Test.png
    2
    Did anyone testet LineageOS 18.1 as their daily driver and can give a review?
    I use it for about a week as daily driver.

    I think it's a lot smoother in daily handling than stock ( I use it with nova launcher). After some tweaking every thing I need is working:
    • I get full safety net with magisk and hide props plugin. I also use systemless host. I do not see netflix in playstore, but I could install the app from apkmirror and start it . I don't have an account, so I can't tell if it really works.
    • NFC fix is installed and works. To use it with the german ausweisApp I had to install xposed and nfc extended module. My finding was, that enabled xposed kills safetynet status, so it's not active until I need it.
    • The german bank app dkb tan2go has a very aggressive root detection, it works while magisk is frozen (with titanium).
    • All other banking apps I tried did work with magisk hide (I don't use garmin pay with my watch, so I did not try google pay)
    • Switching audio after inserting / releasing wired headsets does work.
    • Fast charging works (did not try offline charging, I just switch my phone to flight mode if I don't use it)
    I just found two minor issues until now:
    • Bluetooth is sometimes a bit buggy: Headphones disconnect after starting to play audio - but this happens only for 1- 4 times, then the connection is stable. This affects different receiver, so I think it's a problem with the rom / the phone.
    • Signal meter for mobile radio does not work, but you can use apps/widgets from play store to show signal strength
    Hope this helps
    :cool:
    2
    It may be due to Phenix Kernel. You don't need it at all, use it only when you need to switch SELinux.
    No, it's okay, now I tried it with latest Phenix installed, everything works like a charme (lir-v302-bgZ)
    Pardon my mistake, @TureX .
    2
    LineageOS 18.1- unofficial GSI my experience: for huawei owners, this is basically the same ROM as 17.1 except of dynamic root (Z) - 18.1 is pre-rooted with the SuperUser (you can enable/disable superuser root without rebooting).
    Download:
    GAPPS
    Vanilla

    Screenshot_20210302-225526_Settings.png
    Screenshot_20210302-225652_Trebuchet.png
    Screenshot_20210302-225032_PhhTrebleApp.png
    Screenshot_20210302-224902_Settings.png
    Screenshot_20210302-225157_Trebuchet.png
    Screenshot_20210302-225132_Trebuchet.png