LOSQ/LiR - LineageOS 17.1/18.1-UNOFFICIAL-GSI

Search This thread

surfcoast13

Senior Member
Aug 6, 2021
53
4
Then choose LOSQ, it's the same Lineage, but A10 based. The difference is that you must install root yourself, Magisk or SuperUser. Bonus: working VoLTE .

The problem is that installation is a bit complicated...
I installed 314 via Twrp and it starts - only problem - It says: NO Sim-card
dirt flash with fastboot over that, it doesn`t start the system

flash with twrp it starts the system but no sim card... with fault message: "android process acore ended" - thats the problem
i don`t know how to get both running
ANY IDEAS?
Please! THX!
 
Last edited:

surfcoast13

Senior Member
Aug 6, 2021
53
4
restart the phone. If that doesn't help, you may have a kernel problem. Did you do a factory reset in stock recovery before the first boot?
I flashed the new kernel yesterday withou any problems - stock rom was running and sim card was okay

factory reset was not able to do because twrp was installed - i wiped dalvik cache in twrp

do you have any idea?

maybe i have to flash it with twrp - turn it off, start twrp again and install patched recovery - turn it off and start patched recovery than factory reset and start the system...?
 

surfcoast13

Senior Member
Aug 6, 2021
53
4
maybe i have to flash it with twrp - turn it off, start twrp again and install patched recovery - turn it off and start patched recovery than factory reset and start the system...?
THIS WORKED!!! :p:p:p

THX ALF for your help nerves !!!

Ps: Now i have seen in Magisk Manager, that my P20 lite has no Ramdisk AND "is not A/B" - so i think that a lineage "bvZ" image is not working via fastboot flash- maybe an Lineage "avZ" image is the right one - Funny that it is working via my difficult methode to install.
:LOL:
What do you think?
 
Last edited:
  • Like
Reactions: AltairFR

Bearzy_25

Member
Mar 11, 2022
5
0
OnePlus 7T Pro
Hi everyone,
First of all thanks for still supporting this device and for all the effort you guys put in this commuity.
Hi flashed in my p20 lite the latest LiR version with Gapps and root included, it looks like a really stable rom from what I've seen so far, but still have to try nfc patch and fingerprint ( I'm not in a hurry because it's not my daily driver). I was trying to install magisk to get root access with it ( i followed the guide a few pages back) but even if from the terminal it looked all good (fix+magisk installation) once i reboot into system it shows "Installed N/A" (Currently installed latest version, so 24.3 and TWRP 3.4.0.0 as Erecovery).
Can anybody help me out installing magisk?
thanks in advance😊
 

Bearzy_25

Member
Mar 11, 2022
5
0
OnePlus 7T Pro
Hey man, thanks for ur quick reply. I remeber this, i read your instructions a couple of times trying not to mess up, but it still shows N/A . Do I have to boot into erecovery twrp, flash fix and magisk, then
boot to recovery and then system every time?
 

layalala

Senior Member
Jun 18, 2019
66
3
fastboot flash recovery_ramdisk TWRP-9.1.img works, but if i restart the phone with Power+VolUp it boots to eRecovery, no TWRP.
 

layalala

Senior Member
Jun 18, 2019
66
3
Turn off, then use Power + Vol Up.
if I stay on power button in fastboot, then it just restarts. I can not really turn off.
Ok, I turned it off in eRecovery and it boots now to TWRP, but the touchscreen is dead.
#Edit1: just tried it another 2 times, now touchscreen works... strange.
#Edit2: I swiped both imgs to eRecovery, rebooted to recovery and get TWRP without touchscreen again
#Edit3: now it boots every time TWRP, sometimes with touchscreen, sometimes without. Even if I try to boot to system

#Edit4: OOOOK! My fault! :D
The first img to eRecovery, the 2nd to Recovery. Now it starts the LOS19 with root! Thanks!

But what about the Magisk-App. It shows me that another su command is beeing detected. I suppose its because of the flashed ramdisk with magisk, isnt it? Can I update the app and use it?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    For those who want to try LineageOS 17.1/18.1-UNOFFICIAL-GSI . IMO stable enough to be used as your daily driver.

    LOSQ/LiR is not developed nor maintained by me!
    Credits: @eremitein

    Requirements: basically full stock EMUI 9.1, with stock recovery_ramdisk.

    Note: I prefer to install in fastboot mode, it's quick, easy and most importantly, safe.

    IMPORTANT! Before booting up the ROM, you will need to perform a factory reset in stock recovery!
    Install arm64-b.. only!

    1. LOSQ - LineageOS 17.1-[10]-unofficial-GSI
    with the GAPPS
    GAPPS
    without GAPPS
    Vanilla
    -----------------------
    LiR- LineageOS 18.1-unofficial-[11]-GSI
    Download

    2. Extract the ROM .img file from the compressed file.
    3. Flash extracted losq/lir... .img from fastboot , use command
    fastboot flash system (file_name).img
    4. Run command fastboot reboot, unplug your phone, when appears on screen yellow warning, press and hold for 3 sec Volume Up . In eRecovery select 'Wipe data/factory reset'.Reboot .

    NFC patch:

    https://forum.xda-developers.com/t/losq-lineageos-17-1-unofficial-gsi.4219291/post-84394147

    Magisk root (23.0):

    (Note: If you don't plan to use TWRP, simply install patched Recovery_ramdisk in fastboot mode. Run command
    fastboot flash recovery_ramdisk magisk_patched-23.img ),

    - download and install Magisk manager-23.apk:
    https://mega.nz/file/go0m2RiR#M5UTv6FPjWPtDaGPr-u2tpJMCwdf8uwnniZg69LiGfw

    - Install TWRP-9.1
    https://mega.nz/#!tkcTlATI!A8UJGPBGtxJbLcUOJoxCGJj5PFZXzCnjbb3OkwqKTP8
    over eRecovery (it's necessary on EMUI 9.1):

    - copy TWRP file to the SD card, and also copy to the SD card patched Recovery_ramdisk:
    https://mega.nz/file/lp1kHLxJ#htCMaPjSsg_dy0w_jNOft-t_DZRAPwhOvwy_Wr2cjX8

    - flash TWRP - run command
    fastboot flash recovery_ramdisk (TWRP's_name).img
    - boot into TWRP, select storage - SD Card, select "Install image", find TWRP-9.1.img file and mark eRecovery, swipe. Go back, find magisk_patched-23.img file, mark Recovery, swipe. Go back to the TWRP's main menu, select Reboot > Recovery. Done.
    Note: you then need to boot your phone every time via Recovery. It'll boot into android as normal but with root.

    ( Note: for those who want keep the erecovery as a fail-safe:
    https://forum.xda-developers.com/t/...-erecovery-with-twrp-installed-on-it.4357127/ )

    To remove Magisk reinstall stock recovery_ramdisk via TWRP or fastboot , download Here

    How to boot into TWRP:
    - Turn off your phone, connect to the PC (or charger), then press and hold Power + Volume Up, device will reboot into eRecovery (= TWRP).

    How to boot into patched Recovery :
    - Restart your phone, when appears the yellow warning on the screen, press and hold Volume Up for ~ 2 sec,
    release the button and immediately press and hold again for ~ 2 sec. Repeat it 6-7 times, the device will reboot into Stock Recovery (you can perform Wipe cache or Factory reset).

    Tips:
    https://forum.xda-developers.com/t/treble-gsi-favorite-gallery-camera-and-file-manager.4246019/
    3
    Okay, I have enough gps to use that phone I think with google precision location. But I think if I had to daily dive a car I would get back to stock lol
    Hello, maybe I found how to fix GPS (I'm running Lir again :p ).
    I tried replace some files with default extracted from stock, and it worked :oops: .
    - Download files:
    1
    2
    3
    - Go root/system/etc
    - Replace gps.debug.conf with downloaded gps.debug.conf file
    - Copy to system/etc also second file gps.debug
    - Open system/etc/permissions and copy here android.hardware.location.gps.xml file.
    Restart.
    Screenshot_20210510-133144_GPS_Test.pngScreenshot_20210510-133201_GPS_Test.pngScreenshot_20210510-133229_GPS_Test.png
    2
    Thread closed on request of OP @-Alf-
    Thread reopened, happy flashing :)
    2
    Did anyone testet LineageOS 18.1 as their daily driver and can give a review?
    I use it for about a week as daily driver.

    I think it's a lot smoother in daily handling than stock ( I use it with nova launcher). After some tweaking every thing I need is working:
    • I get full safety net with magisk and hide props plugin. I also use systemless host. I do not see netflix in playstore, but I could install the app from apkmirror and start it . I don't have an account, so I can't tell if it really works.
    • NFC fix is installed and works. To use it with the german ausweisApp I had to install xposed and nfc extended module. My finding was, that enabled xposed kills safetynet status, so it's not active until I need it.
    • The german bank app dkb tan2go has a very aggressive root detection, it works while magisk is frozen (with titanium).
    • All other banking apps I tried did work with magisk hide (I don't use garmin pay with my watch, so I did not try google pay)
    • Switching audio after inserting / releasing wired headsets does work.
    • Fast charging works (did not try offline charging, I just switch my phone to flight mode if I don't use it)
    I just found two minor issues until now:
    • Bluetooth is sometimes a bit buggy: Headphones disconnect after starting to play audio - but this happens only for 1- 4 times, then the connection is stable. This affects different receiver, so I think it's a problem with the rom / the phone.
    • Signal meter for mobile radio does not work, but you can use apps/widgets from play store to show signal strength
    Hope this helps
    :cool: