LOSQ/LiR - LineageOS 17.1/18.1-UNOFFICIAL-GSI

Search This thread


Senior Member
Sep 28, 2017
Huawei P9 Lite
Huawei P10 Lite
Hi guys, I'm here firsteval to say thanks to @-Alf- and his "insane" knowledge about this incredibly complicated device, after 6 days of full immersion I've, thanks his tricks, every instruction for manage this device on modding.
Currently I run a spectacular GSI, compiled by Robothanzo (RRq), found on 4pda forum, in gsi section,

there are a lot of fully working GSIs, even for this poor (in terms of customization) Huawei device.
Sorry for my poor English and thanks again to @-Alf- .
Thanks, but I don't have "insane" knowledge, just 6 years of experience with Hua/Ho devices, as a hobbyist :) .
  • Like
Reactions: autokoise


Feb 18, 2020
Thanks, but I don't have "insane" knowledge, just 6 years of experience with Hua/Ho devices, as a hobbyist :) .
Thanks again to you, in your posts I've found every instruction need to know for properly modding a Kirin device, i come from Xiaomi, where the customisation is simple like drink a glass of water, vice-versa on Hua/Ho devices the frustration is always around the corner!!

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    For those who want to try LineageOS 17.1/18.1-UNOFFICIAL-GSI . IMO stable enough to be used as your daily driver.

    LOSQ/LiR is not developed nor maintained by me!
    Credits: @eremitein

    Requirements: basically full stock EMUI 9.1, with stock recovery_ramdisk.

    Note: I prefer to install in fastboot mode, it's quick, easy and most importantly, safe.

    IMPORTANT! Before booting up the ROM, you will need to perform a factory reset in stock recovery!
    Install arm64-b.. only!

    1. LOSQ - LineageOS 17.1-[10]-unofficial-GSI
    with the GAPPS
    without GAPPS
    LiR- LineageOS 18.1-unofficial-[11]-GSI

    2. Extract the ROM .img file from the compressed file.
    3. Flash extracted losq/lir... .img from fastboot , use command
    fastboot flash system (file_name).img
    4. Run command fastboot reboot, unplug your phone, when appears on screen yellow warning, press and hold for 3 sec Volume Up . In eRecovery select 'Wipe data/factory reset'.Reboot .

    NFC patch:


    Magisk root (23.0):

    (Note: If you don't plan to use TWRP, simply install patched Recovery_ramdisk in fastboot mode. Run command
    fastboot flash recovery_ramdisk magisk_patched-23.img ),

    - download and install Magisk manager-23.apk:

    - Install TWRP-9.1
    over eRecovery (it's necessary on EMUI 9.1):

    - copy TWRP file to the SD card, and also copy to the SD card patched Recovery_ramdisk:

    - flash TWRP - run command
    fastboot flash recovery_ramdisk (TWRP's_name).img
    - boot into TWRP, select storage - SD Card, select "Install image", find TWRP-9.1.img file and mark eRecovery, swipe. Go back, find magisk_patched-23.img file, mark Recovery, swipe. Go back to the TWRP's main menu, select Reboot > Recovery. Done.
    Note: you then need to boot your phone every time via Recovery. It'll boot into android as normal but with root.

    ( Note: for those who want keep the erecovery as a fail-safe:
    https://forum.xda-developers.com/t/...-erecovery-with-twrp-installed-on-it.4357127/ )

    To remove Magisk reinstall stock recovery_ramdisk via TWRP or fastboot , download Here

    How to boot into TWRP:
    - Turn off your phone, connect to the PC (or charger), then press and hold Power + Volume Up, device will reboot into eRecovery (= TWRP).

    How to boot into patched Recovery :
    - Restart your phone, when appears the yellow warning on the screen, press and hold Volume Up for ~ 2 sec,
    release the button and immediately press and hold again for ~ 2 sec. Repeat it 6-7 times, the device will reboot into Stock Recovery (you can perform Wipe cache or Factory reset).

    Okay, I have enough gps to use that phone I think with google precision location. But I think if I had to daily dive a car I would get back to stock lol
    Hello, maybe I found how to fix GPS (I'm running Lir again :p ).
    I tried replace some files with default extracted from stock, and it worked :oops: .
    - Download files:
    - Go root/system/etc
    - Replace gps.debug.conf with downloaded gps.debug.conf file
    - Copy to system/etc also second file gps.debug
    - Open system/etc/permissions and copy here android.hardware.location.gps.xml file.
    Did anyone testet LineageOS 18.1 as their daily driver and can give a review?
    I use it for about a week as daily driver.

    I think it's a lot smoother in daily handling than stock ( I use it with nova launcher). After some tweaking every thing I need is working:
    • I get full safety net with magisk and hide props plugin. I also use systemless host. I do not see netflix in playstore, but I could install the app from apkmirror and start it . I don't have an account, so I can't tell if it really works.
    • NFC fix is installed and works. To use it with the german ausweisApp I had to install xposed and nfc extended module. My finding was, that enabled xposed kills safetynet status, so it's not active until I need it.
    • The german bank app dkb tan2go has a very aggressive root detection, it works while magisk is frozen (with titanium).
    • All other banking apps I tried did work with magisk hide (I don't use garmin pay with my watch, so I did not try google pay)
    • Switching audio after inserting / releasing wired headsets does work.
    • Fast charging works (did not try offline charging, I just switch my phone to flight mode if I don't use it)
    I just found two minor issues until now:
    • Bluetooth is sometimes a bit buggy: Headphones disconnect after starting to play audio - but this happens only for 1- 4 times, then the connection is stable. This affects different receiver, so I think it's a problem with the rom / the phone.
    • Signal meter for mobile radio does not work, but you can use apps/widgets from play store to show signal strength
    Hope this helps
    LineageOS 18.1- unofficial GSI my experience: for huawei owners, this is basically the same ROM as 17.1 except of dynamic root (Z) - 18.1 is pre-rooted with the SuperUser (you can enable/disable superuser root without rebooting).